- update from CVS

- sync with .utf8 patch
- add displaying of username/hostname in xterm title
This commit is contained in:
Jindrich Novy 2005-03-24 14:34:59 +00:00
parent 50f355b645
commit e52ead9872
3 changed files with 143 additions and 93 deletions

33
mc-userhost.patch Normal file
View File

@ -0,0 +1,33 @@
--- mc-4.6.1a/src/main.c.hostname 2005-03-23 13:59:31.198747928 +0100
+++ mc-4.6.1a/src/main.c 2005-03-23 16:00:49.135333392 +0100
@@ -32,6 +32,7 @@
#include <sys/types.h>
#include <sys/stat.h>
#include <unistd.h>
+#include <pwd.h>
#include "global.h"
#include "tty.h"
@@ -1612,9 +1613,22 @@ void
update_xterm_title_path (void)
{
unsigned char *p, *s;
+ char h[64];
+ struct passwd *pw;
if (xterm_flag && xterm_title) {
p = s = g_strdup (strip_home_and_password (current_panel->cwd));
+ if ( !gethostname (h, 64) ) {
+ h[63] = '\0'; /* Be sure the hostname is NUL terminated */
+ s = g_strdup_printf ("%s:%s", h, s);
+ g_free (p);
+ p = s;
+ }
+ if ( (pw = getpwuid(getuid())) ) {
+ s = g_strdup_printf ("%s@%s", pw->pw_name, s);
+ g_free (p);
+ p = s;
+ }
do {
if (*s < ' ')
*s = '?';

View File

@ -1,5 +1,5 @@
--- mc-4.6.1a-20050309/edit/editdraw.c.utf8 2005-02-22 18:00:38.000000000 +0100
+++ mc-4.6.1a-20050309/edit/editdraw.c 2005-03-09 14:33:33.474574536 +0100
--- mc-4.6.1a/edit/editdraw.c.utf8 2005-02-22 18:00:38.000000000 +0100
+++ mc-4.6.1a/edit/editdraw.c 2005-03-24 15:02:11.176347960 +0100
@@ -61,7 +61,7 @@
static void status_string (WEdit * edit, char *s, int w)
@ -223,8 +223,8 @@
print_to_widget (edit, row, start_col, start_col_real, end_col, line);
}
--- mc-4.6.1a-20050309/edit/editkeys.c.utf8 2005-02-22 18:00:38.000000000 +0100
+++ mc-4.6.1a-20050309/edit/editkeys.c 2005-03-09 14:33:33.475574384 +0100
--- mc-4.6.1a/edit/editkeys.c.utf8 2005-02-22 18:00:38.000000000 +0100
+++ mc-4.6.1a/edit/editkeys.c 2005-03-24 15:02:11.177347808 +0100
@@ -177,10 +177,10 @@ static long const common_key_map[] = {
* 'command' is one of the editor commands from editcmddef.h.
*/
@ -279,8 +279,8 @@
/* unchanged, key has no function here */
return 0;
}
--- mc-4.6.1a-20050309/edit/wordproc.c.utf8 2005-02-22 18:00:38.000000000 +0100
+++ mc-4.6.1a-20050309/edit/wordproc.c 2005-03-09 14:33:33.476574232 +0100
--- mc-4.6.1a/edit/wordproc.c.utf8 2005-02-22 18:00:38.000000000 +0100
+++ mc-4.6.1a/edit/wordproc.c 2005-03-24 15:02:11.178347656 +0100
@@ -41,7 +41,12 @@
#define tab_width option_tab_spacing
@ -507,8 +507,8 @@
g_free (t);
return;
}
--- mc-4.6.1a-20050309/edit/editcmd.c.utf8 2005-02-22 18:00:38.000000000 +0100
+++ mc-4.6.1a-20050309/edit/editcmd.c 2005-03-09 14:33:33.479573776 +0100
--- mc-4.6.1a/edit/editcmd.c.utf8 2005-03-17 22:18:23.000000000 +0100
+++ mc-4.6.1a/edit/editcmd.c 2005-03-24 15:19:16.066540968 +0100
@@ -60,7 +60,7 @@
#define edit_get_save_file(f,h) input_expand_dialog (h, _(" Enter file name: "), f)
@ -1232,7 +1232,7 @@
return s + n - str;
nospc:
va_end (ap);
@@ -1924,8 +2195,11 @@ edit_replace_cmd (WEdit *edit, int again
@@ -1922,8 +2193,11 @@ edit_replace_cmd (WEdit *edit, int again
}
}
if (replace_yes) { /* delete then insert new */
@ -1245,7 +1245,7 @@
int ret = 0;
/* we need to fill in sargs just like with scanf */
@@ -1934,17 +2208,25 @@ edit_replace_cmd (WEdit *edit, int again
@@ -1932,17 +2206,25 @@ edit_replace_cmd (WEdit *edit, int again
for (k = 1;
k < NUM_REPL_ARGS && pmatch[k].rm_eo >= 0;
k++) {
@ -1272,19 +1272,23 @@
edit->
search_start
-
@@ -1961,7 +2243,11 @@ edit_replace_cmd (WEdit *edit, int again
@@ -1959,9 +2241,15 @@ edit_replace_cmd (WEdit *edit, int again
sargs[k - 1][0] = 0;
}
if (!ret)
+#ifndef UTF8
ret = snprintf_p (repl_str, MAX_REPL_LEN + 2, input2, PRINTF_ARGS);
ret =
snprintf_p (repl_str, MAX_REPL_LEN + 2, input2,
PRINTF_ARGS);
+#else /* UTF8 */
+ ret = snprintf_p (repl_str, MAX_REPL_LEN + 2, winput2, PRINTF_ARGS);
+ ret =
+ snprintf_p (repl_str, MAX_REPL_LEN + 2, winput2,
+ PRINTF_ARGS);
+#endif /* UTF8 */
if (ret >= 0) {
times_replaced++;
while (i--)
@@ -1979,10 +2265,18 @@ edit_replace_cmd (WEdit *edit, int again
@@ -1981,10 +2269,18 @@ edit_replace_cmd (WEdit *edit, int again
times_replaced++;
while (i--)
edit_delete (edit);
@ -1303,7 +1307,7 @@
}
/* so that we don't find the same string again */
if (replace_backwards) {
@@ -2158,16 +2452,17 @@ edit_ok_to_exit (WEdit *edit)
@@ -2157,16 +2453,17 @@ edit_ok_to_exit (WEdit *edit)
#define TEMP_BUF_LEN 1024
/* Return a null terminated length of text. Result must be g_free'd */
@ -1325,7 +1329,7 @@
x = edit_move_forward3 (edit, edit_bol (edit, start), 0,
start);
c = edit_get_byte (edit, start);
@@ -2200,11 +2495,15 @@ edit_save_block (WEdit * edit, const cha
@@ -2199,11 +2496,15 @@ edit_save_block (WEdit * edit, const cha
return 0;
if (column_highlighting) {
@ -1342,7 +1346,7 @@
if (r < 0)
break;
p += r;
@@ -2212,15 +2511,19 @@ edit_save_block (WEdit * edit, const cha
@@ -2211,15 +2512,19 @@ edit_save_block (WEdit * edit, const cha
}
g_free (block);
} else {
@ -1364,7 +1368,7 @@
start = end;
}
g_free (buf);
@@ -2559,17 +2862,20 @@ edit_block_process_cmd (WEdit *edit, con
@@ -2558,17 +2863,20 @@ edit_block_process_cmd (WEdit *edit, con
/* prints at the cursor */
/* returns the number of chars printed */
@ -1387,7 +1391,7 @@
static void pipe_mail (WEdit *edit, char *to, char *subject, char *cc)
{
FILE *p = 0;
@@ -2663,15 +2969,20 @@ void edit_mail_dialog (WEdit * edit)
@@ -2662,15 +2970,20 @@ void edit_mail_dialog (WEdit * edit)
/* find first character of current word */
static int edit_find_word_start (WEdit *edit, long *word_start, int *word_len)
{
@ -1410,7 +1414,7 @@
return 0;
/* search start of word to be completed */
@@ -2681,11 +2992,19 @@ static int edit_find_word_start (WEdit *
@@ -2680,11 +2993,19 @@ static int edit_find_word_start (WEdit *
return 0;
last = c;
@ -1431,7 +1435,7 @@
return 0;
*word_start = edit->curs1 - (i - 1); /* start found */
@@ -2718,7 +3037,7 @@ edit_collect_completions (WEdit *edit, l
@@ -2717,7 +3038,7 @@ edit_collect_completions (WEdit *edit, l
int *num)
{
int len, max_len = 0, i, skip;
@ -1440,7 +1444,7 @@
/* collect max MAX_WORD_COMPLETIONS completions */
while (*num < MAX_WORD_COMPLETIONS) {
@@ -2739,7 +3058,11 @@ edit_collect_completions (WEdit *edit, l
@@ -2738,7 +3059,11 @@ edit_collect_completions (WEdit *edit, l
buffers1[start >> S_EDIT_BUF_SIZE][start & M_EDIT_BUF_SIZE];
skip = 0;
for (i = 0; i < *num; i++) {
@ -1452,7 +1456,7 @@
(&compl[i].text[word_len], &bufpos[word_len],
max (len, compl[i].len) - word_len) == 0) {
skip = 1;
@@ -2749,7 +3072,7 @@ edit_collect_completions (WEdit *edit, l
@@ -2748,7 +3073,7 @@ edit_collect_completions (WEdit *edit, l
if (skip)
continue;
@ -1461,7 +1465,7 @@
compl[*num].len = len;
for (i = 0; i < len; i++)
compl[*num].text[i] = *(bufpos + i);
@@ -2763,6 +3086,18 @@ edit_collect_completions (WEdit *edit, l
@@ -2762,6 +3087,18 @@ edit_collect_completions (WEdit *edit, l
return max_len;
}
@ -1480,7 +1484,7 @@
/* let the user select its preferred completion */
static void
@@ -2772,9 +3107,13 @@ edit_completion_dialog (WEdit *edit, int
@@ -2771,9 +3108,13 @@ edit_completion_dialog (WEdit *edit, int
int start_x, start_y, offset, i;
char *curr = NULL;
Dlg_head *compl_dlg;
@ -1494,7 +1498,7 @@
/* calculate the dialog metrics */
compl_dlg_h = num_compl + 2;
@@ -2810,8 +3149,16 @@ edit_completion_dialog (WEdit *edit, int
@@ -2809,8 +3150,16 @@ edit_completion_dialog (WEdit *edit, int
add_widget (compl_dlg, compl_list);
/* fill the listbox with the completions */
@ -1511,7 +1515,7 @@
/* pop up the dialog */
run_dlg (compl_dlg);
@@ -2819,9 +3166,17 @@ edit_completion_dialog (WEdit *edit, int
@@ -2818,9 +3167,17 @@ edit_completion_dialog (WEdit *edit, int
/* apply the choosen completion */
if (compl_dlg->ret_value == B_ENTER) {
listbox_get_current (compl_list, &curr, NULL);
@ -1530,7 +1534,7 @@
}
/* destroy dialog before return */
@@ -2838,8 +3193,9 @@ edit_complete_word_cmd (WEdit *edit)
@@ -2837,8 +3194,9 @@ edit_complete_word_cmd (WEdit *edit)
{
int word_len = 0, i, num_compl = 0, max_len;
long word_start = 0;
@ -1542,7 +1546,7 @@
struct selection compl[MAX_WORD_COMPLETIONS]; /* completions */
/* don't want to disturb another search */
@@ -2856,16 +3212,32 @@ edit_complete_word_cmd (WEdit *edit)
@@ -2855,16 +3213,32 @@ edit_complete_word_cmd (WEdit *edit)
/* prepare match expression */
bufpos = &edit->buffers1[word_start >> S_EDIT_BUF_SIZE]
[word_start & M_EDIT_BUF_SIZE];
@ -1575,8 +1579,8 @@
if (num_compl > 0) {
/* insert completed word if there is only one match */
--- mc-4.6.1a-20050309/edit/edit.c.utf8 2005-02-22 18:00:38.000000000 +0100
+++ mc-4.6.1a-20050309/edit/edit.c 2005-03-09 14:33:33.481573472 +0100
--- mc-4.6.1a/edit/edit.c.utf8 2005-02-22 18:00:38.000000000 +0100
+++ mc-4.6.1a/edit/edit.c 2005-03-24 15:02:11.188346136 +0100
@@ -103,7 +103,7 @@ char *option_backup_ext = "~";
static void edit_move_to_prev_col (WEdit *edit, long p);
static void user_menu (WEdit *edit);
@ -2178,8 +2182,8 @@
if (edit->overwrite) {
if (edit_get_byte (edit, edit->curs1) != '\n')
edit_delete (edit);
--- mc-4.6.1a-20050309/edit/edit-widget.h.utf8 2004-12-03 18:09:27.000000000 +0100
+++ mc-4.6.1a-20050309/edit/edit-widget.h 2005-03-09 14:33:33.482573320 +0100
--- mc-4.6.1a/edit/edit-widget.h.utf8 2004-12-03 18:09:27.000000000 +0100
+++ mc-4.6.1a/edit/edit-widget.h 2005-03-24 15:02:11.188346136 +0100
@@ -25,6 +25,11 @@ struct syntax_rule {
unsigned char border;
};
@ -2216,8 +2220,8 @@
unsigned long stack_size;
unsigned long stack_size_mask;
unsigned long stack_bottom;
--- mc-4.6.1a-20050309/edit/edit.h.utf8 2005-02-22 18:00:38.000000000 +0100
+++ mc-4.6.1a-20050309/edit/edit.h 2005-03-09 14:33:33.483573168 +0100
--- mc-4.6.1a/edit/edit.h.utf8 2005-02-22 18:00:38.000000000 +0100
+++ mc-4.6.1a/edit/edit.h 2005-03-24 15:02:11.205343552 +0100
@@ -23,6 +23,27 @@
#ifndef MC_EDIT_H
#define MC_EDIT_H
@ -2331,8 +2335,8 @@
#define get_sys_error(s) (s)
--- mc-4.6.1a-20050309/src/help.c.utf8 2005-02-08 23:33:52.000000000 +0100
+++ mc-4.6.1a-20050309/src/help.c 2005-03-09 14:33:33.483573168 +0100
--- mc-4.6.1a/src/help.c.utf8 2005-02-08 23:33:52.000000000 +0100
+++ mc-4.6.1a/src/help.c 2005-03-24 15:02:11.206343400 +0100
@@ -453,10 +453,28 @@ static void help_show (Dlg_head *h, cons
#ifndef HAVE_SLANG
addch (acs_map [c]);
@ -2375,8 +2379,8 @@
if (!filename)
g_free (hlpfile);
--- mc-4.6.1a-20050309/src/learn.c.utf8 2005-02-08 10:04:03.000000000 +0100
+++ mc-4.6.1a-20050309/src/learn.c 2005-03-09 14:33:33.484573016 +0100
--- mc-4.6.1a/src/learn.c.utf8 2005-02-08 10:04:03.000000000 +0100
+++ mc-4.6.1a/src/learn.c 2005-03-24 15:02:11.208343096 +0100
@@ -237,7 +237,7 @@ init_learn (void)
learn_but[0].x = 78 / 2 + 4;
@ -2386,8 +2390,8 @@
learn_title = _(learn_title);
i18n_flag = 1;
--- mc-4.6.1a-20050309/src/main.c.utf8 2005-02-08 20:59:45.000000000 +0100
+++ mc-4.6.1a-20050309/src/main.c 2005-03-09 14:33:33.485572864 +0100
--- mc-4.6.1a/src/main.c.utf8 2005-02-08 20:59:45.000000000 +0100
+++ mc-4.6.1a/src/main.c 2005-03-24 15:02:11.210342792 +0100
@@ -1609,7 +1609,7 @@ update_xterm_title_path (void)
if (xterm_flag && xterm_title) {
p = s = g_strdup (strip_home_and_password (current_panel->cwd));
@ -2397,8 +2401,8 @@
*s = '?';
} while (*++s);
fprintf (stdout, "\33]0;mc - %s\7", p);
--- mc-4.6.1a-20050309/src/myslang.h.utf8 2004-12-03 20:17:47.000000000 +0100
+++ mc-4.6.1a-20050309/src/myslang.h 2005-03-09 14:33:33.486572712 +0100
--- mc-4.6.1a/src/myslang.h.utf8 2005-03-19 18:27:36.000000000 +0100
+++ mc-4.6.1a/src/myslang.h 2005-03-24 15:02:11.211342640 +0100
@@ -11,6 +11,10 @@
#endif /* HAVE_SLANG_SLANG_H */
#endif
@ -2410,8 +2414,8 @@
enum {
KEY_BACKSPACE = 400,
KEY_END, KEY_UP, KEY_DOWN, KEY_LEFT, KEY_RIGHT,
--- mc-4.6.1a-20050309/src/util.c.utf8 2005-02-12 15:30:48.000000000 +0100
+++ mc-4.6.1a-20050309/src/util.c 2005-03-09 14:33:33.488572408 +0100
--- mc-4.6.1a/src/util.c.utf8 2005-03-23 06:29:06.000000000 +0100
+++ mc-4.6.1a/src/util.c 2005-03-24 15:02:11.215342032 +0100
@@ -24,6 +24,9 @@
#include <config.h>
@ -2850,8 +2854,8 @@
}
*w = 0;
return s;
--- mc-4.6.1a-20050309/src/util.h.utf8 2005-02-08 11:46:01.000000000 +0100
+++ mc-4.6.1a-20050309/src/util.h 2005-03-09 14:33:33.488572408 +0100
--- mc-4.6.1a/src/util.h.utf8 2005-02-08 11:46:01.000000000 +0100
+++ mc-4.6.1a/src/util.h 2005-03-24 15:02:11.216341880 +0100
@@ -94,6 +94,13 @@ void init_uid_gid_cache (void);
char *get_group (int);
char *get_owner (int);
@ -2866,8 +2870,8 @@
#define MAX_I18NTIMELENGTH 14
#define MIN_I18NTIMELENGTH 10
#define STD_I18NTIMELENGTH 12
--- mc-4.6.1a-20050309/src/widget.c.utf8 2005-02-08 23:33:52.000000000 +0100
+++ mc-4.6.1a-20050309/src/widget.c 2005-03-09 14:33:33.491571952 +0100
--- mc-4.6.1a/src/widget.c.utf8 2005-02-08 23:33:52.000000000 +0100
+++ mc-4.6.1a/src/widget.c 2005-03-24 15:02:11.231339600 +0100
@@ -35,6 +35,9 @@
#include "global.h"
@ -3584,8 +3588,8 @@
return in;
}
--- mc-4.6.1a-20050309/src/dialog.c.utf8 2005-02-08 19:25:31.000000000 +0100
+++ mc-4.6.1a-20050309/src/dialog.c 2005-03-09 14:33:33.492571800 +0100
--- mc-4.6.1a/src/dialog.c.utf8 2005-02-08 19:25:31.000000000 +0100
+++ mc-4.6.1a/src/dialog.c 2005-03-24 15:02:11.232339448 +0100
@@ -166,7 +166,7 @@ common_dialog_repaint (struct Dlg_head *
if (h->title) {
@ -3595,8 +3599,8 @@
addstr (h->title);
}
}
--- mc-4.6.1a-20050309/src/hotlist.c.utf8 2005-02-08 10:04:03.000000000 +0100
+++ mc-4.6.1a-20050309/src/hotlist.c 2005-03-09 14:33:33.493571648 +0100
--- mc-4.6.1a/src/hotlist.c.utf8 2005-02-08 10:04:03.000000000 +0100
+++ mc-4.6.1a/src/hotlist.c 2005-03-24 15:02:11.234339144 +0100
@@ -555,7 +555,7 @@ init_i18n_stuff(int list_type, int cols)
row = hotlist_but [i].y;
@ -3657,8 +3661,8 @@
char *label_string = g_strdup (current_panel->cwd);
strip_password (label_string, 1);
--- mc-4.6.1a-20050309/src/panelize.c.utf8 2005-02-08 10:04:03.000000000 +0100
+++ mc-4.6.1a-20050309/src/panelize.c 2005-03-09 14:33:33.494571496 +0100
--- mc-4.6.1a/src/panelize.c.utf8 2005-02-08 10:04:03.000000000 +0100
+++ mc-4.6.1a/src/panelize.c 2005-03-24 15:02:11.235338992 +0100
@@ -127,7 +127,7 @@ init_panelize (void)
i = sizeof (panelize_but) / sizeof (panelize_but[0]);
while (i--) {
@ -3683,8 +3687,8 @@
#endif /* ENABLE_NLS */
--- mc-4.6.1a-20050309/src/layout.c.utf8 2005-02-08 23:33:52.000000000 +0100
+++ mc-4.6.1a-20050309/src/layout.c 2005-03-09 14:33:33.495571344 +0100
--- mc-4.6.1a/src/layout.c.utf8 2005-02-08 23:33:52.000000000 +0100
+++ mc-4.6.1a/src/layout.c 2005-03-24 15:02:11.236338840 +0100
@@ -370,36 +370,36 @@ init_layout (void)
while (i--) {
@ -3758,8 +3762,8 @@
widget_set_size (&the_menubar->widget, 0, 0, 1, COLS);
--- mc-4.6.1a-20050309/src/menu.h.utf8 2004-12-03 20:17:47.000000000 +0100
+++ mc-4.6.1a-20050309/src/menu.h 2005-03-09 14:33:33.496571192 +0100
--- mc-4.6.1a/src/menu.h.utf8 2004-12-03 20:17:47.000000000 +0100
+++ mc-4.6.1a/src/menu.h 2005-03-24 15:02:11.236338840 +0100
@@ -21,6 +21,8 @@ typedef struct Menu {
menu_entry *entries;
int start_x; /* position relative to menubar start */
@ -3769,8 +3773,8 @@
} Menu;
extern int menubar_visible;
--- mc-4.6.1a-20050309/src/screen.c.utf8 2005-02-26 17:39:32.000000000 +0100
+++ mc-4.6.1a-20050309/src/screen.c 2005-03-09 14:33:33.498570888 +0100
--- mc-4.6.1a/src/screen.c.utf8 2005-03-17 23:40:11.000000000 +0100
+++ mc-4.6.1a/src/screen.c 2005-03-24 15:02:11.239338384 +0100
@@ -171,22 +171,59 @@ add_permission_string (char *dest, int w
static const char *
string_file_name (file_entry *fe, int len)
@ -4128,8 +4132,8 @@
} else {
attrset (NORMAL_COLOR);
one_vline ();
--- mc-4.6.1a-20050309/src/file.c.utf8 2005-02-08 10:04:03.000000000 +0100
+++ mc-4.6.1a-20050309/src/file.c 2005-03-09 14:33:33.499570736 +0100
--- mc-4.6.1a/src/file.c.utf8 2005-02-08 10:04:03.000000000 +0100
+++ mc-4.6.1a/src/file.c 2005-03-24 15:02:11.240338232 +0100
@@ -165,15 +165,20 @@ static const unsigned char *
do_transform_source (FileOpContext *ctx, const unsigned char *source)
{
@ -4168,8 +4172,8 @@
return fntarget;
}
--- mc-4.6.1a-20050309/src/view.c.utf8 2005-02-08 10:53:51.000000000 +0100
+++ mc-4.6.1a-20050309/src/view.c 2005-03-09 14:33:33.501570432 +0100
--- mc-4.6.1a/src/view.c.utf8 2005-02-08 10:53:51.000000000 +0100
+++ mc-4.6.1a/src/view.c 2005-03-24 15:02:11.242337928 +0100
@@ -41,6 +41,10 @@
#endif
#include <unistd.h>
@ -4281,8 +4285,8 @@
}
col++;
if (boldflag != MARK_NORMAL) {
--- mc-4.6.1a-20050309/src/wtools.c.utf8 2005-02-08 23:33:52.000000000 +0100
+++ mc-4.6.1a-20050309/src/wtools.c 2005-03-09 14:33:33.502570280 +0100
--- mc-4.6.1a/src/wtools.c.utf8 2005-02-08 23:33:52.000000000 +0100
+++ mc-4.6.1a/src/wtools.c 2005-03-24 15:02:11.243337776 +0100
@@ -49,11 +49,11 @@ create_listbox_window (int cols, int lin
/* Adjust sizes */
lines = (lines > LINES - 6) ? LINES - 6 : lines;
@ -4342,8 +4346,8 @@
quick_widgets[0].x_divisions = quick_widgets[1].x_divisions = len;
#endif /* ENABLE_NLS */
--- mc-4.6.1a-20050309/src/find.c.utf8 2005-02-08 23:33:52.000000000 +0100
+++ mc-4.6.1a-20050309/src/find.c 2005-03-09 14:33:33.503570128 +0100
--- mc-4.6.1a/src/find.c.utf8 2005-02-08 23:33:52.000000000 +0100
+++ mc-4.6.1a/src/find.c 2005-03-24 15:02:11.244337624 +0100
@@ -217,7 +217,7 @@ find_parameters (char **start_dir, char
int l1, maxlen = 0;
@ -4382,8 +4386,8 @@
fbuts[2].len += 2; /* DEFPUSH_BUTTON */
i18n_flag = 1;
}
--- mc-4.6.1a-20050309/src/widget.h.utf8 2005-02-08 10:58:40.000000000 +0100
+++ mc-4.6.1a-20050309/src/widget.h 2005-03-09 14:33:33.504569976 +0100
--- mc-4.6.1a/src/widget.h.utf8 2005-02-08 10:58:40.000000000 +0100
+++ mc-4.6.1a/src/widget.h 2005-03-24 15:02:11.245337472 +0100
@@ -22,6 +22,7 @@ typedef struct WButton {
char *text; /* text of button */
int hotkey; /* hot KEY */
@ -4426,8 +4430,8 @@
GList *history; /* The history */
int need_push; /* need to push the current Input on hist? */
char **completions; /* Possible completions array */
--- mc-4.6.1a-20050309/src/boxes.c.utf8 2005-02-08 10:04:03.000000000 +0100
+++ mc-4.6.1a-20050309/src/boxes.c 2005-03-09 14:33:33.505569824 +0100
--- mc-4.6.1a/src/boxes.c.utf8 2005-02-08 10:04:03.000000000 +0100
+++ mc-4.6.1a/src/boxes.c 2005-03-24 15:02:11.246337320 +0100
@@ -153,23 +153,23 @@ display_init (int radio_sel, char *init_
display_title = _(display_title);
for (i = 0; i < LIST_TYPES; i++) {
@ -4600,9 +4604,9 @@
i18n_flag = 1;
}
--- mc-4.6.1a-20050309/src/achown.c.utf8 2005-02-08 10:04:03.000000000 +0100
+++ mc-4.6.1a-20050309/src/achown.c 2005-03-09 14:33:33.506569672 +0100
@@ -583,6 +583,12 @@ init_chown_advanced (void)
--- mc-4.6.1a/src/achown.c.utf8 2005-03-17 23:03:31.000000000 +0100
+++ mc-4.6.1a/src/achown.c 2005-03-24 15:02:11.247337168 +0100
@@ -579,6 +579,12 @@ init_chown_advanced (void)
b_att[2] = button_new (XTRACT (6));
b_user = button_new (XTRACT (5));
b_group = button_new (XTRACT (4));
@ -4615,8 +4619,8 @@
add_widget (ch_dlg, b_group);
add_widget (ch_dlg, b_user);
--- mc-4.6.1a-20050309/src/menu.c.utf8 2005-02-08 10:04:03.000000000 +0100
+++ mc-4.6.1a-20050309/src/menu.c 2005-03-09 14:33:33.507569520 +0100
--- mc-4.6.1a/src/menu.c.utf8 2005-02-08 10:04:03.000000000 +0100
+++ mc-4.6.1a/src/menu.c 2005-03-24 15:02:11.248337016 +0100
@@ -22,6 +22,7 @@
#include <string.h>
@ -4819,8 +4823,8 @@
g_free (menu->name);
g_free (menu->help_node);
g_free (menu);
--- mc-4.6.1a-20050309/src/option.c.utf8 2005-02-08 10:04:03.000000000 +0100
+++ mc-4.6.1a-20050309/src/option.c 2005-03-09 14:33:33.508569368 +0100
--- mc-4.6.1a/src/option.c.utf8 2005-02-08 10:04:03.000000000 +0100
+++ mc-4.6.1a/src/option.c 2005-03-24 15:02:11.249336864 +0100
@@ -123,12 +123,12 @@ init_configure (void)
title2 = _(" Pause after run... ");
title3 = _(" Other options ");
@ -4868,8 +4872,8 @@
i18n_config_flag = 1;
}
--- mc-4.6.1a-20050309/src/filegui.c.utf8 2005-02-08 10:04:03.000000000 +0100
+++ mc-4.6.1a-20050309/src/filegui.c 2005-03-09 14:33:33.509569216 +0100
--- mc-4.6.1a/src/filegui.c.utf8 2005-02-08 10:04:03.000000000 +0100
+++ mc-4.6.1a/src/filegui.c 2005-03-24 15:02:11.251336560 +0100
@@ -65,6 +65,7 @@
#include "filegui.h"
#include "key.h" /* get_event */
@ -5015,22 +5019,28 @@
+ g_free(def_text);
return dest_dir;
}
--- mc-4.6.1a-20050309/acinclude.m4.utf8 2005-01-11 10:16:52.000000000 +0100
+++ mc-4.6.1a-20050309/acinclude.m4 2005-03-09 14:33:33.510569064 +0100
@@ -714,11 +714,11 @@ AC_DEFUN([MC_WITH_SLANG], [
[LIBS="$ac_save_LIBS"; MC_USE_TERMCAP])
--- mc-4.6.1a/acinclude.m4.utf8 2005-03-19 22:53:24.000000000 +0100
+++ mc-4.6.1a/acinclude.m4 2005-03-24 15:26:09.502689120 +0100
@@ -769,14 +769,14 @@ AC_DEFUN([MC_WITH_SLANG], [
fi
dnl Unless external S-Lang was requested, reject S-Lang with UTF-8 hacks
dnl Unless external S-Lang was requested, reject S-Lang with UTF-8 hacks
- if test x$with_screen = xslang; then
- :
- m4_if([$1], strict, ,
- [AC_CHECK_LIB([slang], [SLsmg_write_nwchars],
- [AC_MSG_WARN([Rejecting S-Lang with UTF-8 support, \
-it doesn't work well])
-it's not fully supported yet])
- with_screen=mcslang])])
- fi
+dnl if test x$with_screen = xslang; then
+dnl :
+dnl m4_if([$1], strict, ,
+dnl [AC_CHECK_LIB([slang], [SLsmg_write_nwchars],
+dnl [AC_MSG_WARN([Rejecting S-Lang with UTF-8 support, \
+dnl it doesn't work well])
+dnl it's not fully supported yet])
+dnl with_screen=mcslang])])
+dnl fi
dnl Check the library
if test x$with_screen = xslang; then
if test x$with_screen = xslang; then
AC_DEFINE(HAVE_SYSTEM_SLANG, 1,

11
mc.spec
View File

@ -1,12 +1,12 @@
Summary: User-friendly text console file manager and visual shell.
Name: mc
Version: 4.6.1a
Release: 0.6
Release: 0.7
Epoch: 1
License: GPL
Group: System Environment/Shells
#Source0: http://www.ibiblio.org/pub/Linux/utils/file/managers/mc/mc-%{version}.tar.gz
%define date 20050309
%define date 20050324
Source0: mc-%{version}-%{date}.tar.bz2
URL: http://www.ibiblio.org/mc/
BuildRoot: %{_tmppath}/%{name}-%{version}-root
@ -20,6 +20,7 @@ Patch2: mc-promptfix.patch
Patch3: mc-uglydir.patch
Patch4: mc-fish-upload.patch
Patch5: mc-spaceprompt.patch
Patch6: mc-userhost.patch
%description
Midnight Commander is a visual shell much like a file manager, only
@ -37,6 +38,7 @@ poke into RPMs for specific files.
%patch3 -p1 -b .uglydir
%patch4 -p1 -b .fish-upload
%patch5 -p1 -b .spaceprompt
%patch6 -p1 -b .userhost
# convert files in /lib to UTF-8
pushd lib
@ -170,6 +172,11 @@ rm -rf $RPM_BUILD_ROOT
%dir %{_datadir}/mc
%changelog
* Thu Mar 24 2005 Jindrich Novy <jnovy@redhat.com> 4.6.1a-0.7
- update from CVS
- sync with .utf8 patch
- add displaying of username/hostname in xterm title
* Mon Mar 21 2005 Jindrich Novy <jnovy@redhat.com> 4.6.1a-0.6
- fix refusal to chdir/start file action when spaces are typed in
command prompt and Enter is pressed (#151637)