- fix 188438
This commit is contained in:
parent
0dbe875bb4
commit
dea20ddd6c
@ -1,12 +1,14 @@
|
||||
--- mc-4.6.1a/src/file.c.delcheck 2006-01-11 20:02:10.000000000 +0100
|
||||
+++ mc-4.6.1a/src/file.c 2006-01-11 21:38:45.000000000 +0100
|
||||
@@ -1758,6 +1758,10 @@ panel_operate (void *source_panel, FileO
|
||||
--- mc-4.6.1a/src/file.c.delcheck 2006-04-28 13:46:33.000000000 +0200
|
||||
+++ mc-4.6.1a/src/file.c 2006-04-28 13:52:48.000000000 +0200
|
||||
@@ -1755,6 +1755,12 @@
|
||||
free_linklist (&linklist);
|
||||
free_linklist (&dest_dirs);
|
||||
|
||||
+ /* Update panel contents to avoid actions on deleted files */
|
||||
+ if (!panel->is_panelized) {
|
||||
+ update_panels (UP_RELOAD, UP_KEEPSEL);
|
||||
+ repaint_screen ();
|
||||
+ }
|
||||
+
|
||||
if (single_entry) {
|
||||
if (force_single) {
|
||||
|
5
mc.spec
5
mc.spec
@ -1,7 +1,7 @@
|
||||
Summary: User-friendly text console file manager and visual shell.
|
||||
Name: mc
|
||||
Version: 4.6.1a
|
||||
Release: 13
|
||||
Release: 14
|
||||
Epoch: 1
|
||||
License: GPL
|
||||
Group: System Environment/Shells
|
||||
@ -190,6 +190,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%dir %{_sysconfdir}/mc
|
||||
|
||||
%changelog
|
||||
* Fri Apr 28 2006 Jindrich Novy <jnovy@redhat.com> 4.6.1a-14
|
||||
- don't reread panel contents while in panelized mode (#188438)
|
||||
|
||||
* Thu Mar 30 2006 Jindrich Novy <jnovy@redhat.com> 4.6.1a-13
|
||||
- comment fallback to use only dd in FISH upload patch
|
||||
- drop .promptfix patch so that prompt is displayed only
|
||||
|
Loading…
Reference in New Issue
Block a user