- update to new upstream CVS snapshot (2007-06-04-22)

- don't print prompts multiple times when switching between mc and subshell
This commit is contained in:
Jindrich Novy 2007-06-12 14:49:42 +00:00
parent fccc601927
commit d9f085bd41
5 changed files with 33 additions and 4 deletions

View File

@ -8,3 +8,4 @@ mc-2006-11-14-16.tar.gz
mc-2006-12-28-05.tar.gz
mc-2007-01-22-13.tar.gz
mc-2007-01-24-03.tar.gz
mc-2007-06-04-22.tar.gz

21
mc-prompt.patch Normal file
View File

@ -0,0 +1,21 @@
--- mc-2007-06-04-22/src/main.c.prompt 2007-06-12 15:23:25.000000000 +0200
+++ mc-2007-06-04-22/src/main.c 2007-06-12 15:45:08.000000000 +0200
@@ -453,9 +453,16 @@ do_possible_cd (const char *new_dir)
void
do_update_prompt (void)
{
+ static char *old_subshell_prompt = NULL;
+
if (update_prompt) {
- printf ("%s", subshell_prompt);
- fflush (stdout);
+ if (old_subshell_prompt == NULL
+ || strcmp (old_subshell_prompt, subshell_prompt)) {
+ g_free (old_subshell_prompt);
+ old_subshell_prompt = g_strdup (subshell_prompt);
+ printf ("\r\n%s", subshell_prompt);
+ fflush (stdout);
+ }
update_prompt = 0;
}
}

View File

@ -3712,7 +3712,7 @@
+#ifdef UTF8
+ mc_wchar_t *winput2 = mbstr_to_wchar(input2);
+#endif /* UTF8 */
if (replace_scanf || replace_regexp) {
if (replace_scanf) {
- char repl_str[MAX_REPL_LEN + 2];
+ mc_wchar_t repl_str[MAX_REPL_LEN + 2];
int ret = 0;

11
mc.spec
View File

@ -1,9 +1,9 @@
%define date 2007-01-24-03
%define date 2007-06-04-22
Summary: User-friendly text console file manager and visual shell
Name: mc
Version: 4.6.1a
Release: 45.20070124cvs%{?dist}
Release: 46.20070604cvs%{?dist}
Epoch: 1
License: GPL
Group: System Environment/Shells
@ -28,6 +28,7 @@ Patch11: mc-utf8-8bit-hex.patch
Patch12: mc-ipv6.patch
Patch13: mc-newlinedir.patch
Patch14: mc-cloexec.patch
Patch15: mc-prompt.patch
%description
Midnight Commander is a visual shell much like a file manager, only
@ -54,6 +55,7 @@ specific files.
%patch12 -p1 -b .ipv6
%patch13 -p1 -b .newlinedir
%patch14 -p1 -b .cloexec
%patch15 -p1 -b .prompt
# convert files in /lib to UTF-8
pushd lib
@ -192,6 +194,11 @@ rm -rf $RPM_BUILD_ROOT
%dir %{_libexecdir}/mc
%changelog
* Tue Jul 12 2007 Jindrich Novy <jnovy@redhat.com> 4.6.1a-46
- update to new upstream CVS snapshot (2007-06-04-22)
- don't print prompts multiple times when switching
between mc and subshell
* Mon Apr 16 2007 Jindrich Novy <jnovy@redhat.com> 4.6.1a-45
- fix segmentation fault while editing non-UTF8 files (#229383)

View File

@ -1 +1 @@
21750fc365562ee1f2b20f32defa339d mc-2007-01-24-03.tar.gz
f5b70d9409ac7885c50cdf388b15721e mc-2007-06-04-22.tar.gz