Update to 4.8.12

This commit is contained in:
Jindrich Novy 2014-06-09 08:45:57 +01:00
parent 7f0972557f
commit d3b3efd010
6 changed files with 6 additions and 44 deletions

2
.gitignore vendored
View File

@ -1 +1 @@
/mc-4.8.11.tar.xz
/mc-4.8.12.tar.xz

View File

@ -1,12 +0,0 @@
diff -up mc-4.8.7/lib/vfs/direntry.c.VFSsegfault mc-4.8.7/lib/vfs/direntry.c
--- mc-4.8.7/lib/vfs/direntry.c.VFSsegfault 2012-12-27 09:13:20.000000000 +0100
+++ mc-4.8.7/lib/vfs/direntry.c 2013-03-21 10:54:15.344172569 +0100
@@ -656,6 +656,8 @@ vfs_s_close (void *fh)
int res = 0;
struct vfs_class *me = FH_SUPER->me;
+ if (!me) return -1;
+
FH_SUPER->fd_usage--;
if (!FH_SUPER->fd_usage)
vfs_stamp_create (me, FH_SUPER);

View File

@ -1,12 +0,0 @@
diff -up mc-4.8.10/src/vfs/cpio/cpio.c.cpiosegfault mc-4.8.10/src/vfs/cpio/cpio.c
--- mc-4.8.10/src/vfs/cpio/cpio.c.cpiosegfault 2013-08-03 07:40:32.068958650 +0200
+++ mc-4.8.10/src/vfs/cpio/cpio.c 2013-08-03 07:42:11.926345838 +0200
@@ -784,7 +784,7 @@ cpio_super_same (const vfs_path_element_
return 0;
/* Has the cached archive been changed on the disk? */
- if (((cpio_super_data_t *) parc->data)->st.st_mtime < archive_stat->st_mtime)
+ if (parc->data && ((cpio_super_data_t *) parc->data)->st.st_mtime < archive_stat->st_mtime)
{
/* Yes, reload! */
(*vfs_cpiofs_ops.free) ((vfsid) parc);

View File

@ -1,12 +0,0 @@
diff -up mc-4.8.10/lib/widget/widget-common.h.widgetsegfault mc-4.8.10/lib/widget/widget-common.h
--- mc-4.8.10/lib/widget/widget-common.h.widgetsegfault 2013-08-03 07:42:45.329299880 +0200
+++ mc-4.8.10/lib/widget/widget-common.h 2013-08-03 07:44:22.162755951 +0200
@@ -159,7 +159,7 @@ gboolean mouse_global_in_widget (const G
static inline cb_ret_t
send_message (void *w, void *sender, widget_msg_t msg, int parm, void *data)
{
- return WIDGET (w)->callback (WIDGET (w), WIDGET (sender), msg, parm, data);
+ return w ? WIDGET (w)->callback (WIDGET (w), WIDGET (sender), msg, parm, data) : 1;
}
/* --------------------------------------------------------------------------------------------- */

11
mc.spec
View File

@ -1,6 +1,6 @@
Summary: User-friendly text console file manager and visual shell
Name: mc
Version: 4.8.11
Version: 4.8.12
Release: 2%{?dist}
Epoch: 1
License: GPLv3+
@ -10,9 +10,6 @@ URL: http://www.midnight-commander.org/
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: glib2-devel e2fsprogs-devel slang-devel gpm-devel groff
BuildRequires: aspell-devel libssh2-devel >= 1.2.5
Patch0: mc-cpiosegfault.patch
Patch1: mc-widgetsegfault.patch
Patch2: mc-VFSsegfault.patch
%description
Midnight Commander is a visual shell much like a file manager, only
@ -23,9 +20,6 @@ specific files.
%prep
%setup -q
%patch0 -p1 -b .cpiosegfault
%patch1 -p1 -b .widgetsegfault
%patch2 -p1 -b .VFSsegfault
%build
export CFLAGS="-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE $RPM_OPT_FLAGS -Wno-strict-aliasing"
@ -81,6 +75,9 @@ rm -rf $RPM_BUILD_ROOT
%dir %{_libexecdir}/mc/ext.d
%changelog
* Mon Jun 09 2014 Jindrich Novy <novyjindrich@gmail.com> 4.8.12
- update to 4.8.12
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:4.8.11-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild

View File

@ -1 +1,2 @@
1a2d74b75ddbff0b0d6cdc04bf4a7d31 mc-4.8.11.tar.xz
7ecccc03df060cd0ca1414a5a14e6649 mc-4.8.12.tar.xz