don't hang when ftpfs times out, extension file fixes
This commit is contained in:
parent
29b4ad962a
commit
b52d9c6026
@ -1,6 +1,6 @@
|
|||||||
--- mc-4.6.1/lib/mc.ext.in.extensions 2005-07-23 18:51:15.000000000 +0200
|
--- mc-4.6.1/lib/mc.ext.in.extensions 2005-07-23 18:51:15.000000000 +0200
|
||||||
+++ mc-4.6.1/lib/mc.ext.in 2005-07-25 09:53:08.367448216 +0200
|
+++ mc-4.6.1/lib/mc.ext.in 2005-08-17 10:30:06.000000000 +0200
|
||||||
@@ -210,14 +210,25 @@ shell/.7z
|
@@ -210,14 +210,25 @@
|
||||||
|
|
||||||
# C
|
# C
|
||||||
shell/.c
|
shell/.c
|
||||||
@ -28,7 +28,7 @@
|
|||||||
Open=%var{EDITOR:vi} %f
|
Open=%var{EDITOR:vi} %f
|
||||||
|
|
||||||
# Object
|
# Object
|
||||||
@@ -242,9 +253,11 @@ regex/\.(te?xi|texinfo)$
|
@@ -242,9 +253,11 @@
|
||||||
# GNU Info page
|
# GNU Info page
|
||||||
type/^Info\ text
|
type/^Info\ text
|
||||||
Open=info -f %f
|
Open=info -f %f
|
||||||
@ -40,7 +40,7 @@
|
|||||||
|
|
||||||
# Manual page
|
# Manual page
|
||||||
# Exception - .so libraries are not manual pages
|
# Exception - .so libraries are not manual pages
|
||||||
@@ -313,6 +326,12 @@ type/^PPM
|
@@ -313,6 +326,12 @@
|
||||||
type/^Netpbm
|
type/^Netpbm
|
||||||
Include=image
|
Include=image
|
||||||
|
|
||||||
@ -53,7 +53,7 @@
|
|||||||
shell/.xcf
|
shell/.xcf
|
||||||
Open=gimp %f
|
Open=gimp %f
|
||||||
|
|
||||||
@@ -324,7 +343,7 @@ shell/.xpm
|
@@ -324,7 +343,7 @@
|
||||||
View=sxpm %f
|
View=sxpm %f
|
||||||
|
|
||||||
include/image
|
include/image
|
||||||
@ -62,7 +62,7 @@
|
|||||||
View=%view{ascii} identify %f
|
View=%view{ascii} identify %f
|
||||||
#View=%view{ascii} asciiview %f
|
#View=%view{ascii} asciiview %f
|
||||||
|
|
||||||
@@ -342,8 +361,12 @@ regex/\.([wW][aA][wW]22)$
|
@@ -342,8 +361,12 @@
|
||||||
Open=vplay -s 22 %f
|
Open=vplay -s 22 %f
|
||||||
|
|
||||||
regex/\.([mM][pP]3)$
|
regex/\.([mM][pP]3)$
|
||||||
@ -77,7 +77,7 @@
|
|||||||
|
|
||||||
regex/\.([oO][gG][gG])$
|
regex/\.([oO][gG][gG])$
|
||||||
Open=if [ "$DISPLAY" = "" ]; then ogg123 %f; else (xmms %f &); fi
|
Open=if [ "$DISPLAY" = "" ]; then ogg123 %f; else (xmms %f &); fi
|
||||||
@@ -356,6 +379,9 @@ regex/\.([wW][mM][aA])$
|
@@ -356,6 +379,9 @@
|
||||||
Open=mplayer -vo null %f
|
Open=mplayer -vo null %f
|
||||||
View=%view{ascii} mplayer -quiet -slave -frames 0 -vo null -ao null -identify %f 2>/dev/null | tail +13 || file %f
|
View=%view{ascii} mplayer -quiet -slave -frames 0 -vo null -ao null -identify %f 2>/dev/null | tail +13 || file %f
|
||||||
|
|
||||||
@ -87,7 +87,7 @@
|
|||||||
|
|
||||||
### Play lists ###
|
### Play lists ###
|
||||||
|
|
||||||
@@ -380,20 +406,28 @@ regex/\.([mM][oO][vV]|[qQ][tT])$
|
@@ -380,20 +406,28 @@
|
||||||
regex/\.([mM][pP]4|[mM][pP][eE]?[gG])$
|
regex/\.([mM][pP]4|[mM][pP][eE]?[gG])$
|
||||||
Include=video
|
Include=video
|
||||||
|
|
||||||
@ -116,3 +116,22 @@
|
|||||||
#Open=(gtv %f >/dev/null 2>&1 &)
|
#Open=(gtv %f >/dev/null 2>&1 &)
|
||||||
#Open=(xanim %f >/dev/null 2>&1 &)
|
#Open=(xanim %f >/dev/null 2>&1 &)
|
||||||
|
|
||||||
|
@@ -407,7 +441,8 @@
|
||||||
|
|
||||||
|
# PDF
|
||||||
|
type/^PDF
|
||||||
|
- Open=(xpdf %f &)
|
||||||
|
+ Open=(evince %f &)
|
||||||
|
+ #Open=(xpdf %f &)
|
||||||
|
#Open=(acroread %f &)
|
||||||
|
#Open=(ghostview %f &)
|
||||||
|
View=%view{ascii} pdftotext %f -
|
||||||
|
@@ -418,7 +453,7 @@
|
||||||
|
# html
|
||||||
|
regex/\.([hH][tT][mM][lL]?)$
|
||||||
|
Open=(if test -n "@X11_WWW@" && test -n "$DISPLAY"; then (@X11_WWW@ file://%d/%p &) 1>&2; else links %f || lynx -force_html %f || ${PAGER:-more} %f; fi) 2>/dev/null
|
||||||
|
- View=%view{ascii} lynx -dump -force_html %f
|
||||||
|
+ View=%view{ascii} links -dump %f
|
||||||
|
|
||||||
|
# StarOffice 5.2
|
||||||
|
shell/.sdw
|
||||||
|
8
mc.spec
8
mc.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: User-friendly text console file manager and visual shell.
|
Summary: User-friendly text console file manager and visual shell.
|
||||||
Name: mc
|
Name: mc
|
||||||
Version: 4.6.1a
|
Version: 4.6.1a
|
||||||
Release: 0.12
|
Release: 0.13
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
License: GPL
|
License: GPL
|
||||||
Group: System Environment/Shells
|
Group: System Environment/Shells
|
||||||
@ -20,6 +20,7 @@ Patch4: mc-fish-upload.patch
|
|||||||
Patch5: mc-userhost.patch
|
Patch5: mc-userhost.patch
|
||||||
Patch6: mc-64bit.patch
|
Patch6: mc-64bit.patch
|
||||||
Patch7: mc-gcc4.patch
|
Patch7: mc-gcc4.patch
|
||||||
|
Patch8: mc-ftpcrash.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Midnight Commander is a visual shell much like a file manager, only
|
Midnight Commander is a visual shell much like a file manager, only
|
||||||
@ -39,6 +40,7 @@ poke into RPMs for specific files.
|
|||||||
%patch5 -p1 -b .userhost
|
%patch5 -p1 -b .userhost
|
||||||
%patch6 -p1 -b .64bit
|
%patch6 -p1 -b .64bit
|
||||||
%patch7 -p1 -b .gcc4
|
%patch7 -p1 -b .gcc4
|
||||||
|
%patch8 -p1 -b .ftpcrash
|
||||||
|
|
||||||
# convert files in /lib to UTF-8
|
# convert files in /lib to UTF-8
|
||||||
pushd lib
|
pushd lib
|
||||||
@ -173,6 +175,10 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%dir %{_datadir}/mc
|
%dir %{_datadir}/mc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Aug 29 2005 Jindrich Novy <jnovy@redhat.com> 4.6.1a-0.13
|
||||||
|
- don't hang when ftpfs connection times out - Hans de Goede (#166976)
|
||||||
|
- fix extension file to better fit FC (xpdf->evince, lynx->links)
|
||||||
|
|
||||||
* Mon Jul 25 2005 Jindrich Novy <jnovy@redhat.com> 4.6.1a-0.12
|
* Mon Jul 25 2005 Jindrich Novy <jnovy@redhat.com> 4.6.1a-0.12
|
||||||
- new mc release 4.6.1
|
- new mc release 4.6.1
|
||||||
- sync extensions patch
|
- sync extensions patch
|
||||||
|
Loading…
Reference in New Issue
Block a user