Update to 4.8.5
This commit is contained in:
parent
a2c9177049
commit
b3be159c19
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
||||
/mc-4.8.4.tar.xz
|
||||
/mc-4.8.5.tar.xz
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -up mc-4.8.4/src/editor/editcmd.c.altminus mc-4.8.4/src/editor/editcmd.c
|
||||
--- mc-4.8.4/src/editor/editcmd.c.altminus 2012-07-18 11:30:23.000000000 +0200
|
||||
+++ mc-4.8.4/src/editor/editcmd.c 2012-07-31 11:21:14.261033325 +0200
|
||||
@@ -3496,7 +3496,7 @@ edit_load_back_cmd (WEdit * edit)
|
||||
return FALSE;
|
||||
|
||||
edit_stack_iterator--;
|
||||
- if (edit_history_moveto[edit_stack_iterator].filename_vpath != NULL)
|
||||
+ if (edit_stack_iterator >= 0 && edit_history_moveto[edit_stack_iterator].filename_vpath != NULL)
|
||||
return edit_reload_line (edit, edit_history_moveto[edit_stack_iterator].filename_vpath,
|
||||
edit_history_moveto[edit_stack_iterator].line);
|
||||
|
@ -1,39 +0,0 @@
|
||||
Index: src/editor/spell.c
|
||||
===================================================================
|
||||
--- src/editor/spell.c (revision 94bd4b1f78901cd83406f3daa9a0d0f8f2152321)
|
||||
+++ src/editor/spell.c (revision a8429411758003fab3b9f27e6bccad6b6b5c2d3c)
|
||||
@@ -72,7 +72,5 @@
|
||||
static const char *(*mc_aspell_config_retrieve) (struct AspellConfig * ths, const char *key);
|
||||
static void (*mc_delete_aspell_speller) (struct AspellSpeller * ths);
|
||||
-/*
|
||||
- static void (*mc_delete_aspell_config) (struct AspellConfig * ths);
|
||||
- */
|
||||
+static void (*mc_delete_aspell_config) (struct AspellConfig * ths);
|
||||
static void (*mc_delete_aspell_can_have_error) (struct AspellCanHaveError * ths);
|
||||
static const char *(*mc_aspell_error_message) (const struct AspellCanHaveError * ths);
|
||||
@@ -229,5 +227,5 @@
|
||||
goto error_ret;
|
||||
|
||||
- if (!g_module_symbol (spell_module, "delete_aspell_config", (void *) &mc_delete_aspell_speller))
|
||||
+ if (!g_module_symbol (spell_module, "delete_aspell_config", (void *) &mc_delete_aspell_config))
|
||||
goto error_ret;
|
||||
|
||||
@@ -312,5 +310,5 @@
|
||||
edit_error_dialog (_("Error"), mc_aspell_error_message (error));
|
||||
mc_delete_aspell_can_have_error (error);
|
||||
- g_free (global_speller);
|
||||
+ aspell_clean ();
|
||||
}
|
||||
}
|
||||
@@ -327,5 +325,10 @@
|
||||
return;
|
||||
|
||||
- mc_delete_aspell_speller (global_speller->speller);
|
||||
+ if (global_speller->speller != NULL)
|
||||
+ mc_delete_aspell_speller (global_speller->speller);
|
||||
+
|
||||
+ if (global_speller->config != NULL)
|
||||
+ mc_delete_aspell_config (global_speller->config);
|
||||
+
|
||||
g_free (global_speller);
|
||||
global_speller = NULL;
|
@ -1,79 +0,0 @@
|
||||
Index: src/filemanager/midnight.c
|
||||
===================================================================
|
||||
--- src/filemanager/midnight.c (revision c1f2a8ac49d29da749f078d69174f83b96720514)
|
||||
+++ src/filemanager/midnight.c (revision 9bec27cb0473c4e0545f33cb18ae794b84e8b2bb)
|
||||
@@ -1598,5 +1598,5 @@
|
||||
{
|
||||
/* menubar */
|
||||
- if (menubar_visible)
|
||||
+ if (menubar_visible || the_menubar->is_active)
|
||||
ret = ((Widget *) the_menubar)->mouse (event, the_menubar);
|
||||
else
|
||||
@@ -1605,10 +1605,12 @@
|
||||
|
||||
w = get_panel_widget (0);
|
||||
- ret = w->mouse (event, w);
|
||||
+ if (w->mouse != NULL)
|
||||
+ ret = w->mouse (event, w);
|
||||
|
||||
if (ret == MOU_UNHANDLED)
|
||||
{
|
||||
w = get_panel_widget (1);
|
||||
- ret = w->mouse (event, w);
|
||||
+ if (w->mouse != NULL)
|
||||
+ ret = w->mouse (event, w);
|
||||
}
|
||||
|
||||
Index: src/filemanager/panel.c
|
||||
===================================================================
|
||||
--- src/filemanager/panel.c (revision c1f2a8ac49d29da749f078d69174f83b96720514)
|
||||
+++ src/filemanager/panel.c (revision 9bec27cb0473c4e0545f33cb18ae794b84e8b2bb)
|
||||
@@ -3555,8 +3555,8 @@
|
||||
|
||||
/* 1st line */
|
||||
- if (mouse_down && local.y == 1)
|
||||
+ if (local.y == 1)
|
||||
{
|
||||
/* "<" button */
|
||||
- if (local.x == 2)
|
||||
+ if (mouse_down && local.x == 2)
|
||||
{
|
||||
directory_history_prev (panel);
|
||||
@@ -3565,5 +3565,5 @@
|
||||
|
||||
/* ">" button */
|
||||
- if (local.x == w->cols - 1)
|
||||
+ if (mouse_down && local.x == w->cols - 1)
|
||||
{
|
||||
directory_history_next (panel);
|
||||
@@ -3572,5 +3572,5 @@
|
||||
|
||||
/* "^" button */
|
||||
- if (local.x >= w->cols - 4 && local.x <= w->cols - 2)
|
||||
+ if (mouse_down && local.x >= w->cols - 4 && local.x <= w->cols - 2)
|
||||
{
|
||||
directory_history_list (panel);
|
||||
@@ -3580,5 +3580,5 @@
|
||||
|
||||
/* "." button show/hide hidden files */
|
||||
- if (local.x == w->cols - 5)
|
||||
+ if (mouse_down && local.x == w->cols - 5)
|
||||
{
|
||||
midnight_dlg->callback (midnight_dlg, NULL, DLG_ACTION, CK_ShowHidden, NULL);
|
||||
Index: src/filemanager/tree.c
|
||||
===================================================================
|
||||
--- src/filemanager/tree.c (revision 9b5e5a5106a41bc070e45a2dd176aeaad52fc510)
|
||||
+++ src/filemanager/tree.c (revision 9bec27cb0473c4e0545f33cb18ae794b84e8b2bb)
|
||||
@@ -637,9 +637,9 @@
|
||||
Gpm_Event local;
|
||||
|
||||
+ if (!mouse_global_in_widget (event, w))
|
||||
+ return MOU_UNHANDLED;
|
||||
+
|
||||
/* rest of the upper frame - call menu */
|
||||
if (tree->is_panel && (event->type & GPM_DOWN) != 0 && event->y == w->owner->y + 1)
|
||||
- return MOU_UNHANDLED;
|
||||
-
|
||||
- if (!mouse_global_in_widget (event, w))
|
||||
return MOU_UNHANDLED;
|
||||
|
12
mc.spec
12
mc.spec
@ -1,7 +1,7 @@
|
||||
Summary: User-friendly text console file manager and visual shell
|
||||
Name: mc
|
||||
Version: 4.8.4
|
||||
Release: 5%{?dist}
|
||||
Version: 4.8.5
|
||||
Release: 1%{?dist}
|
||||
Epoch: 1
|
||||
License: GPLv3+
|
||||
Group: System Environment/Shells
|
||||
@ -10,8 +10,6 @@ URL: http://www.midnight-commander.org/
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: glib2-devel e2fsprogs-devel slang-devel gpm-devel groff
|
||||
BuildRequires: aspell-devel libssh2-devel >= 1.2.5
|
||||
Patch1: mc-aspell.patch
|
||||
Patch2: mc-altminus.patch
|
||||
|
||||
%description
|
||||
Midnight Commander is a visual shell much like a file manager, only
|
||||
@ -22,9 +20,6 @@ specific files.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch1 -p0 -b .spell
|
||||
%patch2 -p1 -b .altminus
|
||||
%patch3 -p1 -b .exit
|
||||
|
||||
%build
|
||||
export CFLAGS="-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE $RPM_OPT_FLAGS -Wno-strict-aliasing"
|
||||
@ -80,6 +75,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%dir %{_libexecdir}/mc/ext.d
|
||||
|
||||
%changelog
|
||||
* Tue Sep 11 2012 Jindrich Novy <jnovy@redhat.com> 4.8.5-1
|
||||
- update to 4.8.5 (#815307)
|
||||
|
||||
* Thu Aug 09 2012 Jindrich Novy <jnovy@redhat.com> 4.8.4-5
|
||||
- handle overlapping menus correctly (#844392)
|
||||
(https://www.midnight-commander.org/ticket/2817)
|
||||
|
Loading…
Reference in New Issue
Block a user