update to 4.8.4

This commit is contained in:
Jindrich Novy 2012-07-19 08:40:43 +02:00
parent 633218668e
commit 9d76dc9ced
4 changed files with 8 additions and 139 deletions

2
.gitignore vendored
View File

@ -1 +1 @@
/mc-4.8.3.tar.xz
/mc-4.8.4.tar.xz

View File

@ -1,133 +0,0 @@
diff -up mc-4.8.0/misc/mc.ext.in.extensions mc-4.8.0/misc/mc.ext.in
--- mc-4.8.0/misc/mc.ext.in.extensions 2011-10-17 11:33:45.000000000 +0200
+++ mc-4.8.0/misc/mc.ext.in 2011-11-09 07:04:24.981728775 +0100
@@ -403,7 +403,7 @@ shell/.ico
Include=image
include/image
- Open=if [ "$DISPLAY" = "" ]; then zgv %f; else (gqview %f &); fi
+ Open=if [ "$DISPLAY" = "" ]; then zgv %f; else (xdg-open %f &); fi
View=%view{ascii} identify %f
#View=%view{ascii} asciiview %f
@@ -411,7 +411,8 @@ include/image
### Sound files ###
regex/\.([wW][aA][vV]|[sS][nN][dD]|[vV][oO][cC]|[aA][uU]|[sS][mM][pP]|[aA][iI][fF][fF]|[sS][nN][dD])$
- Open=if [ "$DISPLAY" = "" ]; then play %f; else (xmms %f >/dev/null 2>&1 &); fi
+ Include=audio
+# Open=if [ "$DISPLAY" = "" ]; then play %f; else (xmms %f >/dev/null 2>&1 &); fi
regex/\.([mM][oO][dD]|[sS]3[mM]|[xX][mM]|[iI][tT]|[mM][tT][mM]|669|[sS][tT][mM]|[uU][lL][tT]|[fF][aA][rR])$
Open=mikmod %f
@@ -421,15 +422,22 @@ regex/\.([wW][aA][wW]22)$
Open=vplay -s 22 %f
regex/\.([mM][pP]3)$
- Open=if [ "$DISPLAY" = "" ]; then mpg123 %f; else (xmms %f >/dev/null 2>&1 &); fi
- View=%view{ascii} mpg123 -vtn1 %f 2>&1 | sed -n '/^Title/,/^Comment/p;/^MPEG/,/^Audio/p'
+ Include=audio
+# Open=if [ "$DISPLAY" = "" ]; then mpg123 %f; else (xmms %f >/dev/null 2>&1 &); fi
+# View=%view{ascii} mpg123 -vtn1 %f 2>&1 | sed -n '/^Title/,/^Comment/p;/^MPEG/,/^Audio/p'
+
+regex/\.([mM][kK][aA])$
+ Include=audio
regex/\.([oO][gG][gG|aA|vV|xX])$
- Open=if [ "$DISPLAY" = "" ]; then ogg123 %f; else (xmms %f >/dev/null 2>&1 &); fi
+ Include=audio
+# Open=ogg123 %f
+# Open=if [ "$DISPLAY" = "" ]; then ogg123 %f; else (xmms %f >/dev/null 2>&1 &); fi
View=%view{ascii} ogginfo %s
regex/\.([sS][pP][xX]|[fF][lL][aA][cC])$
- Open=if [ "$DISPLAY" = "" ]; then play %f; else (xmms %f >/dev/null 2>&1 &); fi
+ Include=audio
+# Open=if [ "$DISPLAY" = "" ]; then play %f; else (xmms %f >/dev/null 2>&1 &); fi
regex/\.([mM][iI][dD][iI]?|[rR][mM][iI][dD]?)$
Open=timidity %f
@@ -438,11 +446,15 @@ regex/\.([wW][mM][aA])$
Open=mplayer -vo null %f
View=%view{ascii} mplayer -quiet -slave -frames 0 -vo null -ao null -identify %f 2>/dev/null | tail +13 || file %f
+include/audio
+ Open=mplayer %f
+ View=%view{ascii} mplayer -identify -vo null -ao null -frames 0 %f 2>&1 | sed -n '/^ID_/p'
### Play lists ###
regex/\.([mM]3[uU]|[pP][lL][sS])$
- Open=if [ -z "$DISPLAY" ]; then mplayer -vo null -playlist %f; else (xmms -p %f >/dev/null 2>&1 &); fi
+ Open=mplayer -vo null -playlist %f
+# Open=if [ -z "$DISPLAY" ]; then mplayer -vo null -playlist %f; else (xmms -p %f >/dev/null 2>&1 &); fi
### Video ###
@@ -494,12 +506,12 @@ include/video
# Postscript
type/^PostScript
- Open=(gv %f &)
+ Open=(xdg-open %f &)
View=%view{ascii} ps2ascii %f
# PDF
type/^PDF
- Open=(xpdf %f &)
+ Open=(xdg-open %f &)
#Open=(acroread %f &)
#Open=(ghostview %f &)
View=%view{ascii} pdftotext %f -
@@ -509,7 +521,7 @@ type/^PDF
# html
regex/\.([hH][tT][mM][lL]?)$
- Open=(if test -n "@X11_WWW@" && test -n "$DISPLAY"; then (@X11_WWW@ file://%d/%p &) 1>&2; else links %f || lynx -force_html %f || ${PAGER:-more} %f; fi) 2>/dev/null
+ Open=xdg-open file://%d/%p 1>&2
View=%view{ascii} links -dump %f 2>/dev/null || w3m -dump %f 2>/dev/null || lynx -dump -force_html %f
# StarOffice 5.2
@@ -527,22 +539,27 @@ shell/.abw
# Microsoft Word Document
regex/\.([Dd][oO][cCtT]|[Ww][rR][iI])$
- Open=(abiword %f >/dev/null 2>&1 &)
+ Open=(xdg-open %f &)
+# Open=(abiword %f >/dev/null 2>&1 &)
View=%view{ascii} antiword -t %f || catdoc -w %f || word2x -f text %f - || strings %f
type/^Microsoft\ Word
- Open=(abiword %f >/dev/null 2>&1 &)
+ Open=(xdg-open %f &)
+# Open=(abiword %f >/dev/null 2>&1 &)
View=%view{ascii} antiword -t %f || catdoc -w %f || word2x -f text %f - || strings %f
# RTF document
regex/\.([rR][tT][fF])$
- Open=(abiword %f >/dev/null 2>&1 &)
+ Open=(xdg-open %f &)
+# Open=(abiword %f >/dev/null 2>&1 &)
# Microsoft Excel Worksheet
regex/\.([xX][lL][sSwW])$
- Open=(gnumeric %f >/dev/null 2>&1 &)
+ Open=(xdg-open %f &)
+# Open=(gnumeric %f >/dev/null 2>&1 &)
View=%view{ascii} xls2csv %f || strings %f
type/^Microsoft\ Excel
- Open=(gnumeric %f >/dev/null 2>&1 &)
+ Open=(xdg-open %f &)
+# Open=(gnumeric %f >/dev/null 2>&1 &)
View=%view{ascii} xls2csv %f || strings %f
# Use OpenOffice.org to open any MS Office documents
@@ -584,7 +584,7 @@
# DjVu
regex/\.(djvu?|DJVU?)$
- Open=djview %f &
+ Open=(xdg-open %f || djview %f) &
View=%view{ascii} djvused -e print-pure-txt %f
### Miscellaneous ###

10
mc.spec
View File

@ -1,6 +1,6 @@
Summary: User-friendly text console file manager and visual shell
Name: mc
Version: 4.8.3
Version: 4.8.4
Release: 1%{?dist}
Epoch: 1
License: GPLv3+
@ -10,8 +10,6 @@ URL: http://www.midnight-commander.org/
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: glib2-devel e2fsprogs-devel slang-devel gpm-devel groff
Patch0: mc-extensions.patch
%description
Midnight Commander is a visual shell much like a file manager, only
with many more features. It is a text mode application, but it also
@ -21,7 +19,6 @@ specific files.
%prep
%setup -q
%patch0 -p1 -b .extensions
%build
export CFLAGS="-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE $RPM_OPT_FLAGS -Wno-strict-aliasing"
@ -58,6 +55,7 @@ rm -rf $RPM_BUILD_ROOT
%attr(711, root, root) %{_libexecdir}/mc/cons.saver
%{_libexecdir}/mc/mc*
%{_libexecdir}/mc/extfs.d/*
%{_libexecdir}/mc/ext.d/*
%{_libexecdir}/mc/fish/*
%{_mandir}/man1/*
%{_sysconfdir}/profile.d/*
@ -71,8 +69,12 @@ rm -rf $RPM_BUILD_ROOT
%dir %{_libexecdir}/mc
%dir %{_libexecdir}/mc/fish
%dir %{_libexecdir}/mc/extfs.d
%dir %{_libexecdir}/mc/ext.d
%changelog
* Tue Jul 18 2012 Jindrich Novy <jnovy@redhat.com> 4.8.4-1
- update to 4.8.4
* Mon Apr 23 2012 Jindrich Novy <jnovy@redhat.com> 1:4.8.3-1
- update to 4.8.3

View File

@ -1 +1 @@
1e29f8d2ce66b686b905857553a092be mc-4.8.3.tar.xz
eef6144d9f0331437e9a51adbb77c757 mc-4.8.4.tar.xz