diff --git a/mc-python3.patch b/mc-python3.patch
deleted file mode 100644
index ce06610..0000000
--- a/mc-python3.patch
+++ /dev/null
@@ -1,69 +0,0 @@
---- a/src/vfs/extfs/helpers/uc1541
-+++ b/src/vfs/extfs/helpers/uc1541
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
- """
- UC1541 Virtual filesystem
-
---- a/src/vfs/extfs/helpers/s3+.in (original)
-+++ b/src/vfs/extfs/helpers/s3+.in (refactored)
-@@ -153,16 +153,16 @@
- Propagates exception safely.
- """
- from threading import Thread
-- import Queue
-+ import queue
-
- items = list(iterable)
- nitems = len(items)
- if nitems < 2:
-- return map(fun, items)
-+ return list(map(fun, items))
-
- # Create and fill input queue
-- input = Queue.Queue()
-- output = Queue.Queue()
-+ input = queue.Queue()
-+ output = queue.Queue()
-
- for i,item in enumerate(items):
- input.put( (i,item) )
-@@ -181,7 +181,7 @@
- output.put( (i,result) )
- except:
- output.put( (None,sys.exc_info()) )
-- except Queue.Empty:
-+ except queue.Empty:
- return
-
- # Start threads
-@@ -196,8 +196,8 @@
- try:
- i,res = output.get()
- if i == None:
-- raise res[0],res[1],res[2]
-- except Queue.Empty:
-+ raise res[0](res[1]).with_traceback(res[2])
-+ except queue.Empty:
- break
- ret.append(res)
-
-@@ -241,7 +241,7 @@
- b = s3.get_bucket(name, validate=False)
- b.get_location() # just to raise an exception on error
- return b
-- except boto.exception.S3ResponseError, e:
-+ except boto.exception.S3ResponseError as e:
- # Seems this is the only proper way to switch to the bucket's region.
- # Requesting of the default region for "?location" does not work unfortunately.
- m = re.search(r'(.*?)', e.body)
-@@ -340,7 +340,7 @@
- expr = re.compile(r'^(\d{4})-(\d{2})-(\d{2})T(\d{2}):(\d{2}):(\d{2})\.\d{3}Z$')
- def convDate(awsdatetime):
- m = expr.match(awsdatetime)
-- ye,mo,da,ho,mi,se = map(int,m.groups())
-+ ye,mo,da,ho,mi,se = list(map(int,m.groups()))
-
- dt = datetime.datetime(ye,mo,da,ho,mi,se, tzinfo=pytz.utc)
- return dt.astimezone(tz).strftime('%m-%d-%Y %H:%M')
diff --git a/mc.spec b/mc.spec
index 24aa374..3f58061 100644
--- a/mc.spec
+++ b/mc.spec
@@ -5,14 +5,13 @@
Summary: User-friendly text console file manager and visual shell
Name: mc
Epoch: 1
-Version: 4.8.30
-Release: 4%{?dist}
+Version: 4.8.31
+Release: 1%{?dist}
License: GPL-3.0-or-later
URL: https://midnight-commander.org/
VCS: https://github.com/MidnightCommander/mc/
Source: %{VCS}/archive/%{version}/%{name}-%{version}.tar.gz
Patch: %{name}-spec.syntax.patch
-Patch: %{name}-python3.patch
Patch: %{name}-default_setup.patch
Patch: %{name}-tmpdir.patch
BuildRequires: autoconf
@@ -59,12 +58,11 @@ Midnight Commander s3+ and UC1541 EXTFS backend scripts.
PYTHON=%__python3 \
--disable-rpath \
--disable-vfs-sftp \
- --disable-vfs-smb \
--enable-charset \
--enable-largefile \
--enable-vfs-cpio \
--enable-vfs-extfs \
- --enable-vfs-fish \
+ --enable-vfs-shell \
--enable-vfs-ftp \
--enable-vfs-sfs \
--enable-vfs-tar \
@@ -95,7 +93,7 @@ Midnight Commander s3+ and UC1541 EXTFS backend scripts.
%{_libexecdir}/mc/mc*
%{_libexecdir}/mc/extfs.d
%{_libexecdir}/mc/ext.d
-%{_libexecdir}/mc/fish
+%{_libexecdir}/mc/shell
%{_datadir}/mc
%{_mandir}/man1/*
%exclude %{_libexecdir}/mc/extfs.d/{s3+,uc1541}
@@ -104,6 +102,12 @@ Midnight Commander s3+ and UC1541 EXTFS backend scripts.
%{_libexecdir}/mc/extfs.d/{s3+,uc1541}
%changelog
+* Mon Feb 12 2024 Jindrich Novy - 1:4.8.31-1
+- update to 4.8.31
+- drop upstreamed python3 patch
+- rename fish -> shell
+- drop obsolete smb option
+
* Tue Feb 06 2024 Yaakov Selkowitz - 1:4.8.30-4
- Disable gpm on ELN
diff --git a/sources b/sources
index 0ae7935..a915439 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-SHA512 (mc-4.8.30.tar.gz) = de11b3fae3a6ddebb74ed43a2d1061a9fb44771573f92167b7c3d82e30a97fc62752bf796a2d44f993fcb8652df55ee611324fc0e9c83bcd93e1f54311fece74
+SHA512 (mc-4.8.31.tar.gz) = 94a8fc12654c42d2fb89749f436155d5e4815181dd9ecd85b1585e5a259a658c17376c4bdaf24b619397ff3727ab65a1b87e04a8b60d8778dc0de14b4ad327ed