- don't preserve attributes in copy/move while the option is switched off
(#195614) - rebuild to fix iso9660 vfs because of missing gawk in buildroot(#381751, #363611)
This commit is contained in:
parent
9d9ed959fd
commit
910fbe258d
12
mc-preserveattr.patch
Normal file
12
mc-preserveattr.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -up mc-2007-06-04-22/src/file.c.preserveattr mc-2007-06-04-22/src/file.c
|
||||||
|
--- mc-2007-06-04-22/src/file.c.preserveattr 2007-11-14 14:45:23.000000000 +0100
|
||||||
|
+++ mc-2007-06-04-22/src/file.c 2007-11-14 14:45:23.000000000 +0100
|
||||||
|
@@ -800,7 +800,7 @@ copy_file_file (FileOpContext *ctx, cons
|
||||||
|
}
|
||||||
|
}
|
||||||
|
|
||||||
|
- if (!appending) {
|
||||||
|
+ if (!appending && ctx->preserve) {
|
||||||
|
while (mc_chmod (dst_path, (src_mode & ctx->umask_kill))) {
|
||||||
|
temp_status = file_error (
|
||||||
|
_(" Cannot chmod target file \"%s\" \n %s "), dst_path);
|
10
mc.spec
10
mc.spec
@ -3,7 +3,7 @@
|
|||||||
Summary: User-friendly text console file manager and visual shell
|
Summary: User-friendly text console file manager and visual shell
|
||||||
Name: mc
|
Name: mc
|
||||||
Version: 4.6.1a
|
Version: 4.6.1a
|
||||||
Release: 49.20070604cvs%{?dist}
|
Release: 50.20070604cvs%{?dist}
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
Group: System Environment/Shells
|
Group: System Environment/Shells
|
||||||
@ -30,6 +30,7 @@ Patch13: mc-newlinedir.patch
|
|||||||
Patch14: mc-cloexec.patch
|
Patch14: mc-cloexec.patch
|
||||||
Patch15: mc-prompt.patch
|
Patch15: mc-prompt.patch
|
||||||
Patch16: mc-refresh.patch
|
Patch16: mc-refresh.patch
|
||||||
|
Patch17: mc-preserveattr.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Midnight Commander is a visual shell much like a file manager, only
|
Midnight Commander is a visual shell much like a file manager, only
|
||||||
@ -58,6 +59,7 @@ specific files.
|
|||||||
%patch14 -p1 -b .cloexec
|
%patch14 -p1 -b .cloexec
|
||||||
%patch15 -p1 -b .prompt
|
%patch15 -p1 -b .prompt
|
||||||
%patch16 -p1 -b .refresh
|
%patch16 -p1 -b .refresh
|
||||||
|
%patch17 -p1 -b .preserveattr
|
||||||
|
|
||||||
# convert files in /lib to UTF-8
|
# convert files in /lib to UTF-8
|
||||||
pushd lib
|
pushd lib
|
||||||
@ -196,6 +198,12 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%dir %{_libexecdir}/mc
|
%dir %{_libexecdir}/mc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Nov 14 2007 Jindrich Novy <jnovy@redhat.com> 4.6.1a-50
|
||||||
|
- don't preserve attributes in copy/move while the option is
|
||||||
|
switched off (#195614)
|
||||||
|
- rebuild to fix iso9660 vfs because of missing gawk in
|
||||||
|
buildroot(#381751, #363611)
|
||||||
|
|
||||||
* Thu Aug 23 2007 Jindrich Novy <jnovy@redhat.com> 4.6.1a-49
|
* Thu Aug 23 2007 Jindrich Novy <jnovy@redhat.com> 4.6.1a-49
|
||||||
- update License
|
- update License
|
||||||
- rebuild for ppc32
|
- rebuild for ppc32
|
||||||
|
Loading…
Reference in New Issue
Block a user