Port configure script to C99
Related to: <https://fedoraproject.org/wiki/Changes/PortingToModernC> <https://fedoraproject.org/wiki/Toolchain/PortingToModernC>
This commit is contained in:
parent
9a7e7f7eea
commit
8f0d8878c8
18
mc-configure-c99.patch
Normal file
18
mc-configure-c99.patch
Normal file
@ -0,0 +1,18 @@
|
|||||||
|
Include <fcntl.h> for the declaration of posix_fallocate. This
|
||||||
|
avoids an implicit function declaration and build issues with future
|
||||||
|
compilers.
|
||||||
|
|
||||||
|
Submitted upstream: <https://midnight-commander.org/ticket/4438>
|
||||||
|
|
||||||
|
diff --git a/m4.include/mc-get-fs-info.m4 b/m4.include/mc-get-fs-info.m4
|
||||||
|
index 5afc9f1bb938bfcd..403045aadc810ba7 100644
|
||||||
|
--- a/m4.include/mc-get-fs-info.m4
|
||||||
|
+++ b/m4.include/mc-get-fs-info.m4
|
||||||
|
@@ -8,6 +8,7 @@ AC_DEFUN([gl_POSIX_FALLOCATE], [
|
||||||
|
AC_LINK_IFELSE([AC_LANG_PROGRAM([[
|
||||||
|
#define _XOPEN_SOURCE 600
|
||||||
|
#include <stdlib.h>
|
||||||
|
+ #include <fcntl.h>
|
||||||
|
#if defined(__GLIBC__) && (__GLIBC__ < 2 || __GLIBC_MINOR__ < 7)
|
||||||
|
possibly broken posix_fallocate
|
||||||
|
#endif
|
6
mc.spec
6
mc.spec
@ -5,7 +5,7 @@ Summary: User-friendly text console file manager and visual shell
|
|||||||
Name: mc
|
Name: mc
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 4.8.28
|
Version: 4.8.28
|
||||||
Release: 4%{?dist}
|
Release: 5%{?dist}
|
||||||
License: GPL-3.0-or-later
|
License: GPL-3.0-or-later
|
||||||
URL: https://midnight-commander.org/
|
URL: https://midnight-commander.org/
|
||||||
VCS: https://github.com/MidnightCommander/mc/
|
VCS: https://github.com/MidnightCommander/mc/
|
||||||
@ -15,6 +15,7 @@ Patch: %{name}-python3.patch
|
|||||||
Patch: %{name}-default_setup.patch
|
Patch: %{name}-default_setup.patch
|
||||||
Patch: %{name}-tmpdir.patch
|
Patch: %{name}-tmpdir.patch
|
||||||
Patch: %{VCS}/commit/34d3726b.patch#/%{name}-Ticket-4374-fix-file-sort-by-version.patch
|
Patch: %{VCS}/commit/34d3726b.patch#/%{name}-Ticket-4374-fix-file-sort-by-version.patch
|
||||||
|
Patch: mc-configure-c99.patch
|
||||||
BuildRequires: autoconf
|
BuildRequires: autoconf
|
||||||
BuildRequires: automake
|
BuildRequires: automake
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
@ -102,6 +103,9 @@ Midnight Commander s3+ and UC1541 EXTFS backend scripts.
|
|||||||
%{_libexecdir}/mc/extfs.d/{s3+,uc1541}
|
%{_libexecdir}/mc/extfs.d/{s3+,uc1541}
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Feb 05 2023 Florian Weimer <fweimer@redhat.com> - 1:4.8.28-5
|
||||||
|
- Port configure script to C99
|
||||||
|
|
||||||
* Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1:4.8.28-4
|
* Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1:4.8.28-4
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user