import mc-4.8.26-5.el9
This commit is contained in:
commit
6977c05226
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/4.8.26.tar.gz
|
1
.mc.metadata
Normal file
1
.mc.metadata
Normal file
@ -0,0 +1 @@
|
||||
d62a246b25c6e501c0553351d4c76c6dc69828fe SOURCES/4.8.26.tar.gz
|
13
SOURCES/mc-default_setup.patch
Normal file
13
SOURCES/mc-default_setup.patch
Normal file
@ -0,0 +1,13 @@
|
||||
--- mc-4.8.23.orig/src/setup.c 2019-06-16 18:49:31.000000000 +0100
|
||||
+++ mc-4.8.23/src/setup.c 2019-07-06 13:13:22.792243501 +0100
|
||||
@@ -138,8 +138,8 @@
|
||||
.fast_reload_msg_shown = FALSE,
|
||||
.mark_moves_down = TRUE,
|
||||
.reverse_files_only = TRUE,
|
||||
- .auto_save_setup = FALSE,
|
||||
- .navigate_with_arrows = FALSE,
|
||||
+ .auto_save_setup = TRUE,
|
||||
+ .navigate_with_arrows = TRUE,
|
||||
.scroll_pages = TRUE,
|
||||
.scroll_center = FALSE,
|
||||
.mouse_move_pages = TRUE,
|
70
SOURCES/mc-python3.patch
Normal file
70
SOURCES/mc-python3.patch
Normal file
@ -0,0 +1,70 @@
|
||||
diff -up mc-4.8.24/src/vfs/extfs/helpers/uc1541.python3 mc-4.8.24/src/vfs/extfs/helpers/uc1541
|
||||
--- mc-4.8.24/src/vfs/extfs/helpers/uc1541.python3 2020-01-20 14:40:30.637996501 +0100
|
||||
+++ mc-4.8.24/src/vfs/extfs/helpers/uc1541 2020-01-20 14:37:55.253442507 +0100
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/env python
|
||||
+#!/usr/bin/env python3
|
||||
"""
|
||||
UC1541 Virtual filesystem
|
||||
|
||||
--- a/src/vfs/extfs/helpers/s3+.in (original)
|
||||
+++ b/src/vfs/extfs/helpers/s3+.in (refactored)
|
||||
@@ -153,16 +153,16 @@
|
||||
Propagates exception safely.
|
||||
"""
|
||||
from threading import Thread
|
||||
- import Queue
|
||||
+ import queue
|
||||
|
||||
items = list(iterable)
|
||||
nitems = len(items)
|
||||
if nitems < 2:
|
||||
- return map(fun, items)
|
||||
+ return list(map(fun, items))
|
||||
|
||||
# Create and fill input queue
|
||||
- input = Queue.Queue()
|
||||
- output = Queue.Queue()
|
||||
+ input = queue.Queue()
|
||||
+ output = queue.Queue()
|
||||
|
||||
for i,item in enumerate(items):
|
||||
input.put( (i,item) )
|
||||
@@ -181,7 +181,7 @@
|
||||
output.put( (i,result) )
|
||||
except:
|
||||
output.put( (None,sys.exc_info()) )
|
||||
- except Queue.Empty:
|
||||
+ except queue.Empty:
|
||||
return
|
||||
|
||||
# Start threads
|
||||
@@ -196,8 +196,8 @@
|
||||
try:
|
||||
i,res = output.get()
|
||||
if i == None:
|
||||
- raise res[0],res[1],res[2]
|
||||
- except Queue.Empty:
|
||||
+ raise res[0](res[1]).with_traceback(res[2])
|
||||
+ except queue.Empty:
|
||||
break
|
||||
ret.append(res)
|
||||
|
||||
@@ -241,7 +241,7 @@
|
||||
b = s3.get_bucket(name, validate=False)
|
||||
b.get_location() # just to raise an exception on error
|
||||
return b
|
||||
- except boto.exception.S3ResponseError, e:
|
||||
+ except boto.exception.S3ResponseError as e:
|
||||
# Seems this is the only proper way to switch to the bucket's region.
|
||||
# Requesting of the default region for "?location" does not work unfortunately.
|
||||
m = re.search(r'<Region>(.*?)</Region>', e.body)
|
||||
@@ -340,7 +340,7 @@
|
||||
expr = re.compile(r'^(\d{4})-(\d{2})-(\d{2})T(\d{2}):(\d{2}):(\d{2})\.\d{3}Z$')
|
||||
def convDate(awsdatetime):
|
||||
m = expr.match(awsdatetime)
|
||||
- ye,mo,da,ho,mi,se = map(int,m.groups())
|
||||
+ ye,mo,da,ho,mi,se = list(map(int,m.groups()))
|
||||
|
||||
dt = datetime.datetime(ye,mo,da,ho,mi,se, tzinfo=pytz.utc)
|
||||
return dt.astimezone(tz).strftime('%m-%d-%Y %H:%M')
|
54
SOURCES/mc-spec.syntax.patch
Normal file
54
SOURCES/mc-spec.syntax.patch
Normal file
@ -0,0 +1,54 @@
|
||||
--- mc-4.8.23/misc/syntax/spec.syntax~ 2019-06-16 18:49:31.000000000 +0100
|
||||
+++ mc-4.8.23/misc/syntax/spec.syntax 2019-04-18 06:02:53.000000000 +0100
|
||||
@@ -5,25 +5,24 @@
|
||||
keyword whole Build\{Aa\}rch: green
|
||||
keyword whole Build\{Cc\}onflicts: green
|
||||
keyword whole Build\{Pp\}re\{Rr\}eq: green
|
||||
- keyword whole Build\{Rr\}oot: green
|
||||
+ keyword whole Build\{Rr\}oot: blue
|
||||
keyword whole Build\{Rr\}equires: green
|
||||
keyword whole Conflicts: green
|
||||
- keyword whole Copyright: white
|
||||
+ keyword whole Copyright: blue
|
||||
keyword whole Description: green
|
||||
- keyword whole Distribution: green
|
||||
- keyword whole Doc\{Dd\}ir: green
|
||||
+ keyword whole Distribution: blue
|
||||
+ keyword whole Doc\{Dd\}ir: blue
|
||||
keyword whole Epoch: green
|
||||
- keyword whole Enhances: green
|
||||
keyword whole Exclude\{Aa\}rch: green
|
||||
keyword whole Exclusive\{Aa\}rch: green
|
||||
keyword whole Exclusive\{Oo\}\{Ss\}: green
|
||||
- keyword whole Group: green
|
||||
+ keyword whole Group: blue
|
||||
keyword whole Icon: green
|
||||
keyword whole License: green
|
||||
keyword whole Name: green
|
||||
keyword whole NoSource\[0123456789\]: green
|
||||
keyword whole Obsoletes: green
|
||||
- keyword whole Packager: green
|
||||
+ keyword whole Packager: blue
|
||||
keyword whole Patch\[0123456789\]: green
|
||||
keyword whole Prefix: green
|
||||
keyword whole Pre\{Rr\}eq: green
|
||||
@@ -37,8 +36,8 @@
|
||||
keyword whole Source\[0123456789\]: green
|
||||
keyword whole Suggests: green
|
||||
keyword whole Summary: green
|
||||
- keyword whole Supplements: green
|
||||
- keyword whole Vendor: green
|
||||
+ keyword whole VCS: green
|
||||
+ keyword whole Vendor: blue
|
||||
keyword whole Version: green
|
||||
keyword whole U\{Rr\}\{Ll\}: green
|
||||
|
||||
@@ -92,7 +91,7 @@
|
||||
keyword whole PATCH\[0123456789\] cyan
|
||||
keyword whole SOURCE\[0123456789\] cyan
|
||||
|
||||
-context Group( ): green
|
||||
+context Group( ): blue
|
||||
keyword whole af yellow
|
||||
keyword whole az yellow
|
||||
keyword whole bg yellow
|
32
SOURCES/mc-tmpdir.patch
Normal file
32
SOURCES/mc-tmpdir.patch
Normal file
@ -0,0 +1,32 @@
|
||||
diff -up mc-4.8.24/contrib/mc-wrapper.sh.in.tmpdir mc-4.8.24/contrib/mc-wrapper.sh.in
|
||||
--- mc-4.8.24/contrib/mc-wrapper.sh.in.tmpdir 2020-01-27 09:17:46.815515791 +0100
|
||||
+++ mc-4.8.24/contrib/mc-wrapper.sh.in 2020-01-27 09:18:01.430712110 +0100
|
||||
@@ -1,5 +1,5 @@
|
||||
MC_USER=`whoami`
|
||||
-MC_PWD_FILE="${TMPDIR-/tmp}/mc-$MC_USER/mc.pwd.$$"
|
||||
+MC_PWD_FILE="${TMPDIR-/var/tmp}/mc-$MC_USER/mc.pwd.$$"
|
||||
@bindir@/mc -P "$MC_PWD_FILE" "$@"
|
||||
|
||||
if test -r "$MC_PWD_FILE"; then
|
||||
--- mc-4.8.21/lib/global.h~
|
||||
+++ mc-4.8.21/lib/global.h
|
||||
@@ -131,7 +131,7 @@
|
||||
#define PATH_SEP_STR "/"
|
||||
#define IS_PATH_SEP(c) ((c) == PATH_SEP)
|
||||
#define PATH_ENV_SEP ':'
|
||||
-#define TMPDIR_DEFAULT "/tmp"
|
||||
+#define TMPDIR_DEFAULT "/var/tmp"
|
||||
#define SCRIPT_SUFFIX ""
|
||||
#define get_default_editor() "vi"
|
||||
#define OS_SORT_CASE_SENSITIVE_DEFAULT TRUE
|
||||
--- mc-4.8.22/contrib/mc-wrapper.csh.in~
|
||||
+++ mc-4.8.22/contrib/mc-wrapper.csh.in
|
||||
@@ -3,7 +3,7 @@
|
||||
if ($?TMPDIR) then
|
||||
setenv MC_PWD_FILE $TMPDIR/mc-$MC_USER/mc.pwd.$$
|
||||
else
|
||||
- setenv MC_PWD_FILE /tmp/mc-$MC_USER/mc.pwd.$$
|
||||
+ setenv MC_PWD_FILE /var/tmp/mc-$MC_USER/mc.pwd.$$
|
||||
endif
|
||||
|
||||
@bindir@/mc -P "$MC_PWD_FILE" $*
|
1485
SPECS/mc.spec
Normal file
1485
SPECS/mc.spec
Normal file
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user