- update from CVS
- sync with .utf8 patch and some minor gcc4 fixups - add .fixes patch - drop upstreamed .spaceprompt patch - update .userhost, .64bit patch
This commit is contained in:
parent
b0e168a633
commit
65f3b0ed3f
@ -11,3 +11,4 @@ mc-4.6.1a-20050202.tar.bz2
|
|||||||
mc-4.6.1a-20050309.tar.bz2
|
mc-4.6.1a-20050309.tar.bz2
|
||||||
mc-4.6.1a-20050324.tar.bz2
|
mc-4.6.1a-20050324.tar.bz2
|
||||||
mc-4.6.1a-20050504.tar.bz2
|
mc-4.6.1a-20050504.tar.bz2
|
||||||
|
mc-4.6.1a-20050606.tar.bz2
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- mc-4.6.1-20041020/src/mountlist.c.64bit 2004-09-25 15:46:23.000000000 +0200
|
--- mc-4.6.1a/src/mountlist.c.64bit 2005-02-08 23:33:52.000000000 +0100
|
||||||
+++ mc-4.6.1-20041020/src/mountlist.c 2005-04-01 16:20:27.192132368 +0200
|
+++ mc-4.6.1a/src/mountlist.c 2005-05-10 17:09:24.122853504 +0200
|
||||||
@@ -132,11 +132,19 @@ struct mount_entry
|
@@ -131,11 +131,19 @@ struct mount_entry
|
||||||
|
|
||||||
struct fs_usage
|
struct fs_usage
|
||||||
{
|
{
|
||||||
@ -20,7 +20,7 @@
|
|||||||
};
|
};
|
||||||
|
|
||||||
static int get_fs_usage (char *path, struct fs_usage *fsp);
|
static int get_fs_usage (char *path, struct fs_usage *fsp);
|
||||||
@@ -663,6 +671,7 @@ my_statfs (struct my_statfs *myfs_stats,
|
@@ -665,6 +673,7 @@ my_statfs (struct my_statfs *myfs_stats,
|
||||||
BLOCKS FROMSIZE-byte blocks, rounding away from zero.
|
BLOCKS FROMSIZE-byte blocks, rounding away from zero.
|
||||||
TOSIZE must be positive. Return -1 if FROMSIZE is not positive. */
|
TOSIZE must be positive. Return -1 if FROMSIZE is not positive. */
|
||||||
|
|
||||||
@ -28,7 +28,7 @@
|
|||||||
static long
|
static long
|
||||||
fs_adjust_blocks (long blocks, int fromsize, int tosize)
|
fs_adjust_blocks (long blocks, int fromsize, int tosize)
|
||||||
{
|
{
|
||||||
@@ -670,13 +679,21 @@ fs_adjust_blocks (long blocks, int froms
|
@@ -672,13 +681,21 @@ fs_adjust_blocks (long blocks, int froms
|
||||||
abort ();
|
abort ();
|
||||||
if (fromsize <= 0)
|
if (fromsize <= 0)
|
||||||
return -1;
|
return -1;
|
||||||
@ -52,19 +52,8 @@
|
|||||||
}
|
}
|
||||||
|
|
||||||
#if defined(_AIX) && defined(_I386)
|
#if defined(_AIX) && defined(_I386)
|
||||||
@@ -773,9 +790,7 @@ get_fs_usage (char *path, struct fs_usag
|
--- mc-4.6.1a/acinclude.m4.64bit 2005-05-10 17:09:24.084859280 +0200
|
||||||
|
+++ mc-4.6.1a/acinclude.m4 2005-05-10 17:09:24.124853200 +0200
|
||||||
if (statvfs (path, &fsd) < 0)
|
|
||||||
return -1;
|
|
||||||
- /* f_frsize isn't guaranteed to be supported. */
|
|
||||||
-#define CONVERT_BLOCKS(b) \
|
|
||||||
- fs_adjust_blocks ((b), fsd.f_frsize ? fsd.f_frsize : fsd.f_bsize, 512)
|
|
||||||
+#define CONVERT_BLOCKS(b) fs_adjust_blocks ((b), fsd.f_frsize, 512)
|
|
||||||
#endif
|
|
||||||
|
|
||||||
#if defined(CONVERT_BLOCKS) && !defined(STAT_STATFS2_FS_DATA) && !defined(STAT_READ_FILSYS) /* !Ultrix && !SVR2. */
|
|
||||||
--- mc-4.6.1-20041020/acinclude.m4.64bit 2005-04-01 16:15:56.453290928 +0200
|
|
||||||
+++ mc-4.6.1-20041020/acinclude.m4 2005-04-01 16:15:56.525279984 +0200
|
|
||||||
@@ -501,7 +501,7 @@ dnl job is to detect a method to get fil
|
@@ -501,7 +501,7 @@ dnl job is to detect a method to get fil
|
||||||
if test $ac_cv_func_statvfs = yes; then
|
if test $ac_cv_func_statvfs = yes; then
|
||||||
space=yes
|
space=yes
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- mc-4.6.1-pre3/src/main.c.jn 2005-03-19 15:55:40.000000000 +0100
|
--- mc-4.6.1a/src/main.c.spaceprompt 2005-05-26 15:06:42.285109424 +0200
|
||||||
+++ mc-4.6.1-pre3/src/main.c 2005-03-19 17:04:10.000000000 +0100
|
+++ mc-4.6.1a/src/main.c 2005-05-26 15:15:15.964018360 +0200
|
||||||
@@ -1490,9 +1490,14 @@ midnight_callback (struct Dlg_head *h, d
|
@@ -1490,9 +1491,15 @@ midnight_callback (struct Dlg_head *h, d
|
||||||
if (parm == '\t')
|
if (parm == '\t')
|
||||||
free_completions (cmdline);
|
free_completions (cmdline);
|
||||||
|
|
||||||
@ -8,7 +8,8 @@
|
|||||||
- send_message ((Widget *) cmdline, WIDGET_KEY, parm);
|
- send_message ((Widget *) cmdline, WIDGET_KEY, parm);
|
||||||
- return MSG_HANDLED;
|
- return MSG_HANDLED;
|
||||||
+ if (parm == '\n') {
|
+ if (parm == '\n') {
|
||||||
+ for (i = 0; cmdline->buffer[i] && cmdline->buffer[i] == ' '; i++);
|
+ for (i = 0; cmdline->buffer[i] &&
|
||||||
|
+ (cmdline->buffer[i] == ' ' || cmdline->buffer[i] == '\t'); i++);
|
||||||
+ if (cmdline->buffer[i]) {
|
+ if (cmdline->buffer[i]) {
|
||||||
+ send_message ((Widget *) cmdline, WIDGET_KEY, parm);
|
+ send_message ((Widget *) cmdline, WIDGET_KEY, parm);
|
||||||
+ return MSG_HANDLED;
|
+ return MSG_HANDLED;
|
||||||
@ -18,7 +19,7 @@
|
|||||||
}
|
}
|
||||||
|
|
||||||
/* Ctrl-Enter and Alt-Enter */
|
/* Ctrl-Enter and Alt-Enter */
|
||||||
@@ -1527,7 +1532,7 @@ midnight_callback (struct Dlg_head *h, d
|
@@ -1527,7 +1534,7 @@ midnight_callback (struct Dlg_head *h, d
|
||||||
reverse_selection_cmd ();
|
reverse_selection_cmd ();
|
||||||
return MSG_HANDLED;
|
return MSG_HANDLED;
|
||||||
}
|
}
|
||||||
|
@ -1,5 +1,5 @@
|
|||||||
--- mc-4.6.1a/src/main.c.hostname 2005-03-23 13:59:31.198747928 +0100
|
--- mc-4.6.1a/src/main.c.userhost 2005-06-06 13:35:08.926427736 +0200
|
||||||
+++ mc-4.6.1a/src/main.c 2005-03-23 16:00:49.135333392 +0100
|
+++ mc-4.6.1a/src/main.c 2005-06-06 13:39:11.551543112 +0200
|
||||||
@@ -32,6 +32,7 @@
|
@@ -32,6 +32,7 @@
|
||||||
#include <sys/types.h>
|
#include <sys/types.h>
|
||||||
#include <sys/stat.h>
|
#include <sys/stat.h>
|
||||||
@ -8,26 +8,26 @@
|
|||||||
|
|
||||||
#include "global.h"
|
#include "global.h"
|
||||||
#include "tty.h"
|
#include "tty.h"
|
||||||
@@ -1612,9 +1613,22 @@ void
|
@@ -1611,9 +1612,22 @@ void
|
||||||
update_xterm_title_path (void)
|
update_xterm_title_path (void)
|
||||||
{
|
{
|
||||||
unsigned char *p, *s;
|
char *p, *s;
|
||||||
+ char h[64];
|
+ char h[64];
|
||||||
+ struct passwd *pw;
|
+ struct passwd *pw;
|
||||||
|
|
||||||
if (xterm_flag && xterm_title) {
|
if (xterm_flag && xterm_title) {
|
||||||
p = s = g_strdup (strip_home_and_password (current_panel->cwd));
|
p = s = g_strdup (strip_home_and_password (current_panel->cwd));
|
||||||
+ if ( !gethostname (h, 64) ) {
|
+ if ( !gethostname (h, 64) ) {
|
||||||
+ h[63] = '\0'; /* Be sure the hostname is NUL terminated */
|
+ h[63] = '\0'; /* Be sure the hostname is NUL terminated */
|
||||||
+ s = g_strdup_printf ("%s:%s", h, s);
|
+ s = g_strdup_printf ("%s:%s", h, s);
|
||||||
+ g_free (p);
|
+ g_free (p);
|
||||||
+ p = s;
|
+ p = s;
|
||||||
+ }
|
+ }
|
||||||
+ if ( (pw = getpwuid(getuid())) ) {
|
+ if ( (pw = getpwuid(getuid())) ) {
|
||||||
+ s = g_strdup_printf ("%s@%s", pw->pw_name, s);
|
+ s = g_strdup_printf ("%s@%s", pw->pw_name, s);
|
||||||
+ g_free (p);
|
+ g_free (p);
|
||||||
+ p = s;
|
+ p = s;
|
||||||
+ }
|
+ }
|
||||||
do {
|
do {
|
||||||
if (*s < ' ')
|
#ifndef UTF8
|
||||||
*s = '?';
|
if (!is_printable ((unsigned char) *s))
|
||||||
|
704
mc-utf8.patch
704
mc-utf8.patch
File diff suppressed because it is too large
Load Diff
25
mc.spec
25
mc.spec
@ -1,12 +1,12 @@
|
|||||||
Summary: User-friendly text console file manager and visual shell.
|
Summary: User-friendly text console file manager and visual shell.
|
||||||
Name: mc
|
Name: mc
|
||||||
Version: 4.6.1a
|
Version: 4.6.1a
|
||||||
Release: 0.9
|
Release: 0.10
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
License: GPL
|
License: GPL
|
||||||
Group: System Environment/Shells
|
Group: System Environment/Shells
|
||||||
#Source0: http://www.ibiblio.org/pub/Linux/utils/file/managers/mc/mc-%{version}.tar.gz
|
#Source0: http://www.ibiblio.org/pub/Linux/utils/file/managers/mc/mc-%{version}.tar.gz
|
||||||
%define date 20050504
|
%define date 20050606
|
||||||
Source0: mc-%{version}-%{date}.tar.bz2
|
Source0: mc-%{version}-%{date}.tar.bz2
|
||||||
URL: http://www.ibiblio.org/mc/
|
URL: http://www.ibiblio.org/mc/
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
@ -19,9 +19,9 @@ Patch1: mc-extensions.patch
|
|||||||
Patch2: mc-promptfix.patch
|
Patch2: mc-promptfix.patch
|
||||||
Patch3: mc-uglydir.patch
|
Patch3: mc-uglydir.patch
|
||||||
Patch4: mc-fish-upload.patch
|
Patch4: mc-fish-upload.patch
|
||||||
Patch5: mc-spaceprompt.patch
|
Patch5: mc-userhost.patch
|
||||||
Patch6: mc-userhost.patch
|
Patch6: mc-64bit.patch
|
||||||
Patch7: mc-64bit.patch
|
Patch7: mc-fixes.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Midnight Commander is a visual shell much like a file manager, only
|
Midnight Commander is a visual shell much like a file manager, only
|
||||||
@ -38,9 +38,9 @@ poke into RPMs for specific files.
|
|||||||
%patch2 -p1 -b .promptfix
|
%patch2 -p1 -b .promptfix
|
||||||
%patch3 -p1 -b .uglydir
|
%patch3 -p1 -b .uglydir
|
||||||
%patch4 -p1 -b .fish-upload
|
%patch4 -p1 -b .fish-upload
|
||||||
%patch5 -p1 -b .spaceprompt
|
%patch5 -p1 -b .userhost
|
||||||
%patch6 -p1 -b .userhost
|
%patch6 -p1 -b .64bit
|
||||||
%patch7 -p1 -b .64bit
|
%patch7 -p1 -b .fixes
|
||||||
|
|
||||||
# convert files in /lib to UTF-8
|
# convert files in /lib to UTF-8
|
||||||
pushd lib
|
pushd lib
|
||||||
@ -102,7 +102,7 @@ done
|
|||||||
popd
|
popd
|
||||||
|
|
||||||
%build
|
%build
|
||||||
export CFLAGS="-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE $RPM_OPT_FLAGS -Wno-pointer-sign"
|
export CFLAGS="-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE $RPM_OPT_FLAGS"
|
||||||
%configure --with-screen=slang \
|
%configure --with-screen=slang \
|
||||||
--host=%{_host} --build=%{_build} \
|
--host=%{_host} --build=%{_build} \
|
||||||
--target=%{_target_platform} \
|
--target=%{_target_platform} \
|
||||||
@ -174,6 +174,13 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%dir %{_datadir}/mc
|
%dir %{_datadir}/mc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jun 06 2005 Jindrich Novy <jnovy@redhat.com> 4.6.1a-0.10
|
||||||
|
- update from CVS
|
||||||
|
- sync with .utf8 patch and some minor gcc4 fixups
|
||||||
|
- add .fixes patch
|
||||||
|
- drop upstreamed .spaceprompt patch
|
||||||
|
- update .userhost, .64bit patch
|
||||||
|
|
||||||
* Thu May 04 2005 Jindrich Novy <jnovy@redhat.com> 4.6.1a-0.9
|
* Thu May 04 2005 Jindrich Novy <jnovy@redhat.com> 4.6.1a-0.9
|
||||||
- update from CVS
|
- update from CVS
|
||||||
- sync with .utf8 patch
|
- sync with .utf8 patch
|
||||||
|
Loading…
Reference in New Issue
Block a user