- update to mc-4.6.1-pre5
- sync .utf8, .userhost patch - drop upstreamed .fixes patch
This commit is contained in:
parent
a2909d6cfc
commit
556d3c027b
@ -12,3 +12,4 @@ mc-4.6.1a-20050309.tar.bz2
|
||||
mc-4.6.1a-20050324.tar.bz2
|
||||
mc-4.6.1a-20050504.tar.bz2
|
||||
mc-4.6.1a-20050606.tar.bz2
|
||||
mc-4.6.1-pre5.tar.bz2
|
||||
|
@ -1,17 +1,17 @@
|
||||
--- mc-4.6.1a/src/main.c.userhost 2005-06-06 13:35:08.926427736 +0200
|
||||
+++ mc-4.6.1a/src/main.c 2005-06-06 13:39:11.551543112 +0200
|
||||
@@ -32,6 +32,7 @@
|
||||
#include <sys/types.h>
|
||||
#include <sys/stat.h>
|
||||
#include <unistd.h>
|
||||
+#include <pwd.h>
|
||||
--- mc-4.6.1-pre5/src/main.c.userhost 2005-07-08 11:04:37.718907992 +0200
|
||||
+++ mc-4.6.1-pre5/src/main.c 2005-07-08 11:07:53.888085744 +0200
|
||||
@@ -33,6 +33,7 @@
|
||||
# include <unistd.h>
|
||||
#endif
|
||||
|
||||
#include "global.h"
|
||||
#include "tty.h"
|
||||
@@ -1611,9 +1612,22 @@ void
|
||||
+#include <pwd.h>
|
||||
#include <errno.h>
|
||||
#include <ctype.h>
|
||||
#include <signal.h>
|
||||
@@ -1607,9 +1608,22 @@ void
|
||||
update_xterm_title_path (void)
|
||||
{
|
||||
char *p, *s;
|
||||
unsigned char *p, *s;
|
||||
+ char h[64];
|
||||
+ struct passwd *pw;
|
||||
|
||||
@ -30,4 +30,4 @@
|
||||
+ }
|
||||
do {
|
||||
#ifndef UTF8
|
||||
if (!is_printable ((unsigned char) *s))
|
||||
if (!is_printable (*s))
|
||||
|
1011
mc-utf8.patch
1011
mc-utf8.patch
File diff suppressed because it is too large
Load Diff
15
mc.spec
15
mc.spec
@ -1,13 +1,11 @@
|
||||
Summary: User-friendly text console file manager and visual shell.
|
||||
Name: mc
|
||||
Version: 4.6.1a
|
||||
Release: 0.10
|
||||
Release: 0.11
|
||||
Epoch: 1
|
||||
License: GPL
|
||||
Group: System Environment/Shells
|
||||
#Source0: http://www.ibiblio.org/pub/Linux/utils/file/managers/mc/mc-%{version}.tar.gz
|
||||
%define date 20050606
|
||||
Source0: mc-%{version}-%{date}.tar.bz2
|
||||
Source0: http://www.ibiblio.org/pub/Linux/utils/file/managers/mc/mc-4.6.1-pre5.tar.bz2
|
||||
URL: http://www.ibiblio.org/mc/
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
BuildRequires: gpm-devel, slang-devel, glib2-devel
|
||||
@ -21,7 +19,6 @@ Patch3: mc-uglydir.patch
|
||||
Patch4: mc-fish-upload.patch
|
||||
Patch5: mc-userhost.patch
|
||||
Patch6: mc-64bit.patch
|
||||
Patch7: mc-fixes.patch
|
||||
|
||||
%description
|
||||
Midnight Commander is a visual shell much like a file manager, only
|
||||
@ -31,7 +28,7 @@ best features are its ability to FTP, view tar and zip files, and to
|
||||
poke into RPMs for specific files.
|
||||
|
||||
%prep
|
||||
%setup -q -n mc-%{version}
|
||||
%setup -q -n %{name}-4.6.1-pre5
|
||||
|
||||
%patch0 -p1 -b .utf8
|
||||
%patch1 -p1 -b .extensions
|
||||
@ -40,7 +37,6 @@ poke into RPMs for specific files.
|
||||
%patch4 -p1 -b .fish-upload
|
||||
%patch5 -p1 -b .userhost
|
||||
%patch6 -p1 -b .64bit
|
||||
%patch7 -p1 -b .fixes
|
||||
|
||||
# convert files in /lib to UTF-8
|
||||
pushd lib
|
||||
@ -175,6 +171,11 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%dir %{_datadir}/mc
|
||||
|
||||
%changelog
|
||||
* Fri Jul 08 2005 Jindrich Novy <jnovy@redhat.com> 4.6.1a-0.11
|
||||
- update to mc-4.6.1-pre5
|
||||
- sync .utf8, .userhost patch
|
||||
- drop upstreamed .fixes patch
|
||||
|
||||
* Wed Jun 06 2005 Jindrich Novy <jnovy@redhat.com> 4.6.1a-0.10
|
||||
- update from CVS
|
||||
- sync with .utf8 patch and some minor gcc4 fixups
|
||||
|
Loading…
Reference in New Issue
Block a user