- fix IPv6 FISH support
- use better UTF-8 characters for scrollbars
This commit is contained in:
parent
a7efa23441
commit
49c5cabea2
@ -386,3 +386,28 @@
|
|||||||
#define OPT_FLUSH 1
|
#define OPT_FLUSH 1
|
||||||
#define OPT_IGNORE_ERROR 2
|
#define OPT_IGNORE_ERROR 2
|
||||||
|
|
||||||
|
--- mc-2006-08-12-18/vfs/utilvfs.c.ipv6 2006-01-30 18:01:58.000000000 +0100
|
||||||
|
+++ mc-2006-08-12-18/vfs/utilvfs.c 2010-12-14 20:41:09.000000000 +0100
|
||||||
|
@@ -109,7 +109,21 @@ vfs_split_url (const char *path, char **
|
||||||
|
}
|
||||||
|
|
||||||
|
/* Check if the host comes with a port spec, if so, chop it */
|
||||||
|
- colon = strchr (rest, ':');
|
||||||
|
+ if ('[' == *rest) {
|
||||||
|
+ colon = strchr (++rest, ']');
|
||||||
|
+ if (colon) {
|
||||||
|
+ colon[0] = '\0';
|
||||||
|
+ colon[1] = '\0';
|
||||||
|
+ colon++;
|
||||||
|
+ } else {
|
||||||
|
+ g_free (pcopy);
|
||||||
|
+ *host = NULL;
|
||||||
|
+ *port = 0;
|
||||||
|
+ return NULL;
|
||||||
|
+ }
|
||||||
|
+ } else
|
||||||
|
+ colon = strchr (rest, ':');
|
||||||
|
+
|
||||||
|
if (colon) {
|
||||||
|
*colon = 0;
|
||||||
|
if (sscanf (colon + 1, "%d", port) == 1) {
|
||||||
|
@ -78,7 +78,7 @@
|
|||||||
+#else
|
+#else
|
||||||
+ if (color) attrset (MARKED_COLOR);
|
+ if (color) attrset (MARKED_COLOR);
|
||||||
+ if (is_utf8)
|
+ if (is_utf8)
|
||||||
+ SLsmg_write_string("▴");
|
+ SLsmg_write_string("↑");
|
||||||
+ else
|
+ else
|
||||||
+ addch ('^');
|
+ addch ('^');
|
||||||
+ if (color) attrset (NORMAL_COLOR);
|
+ if (color) attrset (NORMAL_COLOR);
|
||||||
@ -98,7 +98,7 @@
|
|||||||
+#else
|
+#else
|
||||||
+ if (color) attrset (MARKED_COLOR);
|
+ if (color) attrset (MARKED_COLOR);
|
||||||
+ if (is_utf8)
|
+ if (is_utf8)
|
||||||
+ SLsmg_write_string("▾");
|
+ SLsmg_write_string("↓");
|
||||||
else
|
else
|
||||||
- addch ('v');
|
- addch ('v');
|
||||||
+ addch('v');
|
+ addch('v');
|
||||||
@ -136,7 +136,7 @@
|
|||||||
+ else {
|
+ else {
|
||||||
+ if (color) attrset (MARKED_COLOR);
|
+ if (color) attrset (MARKED_COLOR);
|
||||||
+ if (is_utf8)
|
+ if (is_utf8)
|
||||||
+ SLsmg_write_string("◈");
|
+ SLsmg_write_string("▮");
|
||||||
+ else
|
+ else
|
||||||
+ addch('*');
|
+ addch('*');
|
||||||
+ if (color) attrset (NORMAL_COLOR);
|
+ if (color) attrset (NORMAL_COLOR);
|
||||||
|
8
mc.spec
8
mc.spec
@ -1,9 +1,9 @@
|
|||||||
%define date 2006-09-25-14
|
%define date 2006-10-15-16
|
||||||
|
|
||||||
Summary: User-friendly text console file manager and visual shell
|
Summary: User-friendly text console file manager and visual shell
|
||||||
Name: mc
|
Name: mc
|
||||||
Version: 4.6.1a
|
Version: 4.6.1a
|
||||||
Release: 31%{?dist}
|
Release: 32%{?dist}
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
License: GPL
|
License: GPL
|
||||||
Group: System Environment/Shells
|
Group: System Environment/Shells
|
||||||
@ -198,6 +198,10 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%dir %{_sysconfdir}/mc
|
%dir %{_sysconfdir}/mc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Oct 27 2006 Jindrich Novy <jnovy@redhat.com> 4.6.1a-32
|
||||||
|
- fix IPv6 FISH support
|
||||||
|
- use better UTF-8 characters for scrollbars
|
||||||
|
|
||||||
* Tue Oct 10 2006 Jindrich Novy <jnovy@redhat.com> 4.6.1a-31
|
* Tue Oct 10 2006 Jindrich Novy <jnovy@redhat.com> 4.6.1a-31
|
||||||
- update to new CVS snapshot
|
- update to new CVS snapshot
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user