- update to 4.7.2

- remove patches applied upstream
This commit is contained in:
Jindrich Novy 2010-05-06 04:38:34 +00:00
parent 2ed07ce7d8
commit 3c576744e5
5 changed files with 9 additions and 56 deletions

View File

@ -1 +1 @@
mc-4.7.1.tar.lzma
mc-4.7.2.tar.lzma

View File

@ -1,21 +0,0 @@
commit 7b9226c5da3a81fb758bee70aafe05bb64d37464
Author: Andrew Borodin <aborodin@vmail.ru>
Date: Sun Feb 28 18:19:52 2010 +0300
Ticket #2068: fixed segfault in panelization of file find result.
Signed-off-by: Andrew Borodin <aborodin@vmail.ru>
diff --git a/src/find.c b/src/find.c
index dc38e5f..883cb07 100644
--- a/src/find.c
+++ b/src/find.c
@@ -1255,7 +1255,7 @@ find_file (const char *start_dir, const char *pattern, const char *content,
const char *lc_filename = NULL;
WLEntry *le = (WLEntry *) entry->data;
- if ((le->text == NULL) || (entry->data == NULL))
+ if ((le->text == NULL) || (le->data == NULL))
continue;
if (content_pattern != NULL)

View File

@ -1,27 +0,0 @@
commit d2a9152cec8db6d21af77bb91490666a85e48d55
Author: Andrew Borodin <aborodin@vmail.ru>
Date: Sat Mar 6 11:08:18 2010 +0300
Ticket #2087: crash in standalone editor and viewer.
Don't try update file manager panels if mc runs as standalone editor or viewer.
Signed-off-by: Andrew Borodin <aborodin@vmail.ru>
diff --git a/src/execute.c b/src/execute.c
index e8f9ad3..16c0898 100644
--- a/src/execute.c
+++ b/src/execute.c
@@ -304,8 +304,10 @@ toggle_panels (void)
}
#endif /* HAVE_SUBSHELL_SUPPORT */
- update_panels (UP_OPTIMIZE, UP_KEEPSEL);
- update_xterm_title_path ();
+ if ((view_one_file == NULL) && (edit_one_file == NULL)) {
+ update_panels (UP_OPTIMIZE, UP_KEEPSEL);
+ update_xterm_title_path ();
+ }
repaint_screen ();
}

13
mc.spec
View File

@ -1,7 +1,7 @@
Summary: User-friendly text console file manager and visual shell
Name: mc
Version: 4.7.1
Release: 3%{?dist}
Version: 4.7.2
Release: 1%{?dist}
Epoch: 1
License: GPLv2
Group: System Environment/Shells
@ -13,8 +13,6 @@ BuildRequires: glib2-devel e2fsprogs-devel slang-devel gpm-devel
Requires: dev >= 3.3-3
Patch0: mc-extensions.patch
Patch1: mc-findfix.patch
Patch2: mc-mceditcrash.patch
%description
Midnight Commander is a visual shell much like a file manager, only
@ -26,8 +24,6 @@ specific files.
%prep
%setup -q
%patch0 -p1 -b .extensions
%patch1 -p1 -b .findfix
%patch2 -p1 -b .mceditcrash
%build
export CFLAGS="-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE $RPM_OPT_FLAGS"
@ -60,6 +56,7 @@ rm -rf $RPM_BUILD_ROOT
%{_bindir}/mcedit
%{_bindir}/mcmfmt
%{_bindir}/mcview
%{_bindir}/mcdiff
%{_datadir}/mc/*
%attr(4711, vcsa, root) %{_libexecdir}/mc/cons.saver
%{_libexecdir}/mc/mc*
@ -86,6 +83,10 @@ rm -rf $RPM_BUILD_ROOT
%dir %{_libexecdir}/mc/extfs.d
%changelog
* Thu May 6 2010 Jindrich Novy <jnovy@redhat.com> 4.7.2-1
- update to 4.7.2
- remove patches applied upstream
* Thu Mar 18 2010 Jindrich Novy <jnovy@redhat.com> 4.7.1-3
- patches from upstream:
- fix crash in mcedit ran stand-alone (#571570)

View File

@ -1 +1 @@
dca7e2392d66e6fc6cce9c43c5fbe48e mc-4.7.1.tar.lzma
8e0c477b0c55123942b4b60827a44058 mc-4.7.2.tar.lzma