- display the Layout dialog correctly on console (#185189)
This commit is contained in:
parent
1ee97a48be
commit
392e264b10
@ -237,3 +237,39 @@
|
|||||||
|
|
||||||
extern int horizontal_split;
|
extern int horizontal_split;
|
||||||
extern int nice_rotating_dash;
|
extern int nice_rotating_dash;
|
||||||
|
--- mc-4.6.1a/src/layout.c.jn 2006-03-16 10:20:31.000000000 +0100
|
||||||
|
+++ mc-4.6.1a/src/layout.c 2006-03-16 10:23:14.000000000 +0100
|
||||||
|
@@ -296,9 +296,9 @@ layout_callback (struct Dlg_head *h, dlg
|
||||||
|
if (old_output_lines != _output_lines){
|
||||||
|
old_output_lines = _output_lines;
|
||||||
|
attrset (COLOR_NORMAL);
|
||||||
|
- dlg_move (h, 9, 16 + first_width);
|
||||||
|
+ dlg_move (h, 10, 16 + first_width);
|
||||||
|
addstr (output_lines_label);
|
||||||
|
- dlg_move (h, 9, 10 + first_width);
|
||||||
|
+ dlg_move (h, 10, 10 + first_width);
|
||||||
|
tty_printf ("%02d", _output_lines);
|
||||||
|
}
|
||||||
|
}
|
||||||
|
@@ -341,7 +341,7 @@ layout_callback (struct Dlg_head *h, dlg
|
||||||
|
if (old_output_lines != _output_lines){
|
||||||
|
old_output_lines = _output_lines;
|
||||||
|
attrset (COLOR_NORMAL);
|
||||||
|
- dlg_move (h, 9, 10 + first_width);
|
||||||
|
+ dlg_move (h, 10, 10 + first_width);
|
||||||
|
tty_printf ("%02d", _output_lines);
|
||||||
|
}
|
||||||
|
}
|
||||||
|
@@ -452,10 +452,10 @@ init_layout (void)
|
||||||
|
0));
|
||||||
|
if (console_flag) {
|
||||||
|
add_widget (layout_dlg,
|
||||||
|
- button_new (9, 12 + first_width, B_MINUS,
|
||||||
|
+ button_new (10, 12 + first_width, B_MINUS,
|
||||||
|
NARROW_BUTTON, "&-", bminus_cback));
|
||||||
|
add_widget (layout_dlg,
|
||||||
|
- button_new (9, 7 + first_width, B_PLUS, NARROW_BUTTON,
|
||||||
|
+ button_new (10, 7 + first_width, B_PLUS, NARROW_BUTTON,
|
||||||
|
"&+", bplus_cback));
|
||||||
|
}
|
||||||
|
#define XTRACT(i) *check_options[i].variable, check_options[i].text
|
||||||
|
5
mc.spec
5
mc.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: User-friendly text console file manager and visual shell.
|
Summary: User-friendly text console file manager and visual shell.
|
||||||
Name: mc
|
Name: mc
|
||||||
Version: 4.6.1a
|
Version: 4.6.1a
|
||||||
Release: 10
|
Release: 11
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
License: GPL
|
License: GPL
|
||||||
Group: System Environment/Shells
|
Group: System Environment/Shells
|
||||||
@ -192,6 +192,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%dir %{_sysconfdir}/mc
|
%dir %{_sysconfdir}/mc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Mar 16 2006 Jindrich Novy <jnovy@redhat.com> 4.6.1a-11
|
||||||
|
- display the Layout dialog correctly on console (#185189)
|
||||||
|
|
||||||
* Wed Mar 8 2006 Jindrich Novy <jnovy@redhat.com> 4.6.1a-10
|
* Wed Mar 8 2006 Jindrich Novy <jnovy@redhat.com> 4.6.1a-10
|
||||||
- fix typo in extensions patch so that C sources are
|
- fix typo in extensions patch so that C sources are
|
||||||
highlighted correctly (#184228)
|
highlighted correctly (#184228)
|
||||||
|
Loading…
Reference in New Issue
Block a user