fix segfault when creating symlinks
This commit is contained in:
parent
336c92dd28
commit
2def6e5d30
@ -1,6 +1,5 @@
|
|||||||
--- mc-4.6.1-pre5/edit/editdraw.c.utf8 2005-05-27 16:19:18.000000000 +0200
|
--- mc-4.6.1-pre5/edit/editdraw.c.utf8 2005-05-27 16:19:18.000000000 +0200
|
||||||
+++ mc-4.6.1-pre5/edit/editdraw.c 2005-07-08 11:22:41.891088768 +0200
|
+++ mc-4.6.1-pre5/edit/editdraw.c 2005-07-08 11:22:41.891088768 +0200
|
||||||
@@ -48,7 +48,7 @@
|
|
||||||
|
|
||||||
static void status_string (WEdit * edit, char *s, int w)
|
static void status_string (WEdit * edit, char *s, int w)
|
||||||
{
|
{
|
||||||
|
8
mc.spec
8
mc.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: User-friendly text console file manager and visual shell.
|
Summary: User-friendly text console file manager and visual shell.
|
||||||
Name: mc
|
Name: mc
|
||||||
Version: 4.6.1a
|
Version: 4.6.1a
|
||||||
Release: 0.14
|
Release: 0.15
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
License: GPL
|
License: GPL
|
||||||
Group: System Environment/Shells
|
Group: System Environment/Shells
|
||||||
@ -23,6 +23,7 @@ Patch7: mc-gcc4.patch
|
|||||||
Patch8: mc-ftpcrash.patch
|
Patch8: mc-ftpcrash.patch
|
||||||
Patch9: mc-specsyntax.patch
|
Patch9: mc-specsyntax.patch
|
||||||
Patch10: mc-find.patch
|
Patch10: mc-find.patch
|
||||||
|
Patch11: mc-symcrash.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Midnight Commander is a visual shell much like a file manager, only
|
Midnight Commander is a visual shell much like a file manager, only
|
||||||
@ -45,6 +46,7 @@ poke into RPMs for specific files.
|
|||||||
%patch8 -p1 -b .ftpcrash
|
%patch8 -p1 -b .ftpcrash
|
||||||
%patch9 -p1 -b .specsyntax
|
%patch9 -p1 -b .specsyntax
|
||||||
%patch10 -p1 -b .find
|
%patch10 -p1 -b .find
|
||||||
|
%patch11 -p1 -b .symcrash
|
||||||
|
|
||||||
# convert files in /lib to UTF-8
|
# convert files in /lib to UTF-8
|
||||||
pushd lib
|
pushd lib
|
||||||
@ -181,6 +183,10 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%dir %{_datadir}/mc
|
%dir %{_datadir}/mc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Sep 13 2005 Jindrich Novy <jnovy@redhat.com> 4.6.1a-0.15
|
||||||
|
- fix segfault when creating symlinks of a particular type and
|
||||||
|
fix creation of dangled symlinks (#168184)
|
||||||
|
|
||||||
* Mon Sep 5 2005 Jindrich Novy <jnovy@redhat.com> 4.6.1a-0.14
|
* Mon Sep 5 2005 Jindrich Novy <jnovy@redhat.com> 4.6.1a-0.14
|
||||||
- backport the new Find dialog from upstream (#167493)
|
- backport the new Find dialog from upstream (#167493)
|
||||||
- disable Xorg usage and drop the dependency
|
- disable Xorg usage and drop the dependency
|
||||||
|
Loading…
Reference in New Issue
Block a user