fix crash in progress bar handling (#643256)
This commit is contained in:
parent
de6a03561c
commit
23cdb05772
12
mc-fileguicrash.patch
Normal file
12
mc-fileguicrash.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -up mc-4.7.5-pre1/src/filemanager/filegui.c.fileguicrash mc-4.7.5-pre1/src/filemanager/filegui.c
|
||||||
|
--- mc-4.7.5-pre1/src/filemanager/filegui.c.fileguicrash 2010-12-06 12:03:56.000000000 +0100
|
||||||
|
+++ mc-4.7.5-pre1/src/filemanager/filegui.c 2010-12-09 08:12:33.452156885 +0100
|
||||||
|
@@ -617,7 +617,7 @@ file_op_context_create_ui_without_init (
|
||||||
|
if ((right_panel == current_panel) && !classic_progressbar)
|
||||||
|
{
|
||||||
|
ui->progress_file_gauge->from_left_to_right = FALSE;
|
||||||
|
- if (dialog_type == FILEGUI_DIALOG_MULTI_ITEM)
|
||||||
|
+ if (verbose && dialog_type == FILEGUI_DIALOG_MULTI_ITEM)
|
||||||
|
ui->progress_total_gauge->from_left_to_right = FALSE;
|
||||||
|
}
|
||||||
|
}
|
7
mc.spec
7
mc.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: User-friendly text console file manager and visual shell
|
Summary: User-friendly text console file manager and visual shell
|
||||||
Name: mc
|
Name: mc
|
||||||
Version: 4.7.5
|
Version: 4.7.5
|
||||||
Release: 0.2.pre1%{?dist}
|
Release: 0.3.pre1%{?dist}
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
Group: System Environment/Shells
|
Group: System Environment/Shells
|
||||||
@ -15,6 +15,7 @@ Requires: dev >= 3.3-3
|
|||||||
Patch0: mc-extensions.patch
|
Patch0: mc-extensions.patch
|
||||||
Patch1: mc-mcviewsegfault.patch
|
Patch1: mc-mcviewsegfault.patch
|
||||||
Patch2: mc-vfscrash.patch
|
Patch2: mc-vfscrash.patch
|
||||||
|
Patch3: mc-fileguicrash.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Midnight Commander is a visual shell much like a file manager, only
|
Midnight Commander is a visual shell much like a file manager, only
|
||||||
@ -28,6 +29,7 @@ specific files.
|
|||||||
%patch0 -p1 -b .extensions
|
%patch0 -p1 -b .extensions
|
||||||
%patch1 -p1 -b .mcviewsegfault
|
%patch1 -p1 -b .mcviewsegfault
|
||||||
%patch2 -p1 -b .vfscrash
|
%patch2 -p1 -b .vfscrash
|
||||||
|
%patch3 -p1 -b .fileguicrash
|
||||||
|
|
||||||
%build
|
%build
|
||||||
export CFLAGS="-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE $RPM_OPT_FLAGS -Wno-strict-aliasing"
|
export CFLAGS="-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE $RPM_OPT_FLAGS -Wno-strict-aliasing"
|
||||||
@ -85,6 +87,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%dir %{_libexecdir}/mc/extfs.d
|
%dir %{_libexecdir}/mc/extfs.d
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Dec 9 2010 Jindrich Novy <jnovy@redhat.com> 4.7.5-0.3.pre1
|
||||||
|
- fix crash in progress bar handling (#643256)
|
||||||
|
|
||||||
* Wed Dec 8 2010 Jindrich Novy <jnovy@redhat.com> 4.7.5-0.2.pre1
|
* Wed Dec 8 2010 Jindrich Novy <jnovy@redhat.com> 4.7.5-0.2.pre1
|
||||||
- fix crash in opening mc VFS (#661290, #588795, #653156)
|
- fix crash in opening mc VFS (#661290, #588795, #653156)
|
||||||
- fix crash while creating a VFS timestamp (#660308)
|
- fix crash while creating a VFS timestamp (#660308)
|
||||||
|
Loading…
Reference in New Issue
Block a user