- update from CVS (fixes #143586)
- merge all UTF-8 related patches to single .utf8 patch - drop BuildRequires gettext-devel, autopoint no more needed
This commit is contained in:
parent
c606788494
commit
22fbca86b0
@ -7,3 +7,4 @@ mc-4.6.1-20041124.tar.bz2
|
||||
mc-4.6.1-20041201-pre1a.tar.bz2
|
||||
mc-4.6.1a-20041209.tar.bz2
|
||||
mc-4.6.1a-20041215.tar.bz2
|
||||
mc-4.6.1a-20050202.tar.bz2
|
||||
|
133
mc-extensions.patch
Normal file
133
mc-extensions.patch
Normal file
@ -0,0 +1,133 @@
|
||||
--- mc-4.6.1-20041103/lib/mc.ext.in.extensions 2004-10-28 08:19:23.000000000 +0200
|
||||
+++ mc-4.6.1-20041103/lib/mc.ext.in 2004-11-03 13:20:09.889755600 +0100
|
||||
@@ -108,14 +108,25 @@
|
||||
|
||||
# C
|
||||
shell/.c
|
||||
- Open=%var{EDITOR:vi} %f
|
||||
+ Include=editor
|
||||
|
||||
# Fortran
|
||||
shell/.f
|
||||
- Open=%var{EDITOR:vi} %f
|
||||
+ Include=editor
|
||||
|
||||
# Header
|
||||
regex/\.(h|hpp)$
|
||||
+ Include=editor
|
||||
+
|
||||
+# Asm
|
||||
+regex/\.([Ss]|[Aa]sm|ASM)$
|
||||
+ Include=editor
|
||||
+
|
||||
+# C++
|
||||
+regex/\.(C|cc|[Cc]pp|CPP)$
|
||||
+ Inlude=editor
|
||||
+
|
||||
+include/editor
|
||||
Open=%var{EDITOR:vi} %f
|
||||
|
||||
# Object
|
||||
@@ -123,14 +134,6 @@
|
||||
#Open=%var{PAGER:more} %f
|
||||
View=%view{ascii} file %f && nm %f
|
||||
|
||||
-# Asm
|
||||
-shell/.s
|
||||
- Open=%var{EDITOR:vi} %f
|
||||
-
|
||||
-# C++
|
||||
-regex/\.(C|cc|cpp)$
|
||||
- Open=%var{EDITOR:vi} %f
|
||||
-
|
||||
### Documentation ###
|
||||
|
||||
# Texinfo
|
||||
@@ -139,9 +142,11 @@
|
||||
# GNU Info page
|
||||
type/^Info\ text
|
||||
Open=info -f %f
|
||||
+ #Open=pinfo %f
|
||||
|
||||
shell/.info
|
||||
Open=info -f %f
|
||||
+ #Open=pinfo %f
|
||||
|
||||
# Manual page
|
||||
# Exception - .so libraries are not manual pages
|
||||
@@ -210,6 +215,12 @@
|
||||
type/^Netpbm
|
||||
Include=image
|
||||
|
||||
+type/^JNG
|
||||
+ Include=image
|
||||
+
|
||||
+type/^MNG
|
||||
+ Include=image
|
||||
+
|
||||
shell/.xcf
|
||||
Open=gimp %f
|
||||
|
||||
@@ -221,7 +232,7 @@
|
||||
View=sxpm %f
|
||||
|
||||
include/image
|
||||
- Open=if [ "$DISPLAY" = "" ]; then zgv %f; else (gqview %f &); fi
|
||||
+ Open=if [ "$DISPLAY" = "" ]; then zgv %f; else (display %f &); fi
|
||||
View=%view{ascii} identify %f
|
||||
#View=%view{ascii} asciiview %f
|
||||
|
||||
@@ -239,8 +250,12 @@
|
||||
Open=vplay -s 22 %f
|
||||
|
||||
regex/\.([mM][pP]3)$
|
||||
- Open=if [ "$DISPLAY" = "" ]; then mpg123 %f; else (xmms %f &); fi
|
||||
- View=%view{ascii} mpg123 -vtn1 %f 2>&1 | sed -n '/^Title/,/^Comment/p;/^MPEG/,/^Audio/p'
|
||||
+ Include=audio
|
||||
+ #Open=if [ "$DISPLAY" = "" ]; then mpg123 %f; else (xmms %f &); fi
|
||||
+ #View=%view{ascii} mpg123 -vtn1 %f 2>&1 | sed -n '/^Title/,/^Comment/p;/^MPEG/,/^Audio/p'
|
||||
+
|
||||
+regex/\.([mM][kK][aA])$
|
||||
+ Include=audio
|
||||
|
||||
regex/\.([oO][gG][gG])$
|
||||
Open=if [ "$DISPLAY" = "" ]; then ogg123 %f; else (xmms %f &); fi
|
||||
@@ -253,6 +268,9 @@
|
||||
Open=mplayer -vo null %f
|
||||
View=%view{ascii} mplayer -quiet -slave -frames 0 -vo null -ao null -identify %f 2>/dev/null | tail +13 || file %f
|
||||
|
||||
+Include/audio
|
||||
+ Open=mplayer %f
|
||||
+ View=%view{ascii} mplayer -identify -vo null -ao null -frames 0 %f 2>&1 | sed -n '/^ID_/p'
|
||||
|
||||
### Play lists ###
|
||||
|
||||
@@ -277,20 +295,28 @@
|
||||
regex/\.([mM][pP]4|[mM][pP][eE]?[gG])$
|
||||
Include=video
|
||||
|
||||
+regex/\.([mM][kK][vV])$
|
||||
+ Include=video
|
||||
+
|
||||
regex/\.([vV][oO][bB])$
|
||||
Include=video
|
||||
|
||||
regex/\.([wW][mM][vV])$
|
||||
Include=video
|
||||
|
||||
+regex/\.([fF][lL][iIcC])$
|
||||
+ Include=video
|
||||
+
|
||||
regex/\.([oO][gG][mM])$
|
||||
Include=video
|
||||
|
||||
regex/\.([rR][aA]?[mM])$
|
||||
Open=(realplay %f >/dev/null 2>&1 &)
|
||||
+ View=%view{ascii} mplayer -identify -vo null -ao null -frames 0 %f 2>&1 | sed -n '/^ID_/p'
|
||||
|
||||
include/video
|
||||
Open=(mplayer %f >/dev/null 2>&1 &)
|
||||
+ View=%view{ascii} mplayer -identify -vo null -ao null -frames 0 %f 2>&1 | sed -n '/^ID_/p'
|
||||
#Open=(gtv %f >/dev/null 2>&1 &)
|
||||
#Open=(xanim %f >/dev/null 2>&1 &)
|
||||
|
5018
mc-utf8.patch
Normal file
5018
mc-utf8.patch
Normal file
File diff suppressed because it is too large
Load Diff
39
mc.spec
39
mc.spec
@ -1,12 +1,12 @@
|
||||
Summary: User-friendly text console file manager and visual shell.
|
||||
Name: mc
|
||||
Version: 4.6.1a
|
||||
Release: 0.3
|
||||
Release: 0.4
|
||||
Epoch: 1
|
||||
License: GPL
|
||||
Group: System Environment/Shells
|
||||
#Source0: http://www.ibiblio.org/pub/Linux/utils/file/managers/mc/mc-%{version}.tar.gz
|
||||
%define date 20041215
|
||||
%define date 20050202
|
||||
Source0: mc-%{version}-%{date}.tar.bz2
|
||||
URL: http://www.ibiblio.org/mc/
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
@ -14,16 +14,11 @@ BuildRequires: gpm-devel, slang-devel, glib2-devel
|
||||
BuildRequires: XFree86-devel, e2fsprogs-devel, gettext, gettext-devel
|
||||
Requires: dev >= 0:3.3-3
|
||||
|
||||
Patch1: mc-CVS-utf8.patch
|
||||
Patch2: mc-CVS-utf8-fix.patch
|
||||
Patch3: mc-CVS-utf8-hint.patch
|
||||
Patch4: mc-CVS-utf8-input.patch
|
||||
Patch5: mc-CVS-utf8-help.patch
|
||||
Patch6: mc-CVS-extensions.patch
|
||||
Patch7: mc-CVS-promptfix.patch
|
||||
Patch8: mc-CVS-uglydir.patch
|
||||
Patch9: mc-CVS-fish-upload.patch
|
||||
Patch10: mc-CVS-logo.patch
|
||||
Patch0: mc-utf8.patch
|
||||
Patch1: mc-extensions.patch
|
||||
Patch2: mc-promptfix.patch
|
||||
Patch3: mc-uglydir.patch
|
||||
Patch4: mc-fish-upload.patch
|
||||
|
||||
%description
|
||||
Midnight Commander is a visual shell much like a file manager, only
|
||||
@ -35,16 +30,11 @@ poke into RPMs for specific files.
|
||||
%prep
|
||||
%setup -q -n mc-%{version}-%{date}
|
||||
|
||||
%patch1 -p1 -b .utf8
|
||||
%patch2 -p1 -b .utf8-fix
|
||||
%patch3 -p1 -b .utf8-hint
|
||||
%patch4 -p1 -b .utf8-input
|
||||
%patch5 -p1 -b .utf8-help
|
||||
%patch6 -p1 -b .extensions
|
||||
%patch7 -p1 -b .promptfix
|
||||
%patch8 -p1 -b .uglydir
|
||||
%patch9 -p1 -b .fishupload
|
||||
%patch10 -p1 -b .logo
|
||||
%patch0 -p1 -b .utf8
|
||||
%patch1 -p1 -b .extensions
|
||||
%patch2 -p1 -b .promptfix
|
||||
%patch3 -p1 -b .uglydir
|
||||
%patch4 -p1 -b .fish-upload
|
||||
|
||||
# convert files in /lib to UTF-8
|
||||
pushd lib
|
||||
@ -178,6 +168,11 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%dir %{_datadir}/mc
|
||||
|
||||
%changelog
|
||||
* Wed Feb 2 2005 Jindrich Novy <jnovy@redhat.com> 4.6.1a-0.4
|
||||
- update from CVS (fixes #143586)
|
||||
- merge all UTF-8 related patches to single .utf8 patch
|
||||
- drop BuildRequires gettext-devel, autopoint no more needed
|
||||
|
||||
* Tue Dec 21 2004 Jindrich Novy <jnovy@redhat.com> 4.6.1a-0.3
|
||||
- rewrote mbstrlen() in utf8 patch, this fixes:
|
||||
- dir name truncation in command prompt for ja_JP, ko_KR locales (#142706)
|
||||
|
Loading…
Reference in New Issue
Block a user