- fix refusal to chdir/start file action when spaces are typed in command
prompt and Enter is pressed (#151637)
This commit is contained in:
parent
543d68acc6
commit
16756fe12e
29
mc-spaceprompt.patch
Normal file
29
mc-spaceprompt.patch
Normal file
@ -0,0 +1,29 @@
|
|||||||
|
--- mc-4.6.1-pre3/src/main.c.jn 2005-03-19 15:55:40.000000000 +0100
|
||||||
|
+++ mc-4.6.1-pre3/src/main.c 2005-03-19 17:04:10.000000000 +0100
|
||||||
|
@@ -1490,9 +1490,14 @@ midnight_callback (struct Dlg_head *h, d
|
||||||
|
if (parm == '\t')
|
||||||
|
free_completions (cmdline);
|
||||||
|
|
||||||
|
- if (parm == '\n' && cmdline->buffer[0]) {
|
||||||
|
- send_message ((Widget *) cmdline, WIDGET_KEY, parm);
|
||||||
|
- return MSG_HANDLED;
|
||||||
|
+ if (parm == '\n') {
|
||||||
|
+ for (i = 0; cmdline->buffer[i] && cmdline->buffer[i] == ' '; i++);
|
||||||
|
+ if (cmdline->buffer[i]) {
|
||||||
|
+ send_message ((Widget *) cmdline, WIDGET_KEY, parm);
|
||||||
|
+ return MSG_HANDLED;
|
||||||
|
+ }
|
||||||
|
+ stuff (cmdline, "", 0);
|
||||||
|
+ cmdline->point = 0;
|
||||||
|
}
|
||||||
|
|
||||||
|
/* Ctrl-Enter and Alt-Enter */
|
||||||
|
@@ -1527,7 +1532,7 @@ midnight_callback (struct Dlg_head *h, d
|
||||||
|
reverse_selection_cmd ();
|
||||||
|
return MSG_HANDLED;
|
||||||
|
}
|
||||||
|
- } else if (!command_prompt || !strlen (cmdline->buffer)) {
|
||||||
|
+ } else if (!command_prompt || !cmdline->buffer[0]) {
|
||||||
|
/* Special treatement '+', '-', '\', '*' only when this is
|
||||||
|
* first char on input line
|
||||||
|
*/
|
8
mc.spec
8
mc.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: User-friendly text console file manager and visual shell.
|
Summary: User-friendly text console file manager and visual shell.
|
||||||
Name: mc
|
Name: mc
|
||||||
Version: 4.6.1a
|
Version: 4.6.1a
|
||||||
Release: 0.5
|
Release: 0.6
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
License: GPL
|
License: GPL
|
||||||
Group: System Environment/Shells
|
Group: System Environment/Shells
|
||||||
@ -19,6 +19,7 @@ Patch1: mc-extensions.patch
|
|||||||
Patch2: mc-promptfix.patch
|
Patch2: mc-promptfix.patch
|
||||||
Patch3: mc-uglydir.patch
|
Patch3: mc-uglydir.patch
|
||||||
Patch4: mc-fish-upload.patch
|
Patch4: mc-fish-upload.patch
|
||||||
|
Patch5: mc-spaceprompt.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Midnight Commander is a visual shell much like a file manager, only
|
Midnight Commander is a visual shell much like a file manager, only
|
||||||
@ -35,6 +36,7 @@ poke into RPMs for specific files.
|
|||||||
%patch2 -p1 -b .promptfix
|
%patch2 -p1 -b .promptfix
|
||||||
%patch3 -p1 -b .uglydir
|
%patch3 -p1 -b .uglydir
|
||||||
%patch4 -p1 -b .fish-upload
|
%patch4 -p1 -b .fish-upload
|
||||||
|
%patch5 -p1 -b .spaceprompt
|
||||||
|
|
||||||
# convert files in /lib to UTF-8
|
# convert files in /lib to UTF-8
|
||||||
pushd lib
|
pushd lib
|
||||||
@ -172,6 +174,10 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%dir %{_datadir}/mc
|
%dir %{_datadir}/mc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Mar 21 2005 Jindrich Novy <jnovy@redhat.com> 4.6.1a-0.6
|
||||||
|
- fix refusal to chdir/start file action when spaces are typed in
|
||||||
|
command prompt and Enter is pressed (#151637)
|
||||||
|
|
||||||
* Thu Mar 3 2005 Jindrich Novy <jnovy@redhat.com> 4.6.1a-0.5
|
* Thu Mar 3 2005 Jindrich Novy <jnovy@redhat.com> 4.6.1a-0.5
|
||||||
- update from CVS
|
- update from CVS
|
||||||
- sync the .utf8 patch with upstream
|
- sync the .utf8 patch with upstream
|
||||||
|
Loading…
Reference in New Issue
Block a user