Update Aether to 0.9.0.M3
This commit is contained in:
parent
1ae0bd3095
commit
e2d80ff7a5
95
0001-Update-Aether-to-0.9.0.M3.patch
Normal file
95
0001-Update-Aether-to-0.9.0.M3.patch
Normal file
@ -0,0 +1,95 @@
|
|||||||
|
From 51bc34848a46cca087fa7872b92af12a89415708 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Mikolaj Izdebski <mizdebsk@redhat.com>
|
||||||
|
Date: Mon, 12 Aug 2013 08:49:19 +0200
|
||||||
|
Subject: [PATCH] Update Aether to 0.9.0.M3
|
||||||
|
|
||||||
|
---
|
||||||
|
apache-maven/pom.xml | 6 +++++-
|
||||||
|
maven-aether-provider/pom.xml | 7 ++++++-
|
||||||
|
maven-compat/pom.xml | 7 ++++++-
|
||||||
|
pom.xml | 9 +++++++--
|
||||||
|
4 files changed, 24 insertions(+), 5 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/apache-maven/pom.xml b/apache-maven/pom.xml
|
||||||
|
index 49ab2e9..9ecc868 100644
|
||||||
|
--- a/apache-maven/pom.xml
|
||||||
|
+++ b/apache-maven/pom.xml
|
||||||
|
@@ -81,7 +81,11 @@
|
||||||
|
</dependency>
|
||||||
|
<dependency>
|
||||||
|
<groupId>org.eclipse.aether</groupId>
|
||||||
|
- <artifactId>aether-connector-wagon</artifactId>
|
||||||
|
+ <artifactId>aether-transport-wagon</artifactId>
|
||||||
|
+ </dependency>
|
||||||
|
+ <dependency>
|
||||||
|
+ <groupId>org.eclipse.aether</groupId>
|
||||||
|
+ <artifactId>aether-connector-basic</artifactId>
|
||||||
|
</dependency>
|
||||||
|
<dependency>
|
||||||
|
<groupId>org.slf4j</groupId>
|
||||||
|
diff --git a/maven-aether-provider/pom.xml b/maven-aether-provider/pom.xml
|
||||||
|
index 1bb1126..90aa2a2 100644
|
||||||
|
--- a/maven-aether-provider/pom.xml
|
||||||
|
+++ b/maven-aether-provider/pom.xml
|
||||||
|
@@ -64,7 +64,12 @@ under the License.
|
||||||
|
</dependency>
|
||||||
|
<dependency>
|
||||||
|
<groupId>org.eclipse.aether</groupId>
|
||||||
|
- <artifactId>aether-connector-wagon</artifactId>
|
||||||
|
+ <artifactId>aether-connector-basic</artifactId>
|
||||||
|
+ <scope>test</scope>
|
||||||
|
+ </dependency>
|
||||||
|
+ <dependency>
|
||||||
|
+ <groupId>org.eclipse.aether</groupId>
|
||||||
|
+ <artifactId>aether-transport-wagon</artifactId>
|
||||||
|
<scope>test</scope>
|
||||||
|
</dependency>
|
||||||
|
<dependency>
|
||||||
|
diff --git a/maven-compat/pom.xml b/maven-compat/pom.xml
|
||||||
|
index 21270b7..74551c9 100644
|
||||||
|
--- a/maven-compat/pom.xml
|
||||||
|
+++ b/maven-compat/pom.xml
|
||||||
|
@@ -73,7 +73,12 @@
|
||||||
|
</dependency>
|
||||||
|
<dependency>
|
||||||
|
<groupId>org.eclipse.aether</groupId>
|
||||||
|
- <artifactId>aether-connector-wagon</artifactId>
|
||||||
|
+ <artifactId>aether-transport-wagon</artifactId>
|
||||||
|
+ <scope>test</scope>
|
||||||
|
+ </dependency>
|
||||||
|
+ <dependency>
|
||||||
|
+ <groupId>org.eclipse.aether</groupId>
|
||||||
|
+ <artifactId>aether-connector-basic</artifactId>
|
||||||
|
<scope>test</scope>
|
||||||
|
</dependency>
|
||||||
|
<dependency>
|
||||||
|
diff --git a/pom.xml b/pom.xml
|
||||||
|
index 19edb60..c4f724c 100644
|
||||||
|
--- a/pom.xml
|
||||||
|
+++ b/pom.xml
|
||||||
|
@@ -58,7 +58,7 @@
|
||||||
|
<cipherVersion>1.7</cipherVersion>
|
||||||
|
<modelloVersion>1.7</modelloVersion>
|
||||||
|
<jxpathVersion>1.3</jxpathVersion>
|
||||||
|
- <aetherVersion>0.9.0.M2</aetherVersion>
|
||||||
|
+ <aetherVersion>0.9.0.M3</aetherVersion>
|
||||||
|
<slf4jVersion>1.7.4</slf4jVersion>
|
||||||
|
<maven.test.redirectTestOutputToFile>true</maven.test.redirectTestOutputToFile>
|
||||||
|
<!-- Control the name of the distribution and information output by mvn -->
|
||||||
|
@@ -284,7 +284,12 @@
|
||||||
|
</dependency>
|
||||||
|
<dependency>
|
||||||
|
<groupId>org.eclipse.aether</groupId>
|
||||||
|
- <artifactId>aether-connector-wagon</artifactId>
|
||||||
|
+ <artifactId>aether-connector-basic</artifactId>
|
||||||
|
+ <version>${aetherVersion}</version>
|
||||||
|
+ </dependency>
|
||||||
|
+ <dependency>
|
||||||
|
+ <groupId>org.eclipse.aether</groupId>
|
||||||
|
+ <artifactId>aether-transport-wagon</artifactId>
|
||||||
|
<version>${aetherVersion}</version>
|
||||||
|
</dependency>
|
||||||
|
<!-- Commons -->
|
||||||
|
--
|
||||||
|
1.8.1.4
|
||||||
|
|
20
maven.spec
20
maven.spec
@ -1,8 +1,6 @@
|
|||||||
%global __requires_exclude %{?__requires_exclude:%__requires_exclude|}^mvn\\(org\\.eclipse\\.aether:.*\\)$
|
|
||||||
|
|
||||||
Name: maven
|
Name: maven
|
||||||
Version: 3.1.0
|
Version: 3.1.0
|
||||||
Release: 5%{?dist}
|
Release: 6%{?dist}
|
||||||
Summary: Java project management and project comprehension tool
|
Summary: Java project management and project comprehension tool
|
||||||
|
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
@ -18,16 +16,19 @@ Source200: %{name}-script
|
|||||||
# Patch1XX could be upstreamed probably
|
# Patch1XX could be upstreamed probably
|
||||||
Patch100: 0005-Use-generics-in-modello-generated-code.patch
|
Patch100: 0005-Use-generics-in-modello-generated-code.patch
|
||||||
|
|
||||||
|
# Forwarded upstream (MNG-5502)
|
||||||
|
Patch200: 0001-Update-Aether-to-0.9.0.M3.patch
|
||||||
|
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
|
|
||||||
BuildRequires: maven-local
|
BuildRequires: maven-local
|
||||||
|
|
||||||
BuildRequires: aether >= 1:0
|
|
||||||
BuildRequires: aether-api >= 1:0
|
BuildRequires: aether-api >= 1:0
|
||||||
BuildRequires: aether-connector-wagon >= 1:0
|
BuildRequires: aether-connector-basic >= 1:0
|
||||||
BuildRequires: aether-impl >= 1:0
|
BuildRequires: aether-impl >= 1:0
|
||||||
BuildRequires: aether-spi >= 1:0
|
BuildRequires: aether-spi >= 1:0
|
||||||
BuildRequires: aether-util >= 1:0
|
BuildRequires: aether-util >= 1:0
|
||||||
|
BuildRequires: aether-transport-wagon >= 1:0
|
||||||
BuildRequires: aopalliance
|
BuildRequires: aopalliance
|
||||||
BuildRequires: apache-commons-cli
|
BuildRequires: apache-commons-cli
|
||||||
BuildRequires: apache-commons-jxpath
|
BuildRequires: apache-commons-jxpath
|
||||||
@ -93,6 +94,7 @@ Group: Documentation
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n apache-%{name}-%{version}%{?ver_add}
|
%setup -q -n apache-%{name}-%{version}%{?ver_add}
|
||||||
%patch100 -p1
|
%patch100 -p1
|
||||||
|
%patch200 -p1
|
||||||
|
|
||||||
# not really used during build, but a precaution
|
# not really used during build, but a precaution
|
||||||
rm maven-ant-tasks-*.jar
|
rm maven-ant-tasks-*.jar
|
||||||
@ -168,15 +170,14 @@ cp -a $M2_HOME/bin/* %{buildroot}%{_datadir}/%{name}/bin
|
|||||||
ln -sf $(build-classpath plexus/classworlds) \
|
ln -sf $(build-classpath plexus/classworlds) \
|
||||||
%{buildroot}%{_datadir}/%{name}/boot/plexus-classworlds.jar
|
%{buildroot}%{_datadir}/%{name}/boot/plexus-classworlds.jar
|
||||||
|
|
||||||
ln -sf %{_javadir}/aether/aether-connector-basic.jar %{buildroot}%{_datadir}/%{name}/lib/
|
|
||||||
ln -sf %{_javadir}/aether/aether-transport-wagon.jar %{buildroot}%{_datadir}/%{name}/lib/
|
|
||||||
(cd %{buildroot}%{_datadir}/%{name}/lib
|
(cd %{buildroot}%{_datadir}/%{name}/lib
|
||||||
build-jar-repository -s -p . \
|
build-jar-repository -s -p . \
|
||||||
aether/aether-api \
|
aether/aether-api \
|
||||||
aether/aether-connector-wagon \
|
aether/aether-connector-basic \
|
||||||
aether/aether-impl \
|
aether/aether-impl \
|
||||||
aether/aether-spi \
|
aether/aether-spi \
|
||||||
aether/aether-util \
|
aether/aether-util \
|
||||||
|
aether/aether-transport-wagon \
|
||||||
aopalliance \
|
aopalliance \
|
||||||
objectweb-asm \
|
objectweb-asm \
|
||||||
cdi-api \
|
cdi-api \
|
||||||
@ -223,6 +224,9 @@ ln -sf %{_javadir}/aether/aether-transport-wagon.jar %{buildroot}%{_datadir}/%{n
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Aug 12 2013 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.1.0-6
|
||||||
|
- Update Aether to 0.9.0.M3
|
||||||
|
|
||||||
* Mon Aug 12 2013 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.1.0-5
|
* Mon Aug 12 2013 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.1.0-5
|
||||||
- Prepare for update to Aether 0.9.0.M3
|
- Prepare for update to Aether 0.9.0.M3
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user