Update to Sisu 0.1.0 and Guice 3.1.6
This commit is contained in:
parent
ed10454bc9
commit
dbd13e666c
197
0001-Update-to-Sisu-0.1.0-and-Guice-3.1.6.patch
Normal file
197
0001-Update-to-Sisu-0.1.0-and-Guice-3.1.6.patch
Normal file
@ -0,0 +1,197 @@
|
||||
From 2247f2e0b045c4b7a99e830ee0c032c787560cbc Mon Sep 17 00:00:00 2001
|
||||
From: Mikolaj Izdebski <mizdebsk@redhat.com>
|
||||
Date: Wed, 13 Nov 2013 14:32:23 +0100
|
||||
Subject: [PATCH] Update to Sisu 0.1.0 and Guice 3.1.6
|
||||
|
||||
Sisu depends on Guice, but dependency scope changed from "compile" to
|
||||
"provided" in Sisu 0.1.0. As a Sisu user, Maven needs to have runtime
|
||||
dependency on Guice.
|
||||
---
|
||||
apache-maven/pom.xml | 12 ++++++++++++
|
||||
maven-aether-provider/pom.xml | 6 +++++-
|
||||
maven-compat/pom.xml | 12 ++++++++++++
|
||||
maven-core/pom.xml | 11 +++++++++++
|
||||
maven-embedder/pom.xml | 11 +++++++++++
|
||||
maven-model-builder/pom.xml | 12 ++++++++++++
|
||||
maven-plugin-api/pom.xml | 12 ++++++++++++
|
||||
pom.xml | 4 ++--
|
||||
8 files changed, 77 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/apache-maven/pom.xml b/apache-maven/pom.xml
|
||||
index 0b56fa8..f7b1267 100644
|
||||
--- a/apache-maven/pom.xml
|
||||
+++ b/apache-maven/pom.xml
|
||||
@@ -57,6 +57,18 @@
|
||||
<groupId>org.eclipse.sisu</groupId>
|
||||
<artifactId>org.eclipse.sisu.plexus</artifactId>
|
||||
</dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>org.sonatype.sisu</groupId>
|
||||
+ <artifactId>sisu-guice</artifactId>
|
||||
+ <classifier>no_aop</classifier>
|
||||
+ <scope>runtime</scope>
|
||||
+ <exclusions>
|
||||
+ <exclusion>
|
||||
+ <groupId>aopalliance</groupId>
|
||||
+ <artifactId>aopalliance</artifactId>
|
||||
+ </exclusion>
|
||||
+ </exclusions>
|
||||
+ </dependency>
|
||||
<!-- CLI -->
|
||||
<dependency>
|
||||
<groupId>commons-cli</groupId>
|
||||
diff --git a/maven-aether-provider/pom.xml b/maven-aether-provider/pom.xml
|
||||
index 62ce127..a71fa47 100644
|
||||
--- a/maven-aether-provider/pom.xml
|
||||
+++ b/maven-aether-provider/pom.xml
|
||||
@@ -80,7 +80,6 @@ under the License.
|
||||
<groupId>org.sonatype.sisu</groupId>
|
||||
<artifactId>sisu-guice</artifactId>
|
||||
<classifier>no_aop</classifier>
|
||||
- <optional>true</optional>
|
||||
<exclusions>
|
||||
<exclusion>
|
||||
<groupId>aopalliance</groupId>
|
||||
@@ -88,6 +87,11 @@ under the License.
|
||||
</exclusion>
|
||||
</exclusions>
|
||||
</dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>javax.inject</groupId>
|
||||
+ <artifactId>javax.inject</artifactId>
|
||||
+ <version>1</version>
|
||||
+ </dependency>
|
||||
<!-- Testing -->
|
||||
<dependency>
|
||||
<groupId>org.eclipse.aether</groupId>
|
||||
diff --git a/maven-compat/pom.xml b/maven-compat/pom.xml
|
||||
index ee6ace7..cf690b8 100644
|
||||
--- a/maven-compat/pom.xml
|
||||
+++ b/maven-compat/pom.xml
|
||||
@@ -64,6 +64,18 @@
|
||||
<artifactId>org.eclipse.sisu.plexus</artifactId>
|
||||
</dependency>
|
||||
<dependency>
|
||||
+ <groupId>org.sonatype.sisu</groupId>
|
||||
+ <artifactId>sisu-guice</artifactId>
|
||||
+ <classifier>no_aop</classifier>
|
||||
+ <scope>runtime</scope>
|
||||
+ <exclusions>
|
||||
+ <exclusion>
|
||||
+ <groupId>aopalliance</groupId>
|
||||
+ <artifactId>aopalliance</artifactId>
|
||||
+ </exclusion>
|
||||
+ </exclusions>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
<groupId>org.codehaus.plexus</groupId>
|
||||
<artifactId>plexus-component-annotations</artifactId>
|
||||
</dependency>
|
||||
diff --git a/maven-core/pom.xml b/maven-core/pom.xml
|
||||
index 713ffcc..b873e0b 100644
|
||||
--- a/maven-core/pom.xml
|
||||
+++ b/maven-core/pom.xml
|
||||
@@ -82,6 +82,17 @@
|
||||
<artifactId>org.eclipse.sisu.plexus</artifactId>
|
||||
</dependency>
|
||||
<dependency>
|
||||
+ <groupId>org.sonatype.sisu</groupId>
|
||||
+ <artifactId>sisu-guice</artifactId>
|
||||
+ <classifier>no_aop</classifier>
|
||||
+ <exclusions>
|
||||
+ <exclusion>
|
||||
+ <groupId>aopalliance</groupId>
|
||||
+ <artifactId>aopalliance</artifactId>
|
||||
+ </exclusion>
|
||||
+ </exclusions>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
<groupId>org.codehaus.plexus</groupId>
|
||||
<artifactId>plexus-interpolation</artifactId>
|
||||
</dependency>
|
||||
diff --git a/maven-embedder/pom.xml b/maven-embedder/pom.xml
|
||||
index 01f6179..0b464ca 100644
|
||||
--- a/maven-embedder/pom.xml
|
||||
+++ b/maven-embedder/pom.xml
|
||||
@@ -65,6 +65,17 @@
|
||||
<artifactId>org.eclipse.sisu.plexus</artifactId>
|
||||
</dependency>
|
||||
<dependency>
|
||||
+ <groupId>org.sonatype.sisu</groupId>
|
||||
+ <artifactId>sisu-guice</artifactId>
|
||||
+ <classifier>no_aop</classifier>
|
||||
+ <exclusions>
|
||||
+ <exclusion>
|
||||
+ <groupId>aopalliance</groupId>
|
||||
+ <artifactId>aopalliance</artifactId>
|
||||
+ </exclusion>
|
||||
+ </exclusions>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
<groupId>org.codehaus.plexus</groupId>
|
||||
<artifactId>plexus-component-annotations</artifactId>
|
||||
</dependency>
|
||||
diff --git a/maven-model-builder/pom.xml b/maven-model-builder/pom.xml
|
||||
index 9150460..a7317c0 100644
|
||||
--- a/maven-model-builder/pom.xml
|
||||
+++ b/maven-model-builder/pom.xml
|
||||
@@ -54,6 +54,18 @@
|
||||
<scope>test</scope>
|
||||
</dependency>
|
||||
<dependency>
|
||||
+ <groupId>org.sonatype.sisu</groupId>
|
||||
+ <artifactId>sisu-guice</artifactId>
|
||||
+ <classifier>no_aop</classifier>
|
||||
+ <scope>test</scope>
|
||||
+ <exclusions>
|
||||
+ <exclusion>
|
||||
+ <groupId>aopalliance</groupId>
|
||||
+ <artifactId>aopalliance</artifactId>
|
||||
+ </exclusion>
|
||||
+ </exclusions>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
<groupId>xmlunit</groupId>
|
||||
<artifactId>xmlunit</artifactId>
|
||||
<version>1.3</version>
|
||||
diff --git a/maven-plugin-api/pom.xml b/maven-plugin-api/pom.xml
|
||||
index d899721..5a41bcd 100644
|
||||
--- a/maven-plugin-api/pom.xml
|
||||
+++ b/maven-plugin-api/pom.xml
|
||||
@@ -58,6 +58,18 @@ under the License.
|
||||
<groupId>org.eclipse.sisu</groupId>
|
||||
<artifactId>org.eclipse.sisu.plexus</artifactId>
|
||||
</dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>org.sonatype.sisu</groupId>
|
||||
+ <artifactId>sisu-guice</artifactId>
|
||||
+ <classifier>no_aop</classifier>
|
||||
+ <scope>runtime</scope>
|
||||
+ <exclusions>
|
||||
+ <exclusion>
|
||||
+ <groupId>aopalliance</groupId>
|
||||
+ <artifactId>aopalliance</artifactId>
|
||||
+ </exclusion>
|
||||
+ </exclusions>
|
||||
+ </dependency>
|
||||
</dependencies>
|
||||
|
||||
<build>
|
||||
diff --git a/pom.xml b/pom.xml
|
||||
index 889ba1d..f6c3246 100644
|
||||
--- a/pom.xml
|
||||
+++ b/pom.xml
|
||||
@@ -51,8 +51,8 @@
|
||||
<plexusUtilsVersion>3.0.15</plexusUtilsVersion>
|
||||
<!-- last Java5 release of Guava -->
|
||||
<guavaVersion>11.0.2</guavaVersion>
|
||||
- <guiceVersion>3.1.3</guiceVersion>
|
||||
- <sisuInjectVersion>0.0.0.M5</sisuInjectVersion>
|
||||
+ <guiceVersion>3.1.6</guiceVersion>
|
||||
+ <sisuInjectVersion>0.1.0</sisuInjectVersion>
|
||||
<wagonVersion>2.4</wagonVersion>
|
||||
<securityDispatcherVersion>1.3</securityDispatcherVersion>
|
||||
<cipherVersion>1.7</cipherVersion>
|
||||
--
|
||||
1.8.1.4
|
||||
|
14
maven.spec
14
maven.spec
@ -1,6 +1,6 @@
|
||||
Name: maven
|
||||
Version: 3.1.1
|
||||
Release: 13%{?dist}
|
||||
Release: 14%{?dist}
|
||||
Summary: Java project management and project comprehension tool
|
||||
|
||||
Group: Development/Tools
|
||||
@ -19,6 +19,8 @@ Patch101: 0001-Migrate-from-easymock-1-to-easymock-3.patch
|
||||
|
||||
# Forwarded upstream (MNG-5502)
|
||||
Patch200: 0001-Update-Aether-to-0.9.0.M3.patch
|
||||
# Forwarded upstream (MNG-5534)
|
||||
Patch201: 0001-Update-to-Sisu-0.1.0-and-Guice-3.1.6.patch
|
||||
|
||||
BuildArch: noarch
|
||||
|
||||
@ -44,7 +46,7 @@ BuildRequires: atinject
|
||||
BuildRequires: buildnumber-maven-plugin
|
||||
BuildRequires: cglib
|
||||
BuildRequires: easymock3
|
||||
BuildRequires: google-guice >= 3.0
|
||||
BuildRequires: google-guice >= 3.1.6
|
||||
BuildRequires: hamcrest
|
||||
BuildRequires: httpcomponents-core
|
||||
BuildRequires: httpcomponents-client
|
||||
@ -70,8 +72,8 @@ BuildRequires: plexus-containers-container-default
|
||||
BuildRequires: plexus-interpolation
|
||||
BuildRequires: plexus-sec-dispatcher
|
||||
BuildRequires: plexus-utils >= 3.0.10
|
||||
BuildRequires: sisu-inject >= 1:0
|
||||
BuildRequires: sisu-plexus >= 1:0
|
||||
BuildRequires: sisu-inject >= 1:0.1
|
||||
BuildRequires: sisu-plexus >= 1:0.1
|
||||
BuildRequires: slf4j
|
||||
BuildRequires: xmlunit
|
||||
BuildRequires: mvn(ch.qos.logback:logback-classic)
|
||||
@ -143,6 +145,7 @@ Group: Documentation
|
||||
%patch100 -p1
|
||||
%patch101 -p1
|
||||
%patch200 -p1
|
||||
%patch201 -p1
|
||||
|
||||
# not really used during build, but a precaution
|
||||
rm maven-ant-tasks-*.jar
|
||||
@ -265,6 +268,9 @@ ln -sf $(build-classpath plexus/classworlds) \
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Nov 13 2013 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.1.1-14
|
||||
- Update to Sisu 0.1.0 and Guice 3.1.6
|
||||
|
||||
* Fri Nov 8 2013 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.1.1-13
|
||||
- Add wagon-http-shared4 to plexus.core
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user