Update to upstream version 3.5.2
This commit is contained in:
parent
529b341b8b
commit
ce002adc00
1
.gitignore
vendored
1
.gitignore
vendored
@ -18,3 +18,4 @@
|
||||
/apache-maven-3.3.9-src.tar.gz
|
||||
/apache-maven-3.4.0-SNAPSHOT-src.tar.gz
|
||||
/apache-maven-3.5.0-src.tar.gz
|
||||
/apache-maven-3.5.2-src.tar.gz
|
||||
|
@ -1,14 +1,14 @@
|
||||
From 8ef7cdcdc1c40742fb091177afe17f771a518f90 Mon Sep 17 00:00:00 2001
|
||||
From 48cb2294352381ef90895a9dbeb57935fb01bcee Mon Sep 17 00:00:00 2001
|
||||
From: Michael Simacek <msimacek@redhat.com>
|
||||
Date: Wed, 1 Feb 2017 14:54:26 +0100
|
||||
Subject: [PATCH 1/4] Adapt mvn script
|
||||
Subject: [PATCH 1/2] Adapt mvn script
|
||||
|
||||
---
|
||||
apache-maven/src/bin/mvn | 19 ++++++++++++++++---
|
||||
1 file changed, 16 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/apache-maven/src/bin/mvn b/apache-maven/src/bin/mvn
|
||||
index 623b5f2..e486b34 100755
|
||||
index e3a5848..defaf5f 100755
|
||||
--- a/apache-maven/src/bin/mvn
|
||||
+++ b/apache-maven/src/bin/mvn
|
||||
@@ -22,7 +22,7 @@
|
||||
@ -65,5 +65,5 @@ index 623b5f2..e486b34 100755
|
||||
|
||||
# For Cygwin, switch paths to Windows format before running java
|
||||
--
|
||||
2.9.4
|
||||
2.13.6
|
||||
|
||||
|
@ -1,7 +1,7 @@
|
||||
From ee59ac079ca7c945c4284fc078526ff3faeadfa1 Mon Sep 17 00:00:00 2001
|
||||
From 4b3b321df55c2bb73a82220f38b8267d1785b470 Mon Sep 17 00:00:00 2001
|
||||
From: Michael Simacek <msimacek@redhat.com>
|
||||
Date: Tue, 6 Jun 2017 13:47:43 +0200
|
||||
Subject: [PATCH 4/4] Invoke logback via reflection
|
||||
Subject: [PATCH 2/2] Invoke logback via reflection
|
||||
|
||||
---
|
||||
.../maven/cli/logging/impl/LogbackConfiguration.java | 19 ++++++++++++++-----
|
||||
@ -49,5 +49,5 @@ index 5d9fab7..ced38cb 100644
|
||||
|
||||
@Override
|
||||
--
|
||||
2.9.4
|
||||
2.13.6
|
||||
|
@ -1,31 +0,0 @@
|
||||
From 3dce15a3da21f5817a1b0193664312ffc8a5345c Mon Sep 17 00:00:00 2001
|
||||
From: Michael Simacek <msimacek@redhat.com>
|
||||
Date: Tue, 18 Apr 2017 16:30:58 +0200
|
||||
Subject: [PATCH 2/4] Update to current slf4j
|
||||
|
||||
---
|
||||
.../src/main/java/org/slf4j/impl/MavenSimpleLogger.java | 7 ++++++-
|
||||
1 file changed, 6 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/maven-slf4j-provider/src/main/java/org/slf4j/impl/MavenSimpleLogger.java b/maven-slf4j-provider/src/main/java/org/slf4j/impl/MavenSimpleLogger.java
|
||||
index 17f1f48..c4acb92 100644
|
||||
--- a/maven-slf4j-provider/src/main/java/org/slf4j/impl/MavenSimpleLogger.java
|
||||
+++ b/maven-slf4j-provider/src/main/java/org/slf4j/impl/MavenSimpleLogger.java
|
||||
@@ -56,8 +56,13 @@ public class MavenSimpleLogger
|
||||
}
|
||||
|
||||
@Override
|
||||
- protected void renderThrowable( Throwable t, PrintStream stream )
|
||||
+ protected void writeThrowable( Throwable t, PrintStream stream )
|
||||
{
|
||||
+ if ( t == null )
|
||||
+ {
|
||||
+ return;
|
||||
+ }
|
||||
+
|
||||
stream.print( buffer().failure( t.getClass().getName() ) );
|
||||
if ( t.getMessage() != null )
|
||||
{
|
||||
--
|
||||
2.9.4
|
||||
|
@ -1,54 +0,0 @@
|
||||
From b54789188f2a61b5d58ff53986a5efe042d84fdf Mon Sep 17 00:00:00 2001
|
||||
From: Michael Simacek <msimacek@redhat.com>
|
||||
Date: Tue, 18 Apr 2017 16:51:34 +0200
|
||||
Subject: [PATCH 3/4] Replace groovy invocation with antrun
|
||||
|
||||
---
|
||||
maven-slf4j-provider/pom.xml | 23 ++++++++++++++---------
|
||||
1 file changed, 14 insertions(+), 9 deletions(-)
|
||||
|
||||
diff --git a/maven-slf4j-provider/pom.xml b/maven-slf4j-provider/pom.xml
|
||||
index 363e00d..9be251b 100644
|
||||
--- a/maven-slf4j-provider/pom.xml
|
||||
+++ b/maven-slf4j-provider/pom.xml
|
||||
@@ -95,22 +95,27 @@ under the License.
|
||||
</executions>
|
||||
</plugin>
|
||||
<plugin>
|
||||
- <groupId>org.codehaus.gmaven</groupId>
|
||||
- <artifactId>groovy-maven-plugin</artifactId>
|
||||
- <version>2.0</version>
|
||||
+ <groupId>org.apache.maven.plugins</groupId>
|
||||
+ <artifactId>maven-antrun-plugin</artifactId>
|
||||
+ <version>1.8</version>
|
||||
<executions>
|
||||
<execution>
|
||||
- <id>patch-slf4j-simple</id>
|
||||
<phase>process-sources</phase>
|
||||
- <goals>
|
||||
- <goal>execute</goal>
|
||||
- </goals>
|
||||
<configuration>
|
||||
- <source>${project.basedir}/src/main/script/patch-slf4j-simple.groovy</source>
|
||||
+ <target>
|
||||
+ <replace
|
||||
+ file="${project.build.directory}/generated-sources/slf4j-simple/org/slf4j/impl/StaticLoggerBinder.java"
|
||||
+ token="\\bSimpleLoggerFactory\\b"
|
||||
+ value="MavenSimpleLoggerFactory"
|
||||
+ />
|
||||
+ </target>
|
||||
</configuration>
|
||||
+ <goals>
|
||||
+ <goal>run</goal>
|
||||
+ </goals>
|
||||
</execution>
|
||||
</executions>
|
||||
</plugin>
|
||||
</plugins>
|
||||
</build>
|
||||
-</project>
|
||||
\ No newline at end of file
|
||||
+</project>
|
||||
--
|
||||
2.9.4
|
||||
|
29
maven.spec
29
maven.spec
@ -4,8 +4,8 @@
|
||||
|
||||
Name: maven
|
||||
Epoch: 1
|
||||
Version: 3.5.0
|
||||
Release: 7%{?dist}
|
||||
Version: 3.5.2
|
||||
Release: 1%{?dist}
|
||||
Summary: Java project management and project comprehension tool
|
||||
License: ASL 2.0
|
||||
URL: http://maven.apache.org/
|
||||
@ -16,23 +16,20 @@ Source1: maven-bash-completion
|
||||
Source2: mvn.1
|
||||
|
||||
Patch1: 0001-Adapt-mvn-script.patch
|
||||
# Part of https://github.com/apache/maven/pull/109
|
||||
Patch2: 0002-Update-to-current-slf4j.patch
|
||||
# Fedora specific, avoids usage of unpackaged groovy-maven-plugin
|
||||
Patch3: 0003-Replace-groovy-invocation-with-antrun.patch
|
||||
# Downstream-specific, avoids dependency on logback
|
||||
# Used only when %%without logback is in effect
|
||||
Patch4: 0004-Invoke-logback-via-reflection.patch
|
||||
Patch2: 0002-Invoke-logback-via-reflection.patch
|
||||
|
||||
BuildRequires: maven-local
|
||||
BuildRequires: mvn(com.google.guava:guava)
|
||||
BuildRequires: mvn(com.google.inject:guice::no_aop:)
|
||||
BuildRequires: mvn(commons-cli:commons-cli)
|
||||
BuildRequires: mvn(commons-jxpath:commons-jxpath)
|
||||
BuildRequires: mvn(javax.annotation:jsr250-api)
|
||||
BuildRequires: mvn(javax.inject:javax.inject)
|
||||
BuildRequires: mvn(junit:junit)
|
||||
BuildRequires: mvn(org.apache.commons:commons-lang3)
|
||||
BuildRequires: mvn(org.apache.maven:maven-parent:pom:)
|
||||
BuildRequires: mvn(org.apache.maven.plugins:maven-antrun-plugin)
|
||||
BuildRequires: mvn(org.apache.maven.plugins:maven-assembly-plugin)
|
||||
BuildRequires: mvn(org.apache.maven.plugins:maven-dependency-plugin)
|
||||
BuildRequires: mvn(org.apache.maven.resolver:maven-resolver-api)
|
||||
@ -52,20 +49,18 @@ BuildRequires: mvn(org.codehaus.plexus:plexus-component-annotations)
|
||||
BuildRequires: mvn(org.codehaus.plexus:plexus-component-metadata)
|
||||
BuildRequires: mvn(org.codehaus.plexus:plexus-interpolation)
|
||||
BuildRequires: mvn(org.codehaus.plexus:plexus-utils)
|
||||
BuildRequires: mvn(org.eclipse.sisu:org.eclipse.sisu.inject)
|
||||
BuildRequires: mvn(org.eclipse.sisu:org.eclipse.sisu.plexus)
|
||||
BuildRequires: mvn(org.eclipse.sisu:sisu-maven-plugin)
|
||||
BuildRequires: mvn(org.fusesource.jansi:jansi)
|
||||
BuildRequires: mvn(org.mockito:mockito-core)
|
||||
BuildRequires: mvn(org.slf4j:jcl-over-slf4j)
|
||||
BuildRequires: mvn(org.slf4j:slf4j-api)
|
||||
BuildRequires: mvn(org.slf4j:slf4j-simple)
|
||||
BuildRequires: mvn(org.sonatype.plexus:plexus-cipher)
|
||||
BuildRequires: mvn(org.sonatype.plexus:plexus-sec-dispatcher)
|
||||
BuildRequires: mvn(regexp:regexp)
|
||||
BuildRequires: mvn(xmlunit:xmlunit)
|
||||
|
||||
# Missed by builddep
|
||||
BuildRequires: mvn(org.slf4j:jcl-over-slf4j:pom:)
|
||||
|
||||
BuildRequires: slf4j-sources = %{bundled_slf4j_version}
|
||||
|
||||
%if %{with logback}
|
||||
@ -86,12 +81,13 @@ Requires: %{name}-lib = %{epoch}:%{version}-%{release}
|
||||
# everything seems to be easier.
|
||||
Requires: aopalliance
|
||||
Requires: apache-commons-cli
|
||||
Requires: apache-commons-codec
|
||||
Requires: apache-commons-io
|
||||
Requires: apache-commons-lang
|
||||
Requires: apache-commons-lang3
|
||||
Requires: apache-commons-logging
|
||||
Requires: atinject
|
||||
Requires: cdi-api
|
||||
Requires: geronimo-annotation
|
||||
Requires: google-guice
|
||||
Requires: guava
|
||||
Requires: hawtjni-runtime
|
||||
@ -151,8 +147,6 @@ Summary: API documentation for %{name}
|
||||
%setup -q -n apache-%{name}-%{version}
|
||||
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
|
||||
# not really used during build, but a precaution
|
||||
find -name '*.jar' -not -path '*/test/*' -delete
|
||||
@ -183,7 +177,7 @@ sed -i "
|
||||
|
||||
%if %{without logback}
|
||||
%pom_remove_dep -r :logback-classic
|
||||
%patch4 -p1
|
||||
%patch2 -p1
|
||||
%endif
|
||||
|
||||
%mvn_alias :maven-resolver-provider :maven-aether-provider
|
||||
@ -252,6 +246,9 @@ ln -sf %{_sysconfdir}/%{name}/logging %{buildroot}%{_datadir}/%{name}/conf
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Oct 25 2017 Michael Simacek <msimacek@redhat.com> - 1:3.5.2-1
|
||||
- Update to upstream version 3.5.2
|
||||
|
||||
* Fri Sep 15 2017 Michael Simacek <msimacek@redhat.com> - 1:3.5.0-7
|
||||
- Fix FTBFS after maven-remote-reources-plugin update
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (apache-maven-3.5.0-src.tar.gz) = 12594ee1316dc3d9ab61e761105575c8dc96b8f07512f398cc8091ac801312e58da5f115cee38c0cb92eeda53b62c7e6651ad412e71be9498c697c4d5c362e71
|
||||
SHA512 (apache-maven-3.5.2-src.tar.gz) = 1aba1e60be54fe9b9daa700d0b83083314485c479825baeadc92aa6fe40aefc12cf123caf48b8d2622fcd656c4de5d27cb5a706e38fab8ad6b1abaa6ca108696
|
||||
|
Loading…
Reference in New Issue
Block a user