Make javadoc noarch
- Make compilation source level 1.5
This commit is contained in:
parent
dc239c72e5
commit
7dbeeb52a2
@ -1,7 +1,7 @@
|
||||
From d0dbdcde31414336340a5089fecf4f93cb5125ad Mon Sep 17 00:00:00 2001
|
||||
From: Stanislav Ochotnicky <sochotnicky@redhat.com>
|
||||
Date: Tue, 12 Oct 2010 16:56:50 +0200
|
||||
Subject: [PATCH 1/5] Add plugin-api deps
|
||||
Subject: [PATCH 1/6] Add plugin-api deps
|
||||
|
||||
---
|
||||
maven-plugin-api/pom.xml | 5 +++++
|
||||
|
@ -1,7 +1,7 @@
|
||||
From 46e6dbc205065a670fa3b6e7c41e02e30b2fdb7a Mon Sep 17 00:00:00 2001
|
||||
From: Stanislav Ochotnicky <sochotnicky@redhat.com>
|
||||
Date: Tue, 18 Jan 2011 11:09:32 +0100
|
||||
Subject: [PATCH 2/5] Use custom resolver
|
||||
Subject: [PATCH 2/6] Use custom resolver
|
||||
|
||||
WorkspaceReader is used to resolve main dependencies, but we had to
|
||||
add this resolve to ProjectModelResolver and DefaultModelResolver as
|
||||
|
@ -1,7 +1,7 @@
|
||||
From b38e59d0512fed8f376fcbdea71204b04cdee1cb Mon Sep 17 00:00:00 2001
|
||||
From: Stanislav Ochotnicky <sochotnicky@redhat.com>
|
||||
Date: Mon, 22 Aug 2011 15:59:53 +0200
|
||||
Subject: [PATCH 3/5] Use utf-8 source encoding
|
||||
Subject: [PATCH 3/6] Use utf-8 source encoding
|
||||
|
||||
---
|
||||
pom.xml | 1 +
|
||||
|
@ -1,7 +1,7 @@
|
||||
From c626f99ce509b9a505d2ced39efd7ae7c748d71e Mon Sep 17 00:00:00 2001
|
||||
From: Stanislav Ochotnicky <sochotnicky@redhat.com>
|
||||
Date: Tue, 30 Aug 2011 11:44:42 +0200
|
||||
Subject: [PATCH 4/5] Fix text scope skipping with maven.test.skip
|
||||
Subject: [PATCH 4/6] Fix text scope skipping with maven.test.skip
|
||||
|
||||
Previously maven put test dependencies into dependency graph even when
|
||||
"maven.test.skip" was true, therefore. This patch fixes that with few
|
||||
|
@ -1,7 +1,7 @@
|
||||
From 1c572bcc5083b79307ab0c0e4ee9ba15e334c7d3 Mon Sep 17 00:00:00 2001
|
||||
From: Stanislav Ochotnicky <sochotnicky@redhat.com>
|
||||
Date: Tue, 31 Jan 2012 13:12:32 +0100
|
||||
Subject: [PATCH 5/5] Use generics in modello generated code
|
||||
Subject: [PATCH 5/6] Use generics in modello generated code
|
||||
|
||||
---
|
||||
maven-model/pom.xml | 2 ++
|
||||
|
33
0006-Make-compiler-plugin-default-to-source-1.5.patch
Normal file
33
0006-Make-compiler-plugin-default-to-source-1.5.patch
Normal file
@ -0,0 +1,33 @@
|
||||
From 62e01ae45ea1da847e4cabdcbd64950654f9d4a5 Mon Sep 17 00:00:00 2001
|
||||
From: Stanislav Ochotnicky <sochotnicky@redhat.com>
|
||||
Date: Thu, 9 Feb 2012 11:11:26 +0100
|
||||
Subject: [PATCH 6/6] Make compiler plugin default to source 1.5
|
||||
|
||||
This will help with modello problems and is generally better probably
|
||||
---
|
||||
pom.xml | 9 +++++++++
|
||||
1 files changed, 9 insertions(+), 0 deletions(-)
|
||||
|
||||
diff --git a/pom.xml b/pom.xml
|
||||
index c55f33c..fd27b03 100644
|
||||
--- a/pom.xml
|
||||
+++ b/pom.xml
|
||||
@@ -393,6 +393,15 @@
|
||||
<pluginManagement>
|
||||
<plugins>
|
||||
<plugin>
|
||||
+ <groupId>org.apache.maven.plugins</groupId>
|
||||
+ <artifactId>maven-compiler-plugin</artifactId>
|
||||
+ <version>2.1</version>
|
||||
+ <configuration>
|
||||
+ <source>1.5</source>
|
||||
+ <target>1.5</target>
|
||||
+ </configuration>
|
||||
+ </plugin>
|
||||
+ <plugin>
|
||||
<groupId>org.codehaus.plexus</groupId>
|
||||
<artifactId>plexus-component-metadata</artifactId>
|
||||
<version>${plexusVersion}</version>
|
||||
--
|
||||
1.7.7.6
|
||||
|
16
maven.spec
16
maven.spec
@ -2,7 +2,7 @@
|
||||
|
||||
Name: maven
|
||||
Version: 3.0.4
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Summary: Java project management and project comprehension tool
|
||||
|
||||
Group: Development/Tools
|
||||
@ -32,6 +32,8 @@ Source250: repo-metadata.tar.xz
|
||||
|
||||
# Patch1XX could be upstreamed probably
|
||||
Patch100: 0005-Use-generics-in-modello-generated-code.patch
|
||||
Patch101: 0006-Make-compiler-plugin-default-to-source-1.5.patch
|
||||
|
||||
# Patch15X are already upstream
|
||||
Patch150: 0001-Add-plugin-api-deps.patch
|
||||
Patch151: 0003-Use-utf-8-source-encoding.patch
|
||||
@ -111,17 +113,19 @@ reporting and documentation from a central piece of information.
|
||||
Summary: API documentation for %{name}
|
||||
Group: Documentation
|
||||
Requires: jpackage-utils
|
||||
BuildArch: noarch
|
||||
|
||||
%description javadoc
|
||||
%{summary}.
|
||||
|
||||
%prep
|
||||
%setup -q -n apache-%{name}-%{version}%{?ver_add}
|
||||
%patch100 -p1
|
||||
%patch150 -p1
|
||||
%patch151 -p1
|
||||
%patch200 -p1
|
||||
%patch201 -p1
|
||||
%patch100 -p1
|
||||
%patch101 -p1
|
||||
|
||||
# get custom resolver in place
|
||||
mkdir -p maven-aether-provider/src/main/java/org/apache/maven/artifact/resolver \
|
||||
@ -156,7 +160,8 @@ mvn-rpmbuild -e install javadoc:aggregate
|
||||
|
||||
mkdir m2home
|
||||
(cd m2home
|
||||
tar xvf ../apache-maven/target/*tar.gz
|
||||
tar --delay-directory-restore -xvf ../apache-maven/target/*tar.gz
|
||||
chmod -R +rwX apache-%{name}-%{version}%{?ver_add}
|
||||
chmod -x apache-%{name}-%{version}%{?ver_add}/conf/settings.xml
|
||||
)
|
||||
|
||||
@ -340,6 +345,11 @@ install -Dm 644 %{SOURCE1} %{buildroot}%{_sysconfdir}/bash_completion.d/%{name}
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Feb 9 2012 Stanislav Ochotnicky <sochotnicky@redhat.com> - 3.0.4-2
|
||||
- Make javadoc noarch
|
||||
- Make compilation source level 1.5
|
||||
- Fix borked tarball unpacking (reason unknown)
|
||||
|
||||
* Tue Jan 31 2012 Stanislav Ochotnicky <sochotnicky@redhat.com> - 3.0.4-1
|
||||
- Update to latest upstream version
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user