Update to upstream version 3.6.3
This commit is contained in:
parent
f7004f1462
commit
7c1e8179ba
1
.gitignore
vendored
1
.gitignore
vendored
@ -23,3 +23,4 @@
|
||||
/apache-maven-3.5.4-src.tar.gz
|
||||
/apache-maven-3.6.1-src.tar.gz
|
||||
/apache-maven-3.6.2-src.tar.gz
|
||||
/apache-maven-3.6.3-src.tar.gz
|
||||
|
@ -9,7 +9,7 @@ Subject: [PATCH 4/4] Use non-shaded HTTP wagon
|
||||
2 files changed, 16 deletions(-)
|
||||
|
||||
diff --git a/apache-maven/pom.xml b/apache-maven/pom.xml
|
||||
index 2686570af..d22ae121d 100644
|
||||
index 82e12a3..f02a45e 100644
|
||||
--- a/apache-maven/pom.xml
|
||||
+++ b/apache-maven/pom.xml
|
||||
@@ -63,21 +63,6 @@ under the License.
|
||||
@ -33,12 +33,12 @@ index 2686570af..d22ae121d 100644
|
||||
- </exclusions>
|
||||
</dependency>
|
||||
<dependency>
|
||||
<groupId>org.slf4j</groupId>
|
||||
<!-- this is included in Wagon Http
|
||||
diff --git a/pom.xml b/pom.xml
|
||||
index 237cdc39e..85436c54d 100644
|
||||
index 44e287a..cdef69c 100644
|
||||
--- a/pom.xml
|
||||
+++ b/pom.xml
|
||||
@@ -324,7 +324,6 @@ under the License.
|
||||
@@ -328,7 +328,6 @@ under the License.
|
||||
<groupId>org.apache.maven.wagon</groupId>
|
||||
<artifactId>wagon-http</artifactId>
|
||||
<version>${wagonVersion}</version>
|
||||
@ -47,5 +47,5 @@ index 237cdc39e..85436c54d 100644
|
||||
<exclusion>
|
||||
<groupId>commons-logging</groupId>
|
||||
--
|
||||
2.21.0
|
||||
2.24.1
|
||||
|
||||
|
@ -8,7 +8,7 @@ Subject: [PATCH] Remove dependency on powermock
|
||||
1 file changed, 66 deletions(-)
|
||||
|
||||
diff --git a/maven-model-builder/src/test/java/org/apache/maven/model/interpolation/StringSearchModelInterpolatorTest.java b/maven-model-builder/src/test/java/org/apache/maven/model/interpolation/StringSearchModelInterpolatorTest.java
|
||||
index b66abca..a5b2aa0 100644
|
||||
index 45800d6..fbf3b23 100644
|
||||
--- a/maven-model-builder/src/test/java/org/apache/maven/model/interpolation/StringSearchModelInterpolatorTest.java
|
||||
+++ b/maven-model-builder/src/test/java/org/apache/maven/model/interpolation/StringSearchModelInterpolatorTest.java
|
||||
@@ -36,8 +36,6 @@ import java.util.concurrent.FutureTask;
|
||||
@ -92,5 +92,5 @@ index b66abca..a5b2aa0 100644
|
||||
throws Exception
|
||||
{
|
||||
--
|
||||
2.21.0
|
||||
2.24.1
|
||||
|
||||
|
20
maven.spec
20
maven.spec
@ -4,16 +4,16 @@
|
||||
|
||||
Name: maven
|
||||
Epoch: 1
|
||||
Version: 3.6.2
|
||||
Release: 4%{?dist}
|
||||
Version: 3.6.3
|
||||
Release: 1%{?dist}
|
||||
Summary: Java project management and project comprehension tool
|
||||
# maven itself is ASL 2.0
|
||||
# bundled slf4j is MIT
|
||||
License: ASL 2.0 and MIT
|
||||
URL: http://maven.apache.org/
|
||||
URL: https://maven.apache.org/
|
||||
BuildArch: noarch
|
||||
|
||||
Source0: http://archive.apache.org/dist/%{name}/%{name}-3/%{version}/sources/apache-%{name}-%{version}-src.tar.gz
|
||||
Source0: https://archive.apache.org/dist/%{name}/%{name}-3/%{version}/source/apache-%{name}-%{version}-src.tar.gz
|
||||
Source1: maven-bash-completion
|
||||
Source2: mvn.1
|
||||
|
||||
@ -137,17 +137,14 @@ Configures Maven to run with OpenJDK 11.
|
||||
%prep
|
||||
%setup -q -n apache-%{name}-%{version}
|
||||
|
||||
find -name '*.java' -exec sed -i 's/\r//' {} +
|
||||
find -name 'pom.xml' -exec sed -i 's/\r//' {} +
|
||||
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
|
||||
# TODO Delete after maven-3.6.3
|
||||
# Fix Tycho pomless build
|
||||
# https://issues.apache.org/jira/browse/MNG-6765
|
||||
# https://github.com/apache/maven/commit/07ab962c85950b034be3216996900920c0204c3a
|
||||
sed -i 's/@Named/@Named\( "core-default" \)/' maven-model-builder/src/main/java/org/apache/maven/model/building/DefaultModelProcessor.java
|
||||
|
||||
# not really used during build, but a precaution
|
||||
find -name '*.jar' -not -path '*/test/*' -delete
|
||||
find -name '*.class' -delete
|
||||
@ -280,6 +277,9 @@ update-alternatives --install %{_bindir}/mvn mvn %{homedir}/bin/mvn %{?maven_alt
|
||||
%config %{_javaconfdir}/maven.conf-openjdk11
|
||||
|
||||
%changelog
|
||||
* Thu Feb 27 2020 Marian Koncek <mkoncek@redhat.com> - 1:3.6.3-1
|
||||
- Update to upstream version 3.6.3
|
||||
|
||||
* Sat Jan 25 2020 Mikolaj Izdebski <mizdebsk@redhat.com> - 1:3.6.2-4
|
||||
- Build with OpenJDK 8
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (apache-maven-3.6.2-src.tar.gz) = 235198b48d29fe2f2394f2607a9a1637acfd0286beacb974c566f7f36ac6c469871a0db287539b2b62e6322d7423f586949e41cbbfea330fe03bf690688f6fd7
|
||||
SHA512 (apache-maven-3.6.3-src.tar.gz) = 14eef64ad13c1f689f2ab0d2b2b66c9273bf336e557d81d5c22ddb001c47cf51f03bb1465d6059ce9fdc2e43180ceb0638ce914af1f53af9c2398f5d429f114c
|
||||
|
Loading…
Reference in New Issue
Block a user