Update to upstream version 3.8.5
This commit is contained in:
parent
a11388379f
commit
793359dda5
1
.gitignore
vendored
1
.gitignore
vendored
@ -28,3 +28,4 @@
|
||||
/apache-maven-3.6.2-src.tar.gz
|
||||
/apache-maven-3.6.3-src.tar.gz
|
||||
/apache-maven-3.8.4-src.tar.gz
|
||||
/apache-maven-3.8.5-src.tar.gz
|
||||
|
@ -1,14 +1,14 @@
|
||||
From 247eafd819d6092661ebc57c54815acd20abd3de Mon Sep 17 00:00:00 2001
|
||||
From 3c59030162ccb3c38cf62a74a36e52cead52706b Mon Sep 17 00:00:00 2001
|
||||
From: Michael Simacek <msimacek@redhat.com>
|
||||
Date: Wed, 1 Feb 2017 14:54:26 +0100
|
||||
Subject: [PATCH 1/4] Adapt mvn script
|
||||
Subject: [PATCH 1/6] Adapt mvn script
|
||||
|
||||
---
|
||||
apache-maven/src/bin/mvn | 9 +++++++--
|
||||
1 file changed, 7 insertions(+), 2 deletions(-)
|
||||
apache-maven/src/bin/mvn | 11 +++++++++--
|
||||
1 file changed, 9 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/apache-maven/src/bin/mvn b/apache-maven/src/bin/mvn
|
||||
index a554c6617..739501af4 100755
|
||||
index dfa384b8e..605c0edd3 100755
|
||||
--- a/apache-maven/src/bin/mvn
|
||||
+++ b/apache-maven/src/bin/mvn
|
||||
@@ -22,7 +22,7 @@
|
||||
@ -20,7 +20,7 @@ index a554c6617..739501af4 100755
|
||||
# MAVEN_OPTS (Optional) Java runtime options used when Maven is executed.
|
||||
# MAVEN_SKIP_RC (Optional) Flag to disable loading of mavenrc files.
|
||||
# -----------------------------------------------------------------------------
|
||||
@@ -33,12 +33,18 @@ if [ -z "$MAVEN_SKIP_RC" ] ; then
|
||||
@@ -37,12 +37,18 @@ if [ -z "$MAVEN_SKIP_RC" ] ; then
|
||||
. /etc/mavenrc
|
||||
fi
|
||||
|
||||
@ -39,7 +39,7 @@ index a554c6617..739501af4 100755
|
||||
# OS specific support. $var _must_ be set to either true or false.
|
||||
cygwin=false;
|
||||
mingw=false;
|
||||
@@ -63,7 +67,8 @@ done
|
||||
@@ -67,7 +73,8 @@ done
|
||||
|
||||
saveddir=`pwd`
|
||||
|
||||
@ -50,5 +50,5 @@ index a554c6617..739501af4 100755
|
||||
# make it fully qualified
|
||||
MAVEN_HOME=`cd "$MAVEN_HOME" && pwd`
|
||||
--
|
||||
2.21.0
|
||||
2.35.1
|
||||
|
||||
|
@ -1,7 +1,7 @@
|
||||
From 7610a10691e680db00edcbd4ce6767a30641cd71 Mon Sep 17 00:00:00 2001
|
||||
From 4d0c432cf88f2f70e6f793569d3dedace062fdef Mon Sep 17 00:00:00 2001
|
||||
From: Michael Simacek <msimacek@redhat.com>
|
||||
Date: Tue, 6 Jun 2017 13:47:43 +0200
|
||||
Subject: [PATCH 2/4] Invoke logback via reflection
|
||||
Subject: [PATCH 2/6] Invoke logback via reflection
|
||||
|
||||
---
|
||||
.../logging/impl/LogbackConfiguration.java | 19 ++++++++++++++-----
|
||||
@ -49,5 +49,5 @@ index 5d9fab744..ced38cb5a 100644
|
||||
|
||||
@Override
|
||||
--
|
||||
2.21.0
|
||||
2.35.1
|
||||
|
||||
|
@ -1,7 +1,7 @@
|
||||
From c8933d155694ce37b1d4be59a744c8f7cbde6bb5 Mon Sep 17 00:00:00 2001
|
||||
From 81328d875bca5aae7d26e2058f4568a610c680d4 Mon Sep 17 00:00:00 2001
|
||||
From: Mikolaj Izdebski <mizdebsk@redhat.com>
|
||||
Date: Mon, 1 Jul 2019 09:51:56 +0200
|
||||
Subject: [PATCH 4/4] Use non-shaded HTTP wagon
|
||||
Subject: [PATCH 3/6] Use non-shaded HTTP wagon
|
||||
|
||||
---
|
||||
apache-maven/pom.xml | 15 ---------------
|
||||
@ -9,7 +9,7 @@ Subject: [PATCH 4/4] Use non-shaded HTTP wagon
|
||||
2 files changed, 16 deletions(-)
|
||||
|
||||
diff --git a/apache-maven/pom.xml b/apache-maven/pom.xml
|
||||
index 47e74b5..b9ae3de 100644
|
||||
index 7ff412767..b15091576 100644
|
||||
--- a/apache-maven/pom.xml
|
||||
+++ b/apache-maven/pom.xml
|
||||
@@ -63,21 +63,6 @@ under the License.
|
||||
@ -32,13 +32,13 @@ index 47e74b5..b9ae3de 100644
|
||||
- </exclusion>
|
||||
- </exclusions>
|
||||
</dependency>
|
||||
<!-- This is included in Wagon HTTP.
|
||||
We are just making the dependency explicit
|
||||
<dependency>
|
||||
<groupId>org.slf4j</groupId>
|
||||
diff --git a/pom.xml b/pom.xml
|
||||
index c60fe57..f851370 100644
|
||||
index c319cae26..42afab5f1 100644
|
||||
--- a/pom.xml
|
||||
+++ b/pom.xml
|
||||
@@ -334,7 +334,6 @@ under the License.
|
||||
@@ -333,7 +333,6 @@ under the License.
|
||||
<groupId>org.apache.maven.wagon</groupId>
|
||||
<artifactId>wagon-http</artifactId>
|
||||
<version>${wagonVersion}</version>
|
||||
@ -47,5 +47,5 @@ index c60fe57..f851370 100644
|
||||
<exclusion>
|
||||
<groupId>commons-logging</groupId>
|
||||
--
|
||||
2.24.1
|
||||
2.35.1
|
||||
|
||||
|
@ -1,17 +1,17 @@
|
||||
From f6eb583525c7f777bde16182c57a47345fd53cb0 Mon Sep 17 00:00:00 2001
|
||||
From d0bc26194a0e432206d7f92cf0b6fbef67946cc4 Mon Sep 17 00:00:00 2001
|
||||
From: Marian Koncek <mkoncek@redhat.com>
|
||||
Date: Thu, 5 Sep 2019 15:21:04 +0200
|
||||
Subject: [PATCH] Remove dependency on powermock
|
||||
Subject: [PATCH 4/6] Remove dependency on powermock
|
||||
|
||||
---
|
||||
.../StringSearchModelInterpolatorTest.java | 66 -------------------
|
||||
1 file changed, 66 deletions(-)
|
||||
|
||||
diff --git a/maven-model-builder/src/test/java/org/apache/maven/model/interpolation/StringSearchModelInterpolatorTest.java b/maven-model-builder/src/test/java/org/apache/maven/model/interpolation/StringSearchModelInterpolatorTest.java
|
||||
index 45800d6..fbf3b23 100644
|
||||
index c95e37271..aafafa52f 100644
|
||||
--- a/maven-model-builder/src/test/java/org/apache/maven/model/interpolation/StringSearchModelInterpolatorTest.java
|
||||
+++ b/maven-model-builder/src/test/java/org/apache/maven/model/interpolation/StringSearchModelInterpolatorTest.java
|
||||
@@ -36,8 +36,6 @@ import java.util.concurrent.FutureTask;
|
||||
@@ -36,8 +36,6 @@
|
||||
import static org.hamcrest.CoreMatchers.anyOf;
|
||||
import static org.hamcrest.CoreMatchers.is;
|
||||
import static org.junit.Assert.assertThat;
|
||||
@ -20,7 +20,7 @@ index 45800d6..fbf3b23 100644
|
||||
|
||||
/**
|
||||
* @author jdcasey
|
||||
@@ -374,70 +372,6 @@ public class StringSearchModelInterpolatorTest
|
||||
@@ -375,70 +373,6 @@ public void testInterpolateObjectWithPomFile()
|
||||
) ) );
|
||||
}
|
||||
|
||||
@ -92,5 +92,5 @@ index 45800d6..fbf3b23 100644
|
||||
throws Exception
|
||||
{
|
||||
--
|
||||
2.24.1
|
||||
2.35.1
|
||||
|
||||
|
@ -1,7 +1,7 @@
|
||||
From b23d2957440cb4ff06a289b4864f782794b45f52 Mon Sep 17 00:00:00 2001
|
||||
From 25be70bc5a6eb0ddc2838a631cf1a5e20c784e1e Mon Sep 17 00:00:00 2001
|
||||
From: Marian Koncek <mkoncek@redhat.com>
|
||||
Date: Fri, 17 Dec 2021 13:05:49 +0100
|
||||
Subject: [PATCH] Port to maven-resolver 1.7.2
|
||||
Subject: [PATCH 5/6] Port to maven-resolver 1.7.2
|
||||
|
||||
---
|
||||
.../org/apache/maven/repository/internal/MavenAetherModule.java | 2 +-
|
||||
@ -21,5 +21,5 @@ index 41e98aaea..d72e3c0f3 100644
|
||||
import org.eclipse.aether.impl.MetadataGeneratorFactory;
|
||||
import org.eclipse.aether.impl.VersionRangeResolver;
|
||||
--
|
||||
2.31.1
|
||||
2.35.1
|
||||
|
||||
|
@ -0,0 +1,37 @@
|
||||
From 7f97d98125938d065c2025716f041a1dbde326c2 Mon Sep 17 00:00:00 2001
|
||||
From: Mikolaj Izdebski <mizdebsk@redhat.com>
|
||||
Date: Fri, 22 Apr 2022 11:15:38 +0200
|
||||
Subject: [PATCH 6/6] Restore DefaultModelValidator compatibility with Maven
|
||||
3.5.4
|
||||
|
||||
---
|
||||
.../maven/model/validation/DefaultModelValidator.java | 6 ++++++
|
||||
1 file changed, 6 insertions(+)
|
||||
|
||||
diff --git a/maven-model-builder/src/main/java/org/apache/maven/model/validation/DefaultModelValidator.java b/maven-model-builder/src/main/java/org/apache/maven/model/validation/DefaultModelValidator.java
|
||||
index f77321c16..4ed22f3ed 100644
|
||||
--- a/maven-model-builder/src/main/java/org/apache/maven/model/validation/DefaultModelValidator.java
|
||||
+++ b/maven-model-builder/src/main/java/org/apache/maven/model/validation/DefaultModelValidator.java
|
||||
@@ -44,6 +44,7 @@
|
||||
import org.apache.maven.model.building.ModelProblem.Version;
|
||||
import org.apache.maven.model.building.ModelProblemCollector;
|
||||
import org.apache.maven.model.building.ModelProblemCollectorRequest;
|
||||
+import org.apache.maven.model.interpolation.DefaultModelVersionProcessor;
|
||||
import org.apache.maven.model.interpolation.ModelVersionProcessor;
|
||||
import org.codehaus.plexus.util.StringUtils;
|
||||
|
||||
@@ -85,6 +86,11 @@
|
||||
|
||||
private ModelVersionProcessor versionProcessor;
|
||||
|
||||
+ public DefaultModelValidator()
|
||||
+ {
|
||||
+ this( new DefaultModelVersionProcessor() );
|
||||
+ }
|
||||
+
|
||||
@Inject
|
||||
public DefaultModelValidator( ModelVersionProcessor versionProcessor )
|
||||
{
|
||||
--
|
||||
2.35.1
|
||||
|
14
maven.spec
14
maven.spec
@ -6,8 +6,8 @@
|
||||
|
||||
Name: maven
|
||||
Epoch: 1
|
||||
Version: 3.8.4
|
||||
Release: 3%{?dist}
|
||||
Version: 3.8.5
|
||||
Release: 1%{?dist}
|
||||
Summary: Java project management and project comprehension tool
|
||||
# maven itself is ASL 2.0
|
||||
# bundled slf4j is MIT
|
||||
@ -26,6 +26,9 @@ Patch2: 0002-Invoke-logback-via-reflection.patch
|
||||
Patch3: 0003-Use-non-shaded-HTTP-wagon.patch
|
||||
Patch4: 0004-Remove-dependency-on-powermock.patch
|
||||
Patch5: 0005-Port-to-maven-resolver-1.7.2.patch
|
||||
# XMvn needs to be ported to Maven 3.8.5
|
||||
# For now restore backwards compatibility with Maven 3.8.4
|
||||
Patch6: 0006-Restore-DefaultModelValidator-compatibility-with-Mav.patch
|
||||
|
||||
BuildRequires: maven-local-openjdk8
|
||||
%if %{with bootstrap}
|
||||
@ -152,6 +155,7 @@ find -name 'pom.xml' -exec sed -i 's/\r//' {} +
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
%patch5 -p1
|
||||
%patch6 -p1
|
||||
|
||||
# not really used during build, but a precaution
|
||||
find -name '*.jar' -not -path '*/test/*' -delete
|
||||
@ -192,6 +196,9 @@ sed -i "
|
||||
<artifactId>sisu-maven-plugin</artifactId>
|
||||
</plugin>' maven-model-builder/pom.xml
|
||||
|
||||
# XXX extra-enforcer-rules are not packaged yet
|
||||
%pom_remove_dep :extra-enforcer-rules
|
||||
|
||||
%build
|
||||
%mvn_build -- -Dproject.build.sourceEncoding=UTF-8
|
||||
|
||||
@ -293,6 +300,9 @@ if [[ $1 -eq 0 ]]; then update-alternatives --remove mvn %{homedir}/bin/mvn; fi
|
||||
%config %{_javaconfdir}/maven.conf-openjdk17
|
||||
|
||||
%changelog
|
||||
* Thu Apr 21 2022 Mikolaj Izdebski <mizdebsk@redhat.com> - 1:3.8.5-1
|
||||
- Update to upstream version 3.8.5
|
||||
|
||||
* Thu Jan 27 2022 Mikolaj Izdebski <mizdebsk@redhat.com> - 1:3.8.4-3
|
||||
- Suggest OpenJDK 17 as default Maven binding
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (apache-maven-3.8.4-src.tar.gz) = ea4b5f2b29be45d22e716099d0ef87367c78766aade094e8d7f295fe3b2c98cba2bf0f214d3ed55e2c17d2f74c82352cf9dc83fa47ddc97a8d2b847315500431
|
||||
SHA512 (apache-maven-3.8.5-src.tar.gz) = 1aa1b2dcba794b7e4cbc8e2ff9baf642000083fb3883ae93efff26fe259578504b60a8b68404a074f4741922e462fa696cbbe71f9d74e4e6316ed0e389d25667
|
||||
|
Loading…
Reference in New Issue
Block a user