update to version 3.6.1
This commit is contained in:
parent
1c4ff043df
commit
643adf370f
4
.gitignore
vendored
4
.gitignore
vendored
@ -1,3 +1,6 @@
|
|||||||
|
/results_*
|
||||||
|
/*.src.rpm
|
||||||
|
|
||||||
/apache-maven-3.0-src.tar.gz
|
/apache-maven-3.0-src.tar.gz
|
||||||
/apache-maven-3.0.2-src.tar.gz
|
/apache-maven-3.0.2-src.tar.gz
|
||||||
/apache-maven-3.0.3-RC1-src.tar.gz
|
/apache-maven-3.0.3-RC1-src.tar.gz
|
||||||
@ -21,3 +24,4 @@
|
|||||||
/apache-maven-3.5.2-src.tar.gz
|
/apache-maven-3.5.2-src.tar.gz
|
||||||
/apache-maven-3.5.3-src.tar.gz
|
/apache-maven-3.5.3-src.tar.gz
|
||||||
/apache-maven-3.5.4-src.tar.gz
|
/apache-maven-3.5.4-src.tar.gz
|
||||||
|
/apache-maven-3.6.1-src.tar.gz
|
||||||
|
@ -1,14 +1,14 @@
|
|||||||
From 46041685a82b861bc8616bb603e341adb740a302 Mon Sep 17 00:00:00 2001
|
From 056c94f86450c7c27f5bb11f98653c73bfe3d8e4 Mon Sep 17 00:00:00 2001
|
||||||
From: Michael Simacek <msimacek@redhat.com>
|
From: Michael Simacek <msimacek@redhat.com>
|
||||||
Date: Wed, 1 Feb 2017 14:54:26 +0100
|
Date: Wed, 1 Feb 2017 14:54:26 +0100
|
||||||
Subject: [PATCH 1/3] Adapt mvn script
|
Subject: [PATCH 1/4] Adapt mvn script
|
||||||
|
|
||||||
---
|
---
|
||||||
apache-maven/src/bin/mvn | 19 ++++++++++++++++---
|
apache-maven/src/bin/mvn | 17 +++++++++++++++--
|
||||||
1 file changed, 16 insertions(+), 3 deletions(-)
|
1 file changed, 15 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
diff --git a/apache-maven/src/bin/mvn b/apache-maven/src/bin/mvn
|
diff --git a/apache-maven/src/bin/mvn b/apache-maven/src/bin/mvn
|
||||||
index a554c66..818cf70 100755
|
index a554c6617..0c07ba6e2 100755
|
||||||
--- a/apache-maven/src/bin/mvn
|
--- a/apache-maven/src/bin/mvn
|
||||||
+++ b/apache-maven/src/bin/mvn
|
+++ b/apache-maven/src/bin/mvn
|
||||||
@@ -22,7 +22,7 @@
|
@@ -22,7 +22,7 @@
|
||||||
@ -55,15 +55,6 @@ index a554c66..818cf70 100755
|
|||||||
|
|
||||||
# make it fully qualified
|
# make it fully qualified
|
||||||
MAVEN_HOME=`cd "$MAVEN_HOME" && pwd`
|
MAVEN_HOME=`cd "$MAVEN_HOME" && pwd`
|
||||||
@@ -102,7 +115,7 @@ if [ ! -x "$JAVACMD" ] ; then
|
|
||||||
exit 1
|
|
||||||
fi
|
|
||||||
|
|
||||||
-CLASSWORLDS_JAR=`echo "${MAVEN_HOME}"/boot/plexus-classworlds-*.jar`
|
|
||||||
+CLASSWORLDS_JAR=`build-classpath plexus-classworlds`
|
|
||||||
CLASSWORLDS_LAUNCHER=org.codehaus.plexus.classworlds.launcher.Launcher
|
|
||||||
|
|
||||||
# For Cygwin, switch paths to Windows format before running java
|
|
||||||
--
|
--
|
||||||
2.17.1
|
2.21.0
|
||||||
|
|
||||||
|
@ -1,17 +1,17 @@
|
|||||||
From 4e1e32e3a96c6876a22cca6743288b8c8df4adb0 Mon Sep 17 00:00:00 2001
|
From 7610a10691e680db00edcbd4ce6767a30641cd71 Mon Sep 17 00:00:00 2001
|
||||||
From: Michael Simacek <msimacek@redhat.com>
|
From: Michael Simacek <msimacek@redhat.com>
|
||||||
Date: Tue, 6 Jun 2017 13:47:43 +0200
|
Date: Tue, 6 Jun 2017 13:47:43 +0200
|
||||||
Subject: [PATCH 2/3] Invoke logback via reflection
|
Subject: [PATCH 2/4] Invoke logback via reflection
|
||||||
|
|
||||||
---
|
---
|
||||||
.../logging/impl/LogbackConfiguration.java | 19 ++++++++++++++-----
|
.../logging/impl/LogbackConfiguration.java | 19 ++++++++++++++-----
|
||||||
1 file changed, 14 insertions(+), 5 deletions(-)
|
1 file changed, 14 insertions(+), 5 deletions(-)
|
||||||
|
|
||||||
diff --git a/maven-embedder/src/main/java/org/apache/maven/cli/logging/impl/LogbackConfiguration.java b/maven-embedder/src/main/java/org/apache/maven/cli/logging/impl/LogbackConfiguration.java
|
diff --git a/maven-embedder/src/main/java/org/apache/maven/cli/logging/impl/LogbackConfiguration.java b/maven-embedder/src/main/java/org/apache/maven/cli/logging/impl/LogbackConfiguration.java
|
||||||
index 5d9fab7..ced38cb 100644
|
index 5d9fab744..ced38cb5a 100644
|
||||||
--- a/maven-embedder/src/main/java/org/apache/maven/cli/logging/impl/LogbackConfiguration.java
|
--- a/maven-embedder/src/main/java/org/apache/maven/cli/logging/impl/LogbackConfiguration.java
|
||||||
+++ b/maven-embedder/src/main/java/org/apache/maven/cli/logging/impl/LogbackConfiguration.java
|
+++ b/maven-embedder/src/main/java/org/apache/maven/cli/logging/impl/LogbackConfiguration.java
|
||||||
@@ -35,22 +35,31 @@ public class LogbackConfiguration
|
@@ -35,22 +35,31 @@
|
||||||
@Override
|
@Override
|
||||||
public void setRootLoggerLevel( Level level )
|
public void setRootLoggerLevel( Level level )
|
||||||
{
|
{
|
||||||
@ -49,5 +49,5 @@ index 5d9fab7..ced38cb 100644
|
|||||||
|
|
||||||
@Override
|
@Override
|
||||||
--
|
--
|
||||||
2.17.1
|
2.21.0
|
||||||
|
|
||||||
|
@ -0,0 +1,52 @@
|
|||||||
|
From 56d10f48ebb2cdaf3882dc8afbef65a2ab529040 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Sylwester Lachiewicz <slachiewicz@apache.org>
|
||||||
|
Date: Sat, 13 Oct 2018 04:16:44 +0200
|
||||||
|
Subject: [PATCH 3/4] [MNG-6642] Revert "[MNG-5995] Remove dependency to
|
||||||
|
maven-compat (#185)"
|
||||||
|
|
||||||
|
This partially reverts commit bb3ec5da71d26d105972392f0a20bc61bc5d8c53 to restore working with Tycho P2 repository.
|
||||||
|
---
|
||||||
|
.../apache/maven/project/DefaultProjectBuildingHelper.java | 6 +++---
|
||||||
|
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/maven-core/src/main/java/org/apache/maven/project/DefaultProjectBuildingHelper.java b/maven-core/src/main/java/org/apache/maven/project/DefaultProjectBuildingHelper.java
|
||||||
|
index 0bd94a86a..3159fac6b 100644
|
||||||
|
--- a/maven-core/src/main/java/org/apache/maven/project/DefaultProjectBuildingHelper.java
|
||||||
|
+++ b/maven-core/src/main/java/org/apache/maven/project/DefaultProjectBuildingHelper.java
|
||||||
|
@@ -33,7 +33,6 @@
|
||||||
|
import org.apache.maven.artifact.Artifact;
|
||||||
|
import org.apache.maven.artifact.InvalidRepositoryException;
|
||||||
|
import org.apache.maven.artifact.repository.ArtifactRepository;
|
||||||
|
-import org.apache.maven.bridge.MavenRepositorySystem;
|
||||||
|
import org.apache.maven.classrealm.ClassRealmManager;
|
||||||
|
import org.apache.maven.model.Build;
|
||||||
|
import org.apache.maven.model.Extension;
|
||||||
|
@@ -45,6 +44,7 @@
|
||||||
|
import org.apache.maven.plugin.PluginManagerException;
|
||||||
|
import org.apache.maven.plugin.PluginResolutionException;
|
||||||
|
import org.apache.maven.plugin.version.PluginVersionResolutionException;
|
||||||
|
+import org.apache.maven.repository.RepositorySystem;
|
||||||
|
import org.codehaus.plexus.PlexusContainer;
|
||||||
|
import org.codehaus.plexus.classworlds.realm.ClassRealm;
|
||||||
|
import org.codehaus.plexus.component.annotations.Component;
|
||||||
|
@@ -78,7 +78,7 @@
|
||||||
|
private ProjectRealmCache projectRealmCache;
|
||||||
|
|
||||||
|
@Requirement
|
||||||
|
- private MavenRepositorySystem repositorySystem;
|
||||||
|
+ private RepositorySystem repositorySystem;
|
||||||
|
|
||||||
|
@Requirement
|
||||||
|
private MavenPluginManager pluginManager;
|
||||||
|
@@ -92,7 +92,7 @@
|
||||||
|
|
||||||
|
for ( Repository repository : pomRepositories )
|
||||||
|
{
|
||||||
|
- internalRepositories.add( MavenRepositorySystem.buildArtifactRepository( repository ) );
|
||||||
|
+ internalRepositories.add( repositorySystem.buildArtifactRepository( repository ) );
|
||||||
|
}
|
||||||
|
|
||||||
|
repositorySystem.injectMirror( request.getRepositorySession(), internalRepositories );
|
||||||
|
--
|
||||||
|
2.21.0
|
||||||
|
|
51
0004-Use-non-shaded-HTTP-wagon.patch
Normal file
51
0004-Use-non-shaded-HTTP-wagon.patch
Normal file
@ -0,0 +1,51 @@
|
|||||||
|
From c8933d155694ce37b1d4be59a744c8f7cbde6bb5 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Mikolaj Izdebski <mizdebsk@redhat.com>
|
||||||
|
Date: Mon, 1 Jul 2019 09:51:56 +0200
|
||||||
|
Subject: [PATCH 4/4] Use non-shaded HTTP wagon
|
||||||
|
|
||||||
|
---
|
||||||
|
apache-maven/pom.xml | 15 ---------------
|
||||||
|
pom.xml | 1 -
|
||||||
|
2 files changed, 16 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/apache-maven/pom.xml b/apache-maven/pom.xml
|
||||||
|
index 2686570af..d22ae121d 100644
|
||||||
|
--- a/apache-maven/pom.xml
|
||||||
|
+++ b/apache-maven/pom.xml
|
||||||
|
@@ -63,21 +63,6 @@ under the License.
|
||||||
|
<dependency>
|
||||||
|
<groupId>org.apache.maven.wagon</groupId>
|
||||||
|
<artifactId>wagon-http</artifactId>
|
||||||
|
- <classifier>shaded</classifier>
|
||||||
|
- <exclusions>
|
||||||
|
- <exclusion>
|
||||||
|
- <groupId>org.apache.httpcomponents</groupId>
|
||||||
|
- <artifactId>httpclient</artifactId>
|
||||||
|
- </exclusion>
|
||||||
|
- <exclusion>
|
||||||
|
- <groupId>org.apache.httpcomponents</groupId>
|
||||||
|
- <artifactId>httpcore</artifactId>
|
||||||
|
- </exclusion>
|
||||||
|
- <exclusion>
|
||||||
|
- <groupId>org.apache.maven.wagon</groupId>
|
||||||
|
- <artifactId>wagon-http-shared</artifactId>
|
||||||
|
- </exclusion>
|
||||||
|
- </exclusions>
|
||||||
|
</dependency>
|
||||||
|
<dependency>
|
||||||
|
<groupId>org.slf4j</groupId>
|
||||||
|
diff --git a/pom.xml b/pom.xml
|
||||||
|
index 237cdc39e..85436c54d 100644
|
||||||
|
--- a/pom.xml
|
||||||
|
+++ b/pom.xml
|
||||||
|
@@ -324,7 +324,6 @@ under the License.
|
||||||
|
<groupId>org.apache.maven.wagon</groupId>
|
||||||
|
<artifactId>wagon-http</artifactId>
|
||||||
|
<version>${wagonVersion}</version>
|
||||||
|
- <classifier>shaded</classifier>
|
||||||
|
<exclusions>
|
||||||
|
<exclusion>
|
||||||
|
<groupId>commons-logging</groupId>
|
||||||
|
--
|
||||||
|
2.21.0
|
||||||
|
|
52
maven-script
52
maven-script
@ -1,52 +0,0 @@
|
|||||||
#!/bin/sh
|
|
||||||
|
|
||||||
for f in /etc/mavenrc /etc/java/maven.conf "$HOME/.mavenrc"; do
|
|
||||||
[ -f "$f" ] && . "$f"
|
|
||||||
done
|
|
||||||
|
|
||||||
if [ -f /usr/share/java-utils/java-functions ] ; then
|
|
||||||
. /usr/share/java-utils/java-functions
|
|
||||||
set_jvm
|
|
||||||
set_javacmd
|
|
||||||
fi
|
|
||||||
export JAVA_HOME
|
|
||||||
export JAVACMD
|
|
||||||
|
|
||||||
export M2_HOME="${M2_HOME:-/usr/share/maven}"
|
|
||||||
|
|
||||||
|
|
||||||
# traverses directory structure from process work directory to filesystem root
|
|
||||||
# first directory with .mvn subdirectory is considered project base directory
|
|
||||||
find_maven_basedir() {
|
|
||||||
(
|
|
||||||
basedir="`pwd`"
|
|
||||||
wdir="`pwd`"
|
|
||||||
while [ "$wdir" != '/' ] ; do
|
|
||||||
if [ -d "$wdir"/.mvn ] ; then
|
|
||||||
basedir=$wdir
|
|
||||||
break
|
|
||||||
fi
|
|
||||||
wdir="`cd "$wdir/.."; pwd`"
|
|
||||||
done
|
|
||||||
echo "${basedir}"
|
|
||||||
)
|
|
||||||
}
|
|
||||||
|
|
||||||
export MAVEN_PROJECTBASEDIR="${MAVEN_BASEDIR:-`find_maven_basedir`}"
|
|
||||||
|
|
||||||
export MAVEN_CMD_LINE_ARGS="$MAVEN_CONFIG $@"
|
|
||||||
|
|
||||||
project_opts=$(
|
|
||||||
[ -e "$MAVEN_PROJECTBASEDIR/.mvn/jvm.config" ] &&
|
|
||||||
cat /tmp/foo "$MAVEN_PROJECTBASEDIR/.mvn/jvm.config")
|
|
||||||
|
|
||||||
exec "$JAVACMD" \
|
|
||||||
$project_opts \
|
|
||||||
$MAVEN_OPTS \
|
|
||||||
$MAVEN_DEBUG_OPTS \
|
|
||||||
-classpath $(build-classpath plexus-classworlds) \
|
|
||||||
-Dclassworlds.conf="${M2_HOME}/bin/m2.conf" \
|
|
||||||
-Dmaven.home="${M2_HOME}" \
|
|
||||||
-Dmaven.multiModuleProjectDirectory="${MAVEN_PROJECTBASEDIR}" \
|
|
||||||
org.codehaus.plexus.classworlds.launcher.Launcher \
|
|
||||||
"$@"
|
|
23
maven.spec
23
maven.spec
@ -6,8 +6,8 @@
|
|||||||
|
|
||||||
Name: maven
|
Name: maven
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 3.5.4
|
Version: 3.6.1
|
||||||
Release: 12%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Java project management and project comprehension tool
|
Summary: Java project management and project comprehension tool
|
||||||
# maven itself is ASL 2.0
|
# maven itself is ASL 2.0
|
||||||
# bundled slf4j is MIT
|
# bundled slf4j is MIT
|
||||||
@ -15,7 +15,7 @@ License: ASL 2.0 and MIT
|
|||||||
URL: http://maven.apache.org/
|
URL: http://maven.apache.org/
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
|
|
||||||
Source0: http://archive.apache.org/dist/%{name}/%{name}-3/%{version}/source/apache-%{name}-%{version}-src.tar.gz
|
Source0: http://archive.apache.org/dist/%{name}/%{name}-3/%{version}/sources/apache-%{name}-%{version}-src.tar.gz
|
||||||
Source1: maven-bash-completion
|
Source1: maven-bash-completion
|
||||||
Source2: mvn.1
|
Source2: mvn.1
|
||||||
|
|
||||||
@ -23,9 +23,10 @@ Patch1: 0001-Adapt-mvn-script.patch
|
|||||||
# Downstream-specific, avoids dependency on logback
|
# Downstream-specific, avoids dependency on logback
|
||||||
# Used only when %%without logback is in effect
|
# Used only when %%without logback is in effect
|
||||||
Patch2: 0002-Invoke-logback-via-reflection.patch
|
Patch2: 0002-Invoke-logback-via-reflection.patch
|
||||||
|
Patch3: 0003-MNG-6642-Revert-MNG-5995-Remove-dependency-to-maven-.patch
|
||||||
|
Patch4: 0004-Use-non-shaded-HTTP-wagon.patch
|
||||||
|
|
||||||
BuildRequires: maven-local
|
BuildRequires: maven-local
|
||||||
BuildRequires: mvn(com.google.guava:guava:20.0)
|
|
||||||
BuildRequires: mvn(com.google.inject:guice::no_aop:)
|
BuildRequires: mvn(com.google.inject:guice::no_aop:)
|
||||||
BuildRequires: mvn(commons-cli:commons-cli)
|
BuildRequires: mvn(commons-cli:commons-cli)
|
||||||
BuildRequires: mvn(commons-jxpath:commons-jxpath)
|
BuildRequires: mvn(commons-jxpath:commons-jxpath)
|
||||||
@ -44,15 +45,15 @@ BuildRequires: mvn(org.apache.maven.resolver:maven-resolver-transport-wagon)
|
|||||||
BuildRequires: mvn(org.apache.maven.resolver:maven-resolver-util)
|
BuildRequires: mvn(org.apache.maven.resolver:maven-resolver-util)
|
||||||
BuildRequires: mvn(org.apache.maven.shared:maven-shared-utils)
|
BuildRequires: mvn(org.apache.maven.shared:maven-shared-utils)
|
||||||
BuildRequires: mvn(org.apache.maven.wagon:wagon-file)
|
BuildRequires: mvn(org.apache.maven.wagon:wagon-file)
|
||||||
BuildRequires: mvn(org.apache.maven.wagon:wagon-http::shaded:)
|
BuildRequires: mvn(org.apache.maven.wagon:wagon-http)
|
||||||
BuildRequires: mvn(org.apache.maven.wagon:wagon-provider-api)
|
BuildRequires: mvn(org.apache.maven.wagon:wagon-provider-api)
|
||||||
BuildRequires: mvn(org.codehaus.modello:modello-maven-plugin)
|
BuildRequires: mvn(org.codehaus.modello:modello-maven-plugin) >= 1.10.0
|
||||||
BuildRequires: mvn(org.codehaus.mojo:build-helper-maven-plugin)
|
BuildRequires: mvn(org.codehaus.mojo:build-helper-maven-plugin)
|
||||||
BuildRequires: mvn(org.codehaus.plexus:plexus-classworlds)
|
BuildRequires: mvn(org.codehaus.plexus:plexus-classworlds)
|
||||||
BuildRequires: mvn(org.codehaus.plexus:plexus-component-annotations)
|
BuildRequires: mvn(org.codehaus.plexus:plexus-component-annotations)
|
||||||
BuildRequires: mvn(org.codehaus.plexus:plexus-component-metadata)
|
BuildRequires: mvn(org.codehaus.plexus:plexus-component-metadata)
|
||||||
BuildRequires: mvn(org.codehaus.plexus:plexus-interpolation)
|
BuildRequires: mvn(org.codehaus.plexus:plexus-interpolation)
|
||||||
BuildRequires: mvn(org.codehaus.plexus:plexus-utils)
|
BuildRequires: mvn(org.codehaus.plexus:plexus-utils) >= 3.2.0
|
||||||
BuildRequires: mvn(org.eclipse.sisu:org.eclipse.sisu.inject)
|
BuildRequires: mvn(org.eclipse.sisu:org.eclipse.sisu.inject)
|
||||||
BuildRequires: mvn(org.eclipse.sisu:org.eclipse.sisu.plexus)
|
BuildRequires: mvn(org.eclipse.sisu:org.eclipse.sisu.plexus)
|
||||||
BuildRequires: mvn(org.eclipse.sisu:sisu-maven-plugin)
|
BuildRequires: mvn(org.eclipse.sisu:sisu-maven-plugin)
|
||||||
@ -63,7 +64,8 @@ BuildRequires: mvn(org.slf4j:slf4j-api)
|
|||||||
BuildRequires: mvn(org.slf4j:slf4j-simple)
|
BuildRequires: mvn(org.slf4j:slf4j-simple)
|
||||||
BuildRequires: mvn(org.sonatype.plexus:plexus-cipher)
|
BuildRequires: mvn(org.sonatype.plexus:plexus-cipher)
|
||||||
BuildRequires: mvn(org.sonatype.plexus:plexus-sec-dispatcher)
|
BuildRequires: mvn(org.sonatype.plexus:plexus-sec-dispatcher)
|
||||||
BuildRequires: mvn(xmlunit:xmlunit)
|
BuildRequires: mvn(org.xmlunit:xmlunit-core)
|
||||||
|
BuildRequires: mvn(org.xmlunit:xmlunit-matchers)
|
||||||
|
|
||||||
BuildRequires: slf4j-sources = %{bundled_slf4j_version}
|
BuildRequires: slf4j-sources = %{bundled_slf4j_version}
|
||||||
|
|
||||||
@ -157,6 +159,8 @@ Summary: API documentation for %{name}
|
|||||||
%setup -q -n apache-%{name}-%{version}
|
%setup -q -n apache-%{name}-%{version}
|
||||||
|
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
|
%patch3 -p1
|
||||||
|
%patch4 -p1
|
||||||
|
|
||||||
# not really used during build, but a precaution
|
# not really used during build, but a precaution
|
||||||
find -name '*.jar' -not -path '*/test/*' -delete
|
find -name '*.jar' -not -path '*/test/*' -delete
|
||||||
@ -272,6 +276,9 @@ update-alternatives --install %{_bindir}/mvn mvn %{homedir}/bin/mvn %{?maven_alt
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Oct 16 2019 Fabio Valentini <decathorpe@gmail.com> - 1:3.6.1-1
|
||||||
|
- Update to version 3.6.1.
|
||||||
|
|
||||||
* Thu Aug 29 2019 Fabio Valentini <decathorpe@gmail.com> - 1:3.5.4-12
|
* Thu Aug 29 2019 Fabio Valentini <decathorpe@gmail.com> - 1:3.5.4-12
|
||||||
- Remove dependency on logback-classic.
|
- Remove dependency on logback-classic.
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (apache-maven-3.5.4-src.tar.gz) = faf3c13af3350d056fd49aa3d0a631533a0340332bda8f88a9d8a4c489ec291981b29354a9ed6ff7a8565e0b79eaf16803f908067c5dbd16820cd9025852b39f
|
SHA512 (apache-maven-3.6.1-src.tar.gz) = 11a31022cffa0518584703fffd9fce998332ac5f6c2a50db3b590e90f3bdd1508d9e0cb5ba89a699ef6536b237bcc96166cfde3d45bce6346fa21b05b4d12bf8
|
||||||
|
Loading…
Reference in New Issue
Block a user