Merge branch 'master' into f20
Conflicts: maven.spec
This commit is contained in:
commit
5fa15811e9
1
.gitignore
vendored
1
.gitignore
vendored
@ -5,3 +5,4 @@
|
||||
/apache-maven-3.0.4-src.tar.gz
|
||||
/apache-maven-3.0.5-src.tar.gz
|
||||
/apache-maven-3.1.0-src.tar.gz
|
||||
/apache-maven-3.1.1-src.tar.gz
|
||||
|
@ -1,7 +1,7 @@
|
||||
From cb3b8016fa74d1684029034793c0605b36491b60 Mon Sep 17 00:00:00 2001
|
||||
From 13b48a2b020ced6858e90c4d596f6804989844b9 Mon Sep 17 00:00:00 2001
|
||||
From: Mikolaj Izdebski <mizdebsk@redhat.com>
|
||||
Date: Thu, 29 Aug 2013 10:11:48 +0200
|
||||
Subject: [PATCH] Migrate from easymock 1 to easymock 3
|
||||
Subject: [PATCH 2/3] Migrate from easymock 1 to easymock 3
|
||||
|
||||
---
|
||||
maven-compat/pom.xml | 2 +-
|
||||
@ -12,10 +12,10 @@ Subject: [PATCH] Migrate from easymock 1 to easymock 3
|
||||
delete mode 100644 maven-compat/src/test/java/org/apache/maven/artifact/testutils/MockManager.java
|
||||
|
||||
diff --git a/maven-compat/pom.xml b/maven-compat/pom.xml
|
||||
index 21270b7..e07855b 100644
|
||||
index dbb4155..f4cd5a9 100644
|
||||
--- a/maven-compat/pom.xml
|
||||
+++ b/maven-compat/pom.xml
|
||||
@@ -77,7 +77,7 @@
|
||||
@@ -83,7 +83,7 @@
|
||||
<scope>test</scope>
|
||||
</dependency>
|
||||
<dependency>
|
||||
@ -89,10 +89,10 @@ index 4b6f637..0000000
|
||||
-
|
||||
-}
|
||||
diff --git a/maven-compat/src/test/java/org/apache/maven/repository/legacy/DefaultWagonManagerTest.java b/maven-compat/src/test/java/org/apache/maven/repository/legacy/DefaultWagonManagerTest.java
|
||||
index bcda50a..6823ae2 100644
|
||||
index bcda50a..37a281c 100644
|
||||
--- a/maven-compat/src/test/java/org/apache/maven/repository/legacy/DefaultWagonManagerTest.java
|
||||
+++ b/maven-compat/src/test/java/org/apache/maven/repository/legacy/DefaultWagonManagerTest.java
|
||||
@@ -45,7 +45,7 @@ import org.apache.maven.wagon.observers.AbstractTransferListener;
|
||||
@@ -45,7 +45,7 @@
|
||||
import org.apache.maven.wagon.observers.Debug;
|
||||
import org.codehaus.plexus.PlexusTestCase;
|
||||
import org.codehaus.plexus.util.FileUtils;
|
||||
@ -101,7 +101,7 @@ index bcda50a..6823ae2 100644
|
||||
|
||||
/**
|
||||
* @author <a href="michal.maczka@dimatics.com">Michal Maczka</a>
|
||||
@@ -162,15 +162,14 @@ public class DefaultWagonManagerTest
|
||||
@@ -162,15 +162,14 @@ public void testGetRemoteJar()
|
||||
StringWagon wagon = (StringWagon) wagonManager.getWagon( "string" );
|
||||
wagon.addExpectedContent( repo.getLayout().pathOf( artifact ), "expected" );
|
||||
|
||||
@ -120,18 +120,18 @@ index bcda50a..6823ae2 100644
|
||||
|
||||
private Artifact createTestPomArtifact( String directory )
|
||||
diff --git a/pom.xml b/pom.xml
|
||||
index 19edb60..06e6256 100644
|
||||
index 701e727..71e6d5a 100644
|
||||
--- a/pom.xml
|
||||
+++ b/pom.xml
|
||||
@@ -44,7 +44,7 @@
|
||||
<properties>
|
||||
<classWorldsVersion>2.4.2</classWorldsVersion>
|
||||
<classWorldsVersion>2.5.1</classWorldsVersion>
|
||||
<commonsCliVersion>1.2</commonsCliVersion>
|
||||
- <easyMockVersion>1.2_Java1.3</easyMockVersion>
|
||||
+ <easyMockVersion>3.2</easyMockVersion>
|
||||
<junitVersion>3.8.2</junitVersion>
|
||||
<plexusVersion>1.5.5</plexusVersion>
|
||||
<plexusInterpolationVersion>1.16</plexusInterpolationVersion>
|
||||
<plexusInterpolationVersion>1.19</plexusInterpolationVersion>
|
||||
@@ -320,7 +320,7 @@
|
||||
</dependency>
|
||||
<!--bootstrap-start-comment-->
|
||||
@ -142,5 +142,5 @@ index 19edb60..06e6256 100644
|
||||
<version>${easyMockVersion}</version>
|
||||
<scope>test</scope>
|
||||
--
|
||||
1.8.3.1
|
||||
1.8.1.4
|
||||
|
||||
|
@ -1,7 +1,7 @@
|
||||
From 51bc34848a46cca087fa7872b92af12a89415708 Mon Sep 17 00:00:00 2001
|
||||
From 9874d5c9fb80c779682ffc5f8dd45435a17546ce Mon Sep 17 00:00:00 2001
|
||||
From: Mikolaj Izdebski <mizdebsk@redhat.com>
|
||||
Date: Mon, 12 Aug 2013 08:49:19 +0200
|
||||
Subject: [PATCH] Update Aether to 0.9.0.M3
|
||||
Subject: [PATCH 3/3] Update Aether to 0.9.0.M3
|
||||
|
||||
---
|
||||
apache-maven/pom.xml | 6 +++++-
|
||||
@ -11,10 +11,10 @@ Subject: [PATCH] Update Aether to 0.9.0.M3
|
||||
4 files changed, 24 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/apache-maven/pom.xml b/apache-maven/pom.xml
|
||||
index 49ab2e9..9ecc868 100644
|
||||
index 4a53643..0b56fa8 100644
|
||||
--- a/apache-maven/pom.xml
|
||||
+++ b/apache-maven/pom.xml
|
||||
@@ -81,7 +81,11 @@
|
||||
@@ -87,7 +87,11 @@
|
||||
</dependency>
|
||||
<dependency>
|
||||
<groupId>org.eclipse.aether</groupId>
|
||||
@ -28,11 +28,11 @@ index 49ab2e9..9ecc868 100644
|
||||
<dependency>
|
||||
<groupId>org.slf4j</groupId>
|
||||
diff --git a/maven-aether-provider/pom.xml b/maven-aether-provider/pom.xml
|
||||
index 1bb1126..90aa2a2 100644
|
||||
index a5c460a..62ce127 100644
|
||||
--- a/maven-aether-provider/pom.xml
|
||||
+++ b/maven-aether-provider/pom.xml
|
||||
@@ -64,7 +64,12 @@ under the License.
|
||||
</dependency>
|
||||
@@ -91,7 +91,12 @@ under the License.
|
||||
<!-- Testing -->
|
||||
<dependency>
|
||||
<groupId>org.eclipse.aether</groupId>
|
||||
- <artifactId>aether-connector-wagon</artifactId>
|
||||
@ -46,10 +46,10 @@ index 1bb1126..90aa2a2 100644
|
||||
</dependency>
|
||||
<dependency>
|
||||
diff --git a/maven-compat/pom.xml b/maven-compat/pom.xml
|
||||
index 21270b7..74551c9 100644
|
||||
index f4cd5a9..ee6ace7 100644
|
||||
--- a/maven-compat/pom.xml
|
||||
+++ b/maven-compat/pom.xml
|
||||
@@ -73,7 +73,12 @@
|
||||
@@ -79,7 +79,12 @@
|
||||
</dependency>
|
||||
<dependency>
|
||||
<groupId>org.eclipse.aether</groupId>
|
||||
@ -64,16 +64,16 @@ index 21270b7..74551c9 100644
|
||||
</dependency>
|
||||
<dependency>
|
||||
diff --git a/pom.xml b/pom.xml
|
||||
index 19edb60..c4f724c 100644
|
||||
index 71e6d5a..889ba1d 100644
|
||||
--- a/pom.xml
|
||||
+++ b/pom.xml
|
||||
@@ -58,7 +58,7 @@
|
||||
<cipherVersion>1.7</cipherVersion>
|
||||
<modelloVersion>1.7</modelloVersion>
|
||||
<modelloVersion>1.8.1</modelloVersion>
|
||||
<jxpathVersion>1.3</jxpathVersion>
|
||||
- <aetherVersion>0.9.0.M2</aetherVersion>
|
||||
+ <aetherVersion>0.9.0.M3</aetherVersion>
|
||||
<slf4jVersion>1.7.4</slf4jVersion>
|
||||
<slf4jVersion>1.7.5</slf4jVersion>
|
||||
<maven.test.redirectTestOutputToFile>true</maven.test.redirectTestOutputToFile>
|
||||
<!-- Control the name of the distribution and information output by mvn -->
|
||||
@@ -284,7 +284,12 @@
|
||||
|
@ -1,18 +1,18 @@
|
||||
From 1c572bcc5083b79307ab0c0e4ee9ba15e334c7d3 Mon Sep 17 00:00:00 2001
|
||||
From a19f7488a64486c5d9ace8c681a963da92b9e269 Mon Sep 17 00:00:00 2001
|
||||
From: Stanislav Ochotnicky <sochotnicky@redhat.com>
|
||||
Date: Tue, 31 Jan 2012 13:12:32 +0100
|
||||
Subject: [PATCH 5/6] Use generics in modello generated code
|
||||
Subject: [PATCH 1/3] Use generics in modello generated code
|
||||
|
||||
---
|
||||
maven-model/pom.xml | 2 ++
|
||||
pom.xml | 3 +++
|
||||
2 files changed, 5 insertions(+), 0 deletions(-)
|
||||
maven-model/pom.xml | 2 ++
|
||||
pom.xml | 3 +++
|
||||
2 files changed, 5 insertions(+)
|
||||
|
||||
diff --git a/maven-model/pom.xml b/maven-model/pom.xml
|
||||
index 63b2d23..951cd57 100644
|
||||
index 7fd718f..b8781b6 100644
|
||||
--- a/maven-model/pom.xml
|
||||
+++ b/maven-model/pom.xml
|
||||
@@ -50,6 +50,7 @@ under the License.
|
||||
@@ -56,6 +56,7 @@ under the License.
|
||||
<models>
|
||||
<model>src/main/mdo/maven.mdo</model>
|
||||
</models>
|
||||
@ -20,7 +20,7 @@ index 63b2d23..951cd57 100644
|
||||
</configuration>
|
||||
<executions>
|
||||
<execution>
|
||||
@@ -97,6 +98,7 @@ under the License.
|
||||
@@ -103,6 +104,7 @@ under the License.
|
||||
<configuration>
|
||||
<version>3.0.0</version>
|
||||
<packageWithVersion>true</packageWithVersion>
|
||||
@ -29,10 +29,10 @@ index 63b2d23..951cd57 100644
|
||||
</execution>
|
||||
</executions>
|
||||
diff --git a/pom.xml b/pom.xml
|
||||
index 8cba9cc..c55f33c 100644
|
||||
index 922976f..701e727 100644
|
||||
--- a/pom.xml
|
||||
+++ b/pom.xml
|
||||
@@ -424,6 +424,9 @@
|
||||
@@ -382,6 +382,9 @@
|
||||
<groupId>org.codehaus.modello</groupId>
|
||||
<artifactId>modello-maven-plugin</artifactId>
|
||||
<version>${modelloVersion}</version>
|
||||
@ -43,5 +43,5 @@ index 8cba9cc..c55f33c 100644
|
||||
<execution>
|
||||
<id>site-docs</id>
|
||||
--
|
||||
1.7.7.6
|
||||
1.8.1.4
|
||||
|
||||
|
29
maven.spec
29
maven.spec
@ -1,6 +1,6 @@
|
||||
Name: maven
|
||||
Version: 3.1.0
|
||||
Release: 11%{?dist}
|
||||
Version: 3.1.1
|
||||
Release: 12%{?dist}
|
||||
Summary: Java project management and project comprehension tool
|
||||
|
||||
Group: Development/Tools
|
||||
@ -20,9 +20,6 @@ Patch101: 0001-Migrate-from-easymock-1-to-easymock-3.patch
|
||||
# Forwarded upstream (MNG-5502)
|
||||
Patch200: 0001-Update-Aether-to-0.9.0.M3.patch
|
||||
|
||||
# Taken from upstream git (commit 11f46bd, MNG-5503)
|
||||
Patch300: 0001-MNG-5503-Fix-for-the-issue-where-Maven-3.1.0-fails-t.patch
|
||||
|
||||
BuildArch: noarch
|
||||
|
||||
# If XMvn is part of the same RPM transaction then it should be
|
||||
@ -78,6 +75,7 @@ BuildRequires: sisu-plexus >= 1:0
|
||||
BuildRequires: slf4j
|
||||
BuildRequires: xmlunit
|
||||
BuildRequires: mvn(ch.qos.logback:logback-classic)
|
||||
BuildRequires: mvn(org.mockito:mockito-core)
|
||||
|
||||
# Theoretically Maven might be usable with just JRE, but typical Maven
|
||||
# workflow requires full JDK, wso we require it here.
|
||||
@ -145,7 +143,6 @@ Group: Documentation
|
||||
%patch100 -p1
|
||||
%patch101 -p1
|
||||
%patch200 -p1
|
||||
%patch300 -p1
|
||||
|
||||
# not really used during build, but a precaution
|
||||
rm maven-ant-tasks-*.jar
|
||||
@ -250,7 +247,7 @@ ln -sf $(build-classpath plexus/classworlds) \
|
||||
|
||||
|
||||
%files -f .mfiles
|
||||
%doc LICENSE.txt NOTICE.txt README.txt
|
||||
%doc LICENSE NOTICE README.txt
|
||||
%{_datadir}/%{name}
|
||||
%{_bindir}/mvn
|
||||
%dir %{_javadir}/%{name}
|
||||
@ -263,20 +260,34 @@ ln -sf $(build-classpath plexus/classworlds) \
|
||||
%{_mandir}/man1/mvn.1.gz
|
||||
|
||||
%files javadoc -f .mfiles-javadoc
|
||||
%doc LICENSE.txt NOTICE.txt
|
||||
%doc LICENSE NOTICE
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Oct 21 2013 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.1.0-11
|
||||
* Tue Nov 5 2013 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.1.1-6
|
||||
- Update F20 to upstream bugfix release 3.1.1
|
||||
|
||||
* Tue Nov 5 2013 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.1.1-5
|
||||
- Add OrderWithRequires: xmvn
|
||||
- Related: rhbz#1014355
|
||||
|
||||
* Tue Oct 29 2013 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.1.1-4
|
||||
- Add explicit requires
|
||||
|
||||
* Wed Oct 23 2013 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.1.1-3
|
||||
- Rebuild to regenerate broken POM files
|
||||
- Related: rhbz#1021484
|
||||
|
||||
* Mon Oct 21 2013 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.1.0-10
|
||||
- Add dependencies of wagon-http-shaded to plexus.core
|
||||
- Remove objectweb-asm from plexus.core
|
||||
- Add explicit requires
|
||||
- Resolves: rhbz#1023872
|
||||
|
||||
* Mon Oct 7 2013 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.1.1-1
|
||||
- Update to upstream version 3.1.1
|
||||
- Remove patch for MNG-5503 (included upstream)
|
||||
|
||||
* Mon Sep 23 2013 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.1.0-9
|
||||
- Synchronize JAR list in lib/ with upstream release
|
||||
- Remove test dependencies on aopalliance and cglib
|
||||
|
Loading…
Reference in New Issue
Block a user