Update to upstream version 3.2.5
This commit is contained in:
parent
58e6aad3e2
commit
5f6ae673b5
1
.gitignore
vendored
1
.gitignore
vendored
@ -10,3 +10,4 @@
|
||||
/apache-maven-3.2.1-src.tar.gz
|
||||
/apache-maven-3.2.2-src.tar.gz
|
||||
/apache-maven-3.2.3-src.tar.gz
|
||||
/apache-maven-3.2.5-src.tar.gz
|
||||
|
@ -1,152 +0,0 @@
|
||||
From 44bd2d20c196427c66577236ec62aaa77ecbd974 Mon Sep 17 00:00:00 2001
|
||||
From: Mikolaj Izdebski <mizdebsk@redhat.com>
|
||||
Date: Thu, 29 Aug 2013 10:11:48 +0200
|
||||
Subject: [PATCH 1/3] [MNG-5696] Remove dependency on Easymock
|
||||
|
||||
Easymock is not really used for anything, so it can be removed.
|
||||
---
|
||||
maven-compat/pom.xml | 5 --
|
||||
.../maven/artifact/testutils/MockManager.java | 58 ----------------------
|
||||
.../repository/legacy/DefaultWagonManagerTest.java | 6 ---
|
||||
pom.xml | 9 ----
|
||||
4 files changed, 78 deletions(-)
|
||||
delete mode 100644 maven-compat/src/test/java/org/apache/maven/artifact/testutils/MockManager.java
|
||||
|
||||
diff --git a/maven-compat/pom.xml b/maven-compat/pom.xml
|
||||
index 02ac0d3..28db8ba 100644
|
||||
--- a/maven-compat/pom.xml
|
||||
+++ b/maven-compat/pom.xml
|
||||
@@ -82,11 +82,6 @@
|
||||
<artifactId>aether-connector-wagon</artifactId>
|
||||
<scope>test</scope>
|
||||
</dependency>
|
||||
- <dependency>
|
||||
- <groupId>easymock</groupId>
|
||||
- <artifactId>easymock</artifactId>
|
||||
- <scope>test</scope>
|
||||
- </dependency>
|
||||
</dependencies>
|
||||
|
||||
<build>
|
||||
diff --git a/maven-compat/src/test/java/org/apache/maven/artifact/testutils/MockManager.java b/maven-compat/src/test/java/org/apache/maven/artifact/testutils/MockManager.java
|
||||
deleted file mode 100644
|
||||
index 4b6f637..0000000
|
||||
--- a/maven-compat/src/test/java/org/apache/maven/artifact/testutils/MockManager.java
|
||||
+++ /dev/null
|
||||
@@ -1,58 +0,0 @@
|
||||
-package org.apache.maven.artifact.testutils;
|
||||
-
|
||||
-/*
|
||||
- * Licensed to the Apache Software Foundation (ASF) under one
|
||||
- * or more contributor license agreements. See the NOTICE file
|
||||
- * distributed with this work for additional information
|
||||
- * regarding copyright ownership. The ASF licenses this file
|
||||
- * to you under the Apache License, Version 2.0 (the
|
||||
- * "License"); you may not use this file except in compliance
|
||||
- * with the License. You may obtain a copy of the License at
|
||||
- *
|
||||
- * http://www.apache.org/licenses/LICENSE-2.0
|
||||
- *
|
||||
- * Unless required by applicable law or agreed to in writing,
|
||||
- * software distributed under the License is distributed on an
|
||||
- * "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
|
||||
- * KIND, either express or implied. See the License for the
|
||||
- * specific language governing permissions and limitations
|
||||
- * under the License.
|
||||
- */
|
||||
-
|
||||
-import java.util.ArrayList;
|
||||
-import java.util.Iterator;
|
||||
-import java.util.List;
|
||||
-
|
||||
-import org.easymock.MockControl;
|
||||
-
|
||||
-public class MockManager
|
||||
-{
|
||||
-
|
||||
- private List mockControls = new ArrayList();
|
||||
-
|
||||
- public void add( MockControl control )
|
||||
- {
|
||||
- mockControls.add( control );
|
||||
- }
|
||||
-
|
||||
- public void replayAll()
|
||||
- {
|
||||
- for ( Object mockControl : mockControls )
|
||||
- {
|
||||
- MockControl control = (MockControl) mockControl;
|
||||
-
|
||||
- control.replay();
|
||||
- }
|
||||
- }
|
||||
-
|
||||
- public void verifyAll()
|
||||
- {
|
||||
- for ( Object mockControl : mockControls )
|
||||
- {
|
||||
- MockControl control = (MockControl) mockControl;
|
||||
-
|
||||
- control.verify();
|
||||
- }
|
||||
- }
|
||||
-
|
||||
-}
|
||||
diff --git a/maven-compat/src/test/java/org/apache/maven/repository/legacy/DefaultWagonManagerTest.java b/maven-compat/src/test/java/org/apache/maven/repository/legacy/DefaultWagonManagerTest.java
|
||||
index bcda50a..068c0e0 100644
|
||||
--- a/maven-compat/src/test/java/org/apache/maven/repository/legacy/DefaultWagonManagerTest.java
|
||||
+++ b/maven-compat/src/test/java/org/apache/maven/repository/legacy/DefaultWagonManagerTest.java
|
||||
@@ -45,7 +45,6 @@
|
||||
import org.apache.maven.wagon.observers.Debug;
|
||||
import org.codehaus.plexus.PlexusTestCase;
|
||||
import org.codehaus.plexus.util.FileUtils;
|
||||
-import org.easymock.MockControl;
|
||||
|
||||
/**
|
||||
* @author <a href="michal.maczka@dimatics.com">Michal Maczka</a>
|
||||
@@ -162,15 +161,10 @@ public void testGetRemoteJar()
|
||||
StringWagon wagon = (StringWagon) wagonManager.getWagon( "string" );
|
||||
wagon.addExpectedContent( repo.getLayout().pathOf( artifact ), "expected" );
|
||||
|
||||
- MockControl control = MockControl.createControl( UpdateCheckManager.class );
|
||||
- control.replay();
|
||||
-
|
||||
wagonManager.getArtifact( artifact, repo, null, false );
|
||||
|
||||
assertTrue( artifact.getFile().exists() );
|
||||
assertEquals( "expected", FileUtils.fileRead( artifact.getFile(), "UTF-8" ) );
|
||||
-
|
||||
- control.verify();
|
||||
}
|
||||
|
||||
private Artifact createTestPomArtifact( String directory )
|
||||
diff --git a/pom.xml b/pom.xml
|
||||
index 6015e4d..b4c5ebf 100644
|
||||
--- a/pom.xml
|
||||
+++ b/pom.xml
|
||||
@@ -46,7 +46,6 @@
|
||||
<maven.compiler.target>1.6</maven.compiler.target>
|
||||
<classWorldsVersion>2.5.1</classWorldsVersion>
|
||||
<commonsCliVersion>1.2</commonsCliVersion>
|
||||
- <easyMockVersion>1.2_Java1.3</easyMockVersion>
|
||||
<junitVersion>3.8.2</junitVersion>
|
||||
<plexusVersion>1.5.5</plexusVersion>
|
||||
<plexusInterpolationVersion>1.19</plexusInterpolationVersion>
|
||||
@@ -342,14 +341,6 @@
|
||||
<artifactId>plexus-cipher</artifactId>
|
||||
<version>${cipherVersion}</version>
|
||||
</dependency>
|
||||
- <!--bootstrap-start-comment-->
|
||||
- <dependency>
|
||||
- <groupId>easymock</groupId>
|
||||
- <artifactId>easymock</artifactId>
|
||||
- <version>${easyMockVersion}</version>
|
||||
- <scope>test</scope>
|
||||
- </dependency>
|
||||
- <!--bootstrap-end-comment-->
|
||||
</dependencies>
|
||||
<!--bootstrap-start-comment-->
|
||||
</dependencyManagement>
|
||||
--
|
||||
1.9.3
|
||||
|
@ -1,95 +0,0 @@
|
||||
From d1a44fdad163b1bd4a052979f824ffd4522b0780 Mon Sep 17 00:00:00 2001
|
||||
From: Mikolaj Izdebski <mizdebsk@redhat.com>
|
||||
Date: Mon, 12 Aug 2013 08:49:19 +0200
|
||||
Subject: [PATCH 2/3] Update Aether to 0.9.0.M3
|
||||
|
||||
---
|
||||
apache-maven/pom.xml | 6 +++++-
|
||||
maven-aether-provider/pom.xml | 7 ++++++-
|
||||
maven-compat/pom.xml | 7 ++++++-
|
||||
pom.xml | 9 +++++++--
|
||||
4 files changed, 24 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/apache-maven/pom.xml b/apache-maven/pom.xml
|
||||
index 1def243..2923435 100644
|
||||
--- a/apache-maven/pom.xml
|
||||
+++ b/apache-maven/pom.xml
|
||||
@@ -87,7 +87,11 @@
|
||||
</dependency>
|
||||
<dependency>
|
||||
<groupId>org.eclipse.aether</groupId>
|
||||
- <artifactId>aether-connector-wagon</artifactId>
|
||||
+ <artifactId>aether-transport-wagon</artifactId>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>org.eclipse.aether</groupId>
|
||||
+ <artifactId>aether-connector-basic</artifactId>
|
||||
</dependency>
|
||||
<dependency>
|
||||
<groupId>org.slf4j</groupId>
|
||||
diff --git a/maven-aether-provider/pom.xml b/maven-aether-provider/pom.xml
|
||||
index 130805c..801f9fb 100644
|
||||
--- a/maven-aether-provider/pom.xml
|
||||
+++ b/maven-aether-provider/pom.xml
|
||||
@@ -91,7 +91,12 @@ under the License.
|
||||
<!-- Testing -->
|
||||
<dependency>
|
||||
<groupId>org.eclipse.aether</groupId>
|
||||
- <artifactId>aether-connector-wagon</artifactId>
|
||||
+ <artifactId>aether-connector-basic</artifactId>
|
||||
+ <scope>test</scope>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>org.eclipse.aether</groupId>
|
||||
+ <artifactId>aether-transport-wagon</artifactId>
|
||||
<scope>test</scope>
|
||||
</dependency>
|
||||
<dependency>
|
||||
diff --git a/maven-compat/pom.xml b/maven-compat/pom.xml
|
||||
index 28db8ba..348ce29 100644
|
||||
--- a/maven-compat/pom.xml
|
||||
+++ b/maven-compat/pom.xml
|
||||
@@ -79,7 +79,12 @@
|
||||
</dependency>
|
||||
<dependency>
|
||||
<groupId>org.eclipse.aether</groupId>
|
||||
- <artifactId>aether-connector-wagon</artifactId>
|
||||
+ <artifactId>aether-transport-wagon</artifactId>
|
||||
+ <scope>test</scope>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>org.eclipse.aether</groupId>
|
||||
+ <artifactId>aether-connector-basic</artifactId>
|
||||
<scope>test</scope>
|
||||
</dependency>
|
||||
</dependencies>
|
||||
diff --git a/pom.xml b/pom.xml
|
||||
index b4c5ebf..9d858fa 100644
|
||||
--- a/pom.xml
|
||||
+++ b/pom.xml
|
||||
@@ -59,7 +59,7 @@
|
||||
<cipherVersion>1.7</cipherVersion>
|
||||
<modelloVersion>1.8.1</modelloVersion>
|
||||
<jxpathVersion>1.3</jxpathVersion>
|
||||
- <aetherVersion>0.9.0.M2</aetherVersion>
|
||||
+ <aetherVersion>0.9.0.M3</aetherVersion>
|
||||
<slf4jVersion>1.7.5</slf4jVersion>
|
||||
<maven.test.redirectTestOutputToFile>true</maven.test.redirectTestOutputToFile>
|
||||
<!-- Control the name of the distribution and information output by mvn -->
|
||||
@@ -307,7 +307,12 @@
|
||||
</dependency>
|
||||
<dependency>
|
||||
<groupId>org.eclipse.aether</groupId>
|
||||
- <artifactId>aether-connector-wagon</artifactId>
|
||||
+ <artifactId>aether-connector-basic</artifactId>
|
||||
+ <version>${aetherVersion}</version>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>org.eclipse.aether</groupId>
|
||||
+ <artifactId>aether-transport-wagon</artifactId>
|
||||
<version>${aetherVersion}</version>
|
||||
</dependency>
|
||||
<!-- Commons -->
|
||||
--
|
||||
1.9.3
|
||||
|
@ -1,197 +0,0 @@
|
||||
From e3eb56ada370c18c1539e29b929139598a366611 Mon Sep 17 00:00:00 2001
|
||||
From: Mikolaj Izdebski <mizdebsk@redhat.com>
|
||||
Date: Wed, 13 Nov 2013 14:32:23 +0100
|
||||
Subject: [PATCH 3/3] Update to Sisu 0.1.0 and Guice 3.1.6
|
||||
|
||||
Sisu depends on Guice, but dependency scope changed from "compile" to
|
||||
"provided" in Sisu 0.1.0. As a Sisu user, Maven needs to have runtime
|
||||
dependency on Guice.
|
||||
---
|
||||
apache-maven/pom.xml | 12 ++++++++++++
|
||||
maven-aether-provider/pom.xml | 6 +++++-
|
||||
maven-compat/pom.xml | 12 ++++++++++++
|
||||
maven-core/pom.xml | 11 +++++++++++
|
||||
maven-embedder/pom.xml | 11 +++++++++++
|
||||
maven-model-builder/pom.xml | 12 ++++++++++++
|
||||
maven-plugin-api/pom.xml | 12 ++++++++++++
|
||||
pom.xml | 4 ++--
|
||||
8 files changed, 77 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/apache-maven/pom.xml b/apache-maven/pom.xml
|
||||
index 2923435..16393cb 100644
|
||||
--- a/apache-maven/pom.xml
|
||||
+++ b/apache-maven/pom.xml
|
||||
@@ -57,6 +57,18 @@
|
||||
<groupId>org.eclipse.sisu</groupId>
|
||||
<artifactId>org.eclipse.sisu.plexus</artifactId>
|
||||
</dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>org.sonatype.sisu</groupId>
|
||||
+ <artifactId>sisu-guice</artifactId>
|
||||
+ <classifier>no_aop</classifier>
|
||||
+ <scope>runtime</scope>
|
||||
+ <exclusions>
|
||||
+ <exclusion>
|
||||
+ <groupId>aopalliance</groupId>
|
||||
+ <artifactId>aopalliance</artifactId>
|
||||
+ </exclusion>
|
||||
+ </exclusions>
|
||||
+ </dependency>
|
||||
<!-- CLI -->
|
||||
<dependency>
|
||||
<groupId>commons-cli</groupId>
|
||||
diff --git a/maven-aether-provider/pom.xml b/maven-aether-provider/pom.xml
|
||||
index 801f9fb..4fbca7d 100644
|
||||
--- a/maven-aether-provider/pom.xml
|
||||
+++ b/maven-aether-provider/pom.xml
|
||||
@@ -80,7 +80,6 @@ under the License.
|
||||
<groupId>org.sonatype.sisu</groupId>
|
||||
<artifactId>sisu-guice</artifactId>
|
||||
<classifier>no_aop</classifier>
|
||||
- <optional>true</optional>
|
||||
<exclusions>
|
||||
<exclusion>
|
||||
<groupId>aopalliance</groupId>
|
||||
@@ -88,6 +87,11 @@ under the License.
|
||||
</exclusion>
|
||||
</exclusions>
|
||||
</dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>javax.inject</groupId>
|
||||
+ <artifactId>javax.inject</artifactId>
|
||||
+ <version>1</version>
|
||||
+ </dependency>
|
||||
<!-- Testing -->
|
||||
<dependency>
|
||||
<groupId>org.eclipse.aether</groupId>
|
||||
diff --git a/maven-compat/pom.xml b/maven-compat/pom.xml
|
||||
index 348ce29..7884159 100644
|
||||
--- a/maven-compat/pom.xml
|
||||
+++ b/maven-compat/pom.xml
|
||||
@@ -64,6 +64,18 @@
|
||||
<artifactId>org.eclipse.sisu.plexus</artifactId>
|
||||
</dependency>
|
||||
<dependency>
|
||||
+ <groupId>org.sonatype.sisu</groupId>
|
||||
+ <artifactId>sisu-guice</artifactId>
|
||||
+ <classifier>no_aop</classifier>
|
||||
+ <scope>runtime</scope>
|
||||
+ <exclusions>
|
||||
+ <exclusion>
|
||||
+ <groupId>aopalliance</groupId>
|
||||
+ <artifactId>aopalliance</artifactId>
|
||||
+ </exclusion>
|
||||
+ </exclusions>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
<groupId>org.codehaus.plexus</groupId>
|
||||
<artifactId>plexus-component-annotations</artifactId>
|
||||
</dependency>
|
||||
diff --git a/maven-core/pom.xml b/maven-core/pom.xml
|
||||
index fae2904..dc788d2 100644
|
||||
--- a/maven-core/pom.xml
|
||||
+++ b/maven-core/pom.xml
|
||||
@@ -82,6 +82,17 @@
|
||||
<artifactId>org.eclipse.sisu.plexus</artifactId>
|
||||
</dependency>
|
||||
<dependency>
|
||||
+ <groupId>org.sonatype.sisu</groupId>
|
||||
+ <artifactId>sisu-guice</artifactId>
|
||||
+ <classifier>no_aop</classifier>
|
||||
+ <exclusions>
|
||||
+ <exclusion>
|
||||
+ <groupId>aopalliance</groupId>
|
||||
+ <artifactId>aopalliance</artifactId>
|
||||
+ </exclusion>
|
||||
+ </exclusions>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
<groupId>org.codehaus.plexus</groupId>
|
||||
<artifactId>plexus-interpolation</artifactId>
|
||||
</dependency>
|
||||
diff --git a/maven-embedder/pom.xml b/maven-embedder/pom.xml
|
||||
index 2da52a9..f246fe1 100644
|
||||
--- a/maven-embedder/pom.xml
|
||||
+++ b/maven-embedder/pom.xml
|
||||
@@ -65,6 +65,17 @@
|
||||
<artifactId>org.eclipse.sisu.plexus</artifactId>
|
||||
</dependency>
|
||||
<dependency>
|
||||
+ <groupId>org.sonatype.sisu</groupId>
|
||||
+ <artifactId>sisu-guice</artifactId>
|
||||
+ <classifier>no_aop</classifier>
|
||||
+ <exclusions>
|
||||
+ <exclusion>
|
||||
+ <groupId>aopalliance</groupId>
|
||||
+ <artifactId>aopalliance</artifactId>
|
||||
+ </exclusion>
|
||||
+ </exclusions>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
<groupId>org.codehaus.plexus</groupId>
|
||||
<artifactId>plexus-component-annotations</artifactId>
|
||||
</dependency>
|
||||
diff --git a/maven-model-builder/pom.xml b/maven-model-builder/pom.xml
|
||||
index 81cd9d9..c1ca303 100644
|
||||
--- a/maven-model-builder/pom.xml
|
||||
+++ b/maven-model-builder/pom.xml
|
||||
@@ -54,6 +54,18 @@
|
||||
<scope>test</scope>
|
||||
</dependency>
|
||||
<dependency>
|
||||
+ <groupId>org.sonatype.sisu</groupId>
|
||||
+ <artifactId>sisu-guice</artifactId>
|
||||
+ <classifier>no_aop</classifier>
|
||||
+ <scope>test</scope>
|
||||
+ <exclusions>
|
||||
+ <exclusion>
|
||||
+ <groupId>aopalliance</groupId>
|
||||
+ <artifactId>aopalliance</artifactId>
|
||||
+ </exclusion>
|
||||
+ </exclusions>
|
||||
+ </dependency>
|
||||
+ <dependency>
|
||||
<groupId>xmlunit</groupId>
|
||||
<artifactId>xmlunit</artifactId>
|
||||
<version>1.3</version>
|
||||
diff --git a/maven-plugin-api/pom.xml b/maven-plugin-api/pom.xml
|
||||
index 1019ae4..e018cc0 100644
|
||||
--- a/maven-plugin-api/pom.xml
|
||||
+++ b/maven-plugin-api/pom.xml
|
||||
@@ -58,6 +58,18 @@ under the License.
|
||||
<groupId>org.eclipse.sisu</groupId>
|
||||
<artifactId>org.eclipse.sisu.plexus</artifactId>
|
||||
</dependency>
|
||||
+ <dependency>
|
||||
+ <groupId>org.sonatype.sisu</groupId>
|
||||
+ <artifactId>sisu-guice</artifactId>
|
||||
+ <classifier>no_aop</classifier>
|
||||
+ <scope>runtime</scope>
|
||||
+ <exclusions>
|
||||
+ <exclusion>
|
||||
+ <groupId>aopalliance</groupId>
|
||||
+ <artifactId>aopalliance</artifactId>
|
||||
+ </exclusion>
|
||||
+ </exclusions>
|
||||
+ </dependency>
|
||||
</dependencies>
|
||||
|
||||
<build>
|
||||
diff --git a/pom.xml b/pom.xml
|
||||
index 9d858fa..3787a42 100644
|
||||
--- a/pom.xml
|
||||
+++ b/pom.xml
|
||||
@@ -52,8 +52,8 @@
|
||||
<plexusUtilsVersion>3.0.17</plexusUtilsVersion>
|
||||
<!-- Latest version of Guava that works with Sisu -->
|
||||
<guavaVersion>14.0.1</guavaVersion>
|
||||
- <guiceVersion>3.1.3</guiceVersion>
|
||||
- <sisuInjectVersion>0.0.0.M5</sisuInjectVersion>
|
||||
+ <guiceVersion>3.1.6</guiceVersion>
|
||||
+ <sisuInjectVersion>0.1.0</sisuInjectVersion>
|
||||
<wagonVersion>2.6</wagonVersion>
|
||||
<securityDispatcherVersion>1.3</securityDispatcherVersion>
|
||||
<cipherVersion>1.7</cipherVersion>
|
||||
--
|
||||
1.9.3
|
||||
|
18
maven.spec
18
maven.spec
@ -1,6 +1,6 @@
|
||||
Name: maven
|
||||
Version: 3.2.3
|
||||
Release: 4%{?dist}
|
||||
Version: 3.2.5
|
||||
Release: 1%{?dist}
|
||||
Summary: Java project management and project comprehension tool
|
||||
License: ASL 2.0
|
||||
URL: http://maven.apache.org/
|
||||
@ -11,13 +11,6 @@ Source1: maven-bash-completion
|
||||
Source2: mvn.1
|
||||
Source200: %{name}-script
|
||||
|
||||
# Merged upstream (MNG-5696)
|
||||
Patch0001: 0001-MNG-5696-Remove-dependency-on-Easymock.patch
|
||||
# Merged upstream (MNG-5502)
|
||||
Patch0002: 0002-Update-Aether-to-0.9.0.M3.patch
|
||||
# Merged upstream (MNG-5534)
|
||||
Patch0003: 0003-Update-to-Sisu-0.1.0-and-Guice-3.1.6.patch
|
||||
|
||||
# If XMvn is part of the same RPM transaction then it should be
|
||||
# installed first to avoid triggering rhbz#1014355.
|
||||
OrderWithRequires: xmvn
|
||||
@ -135,9 +128,6 @@ Group: Documentation
|
||||
|
||||
%prep
|
||||
%setup -q -n apache-%{name}-%{version}%{?ver_add}
|
||||
%patch0001 -p1
|
||||
%patch0002 -p1
|
||||
%patch0003 -p1
|
||||
|
||||
# not really used during build, but a precaution
|
||||
rm maven-ant-tasks-*.jar
|
||||
@ -157,7 +147,6 @@ sed -i -e s:'-classpath "${M2_HOME}"/boot/plexus-classworlds-\*.jar':'-classpath
|
||||
|
||||
# Disable QA plugins which are not useful for us
|
||||
%pom_remove_plugin :animal-sniffer-maven-plugin
|
||||
%pom_remove_plugin :maven-enforcer-plugin
|
||||
%pom_remove_plugin :apache-rat-plugin
|
||||
|
||||
# logback is not really needed by maven in typical use cases, so set
|
||||
@ -263,6 +252,9 @@ ln -sf $(build-classpath plexus/classworlds) \
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Jan 19 2015 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.2.5-1
|
||||
- Update to upstream version 3.2.5
|
||||
|
||||
* Sat Dec 6 2014 Ville Skyttä <ville.skytta@iki.fi> - 3.2.3-4
|
||||
- Fix bash completion filename
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user