Update to Mockito 2
This commit is contained in:
parent
d18a8dccf1
commit
512a4ddea8
@ -1,205 +0,0 @@
|
||||
From e3b125fab7973d647288b9039fc897438b27c203 Mon Sep 17 00:00:00 2001
|
||||
From: Michael Simacek <msimacek@redhat.com>
|
||||
Date: Tue, 13 Mar 2018 11:49:16 +0100
|
||||
Subject: [PATCH 3/4] Revert "[ MNG-6335] Update Mockito to 2.12.0"
|
||||
|
||||
This reverts commit a03489b67d04a4b014ff5d1c151b331a39bf100b.
|
||||
---
|
||||
.../DefaultToolchainManagerPrivateTest.java | 15 +++++++++------
|
||||
.../toolchain/DefaultToolchainManagerTest.java | 4 ++--
|
||||
.../building/DefaultToolchainsBuilderTest.java | 14 +++++++-------
|
||||
maven-embedder/pom.xml | 1 -
|
||||
.../java/org/apache/maven/cli/MavenCliTest.java | 6 +++---
|
||||
pom.xml | 2 +-
|
||||
6 files changed, 22 insertions(+), 20 deletions(-)
|
||||
|
||||
diff --git a/maven-core/src/test/java/org/apache/maven/toolchain/DefaultToolchainManagerPrivateTest.java b/maven-core/src/test/java/org/apache/maven/toolchain/DefaultToolchainManagerPrivateTest.java
|
||||
index c93756463..1e4844154 100644
|
||||
--- a/maven-core/src/test/java/org/apache/maven/toolchain/DefaultToolchainManagerPrivateTest.java
|
||||
+++ b/maven-core/src/test/java/org/apache/maven/toolchain/DefaultToolchainManagerPrivateTest.java
|
||||
@@ -20,7 +20,8 @@
|
||||
*/
|
||||
|
||||
import static org.junit.Assert.assertEquals;
|
||||
-import static org.mockito.ArgumentMatchers.anyString;
|
||||
+import static org.junit.Assert.fail;
|
||||
+import static org.mockito.Matchers.anyString;
|
||||
import static org.mockito.Mockito.mock;
|
||||
import static org.mockito.Mockito.never;
|
||||
import static org.mockito.Mockito.verify;
|
||||
@@ -144,8 +145,9 @@ public void testToolchainsForConfiguredType()
|
||||
verify( logger, never() ).error( anyString() );
|
||||
assertEquals( 2, toolchains.length );
|
||||
}
|
||||
-
|
||||
- @Test
|
||||
+
|
||||
+ @SuppressWarnings( "unchecked" )
|
||||
+ @Test( expected = MisconfiguredToolchainException.class )
|
||||
public void testMisconfiguredToolchain()
|
||||
throws Exception
|
||||
{
|
||||
@@ -153,11 +155,12 @@ public void testMisconfiguredToolchain()
|
||||
MavenSession session = mock( MavenSession.class );
|
||||
MavenExecutionRequest req = new DefaultMavenExecutionRequest();
|
||||
when( session.getRequest() ).thenReturn( req );
|
||||
+ when(toolchainFactory_basicType.createDefaultToolchain()).thenThrow( MisconfiguredToolchainException.class );
|
||||
|
||||
// execute
|
||||
- ToolchainPrivate[] basics = toolchainManager.getToolchainsForType("basic", session);
|
||||
-
|
||||
+ toolchainManager.getToolchainsForType( "basic", session );
|
||||
+
|
||||
// verify
|
||||
- assertEquals( 0, basics.length );
|
||||
+ fail( "Should exit with a MisconfiguredToolchainException" );
|
||||
}
|
||||
}
|
||||
diff --git a/maven-core/src/test/java/org/apache/maven/toolchain/DefaultToolchainManagerTest.java b/maven-core/src/test/java/org/apache/maven/toolchain/DefaultToolchainManagerTest.java
|
||||
index 84444c08e..6e85c4246 100644
|
||||
--- a/maven-core/src/test/java/org/apache/maven/toolchain/DefaultToolchainManagerTest.java
|
||||
+++ b/maven-core/src/test/java/org/apache/maven/toolchain/DefaultToolchainManagerTest.java
|
||||
@@ -20,6 +20,7 @@
|
||||
*/
|
||||
|
||||
import static org.junit.Assert.assertEquals;
|
||||
+import static org.mockito.Matchers.anyMap;
|
||||
import static org.mockito.Matchers.isA;
|
||||
import static org.mockito.Mockito.mock;
|
||||
import static org.mockito.Mockito.verify;
|
||||
@@ -38,7 +39,6 @@
|
||||
import org.codehaus.plexus.logging.Logger;
|
||||
import org.junit.Before;
|
||||
import org.junit.Test;
|
||||
-import org.mockito.ArgumentMatchers;
|
||||
import org.mockito.InjectMocks;
|
||||
import org.mockito.Mock;
|
||||
import org.mockito.MockitoAnnotations;
|
||||
@@ -142,7 +142,7 @@ public void testRequirements()
|
||||
executionRequest.setToolchains( toolchainModels );
|
||||
when( session.getRequest() ).thenReturn( executionRequest );
|
||||
ToolchainPrivate basicPrivate = mock( ToolchainPrivate.class );
|
||||
- when( basicPrivate.matchesRequirements( ArgumentMatchers.<String, String>anyMap() ) ).thenReturn( false ).thenReturn( true );
|
||||
+ when( basicPrivate.matchesRequirements( anyMap() ) ).thenReturn( false ).thenReturn( true );
|
||||
when( toolchainFactory_basicType.createToolchain( isA( ToolchainModel.class ) ) ).thenReturn( basicPrivate );
|
||||
|
||||
List<Toolchain> toolchains =
|
||||
diff --git a/maven-core/src/test/java/org/apache/maven/toolchain/building/DefaultToolchainsBuilderTest.java b/maven-core/src/test/java/org/apache/maven/toolchain/building/DefaultToolchainsBuilderTest.java
|
||||
index fc530df5a..80fca0942 100644
|
||||
--- a/maven-core/src/test/java/org/apache/maven/toolchain/building/DefaultToolchainsBuilderTest.java
|
||||
+++ b/maven-core/src/test/java/org/apache/maven/toolchain/building/DefaultToolchainsBuilderTest.java
|
||||
@@ -21,7 +21,8 @@
|
||||
|
||||
import static org.junit.Assert.assertEquals;
|
||||
import static org.junit.Assert.assertNotNull;
|
||||
-import static org.mockito.ArgumentMatchers.any;
|
||||
+import static org.mockito.Matchers.any;
|
||||
+import static org.mockito.Matchers.anyMap;
|
||||
import static org.mockito.Mockito.when;
|
||||
|
||||
import java.io.IOException;
|
||||
@@ -34,7 +35,6 @@
|
||||
import org.apache.maven.toolchain.model.ToolchainModel;
|
||||
import org.junit.Before;
|
||||
import org.junit.Test;
|
||||
-import org.mockito.ArgumentMatchers;
|
||||
import org.mockito.InjectMocks;
|
||||
import org.mockito.Mock;
|
||||
import org.mockito.MockitoAnnotations;
|
||||
@@ -78,7 +78,7 @@ public void testBuildRequestWithUserToolchains()
|
||||
toolchain.setType( "TYPE" );
|
||||
toolchain.addProvide( "key", "user_value" );
|
||||
userResult.addToolchain( toolchain );
|
||||
- when( toolchainsReader.read( any( InputStream.class ), ArgumentMatchers.<String, Object>anyMap()) ).thenReturn( userResult );
|
||||
+ when( toolchainsReader.read( any( InputStream.class ), anyMap() ) ).thenReturn( userResult );
|
||||
|
||||
ToolchainsBuildingResult result = toolchainBuilder.build( request );
|
||||
assertNotNull( result.getEffectiveToolchains() );
|
||||
@@ -101,7 +101,7 @@ public void testBuildRequestWithGlobalToolchains()
|
||||
toolchain.setType( "TYPE" );
|
||||
toolchain.addProvide( "key", "global_value" );
|
||||
globalResult.addToolchain( toolchain );
|
||||
- when( toolchainsReader.read( any( InputStream.class ), ArgumentMatchers.<String, Object>anyMap()) ).thenReturn( globalResult );
|
||||
+ when( toolchainsReader.read( any( InputStream.class ), anyMap() ) ).thenReturn( globalResult );
|
||||
|
||||
ToolchainsBuildingResult result = toolchainBuilder.build( request );
|
||||
assertNotNull( result.getEffectiveToolchains() );
|
||||
@@ -131,7 +131,7 @@ public void testBuildRequestWithBothToolchains()
|
||||
globalToolchain.setType( "TYPE" );
|
||||
globalToolchain.addProvide( "key", "global_value" );
|
||||
globalResult.addToolchain( globalToolchain );
|
||||
- when( toolchainsReader.read( any( InputStream.class ), ArgumentMatchers.<String, Object>anyMap()) ).thenReturn( globalResult ).thenReturn( userResult );
|
||||
+ when( toolchainsReader.read( any( InputStream.class ), anyMap() ) ).thenReturn( globalResult ).thenReturn( userResult );
|
||||
|
||||
ToolchainsBuildingResult result = toolchainBuilder.build( request );
|
||||
assertNotNull( result.getEffectiveToolchains() );
|
||||
@@ -150,7 +150,7 @@ public void testStrictToolchainsParseException() throws Exception
|
||||
ToolchainsBuildingRequest request = new DefaultToolchainsBuildingRequest();
|
||||
request.setGlobalToolchainsSource( new StringSource( "" ) );
|
||||
ToolchainsParseException parseException = new ToolchainsParseException( "MESSAGE", 4, 2 );
|
||||
- when( toolchainsReader.read( any( InputStream.class ), ArgumentMatchers.<String, Object>anyMap()) ).thenThrow( parseException );
|
||||
+ when( toolchainsReader.read( any( InputStream.class ), anyMap() ) ).thenThrow( parseException );
|
||||
|
||||
try
|
||||
{
|
||||
@@ -169,7 +169,7 @@ public void testIOException() throws Exception
|
||||
ToolchainsBuildingRequest request = new DefaultToolchainsBuildingRequest();
|
||||
request.setGlobalToolchainsSource( new StringSource( "", "LOCATION" ) );
|
||||
IOException ioException = new IOException( "MESSAGE" );
|
||||
- when( toolchainsReader.read( any( InputStream.class ), ArgumentMatchers.<String, Object>anyMap()) ).thenThrow( ioException );
|
||||
+ when( toolchainsReader.read( any( InputStream.class ), anyMap() ) ).thenThrow( ioException );
|
||||
|
||||
try
|
||||
{
|
||||
diff --git a/maven-embedder/pom.xml b/maven-embedder/pom.xml
|
||||
index e32819196..3320d6c99 100644
|
||||
--- a/maven-embedder/pom.xml
|
||||
+++ b/maven-embedder/pom.xml
|
||||
@@ -137,7 +137,6 @@ under the License.
|
||||
<dependency>
|
||||
<groupId>org.mockito</groupId>
|
||||
<artifactId>mockito-core</artifactId>
|
||||
- <scope>test</scope>
|
||||
</dependency>
|
||||
<dependency>
|
||||
<groupId>org.fusesource.jansi</groupId>
|
||||
diff --git a/maven-embedder/src/test/java/org/apache/maven/cli/MavenCliTest.java b/maven-embedder/src/test/java/org/apache/maven/cli/MavenCliTest.java
|
||||
index 5f4c5b69a..88810d936 100644
|
||||
--- a/maven-embedder/src/test/java/org/apache/maven/cli/MavenCliTest.java
|
||||
+++ b/maven-embedder/src/test/java/org/apache/maven/cli/MavenCliTest.java
|
||||
@@ -24,7 +24,7 @@
|
||||
import static org.junit.Assert.assertTrue;
|
||||
import static org.junit.Assert.fail;
|
||||
import static org.junit.Assume.assumeTrue;
|
||||
-import static org.mockito.Mockito.any;
|
||||
+import static org.mockito.Mockito.isA;
|
||||
import static org.mockito.Mockito.inOrder;
|
||||
import static org.mockito.Mockito.mock;
|
||||
import static org.mockito.Mockito.times;
|
||||
@@ -327,8 +327,8 @@ protected void customizeContainer(PlexusContainer container) {
|
||||
customizedMavenCli.toolchains(cliRequest);
|
||||
|
||||
InOrder orderdEventSpyDispatcherMock = inOrder(eventSpyDispatcherMock);
|
||||
- orderdEventSpyDispatcherMock.verify(eventSpyDispatcherMock, times(1)).onEvent(any(ToolchainsBuildingRequest.class));
|
||||
- orderdEventSpyDispatcherMock.verify(eventSpyDispatcherMock, times(1)).onEvent(any(ToolchainsBuildingResult.class));
|
||||
+ orderdEventSpyDispatcherMock.verify(eventSpyDispatcherMock, times(1)).onEvent(isA(ToolchainsBuildingRequest.class));
|
||||
+ orderdEventSpyDispatcherMock.verify(eventSpyDispatcherMock, times(1)).onEvent(isA(ToolchainsBuildingResult.class));
|
||||
}
|
||||
|
||||
}
|
||||
diff --git a/pom.xml b/pom.xml
|
||||
index 237cdc39e..84fc037bc 100644
|
||||
--- a/pom.xml
|
||||
+++ b/pom.xml
|
||||
@@ -53,7 +53,7 @@ under the License.
|
||||
<commonsCliVersion>1.4</commonsCliVersion>
|
||||
<commonsLangVersion>3.8.1</commonsLangVersion>
|
||||
<junitVersion>4.12</junitVersion>
|
||||
- <mockitoVersion>2.21.0</mockitoVersion>
|
||||
+ <mockitoVersion>1.10.19</mockitoVersion>
|
||||
<plexusVersion>1.7.1</plexusVersion>
|
||||
<plexusInterpolationVersion>1.25</plexusInterpolationVersion>
|
||||
<plexusUtilsVersion>3.2.0</plexusUtilsVersion>
|
||||
--
|
||||
2.20.1
|
||||
|
10
maven.spec
10
maven.spec
@ -5,7 +5,7 @@
|
||||
Name: maven
|
||||
Epoch: 1
|
||||
Version: 3.6.1
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Summary: Java project management and project comprehension tool
|
||||
# maven itself is ASL 2.0
|
||||
# bundled slf4j is MIT
|
||||
@ -21,8 +21,6 @@ Patch1: 0001-Adapt-mvn-script.patch
|
||||
# Downstream-specific, avoids dependency on logback
|
||||
# Used only when %%without logback is in effect
|
||||
Patch2: 0002-Invoke-logback-via-reflection.patch
|
||||
# We don't have mockito 2 yet
|
||||
Patch3: 0003-Revert-MNG-6335-Update-Mockito-to-2.12.0.patch
|
||||
|
||||
BuildRequires: maven-local
|
||||
BuildRequires: mvn(com.google.inject:guice::no_aop:)
|
||||
@ -56,7 +54,7 @@ BuildRequires: mvn(org.eclipse.sisu:org.eclipse.sisu.inject)
|
||||
BuildRequires: mvn(org.eclipse.sisu:org.eclipse.sisu.plexus)
|
||||
BuildRequires: mvn(org.eclipse.sisu:sisu-maven-plugin)
|
||||
BuildRequires: mvn(org.fusesource.jansi:jansi)
|
||||
BuildRequires: mvn(org.mockito:mockito-core) < 2
|
||||
BuildRequires: mvn(org.mockito:mockito-core) >= 2
|
||||
BuildRequires: mvn(org.slf4j:jcl-over-slf4j)
|
||||
BuildRequires: mvn(org.slf4j:slf4j-api)
|
||||
BuildRequires: mvn(org.slf4j:slf4j-simple)
|
||||
@ -155,7 +153,6 @@ Summary: API documentation for %{name}
|
||||
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
|
||||
# not really used during build, but a precaution
|
||||
find -name '*.jar' -not -path '*/test/*' -delete
|
||||
@ -268,6 +265,9 @@ update-alternatives --install %{_bindir}/mvn mvn %{homedir}/bin/mvn %{?maven_alt
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Apr 17 2019 Mikolaj Izdebski <mizdebsk@redhat.com> - 1:3.6.1-2
|
||||
- Update to Mockito 2
|
||||
|
||||
* Sat Apr 13 2019 Mikolaj Izdebski <mizdebsk@redhat.com> - 1:3.6.1-1
|
||||
- Update to upstream version 3.6.1
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user