Update to upstream version 3.5.0
This commit is contained in:
parent
8600459547
commit
0960f8cfc9
1
.gitignore
vendored
1
.gitignore
vendored
@ -17,3 +17,4 @@
|
|||||||
/apache-maven-3.3.8-src.tar.gz
|
/apache-maven-3.3.8-src.tar.gz
|
||||||
/apache-maven-3.3.9-src.tar.gz
|
/apache-maven-3.3.9-src.tar.gz
|
||||||
/apache-maven-3.4.0-SNAPSHOT-src.tar.gz
|
/apache-maven-3.4.0-SNAPSHOT-src.tar.gz
|
||||||
|
/apache-maven-3.5.0-src.tar.gz
|
||||||
|
69
0001-Adapt-mvn-script.patch
Normal file
69
0001-Adapt-mvn-script.patch
Normal file
@ -0,0 +1,69 @@
|
|||||||
|
From 8ef7cdcdc1c40742fb091177afe17f771a518f90 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Michael Simacek <msimacek@redhat.com>
|
||||||
|
Date: Wed, 1 Feb 2017 14:54:26 +0100
|
||||||
|
Subject: [PATCH 1/3] Adapt mvn script
|
||||||
|
|
||||||
|
---
|
||||||
|
apache-maven/src/bin/mvn | 19 ++++++++++++++++---
|
||||||
|
1 file changed, 16 insertions(+), 3 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/apache-maven/src/bin/mvn b/apache-maven/src/bin/mvn
|
||||||
|
index 623b5f2..e486b34 100755
|
||||||
|
--- a/apache-maven/src/bin/mvn
|
||||||
|
+++ b/apache-maven/src/bin/mvn
|
||||||
|
@@ -22,7 +22,7 @@
|
||||||
|
#
|
||||||
|
# Environment Variable Prerequisites
|
||||||
|
#
|
||||||
|
-# JAVA_HOME Must point at your Java Development Kit installation.
|
||||||
|
+# JAVA_HOME (Optional) Must point at your Java Development Kit installation.
|
||||||
|
# MAVEN_OPTS (Optional) Java runtime options used when Maven is executed.
|
||||||
|
# MAVEN_SKIP_RC (Optional) Flag to disable loading of mavenrc files.
|
||||||
|
# -----------------------------------------------------------------------------
|
||||||
|
@@ -33,12 +33,24 @@ if [ -z "$MAVEN_SKIP_RC" ] ; then
|
||||||
|
. /etc/mavenrc
|
||||||
|
fi
|
||||||
|
|
||||||
|
+ if [ -f /etc/java/maven.conf ] ; then
|
||||||
|
+ . /etc/java/maven.conf
|
||||||
|
+ fi
|
||||||
|
+
|
||||||
|
if [ -f "$HOME/.mavenrc" ] ; then
|
||||||
|
. "$HOME/.mavenrc"
|
||||||
|
fi
|
||||||
|
|
||||||
|
fi
|
||||||
|
|
||||||
|
+if [ -f /usr/share/java-utils/java-functions ] ; then
|
||||||
|
+ . /usr/share/java-utils/java-functions
|
||||||
|
+ set_jvm
|
||||||
|
+ set_javacmd
|
||||||
|
+fi
|
||||||
|
+export JAVA_HOME
|
||||||
|
+export JAVACMD
|
||||||
|
+
|
||||||
|
# OS specific support. $var _must_ be set to either true or false.
|
||||||
|
cygwin=false;
|
||||||
|
mingw=false;
|
||||||
|
@@ -63,7 +75,8 @@ done
|
||||||
|
|
||||||
|
saveddir=`pwd`
|
||||||
|
|
||||||
|
-MAVEN_HOME=`dirname "$PRG"`/..
|
||||||
|
+MAVEN_HOME="${_FEDORA_MAVEN_HOME:-`dirname "$PRG"`/..}"
|
||||||
|
+unset _FEDORA_MAVEN_HOME
|
||||||
|
|
||||||
|
# make it fully qualified
|
||||||
|
MAVEN_HOME=`cd "$MAVEN_HOME" && pwd`
|
||||||
|
@@ -102,7 +115,7 @@ if [ ! -x "$JAVACMD" ] ; then
|
||||||
|
exit 1
|
||||||
|
fi
|
||||||
|
|
||||||
|
-CLASSWORLDS_JAR=`echo "${MAVEN_HOME}"/boot/plexus-classworlds-*.jar`
|
||||||
|
+CLASSWORLDS_JAR=`build-classpath plexus-classworlds`
|
||||||
|
CLASSWORLDS_LAUNCHER=org.codehaus.plexus.classworlds.launcher.Launcher
|
||||||
|
|
||||||
|
# For Cygwin, switch paths to Windows format before running java
|
||||||
|
--
|
||||||
|
2.9.3
|
||||||
|
|
@ -1,44 +0,0 @@
|
|||||||
From 0ace877175e4fa35f1de3bf37edc1a05b6927d47 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Mikolaj Izdebski <mizdebsk@redhat.com>
|
|
||||||
Date: Fri, 8 Apr 2016 01:05:29 +0200
|
|
||||||
Subject: [PATCH 1/2] Force SLF4J SimpleLogger re-initialization
|
|
||||||
|
|
||||||
---
|
|
||||||
.../main/java/org/slf4j/impl/MavenSlf4jSimpleFriend.java | 15 +++++++++++++++
|
|
||||||
1 file changed, 15 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/maven-embedder/src/main/java/org/slf4j/impl/MavenSlf4jSimpleFriend.java b/maven-embedder/src/main/java/org/slf4j/impl/MavenSlf4jSimpleFriend.java
|
|
||||||
index bffd18c..5af6a68 100644
|
|
||||||
--- a/maven-embedder/src/main/java/org/slf4j/impl/MavenSlf4jSimpleFriend.java
|
|
||||||
+++ b/maven-embedder/src/main/java/org/slf4j/impl/MavenSlf4jSimpleFriend.java
|
|
||||||
@@ -1,5 +1,7 @@
|
|
||||||
package org.slf4j.impl;
|
|
||||||
|
|
||||||
+import java.lang.reflect.Field;
|
|
||||||
+
|
|
||||||
/*
|
|
||||||
* Licensed to the Apache Software Foundation (ASF) under one
|
|
||||||
* or more contributor license agreements. See the NOTICE file
|
|
||||||
@@ -30,6 +32,19 @@ public class MavenSlf4jSimpleFriend
|
|
||||||
{
|
|
||||||
public static void init()
|
|
||||||
{
|
|
||||||
+ // Force SimpleLogger re-initialization
|
|
||||||
+ // See https://bugzilla.redhat.com/show_bug.cgi?id=1324832
|
|
||||||
+ try
|
|
||||||
+ {
|
|
||||||
+ Field initializedField = SimpleLogger.class.getDeclaredField( "INITIALIZED" );
|
|
||||||
+ initializedField.setAccessible( true );
|
|
||||||
+ initializedField.set( null, false );
|
|
||||||
+ }
|
|
||||||
+ catch ( ReflectiveOperationException e )
|
|
||||||
+ {
|
|
||||||
+ throw new RuntimeException( e );
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
SimpleLogger.init();
|
|
||||||
ILoggerFactory loggerFactory = LoggerFactory.getILoggerFactory();
|
|
||||||
if ( loggerFactory instanceof SimpleLoggerFactory )
|
|
||||||
--
|
|
||||||
2.9.3
|
|
||||||
|
|
@ -1,74 +0,0 @@
|
|||||||
From 4c12151d239f98812ac77703a0e892197387699a Mon Sep 17 00:00:00 2001
|
|
||||||
From: Michael Simacek <msimacek@redhat.com>
|
|
||||||
Date: Wed, 1 Feb 2017 14:54:26 +0100
|
|
||||||
Subject: [PATCH 2/2] Adapt mvn script
|
|
||||||
|
|
||||||
---
|
|
||||||
apache-maven/src/bin/mvn | 22 ++++++++++++++++------
|
|
||||||
1 file changed, 16 insertions(+), 6 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/apache-maven/src/bin/mvn b/apache-maven/src/bin/mvn
|
|
||||||
index 6875628..3b87936 100755
|
|
||||||
--- a/apache-maven/src/bin/mvn
|
|
||||||
+++ b/apache-maven/src/bin/mvn
|
|
||||||
@@ -21,12 +21,9 @@
|
|
||||||
# ----------------------------------------------------------------------------
|
|
||||||
# Maven2 Start Up Batch script
|
|
||||||
#
|
|
||||||
-# Required ENV vars:
|
|
||||||
-# ------------------
|
|
||||||
-# JAVA_HOME - location of a JDK home dir
|
|
||||||
-#
|
|
||||||
# Optional ENV vars
|
|
||||||
# -----------------
|
|
||||||
+# JAVA_HOME - location of a JDK home dir
|
|
||||||
# M2_HOME - location of maven2's installed home dir
|
|
||||||
# MAVEN_OPTS - parameters passed to the Java VM when running Maven
|
|
||||||
# e.g. to debug Maven itself, use
|
|
||||||
@@ -40,12 +37,24 @@ if [ -z "$MAVEN_SKIP_RC" ] ; then
|
|
||||||
. /etc/mavenrc
|
|
||||||
fi
|
|
||||||
|
|
||||||
+ if [ -f /etc/java/maven.conf ] ; then
|
|
||||||
+ . /etc/java/maven.conf
|
|
||||||
+ fi
|
|
||||||
+
|
|
||||||
if [ -f "$HOME/.mavenrc" ] ; then
|
|
||||||
. "$HOME/.mavenrc"
|
|
||||||
fi
|
|
||||||
|
|
||||||
fi
|
|
||||||
|
|
||||||
+if [ -f /usr/share/java-utils/java-functions ] ; then
|
|
||||||
+ . /usr/share/java-utils/java-functions
|
|
||||||
+ set_jvm
|
|
||||||
+ set_javacmd
|
|
||||||
+fi
|
|
||||||
+export JAVA_HOME
|
|
||||||
+export JAVACMD
|
|
||||||
+
|
|
||||||
# OS specific support. $var _must_ be set to either true or false.
|
|
||||||
cygwin=false;
|
|
||||||
darwin=false;
|
|
||||||
@@ -111,7 +120,8 @@ if [ -z "$M2_HOME" ] ; then
|
|
||||||
|
|
||||||
saveddir=`pwd`
|
|
||||||
|
|
||||||
- M2_HOME=`dirname "$PRG"`/..
|
|
||||||
+ M2_HOME="${_FEDORA_MAVEN_HOME:-`dirname "$PRG"`/..}"
|
|
||||||
+ unset _FEDORA_MAVEN_HOME
|
|
||||||
|
|
||||||
# make it fully qualified
|
|
||||||
M2_HOME=`cd "$M2_HOME" && pwd`
|
|
||||||
@@ -238,7 +248,7 @@ export MAVEN_CMD_LINE_ARGS
|
|
||||||
exec "$JAVACMD" \
|
|
||||||
$MAVEN_OPTS \
|
|
||||||
$MAVEN_DEBUG_OPTS \
|
|
||||||
- -classpath "${M2_HOME}"/boot/plexus-classworlds-*.jar \
|
|
||||||
+ -classpath "$(build-classpath plexus-classworlds)" \
|
|
||||||
"-Dclassworlds.conf=${M2_HOME}/bin/m2.conf" \
|
|
||||||
"-Dmaven.home=${M2_HOME}" "-Dmaven.multiModuleProjectDirectory=${MAVEN_PROJECTBASEDIR}" \
|
|
||||||
${CLASSWORLDS_LAUNCHER} "$@"
|
|
||||||
--
|
|
||||||
2.9.3
|
|
||||||
|
|
31
0002-Update-to-current-slf4j.patch
Normal file
31
0002-Update-to-current-slf4j.patch
Normal file
@ -0,0 +1,31 @@
|
|||||||
|
From 3dce15a3da21f5817a1b0193664312ffc8a5345c Mon Sep 17 00:00:00 2001
|
||||||
|
From: Michael Simacek <msimacek@redhat.com>
|
||||||
|
Date: Tue, 18 Apr 2017 16:30:58 +0200
|
||||||
|
Subject: [PATCH 2/3] Update to current slf4j
|
||||||
|
|
||||||
|
---
|
||||||
|
.../src/main/java/org/slf4j/impl/MavenSimpleLogger.java | 7 ++++++-
|
||||||
|
1 file changed, 6 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/maven-slf4j-provider/src/main/java/org/slf4j/impl/MavenSimpleLogger.java b/maven-slf4j-provider/src/main/java/org/slf4j/impl/MavenSimpleLogger.java
|
||||||
|
index 17f1f48..c4acb92 100644
|
||||||
|
--- a/maven-slf4j-provider/src/main/java/org/slf4j/impl/MavenSimpleLogger.java
|
||||||
|
+++ b/maven-slf4j-provider/src/main/java/org/slf4j/impl/MavenSimpleLogger.java
|
||||||
|
@@ -56,8 +56,13 @@ public class MavenSimpleLogger
|
||||||
|
}
|
||||||
|
|
||||||
|
@Override
|
||||||
|
- protected void renderThrowable( Throwable t, PrintStream stream )
|
||||||
|
+ protected void writeThrowable( Throwable t, PrintStream stream )
|
||||||
|
{
|
||||||
|
+ if ( t == null )
|
||||||
|
+ {
|
||||||
|
+ return;
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
stream.print( buffer().failure( t.getClass().getName() ) );
|
||||||
|
if ( t.getMessage() != null )
|
||||||
|
{
|
||||||
|
--
|
||||||
|
2.9.3
|
||||||
|
|
54
0003-Replace-groovy-invocation-with-antrun.patch
Normal file
54
0003-Replace-groovy-invocation-with-antrun.patch
Normal file
@ -0,0 +1,54 @@
|
|||||||
|
From b54789188f2a61b5d58ff53986a5efe042d84fdf Mon Sep 17 00:00:00 2001
|
||||||
|
From: Michael Simacek <msimacek@redhat.com>
|
||||||
|
Date: Tue, 18 Apr 2017 16:51:34 +0200
|
||||||
|
Subject: [PATCH 3/3] Replace groovy invocation with antrun
|
||||||
|
|
||||||
|
---
|
||||||
|
maven-slf4j-provider/pom.xml | 23 ++++++++++++++---------
|
||||||
|
1 file changed, 14 insertions(+), 9 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/maven-slf4j-provider/pom.xml b/maven-slf4j-provider/pom.xml
|
||||||
|
index 363e00d..9be251b 100644
|
||||||
|
--- a/maven-slf4j-provider/pom.xml
|
||||||
|
+++ b/maven-slf4j-provider/pom.xml
|
||||||
|
@@ -95,22 +95,27 @@ under the License.
|
||||||
|
</executions>
|
||||||
|
</plugin>
|
||||||
|
<plugin>
|
||||||
|
- <groupId>org.codehaus.gmaven</groupId>
|
||||||
|
- <artifactId>groovy-maven-plugin</artifactId>
|
||||||
|
- <version>2.0</version>
|
||||||
|
+ <groupId>org.apache.maven.plugins</groupId>
|
||||||
|
+ <artifactId>maven-antrun-plugin</artifactId>
|
||||||
|
+ <version>1.8</version>
|
||||||
|
<executions>
|
||||||
|
<execution>
|
||||||
|
- <id>patch-slf4j-simple</id>
|
||||||
|
<phase>process-sources</phase>
|
||||||
|
- <goals>
|
||||||
|
- <goal>execute</goal>
|
||||||
|
- </goals>
|
||||||
|
<configuration>
|
||||||
|
- <source>${project.basedir}/src/main/script/patch-slf4j-simple.groovy</source>
|
||||||
|
+ <target>
|
||||||
|
+ <replace
|
||||||
|
+ file="${project.build.directory}/generated-sources/slf4j-simple/org/slf4j/impl/StaticLoggerBinder.java"
|
||||||
|
+ token="\\bSimpleLoggerFactory\\b"
|
||||||
|
+ value="MavenSimpleLoggerFactory"
|
||||||
|
+ />
|
||||||
|
+ </target>
|
||||||
|
</configuration>
|
||||||
|
+ <goals>
|
||||||
|
+ <goal>run</goal>
|
||||||
|
+ </goals>
|
||||||
|
</execution>
|
||||||
|
</executions>
|
||||||
|
</plugin>
|
||||||
|
</plugins>
|
||||||
|
</build>
|
||||||
|
-</project>
|
||||||
|
\ No newline at end of file
|
||||||
|
+</project>
|
||||||
|
--
|
||||||
|
2.9.3
|
||||||
|
|
219
maven.spec
219
maven.spec
@ -1,9 +1,11 @@
|
|||||||
%bcond_without logback
|
%bcond_without logback
|
||||||
|
|
||||||
|
%global bundled_slf4j_version 1.7.25
|
||||||
|
|
||||||
Name: maven
|
Name: maven
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 3.3.9
|
Version: 3.5.0
|
||||||
Release: 9%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Java project management and project comprehension tool
|
Summary: Java project management and project comprehension tool
|
||||||
License: ASL 2.0
|
License: ASL 2.0
|
||||||
URL: http://maven.apache.org/
|
URL: http://maven.apache.org/
|
||||||
@ -13,66 +15,59 @@ Source0: http://archive.apache.org/dist/%{name}/%{name}-3/%{version}/sour
|
|||||||
Source1: maven-bash-completion
|
Source1: maven-bash-completion
|
||||||
Source2: mvn.1
|
Source2: mvn.1
|
||||||
|
|
||||||
Patch0: 0001-Force-SLF4J-SimpleLogger-re-initialization.patch
|
Patch1: 0001-Adapt-mvn-script.patch
|
||||||
Patch1: 0002-Adapt-mvn-script.patch
|
# Part of https://github.com/apache/maven/pull/109
|
||||||
|
Patch2: 0002-Update-to-current-slf4j.patch
|
||||||
|
# Fedora specific, avoids usage of unpackaged groovy-maven-plugin
|
||||||
|
Patch3: 0003-Replace-groovy-invocation-with-antrun.patch
|
||||||
|
|
||||||
BuildRequires: maven-local
|
BuildRequires: maven-local
|
||||||
|
BuildRequires: mvn(com.google.guava:guava)
|
||||||
|
BuildRequires: mvn(com.google.inject:guice::no_aop:)
|
||||||
|
BuildRequires: mvn(commons-cli:commons-cli)
|
||||||
|
BuildRequires: mvn(commons-jxpath:commons-jxpath)
|
||||||
|
BuildRequires: mvn(junit:junit)
|
||||||
|
BuildRequires: mvn(org.apache.commons:commons-lang3)
|
||||||
|
BuildRequires: mvn(org.apache.maven:maven-parent:pom:)
|
||||||
|
BuildRequires: mvn(org.apache.maven.plugins:maven-antrun-plugin)
|
||||||
|
BuildRequires: mvn(org.apache.maven.plugins:maven-assembly-plugin)
|
||||||
|
BuildRequires: mvn(org.apache.maven.plugins:maven-dependency-plugin)
|
||||||
|
BuildRequires: mvn(org.apache.maven.resolver:maven-resolver-api)
|
||||||
|
BuildRequires: mvn(org.apache.maven.resolver:maven-resolver-connector-basic)
|
||||||
|
BuildRequires: mvn(org.apache.maven.resolver:maven-resolver-impl)
|
||||||
|
BuildRequires: mvn(org.apache.maven.resolver:maven-resolver-spi)
|
||||||
|
BuildRequires: mvn(org.apache.maven.resolver:maven-resolver-transport-wagon)
|
||||||
|
BuildRequires: mvn(org.apache.maven.resolver:maven-resolver-util)
|
||||||
|
BuildRequires: mvn(org.apache.maven.shared:maven-shared-utils)
|
||||||
|
BuildRequires: mvn(org.apache.maven.wagon:wagon-file)
|
||||||
|
BuildRequires: mvn(org.apache.maven.wagon:wagon-http::shaded:)
|
||||||
|
BuildRequires: mvn(org.apache.maven.wagon:wagon-provider-api)
|
||||||
|
BuildRequires: mvn(org.codehaus.modello:modello-maven-plugin)
|
||||||
|
BuildRequires: mvn(org.codehaus.mojo:build-helper-maven-plugin)
|
||||||
|
BuildRequires: mvn(org.codehaus.plexus:plexus-classworlds)
|
||||||
|
BuildRequires: mvn(org.codehaus.plexus:plexus-component-annotations)
|
||||||
|
BuildRequires: mvn(org.codehaus.plexus:plexus-component-metadata)
|
||||||
|
BuildRequires: mvn(org.codehaus.plexus:plexus-interpolation)
|
||||||
|
BuildRequires: mvn(org.codehaus.plexus:plexus-utils)
|
||||||
|
BuildRequires: mvn(org.eclipse.sisu:org.eclipse.sisu.plexus)
|
||||||
|
BuildRequires: mvn(org.eclipse.sisu:sisu-maven-plugin)
|
||||||
|
BuildRequires: mvn(org.fusesource.jansi:jansi)
|
||||||
|
BuildRequires: mvn(org.mockito:mockito-core)
|
||||||
|
BuildRequires: mvn(org.slf4j:slf4j-api)
|
||||||
|
BuildRequires: mvn(org.slf4j:slf4j-simple)
|
||||||
|
BuildRequires: mvn(org.sonatype.plexus:plexus-cipher)
|
||||||
|
BuildRequires: mvn(org.sonatype.plexus:plexus-sec-dispatcher)
|
||||||
|
BuildRequires: mvn(regexp:regexp)
|
||||||
|
BuildRequires: mvn(xmlunit:xmlunit)
|
||||||
|
|
||||||
|
# Missed by builddep
|
||||||
|
BuildRequires: mvn(org.slf4j:jcl-over-slf4j:pom:)
|
||||||
|
|
||||||
|
BuildRequires: slf4j-sources = %{bundled_slf4j_version}
|
||||||
|
|
||||||
BuildRequires: aether-api >= 1:0
|
|
||||||
BuildRequires: aether-connector-basic >= 1:0
|
|
||||||
BuildRequires: aether-impl >= 1:0
|
|
||||||
BuildRequires: aether-spi >= 1:0
|
|
||||||
BuildRequires: aether-util >= 1:0
|
|
||||||
BuildRequires: aether-transport-wagon >= 1:0
|
|
||||||
BuildRequires: aopalliance
|
|
||||||
BuildRequires: apache-commons-cli
|
|
||||||
BuildRequires: apache-commons-io
|
|
||||||
BuildRequires: apache-commons-lang
|
|
||||||
BuildRequires: apache-commons-lang3
|
|
||||||
BuildRequires: apache-commons-codec
|
|
||||||
BuildRequires: apache-commons-jxpath
|
|
||||||
BuildRequires: apache-commons-logging
|
|
||||||
BuildRequires: apache-resource-bundles
|
|
||||||
BuildRequires: atinject
|
|
||||||
BuildRequires: cglib
|
|
||||||
BuildRequires: easymock3
|
|
||||||
BuildRequires: google-guice >= 3.1.6
|
|
||||||
BuildRequires: hamcrest
|
|
||||||
BuildRequires: httpcomponents-core
|
|
||||||
BuildRequires: httpcomponents-client
|
|
||||||
BuildRequires: jsoup
|
|
||||||
BuildRequires: jsr-305
|
|
||||||
BuildRequires: junit
|
|
||||||
BuildRequires: maven-assembly-plugin
|
|
||||||
BuildRequires: maven-compiler-plugin
|
|
||||||
BuildRequires: maven-install-plugin
|
|
||||||
BuildRequires: maven-jar-plugin
|
|
||||||
BuildRequires: maven-parent
|
|
||||||
BuildRequires: maven-remote-resources-plugin
|
|
||||||
BuildRequires: maven-resources-plugin
|
|
||||||
BuildRequires: maven-surefire-plugin
|
|
||||||
BuildRequires: maven-wagon-file
|
|
||||||
BuildRequires: maven-wagon-http
|
|
||||||
BuildRequires: maven-wagon-http-shared
|
|
||||||
BuildRequires: maven-wagon-provider-api
|
|
||||||
BuildRequires: objectweb-asm
|
|
||||||
BuildRequires: plexus-cipher
|
|
||||||
BuildRequires: plexus-classworlds
|
|
||||||
BuildRequires: plexus-containers-component-annotations
|
|
||||||
BuildRequires: plexus-containers-component-metadata >= 1.5.5
|
|
||||||
BuildRequires: plexus-interpolation
|
|
||||||
BuildRequires: plexus-sec-dispatcher
|
|
||||||
BuildRequires: plexus-utils >= 3.0.10
|
|
||||||
BuildRequires: sisu-inject >= 1:0.1
|
|
||||||
BuildRequires: sisu-plexus >= 1:0.1
|
|
||||||
BuildRequires: sisu-mojos
|
|
||||||
BuildRequires: slf4j
|
|
||||||
BuildRequires: xmlunit
|
|
||||||
%if %{with logback}
|
%if %{with logback}
|
||||||
BuildRequires: mvn(ch.qos.logback:logback-classic)
|
BuildRequires: mvn(ch.qos.logback:logback-classic)
|
||||||
%endif
|
%endif
|
||||||
BuildRequires: mvn(org.mockito:mockito-core)
|
|
||||||
BuildRequires: mvn(org.codehaus.modello:modello-maven-plugin)
|
|
||||||
|
|
||||||
Requires: %{name}-lib = %{epoch}:%{version}-%{release}
|
Requires: %{name}-lib = %{epoch}:%{version}-%{release}
|
||||||
|
|
||||||
@ -86,31 +81,33 @@ Requires: %{name}-lib = %{epoch}:%{version}-%{release}
|
|||||||
# by XMvn. It would be possible to explicitly specify only
|
# by XMvn. It would be possible to explicitly specify only
|
||||||
# dependencies which are not generated automatically, but adding
|
# dependencies which are not generated automatically, but adding
|
||||||
# everything seems to be easier.
|
# everything seems to be easier.
|
||||||
Requires: aether-api
|
|
||||||
Requires: aether-connector-basic
|
|
||||||
Requires: aether-impl
|
|
||||||
Requires: aether-spi
|
|
||||||
Requires: aether-transport-wagon
|
|
||||||
Requires: aether-util
|
|
||||||
Requires: aopalliance
|
Requires: aopalliance
|
||||||
Requires: apache-commons-cli
|
Requires: apache-commons-cli
|
||||||
Requires: apache-commons-io
|
Requires: apache-commons-io
|
||||||
Requires: apache-commons-lang
|
Requires: apache-commons-lang
|
||||||
Requires: apache-commons-lang3
|
Requires: apache-commons-lang3
|
||||||
Requires: apache-commons-codec
|
|
||||||
Requires: apache-commons-logging
|
Requires: apache-commons-logging
|
||||||
Requires: atinject
|
Requires: atinject
|
||||||
|
Requires: cdi-api
|
||||||
Requires: google-guice
|
Requires: google-guice
|
||||||
Requires: guava
|
Requires: guava
|
||||||
|
Requires: hawtjni-runtime
|
||||||
Requires: httpcomponents-client
|
Requires: httpcomponents-client
|
||||||
Requires: httpcomponents-core
|
Requires: httpcomponents-core
|
||||||
Requires: jsoup
|
Requires: jansi
|
||||||
Requires: jsr-305
|
Requires: jansi-native
|
||||||
|
Requires: jcl-over-slf4j
|
||||||
|
Requires: maven-resolver-api
|
||||||
|
Requires: maven-resolver-connector-basic
|
||||||
|
Requires: maven-resolver-impl
|
||||||
|
Requires: maven-resolver-spi
|
||||||
|
Requires: maven-resolver-transport-wagon
|
||||||
|
Requires: maven-resolver-util
|
||||||
|
Requires: maven-shared-utils
|
||||||
Requires: maven-wagon-file
|
Requires: maven-wagon-file
|
||||||
Requires: maven-wagon-http
|
Requires: maven-wagon-http
|
||||||
Requires: maven-wagon-http-shared
|
Requires: maven-wagon-http-shared
|
||||||
Requires: maven-wagon-provider-api
|
Requires: maven-wagon-provider-api
|
||||||
Requires: objectweb-asm
|
|
||||||
Requires: plexus-cipher
|
Requires: plexus-cipher
|
||||||
Requires: plexus-classworlds
|
Requires: plexus-classworlds
|
||||||
Requires: plexus-containers-component-annotations
|
Requires: plexus-containers-component-annotations
|
||||||
@ -121,10 +118,6 @@ Requires: sisu-inject
|
|||||||
Requires: sisu-plexus
|
Requires: sisu-plexus
|
||||||
Requires: slf4j
|
Requires: slf4j
|
||||||
|
|
||||||
# Temporary fix for broken sisu
|
|
||||||
Requires: cdi-api
|
|
||||||
BuildRequires: cdi-api
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Maven is a software project management and comprehension tool. Based on the
|
Maven is a software project management and comprehension tool. Based on the
|
||||||
concept of a project object model (POM), Maven can manage a project's build,
|
concept of a project object model (POM), Maven can manage a project's build,
|
||||||
@ -136,6 +129,12 @@ Summary: Core part of Maven
|
|||||||
# installed first to avoid triggering rhbz#1014355.
|
# installed first to avoid triggering rhbz#1014355.
|
||||||
OrderWithRequires: xmvn-minimal
|
OrderWithRequires: xmvn-minimal
|
||||||
|
|
||||||
|
# Maven upstream uses patched version of SLF4J. They unpack
|
||||||
|
# slf4j-simple-sources.jar, apply non-upstreamable, Maven-specific
|
||||||
|
# patch (using a script written in Groovy), compile and package as
|
||||||
|
# maven-slf4j-provider.jar, together with Maven-specific additions.
|
||||||
|
Provides: bundled(slf4j) = %{bundled_slf4j_version}
|
||||||
|
|
||||||
%description lib
|
%description lib
|
||||||
Core part of Apache Maven that can be used as a library.
|
Core part of Apache Maven that can be used as a library.
|
||||||
|
|
||||||
@ -148,8 +147,9 @@ Summary: API documentation for %{name}
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n apache-%{name}-%{version}
|
%setup -q -n apache-%{name}-%{version}
|
||||||
|
|
||||||
%patch0 -p1
|
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
|
%patch2 -p1
|
||||||
|
%patch3 -p1
|
||||||
|
|
||||||
# not really used during build, but a precaution
|
# not really used during build, but a precaution
|
||||||
find -name '*.jar' -not -path '*/test/*' -delete
|
find -name '*.jar' -not -path '*/test/*' -delete
|
||||||
@ -159,10 +159,10 @@ find -name '*.bat' -delete
|
|||||||
sed -i 's:\r::' apache-maven/src/conf/settings.xml
|
sed -i 's:\r::' apache-maven/src/conf/settings.xml
|
||||||
|
|
||||||
# Disable plugins which are not useful for us
|
# Disable plugins which are not useful for us
|
||||||
%pom_remove_plugin :animal-sniffer-maven-plugin
|
%pom_remove_plugin -r :animal-sniffer-maven-plugin
|
||||||
%pom_remove_plugin :apache-rat-plugin
|
%pom_remove_plugin -r :apache-rat-plugin
|
||||||
%pom_remove_plugin :maven-site-plugin
|
%pom_remove_plugin -r :maven-site-plugin
|
||||||
%pom_remove_plugin :maven-enforcer-plugin
|
%pom_remove_plugin -r :maven-enforcer-plugin
|
||||||
%pom_remove_plugin -r :buildnumber-maven-plugin
|
%pom_remove_plugin -r :buildnumber-maven-plugin
|
||||||
|
|
||||||
%mvn_package :apache-maven __noinstall
|
%mvn_package :apache-maven __noinstall
|
||||||
@ -173,17 +173,11 @@ rm maven-embedder/src/main/java/org/apache/maven/cli/logging/impl/LogbackConfigu
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# Put all JARs in standard location, but create symlinks in Maven lib
|
|
||||||
# directory so that Plexus Classworlds can find them.
|
|
||||||
%mvn_file ":{*}:jar:" %{name}/@1 %{_datadir}/%{name}/lib/@1
|
|
||||||
|
|
||||||
%mvn_build -- -Dproject.build.sourceEncoding=UTF-8
|
%mvn_build -- -Dproject.build.sourceEncoding=UTF-8
|
||||||
|
|
||||||
mkdir m2home
|
mkdir m2home
|
||||||
(cd m2home
|
(cd m2home
|
||||||
tar --delay-directory-restore -xvf ../apache-maven/target/*tar.gz
|
tar --delay-directory-restore -xvf ../apache-maven/target/*tar.gz
|
||||||
chmod -R +rwX apache-%{name}-%{version}%{?ver_add}
|
|
||||||
chmod -x apache-%{name}-%{version}%{?ver_add}/conf/settings.xml
|
|
||||||
)
|
)
|
||||||
|
|
||||||
|
|
||||||
@ -192,15 +186,23 @@ mkdir m2home
|
|||||||
|
|
||||||
export M2_HOME=$(pwd)/m2home/apache-maven-%{version}%{?ver_add}
|
export M2_HOME=$(pwd)/m2home/apache-maven-%{version}%{?ver_add}
|
||||||
|
|
||||||
install -d -m 755 %{buildroot}%{_datadir}/%{name}/bin
|
|
||||||
install -d -m 755 %{buildroot}%{_datadir}/%{name}/conf
|
install -d -m 755 %{buildroot}%{_datadir}/%{name}/conf
|
||||||
install -d -m 755 %{buildroot}%{_datadir}/%{name}/boot
|
|
||||||
install -d -m 755 %{buildroot}%{_datadir}/%{name}/lib/ext
|
|
||||||
install -d -m 755 %{buildroot}%{_bindir}
|
install -d -m 755 %{buildroot}%{_bindir}
|
||||||
install -d -m 755 %{buildroot}%{_sysconfdir}/%{name}
|
install -d -m 755 %{buildroot}%{_sysconfdir}/%{name}
|
||||||
install -d -m 755 %{buildroot}%{_datadir}/bash-completion/completions
|
install -d -m 755 %{buildroot}%{_datadir}/bash-completion/completions
|
||||||
install -d -m 755 %{buildroot}%{_mandir}/man1
|
install -d -m 755 %{buildroot}%{_mandir}/man1
|
||||||
|
|
||||||
|
cp -a $M2_HOME/{bin,lib,boot} %{buildroot}%{_datadir}/%{name}/
|
||||||
|
xmvn-subst -R %{buildroot} -s %{buildroot}%{_datadir}/%{name}
|
||||||
|
|
||||||
|
# Transitive deps of wagon-http, missing because of unshading
|
||||||
|
build-jar-repository -s -p %{buildroot}%{_datadir}/%{name}/lib \
|
||||||
|
commons-logging httpcomponents/{httpclient,httpcore} maven-wagon/http-shared
|
||||||
|
|
||||||
|
# Transitive deps of cdi-api that should have been excluded
|
||||||
|
rm %{buildroot}%{_datadir}/%{name}/lib/jboss-interceptors*.jar
|
||||||
|
rm %{buildroot}%{_datadir}/%{name}/lib/javax.el-api*.jar
|
||||||
|
|
||||||
for cmd in mvn mvnDebug mvnyjp; do
|
for cmd in mvn mvnDebug mvnyjp; do
|
||||||
ln -s %{_datadir}/%{name}/bin/$cmd %{buildroot}%{_bindir}/$cmd
|
ln -s %{_datadir}/%{name}/bin/$cmd %{buildroot}%{_bindir}/$cmd
|
||||||
echo ".so man1/mvn.1" >%{buildroot}%{_mandir}/man1/$cmd.1
|
echo ".so man1/mvn.1" >%{buildroot}%{_mandir}/man1/$cmd.1
|
||||||
@ -214,52 +216,6 @@ ln -sf %{_sysconfdir}/%{name}/settings.xml %{buildroot}%{_datadir}/%{name}/conf/
|
|||||||
mv $M2_HOME/conf/logging %{buildroot}%{_sysconfdir}/%{name}
|
mv $M2_HOME/conf/logging %{buildroot}%{_sysconfdir}/%{name}
|
||||||
ln -sf %{_sysconfdir}/%{name}/logging %{buildroot}%{_datadir}/%{name}/conf
|
ln -sf %{_sysconfdir}/%{name}/logging %{buildroot}%{_datadir}/%{name}/conf
|
||||||
|
|
||||||
cp -a $M2_HOME/bin/* %{buildroot}%{_datadir}/%{name}/bin
|
|
||||||
|
|
||||||
ln -sf $(build-classpath plexus/classworlds) \
|
|
||||||
%{buildroot}%{_datadir}/%{name}/boot/plexus-classworlds.jar
|
|
||||||
|
|
||||||
pushd %{buildroot}%{_datadir}/%{name}/lib
|
|
||||||
build-jar-repository -s -p . \
|
|
||||||
aether/aether-api \
|
|
||||||
aether/aether-connector-basic \
|
|
||||||
aether/aether-impl \
|
|
||||||
aether/aether-spi \
|
|
||||||
aether/aether-transport-wagon \
|
|
||||||
aether/aether-util \
|
|
||||||
aopalliance \
|
|
||||||
cdi-api \
|
|
||||||
commons-cli \
|
|
||||||
commons-io \
|
|
||||||
commons-lang \
|
|
||||||
commons-lang3 \
|
|
||||||
guava \
|
|
||||||
google-guice-no_aop \
|
|
||||||
atinject \
|
|
||||||
jsoup/jsoup \
|
|
||||||
jsr-305 \
|
|
||||||
org.eclipse.sisu.inject \
|
|
||||||
org.eclipse.sisu.plexus \
|
|
||||||
plexus/plexus-cipher \
|
|
||||||
plexus/containers-component-annotations \
|
|
||||||
plexus/interpolation \
|
|
||||||
plexus/plexus-sec-dispatcher \
|
|
||||||
plexus/utils \
|
|
||||||
slf4j/api \
|
|
||||||
slf4j/simple \
|
|
||||||
maven-wagon/file \
|
|
||||||
maven-wagon/http-shaded \
|
|
||||||
maven-wagon/http-shared \
|
|
||||||
maven-wagon/provider-api \
|
|
||||||
\
|
|
||||||
httpcomponents/httpclient \
|
|
||||||
httpcomponents/httpcore \
|
|
||||||
commons-logging \
|
|
||||||
commons-codec \
|
|
||||||
objectweb-asm/asm
|
|
||||||
popd
|
|
||||||
|
|
||||||
|
|
||||||
%files lib -f .mfiles
|
%files lib -f .mfiles
|
||||||
%doc LICENSE NOTICE README.md
|
%doc LICENSE NOTICE README.md
|
||||||
%{_datadir}/%{name}
|
%{_datadir}/%{name}
|
||||||
@ -280,6 +236,9 @@ popd
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Apr 11 2017 Michael Simacek <msimacek@redhat.com> - 1:3.5.0-1
|
||||||
|
- Update to upstream version 3.5.0
|
||||||
|
|
||||||
* Fri Mar 3 2017 Mikolaj Izdebski <mizdebsk@redhat.com> - 1:3.3.9-9
|
* Fri Mar 3 2017 Mikolaj Izdebski <mizdebsk@redhat.com> - 1:3.3.9-9
|
||||||
- Fix bash-completion directory ownership
|
- Fix bash-completion directory ownership
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (apache-maven-3.3.9-src.tar.gz) = 696576a52800f0a475c15779075e5e77a1b426848341dd033f86d127506bfcd1c6be5c73183ffa2d85bbb7ec369c1938f9f0d1f76166b8d2e98bf77c7b7f54b2
|
SHA512 (apache-maven-3.5.0-src.tar.gz) = 12594ee1316dc3d9ab61e761105575c8dc96b8f07512f398cc8091ac801312e58da5f115cee38c0cb92eeda53b62c7e6651ad412e71be9498c697c4d5c362e71
|
||||||
|
Loading…
Reference in New Issue
Block a user