Update to upstream version 3.0.0~M4

This commit is contained in:
Marian Koncek 2021-05-14 18:38:36 +02:00
parent fe430c9ff1
commit b43fb8cc81
7 changed files with 22 additions and 93 deletions

1
.gitignore vendored
View File

@ -26,3 +26,4 @@ surefire-2.10-source-release.zip
/surefire-2.22.0-source-release.zip
/maven-surefire-2.22.0.tar.gz
/maven-surefire-3.0.0-M3.tar.gz
/maven-surefire-3.0.0~M4.tar.gz

View File

@ -1,70 +0,0 @@
From 6a94c7674f844218752827f2b62de629691fcf39 Mon Sep 17 00:00:00 2001
From: Michael Simacek <msimacek@redhat.com>
Date: Fri, 16 Mar 2018 13:45:01 +0100
Subject: [PATCH 2/3] Port to current maven-shared-utils
---
.../plugin/surefire/report/StatelessXmlReporter.java | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/maven-surefire-common/src/main/java/org/apache/maven/plugin/surefire/report/StatelessXmlReporter.java b/maven-surefire-common/src/main/java/org/apache/maven/plugin/surefire/report/StatelessXmlReporter.java
index b89c4e9b0..8cf0b60c3 100644
--- a/maven-surefire-common/src/main/java/org/apache/maven/plugin/surefire/report/StatelessXmlReporter.java
+++ b/maven-surefire-common/src/main/java/org/apache/maven/plugin/surefire/report/StatelessXmlReporter.java
@@ -326,7 +326,7 @@ private static File getReportFile( ReportEntry report, File reportsDirectory, St
}
private static void startTestElement( XMLWriter ppw, WrappedReportEntry report, String reportNameSuffix,
- String timeAsString )
+ String timeAsString ) throws IOException
{
ppw.startElement( "testcase" );
ppw.addAttribute( "name", report.getReportName() );
@@ -349,7 +349,7 @@ private static void startTestElement( XMLWriter ppw, WrappedReportEntry report,
}
private void createTestSuiteElement( XMLWriter ppw, WrappedReportEntry report, TestSetStats testSetStats,
- String timeAsString )
+ String timeAsString ) throws IOException
{
ppw.startElement( "testsuite" );
@@ -377,7 +377,7 @@ private void createTestSuiteElement( XMLWriter ppw, WrappedReportEntry report, T
private static void getTestProblems( OutputStreamWriter outputStreamWriter, XMLWriter ppw,
WrappedReportEntry report, boolean trimStackTrace, OutputStream fw,
- String testErrorType, boolean createOutErrElementsInside )
+ String testErrorType, boolean createOutErrElementsInside ) throws IOException
{
ppw.startElement( testErrorType );
@@ -434,7 +434,7 @@ private static void getTestProblems( OutputStreamWriter outputStreamWriter, XMLW
// Create system-out and system-err elements
private static void createOutErrElements( OutputStreamWriter outputStreamWriter, XMLWriter ppw,
- WrappedReportEntry report, OutputStream fw )
+ WrappedReportEntry report, OutputStream fw ) throws IOException
{
EncodingOutputStream eos = new EncodingOutputStream( fw );
addOutputStreamElement( outputStreamWriter, eos, ppw, report.getStdout(), "system-out" );
@@ -444,7 +444,7 @@ private static void createOutErrElements( OutputStreamWriter outputStreamWriter,
private static void addOutputStreamElement( OutputStreamWriter outputStreamWriter,
EncodingOutputStream eos, XMLWriter xmlWriter,
Utf8RecodingDeferredFileOutputStream utf8RecodingDeferredFileOutputStream,
- String name )
+ String name ) throws IOException
{
if ( utf8RecodingDeferredFileOutputStream != null && utf8RecodingDeferredFileOutputStream.getByteCount() > 0 )
{
@@ -474,7 +474,7 @@ private static void addOutputStreamElement( OutputStreamWriter outputStreamWrite
*
* @param xmlWriter The test suite to report to
*/
- private static void showProperties( XMLWriter xmlWriter, Map<String, String> systemProperties )
+ private static void showProperties( XMLWriter xmlWriter, Map<String, String> systemProperties ) throws IOException
{
xmlWriter.startElement( "properties" );
for ( final Entry<String, String> entry : systemProperties.entrySet() )
--
2.25.2

View File

@ -2,14 +2,11 @@
set -e
name=maven-surefire
if [[ -n "$1" ]]; then
version="$1"
else
version="$(sed -n 's/Version:\s*//p' *.spec)"
fi
version="$(sed -n 's/Version:\s*//p' *.spec)"
upstream_version="${version/'~'/'-'}"
# RETRIEVE
wget "http://repo2.maven.org/maven2/org/apache/maven/surefire/surefire/${version}/surefire-${version}-source-release.zip" -O "${name}-${version}.orig.zip"
wget "https://repo1.maven.org/maven2/org/apache/maven/surefire/surefire/${upstream_version}/surefire-${upstream_version}-source-release.zip" -O "${name}-${version}.orig.zip"
rm -rf tarball-tmp
mkdir tarball-tmp

View File

@ -1,23 +1,24 @@
%bcond_with bootstrap
Name: maven-surefire
Version: 3.0.0~M3
Release: 4%{?dist}
Version: 3.0.0~M4
Release: 1%{?dist}
Summary: Test framework project
License: ASL 2.0 and CPL
URL: https://maven.apache.org/surefire/
BuildArch: noarch
# ./generate-tarball.sh 3.0.0-M3
Source0: %{name}-3.0.0-M3.tar.gz
%global upstream_version %(echo '%{version}' | tr '~' '-')
# ./generate-tarball.sh
Source0: %{name}-%{version}.tar.gz
# Remove bundled binaries which cannot be easily verified for licensing
Source1: generate-tarball.sh
Source2: https://junit.sourceforge.net/cpl-v10.html
Patch1: 0001-Port-to-TestNG-6.11.patch
Patch2: 0002-Port-to-current-maven-shared-utils.patch
Patch3: 0003-Disable-JUnit-4.8-test-grouping.patch
Patch4: 0004-Port-to-maven-shared-utils-3.3.3.patch
Patch2: 0002-Disable-JUnit-4.8-test-grouping.patch
Patch3: 0003-Port-to-maven-shared-utils-3.3.3.patch
BuildRequires: maven-local
%if %{with bootstrap}
@ -63,25 +64,25 @@ Requires: (%{name}-provider-testng = %{version}-%{release} if testng)
Maven surefire plugin for running tests via the surefire framework.
%package provider-junit
Summary: JUnit provider for Maven Surefire
Summary: JUnit provider for Maven Surefire
%description provider-junit
JUnit provider for Maven Surefire.
%package provider-junit5
Summary: JUnit 5 provider for Maven Surefire
Summary: JUnit 5 provider for Maven Surefire
%description provider-junit5
JUnit 5 provider for Maven Surefire.
%package provider-testng
Summary: TestNG provider for Maven Surefire
Summary: TestNG provider for Maven Surefire
%description provider-testng
TestNG provider for Maven Surefire.
%package -n maven-failsafe-plugin
Summary: Maven plugin for running integration tests
Summary: Maven plugin for running integration tests
%description -n maven-failsafe-plugin
The Failsafe Plugin is designed to run integration tests while the
@ -101,19 +102,18 @@ integration-test phase thus enabling the post-integration-test phase
to execute.
%package javadoc
Summary: Javadoc for %{name}
Summary: Javadoc for %{name}
%description javadoc
Javadoc for %{name}.
%prep
%setup -q -n surefire-3.0.0-M3
%setup -q -n surefire-%{upstream_version}
cp -p %{SOURCE2} .
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1
# Disable strict doclint
sed -i /-Xdoclint:all/d pom.xml
@ -149,7 +149,6 @@ rm surefire-providers/surefire-testng-utils/src/main/java/org/apache/maven/suref
%pom_remove_plugin :maven-assembly-plugin maven-surefire-plugin
%pom_remove_dep -r ::::site-source
%build
%mvn_package ":*{surefire-plugin}*" @1
%mvn_package ":*junit-platform*" junit5
@ -161,7 +160,6 @@ rm surefire-providers/surefire-testng-utils/src/main/java/org/apache/maven/suref
%install
%mvn_install
%files -f .mfiles
%doc README.md
%license LICENSE NOTICE cpl-v10.html
@ -176,6 +174,9 @@ rm surefire-providers/surefire-testng-utils/src/main/java/org/apache/maven/suref
%license LICENSE NOTICE cpl-v10.html
%changelog
* Fri May 14 2021 Marian Koncek <mkoncek@redhat.com> - 3.0.0~M4-1
- Update to upstream version 3.0.0~M4
* Tue Nov 05 2019 Mikolaj Izdebski <mizdebsk@redhat.com> - 3.0.0~M3-4
- Mass rebuild for javapackages-tools 201902

View File

@ -1,2 +1,2 @@
SHA512 (maven-surefire-3.0.0-M3.tar.gz) = 1d6ced3e3f778be217c2d38f5ac4e748aa2fbda1c6214f04c3f76b15e56014364d52cb14f0fbb0b5f132e74304f1e3e3ff7fac49fd1e208b673596b25d287040
SHA512 (maven-surefire-3.0.0~M4.tar.gz) = 68ec305ff9bc56ef99af45098705d507ddc0944067fbb1411fceeb7bec8af2399f28ffb6fa722aba0ad65ec7089c76d6093e31eacb61c19c8975b37b06a56406
SHA512 (cpl-v10.html) = f7aa86fafb6a7831b1a5302099fbfe95361bcb5c49a2bc7aac0f5d53cea6c92fc3adbba897a54ab5b0cf32771cdc933fc5bb233461fbd48254a250d0d59109c9