diff --git a/felix-settings.xml b/felix-settings.xml
deleted file mode 100644
index efe7bd7..0000000
--- a/felix-settings.xml
+++ /dev/null
@@ -1,47 +0,0 @@
-
-
-
- JPP
-
-
- internal
- jpp
- __JPP_URL_PLACEHOLDER__
-
-
- external
- jpp
- __JAVADIR_PLACEHOLDER__
-
-
- local
- jpp
- __MAVENREPO_DIR_PLACEHOLDER__
-
-
-
-
- plugins-internal
- plugins-internal
- jpp
- __JPP_URL_PLACEHOLDER__
-
-
- plugins-external
- plugins-external
- jpp
- __JAVADIR_PLACEHOLDER__
-
-
- plugins-maven
- plugins-maven
- jpp
- __MAVENDIR_PLUGIN_PLACEHOLDER__
-
-
-
-
-
- JPP
-
-
diff --git a/maven-plugin-bundle.spec b/maven-plugin-bundle.spec
index aaa0e68..0f491a5 100644
--- a/maven-plugin-bundle.spec
+++ b/maven-plugin-bundle.spec
@@ -1,6 +1,6 @@
Name: maven-plugin-bundle
Version: 2.0.0
-Release: 4%{?dist}
+Release: 5%{?dist}
Summary: Maven Bundle Plugin
Group: Development/Tools
@@ -15,13 +15,13 @@ BuildRequires: felix-osgi-obr
BuildRequires: kxml
BuildRequires: maven-shared-dependency-tree >= 1.1-3
BuildRequires: maven-wagon >= 1.0-0.2.b2
-BuildRequires: maven2-plugin-compiler >= 2.0.8
-BuildRequires: maven2-plugin-install >= 2.0.8
-BuildRequires: maven2-plugin-jar >= 2.0.8
-BuildRequires: maven2-plugin-javadoc >= 2.0.8
-BuildRequires: maven2-plugin-plugin >= 2.0.8
-BuildRequires: maven2-plugin-resources >= 2.0.8
-BuildRequires: maven-surefire-maven-plugin >= 2.3
+BuildRequires: maven-compiler-plugin
+BuildRequires: maven-install-plugin
+BuildRequires: maven-jar-plugin
+BuildRequires: maven-javadoc-plugin
+BuildRequires: maven-plugin-plugin
+BuildRequires: maven-resources-plugin
+BuildRequires: maven-surefire-plugin >= 2.3
BuildRequires: maven-surefire-provider-junit >= 2.3
BuildRequires: maven-doxia-sitetools
Requires: aqute-bndlib >= 0.0.363
@@ -29,7 +29,7 @@ Requires: plexus-utils >= 1.4.5
Requires: felix-osgi-obr
Requires: kxml
Requires: maven2
-Requires: maven-shared-archiver
+Requires: maven-archiver
Requires: maven-shared-dependency-tree
Requires: maven-wagon
Requires: plexus-archiver
@@ -52,29 +52,11 @@ API documentation for %{name}.
%prep
%setup -q -n maven-bundle-plugin-%{version}
-cp %{SOURCE2} settings.xml
%build
-sed -i -e \
- "s|__JPP_URL_PLACEHOLDER__|file://`pwd`/.m2/repository|g" \
- settings.xml
-sed -i -e \
- "s|__JAVADIR_PLACEHOLDER__|file://`pwd`/external_repo|g" \
- settings.xml
-sed -i -e \
- "s|__MAVENREPO_DIR_PLACEHOLDER__|file://`pwd`/.m2/repository|g" \
- settings.xml
-sed -i -e \
- "s|__MAVENDIR_PLUGIN_PLACEHOLDER__|file:///usr/share/maven2/plugins|g" \
- settings.xml
-sed -i -e \
- "s|__ECLIPSEDIR_PLUGIN_PLACEHOLDER__|file:///usr/share/eclipse/plugins|g" \
- settings.xml
-
export MAVEN_REPO_LOCAL=$(pwd)/.m2/repository
mvn-jpp \
-e \
- -s $(pwd)/settings.xml \
-Dmaven2.jpp.mode=true \
-Dmaven.repo.local=$MAVEN_REPO_LOCAL \
install javadoc:javadoc
@@ -113,7 +95,7 @@ rm -rf target/site/api*
%files
%defattr(-,root,root,-)
%{_javadir}/*
-%{_datadir}/maven2/poms/*
+%{_mavenpomdir}/*
%{_mavendepmapfragdir}/*
%files javadoc
@@ -122,6 +104,9 @@ rm -rf target/site/api*
%{_javadocdir}/%{name}
%changelog
+* Thu Sep 9 2010 Alexander Kurtakov 2.0.0-5
+- Fix BuildRequires.
+
* Fri Sep 18 2009 Alexander Kurtakov 2.0.0-4
- Add missing Requires.