parent
802a77cc1b
commit
ebda147116
16
mariadb-recovery.patch
Normal file
16
mariadb-recovery.patch
Normal file
@ -0,0 +1,16 @@
|
|||||||
|
Wrong path used for mysqld
|
||||||
|
|
||||||
|
rhbz: #1403416
|
||||||
|
|
||||||
|
diff -up mariadb-10.1.24/scripts/galera_recovery.sh.mysqldpath mariadb-10.1.24/scripts/galera_recovery.sh
|
||||||
|
--- mariadb-10.1.24/scripts/galera_recovery.sh.mysqldpath 2017-07-18 18:47:33.993396821 +0200
|
||||||
|
+++ mariadb-10.1.24/scripts/galera_recovery.sh 2017-07-18 18:48:17.323509332 +0200
|
||||||
|
@@ -68,7 +68,7 @@ parse_arguments() {
|
||||||
|
|
||||||
|
wsrep_recover_position() {
|
||||||
|
# Redirect server's error log to the log file.
|
||||||
|
- eval /usr/sbin/mysqld $cmdline_args --user=$user --wsrep_recover \
|
||||||
|
+ eval @libexecdir@/mysqld $cmdline_args --user=$user --wsrep_recover \
|
||||||
|
--log-error="$log_file"
|
||||||
|
ret=$?
|
||||||
|
if [ $ret -ne 0 ]; then
|
@ -1,7 +1,10 @@
|
|||||||
|
We have some downstream patches and other scripts that include variables to
|
||||||
|
be expanded by cmake. Cmake needs to know about them, so adding them manually.
|
||||||
|
|
||||||
diff -up mariadb-10.2.8/scripts/CMakeLists.txt.p7 mariadb-10.2.8/scripts/CMakeLists.txt
|
diff -up mariadb-10.2.8/scripts/CMakeLists.txt.p7 mariadb-10.2.8/scripts/CMakeLists.txt
|
||||||
--- mariadb-10.2.8/scripts/CMakeLists.txt.p7 2017-08-20 13:26:10.640779557 +0200
|
--- mariadb-10.2.8/scripts/CMakeLists.txt.p7 2017-08-20 13:26:10.640779557 +0200
|
||||||
+++ mariadb-10.2.8/scripts/CMakeLists.txt 2017-08-20 13:27:05.774925486 +0200
|
+++ mariadb-10.2.8/scripts/CMakeLists.txt 2017-08-20 13:27:05.774925486 +0200
|
||||||
@@ -338,6 +338,33 @@ ELSE()
|
@@ -338,6 +338,34 @@ ELSE()
|
||||||
)
|
)
|
||||||
ENDFOREACH()
|
ENDFOREACH()
|
||||||
|
|
||||||
@ -16,6 +19,7 @@ diff -up mariadb-10.2.8/scripts/CMakeLists.txt.p7 mariadb-10.2.8/scripts/CMakeLi
|
|||||||
+ mysql-scripts-common
|
+ mysql-scripts-common
|
||||||
+ mysql_config_multilib
|
+ mysql_config_multilib
|
||||||
+ clustercheck
|
+ clustercheck
|
||||||
|
+ galera_new_cluster
|
||||||
+ mysql.init
|
+ mysql.init
|
||||||
+ my.cnf
|
+ my.cnf
|
||||||
+ )
|
+ )
|
||||||
|
13
mariadb.spec
13
mariadb.spec
@ -126,7 +126,7 @@
|
|||||||
|
|
||||||
Name: mariadb
|
Name: mariadb
|
||||||
Version: %{compatver}.%{bugfixver}
|
Version: %{compatver}.%{bugfixver}
|
||||||
Release: 1%{?with_debug:.debug}%{?dist}
|
Release: 2%{?with_debug:.debug}%{?dist}
|
||||||
Epoch: 3
|
Epoch: 3
|
||||||
|
|
||||||
Summary: A community developed branch of MySQL
|
Summary: A community developed branch of MySQL
|
||||||
@ -180,6 +180,7 @@ Patch37: %{pkgnamepatch}-notestdb.patch
|
|||||||
|
|
||||||
# Patches for galera
|
# Patches for galera
|
||||||
Patch40: %{pkgnamepatch}-galera.cnf.patch
|
Patch40: %{pkgnamepatch}-galera.cnf.patch
|
||||||
|
Patch43: %{pkgnamepatch}-recovery.patch
|
||||||
|
|
||||||
BuildRequires: cmake gcc-c++
|
BuildRequires: cmake gcc-c++
|
||||||
BuildRequires: libaio-devel
|
BuildRequires: libaio-devel
|
||||||
@ -623,6 +624,7 @@ MariaDB is a community developed branch of MySQL.
|
|||||||
%patch9 -p1
|
%patch9 -p1
|
||||||
%patch37 -p1
|
%patch37 -p1
|
||||||
%patch40 -p1
|
%patch40 -p1
|
||||||
|
%patch43 -p1
|
||||||
|
|
||||||
# workaround for upstream bug #56342
|
# workaround for upstream bug #56342
|
||||||
rm mysql-test/t/ssl_8k_key-master.opt
|
rm mysql-test/t/ssl_8k_key-master.opt
|
||||||
@ -891,6 +893,11 @@ mkdir -p %{buildroot}%{_sysconfdir}/sysconfig
|
|||||||
touch %{buildroot}%{_sysconfdir}/sysconfig/clustercheck
|
touch %{buildroot}%{_sysconfdir}/sysconfig/clustercheck
|
||||||
install -p -m 0755 scripts/clustercheck %{buildroot}%{_bindir}/clustercheck
|
install -p -m 0755 scripts/clustercheck %{buildroot}%{_bindir}/clustercheck
|
||||||
|
|
||||||
|
# install the galera_new_cluster script anyway
|
||||||
|
%if %{without init_systemd}
|
||||||
|
install -p -m 0755 scripts/galera_new_cluster %{buildroot}%{_bindir}/galera_new_cluster
|
||||||
|
%endif
|
||||||
|
|
||||||
# remove SysV init script and a symlink to that
|
# remove SysV init script and a symlink to that
|
||||||
rm %{buildroot}%{_sysconfdir}/init.d/mysql
|
rm %{buildroot}%{_sysconfdir}/init.d/mysql
|
||||||
rm %{buildroot}%{_libexecdir}/rcmysql
|
rm %{buildroot}%{_libexecdir}/rcmysql
|
||||||
@ -1438,6 +1445,10 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Aug 28 2017 Honza Horak <hhorak@redhat.com> - 3:10.2.8-2
|
||||||
|
- Fix paths in galera_recovery and galera_new_cluster
|
||||||
|
Resolves: #1403416
|
||||||
|
|
||||||
* Sun Aug 20 2017 Honza Horak <hhorak@redhat.com> - 3:10.2.8-1
|
* Sun Aug 20 2017 Honza Horak <hhorak@redhat.com> - 3:10.2.8-1
|
||||||
- Rebase to 10.2.8
|
- Rebase to 10.2.8
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user