Update to 10.1.17
This commit is contained in:
parent
3444dbd746
commit
c2703ae4c1
@ -1,23 +0,0 @@
|
||||
From ca26b981274e8f32e7fad85597a1534285c79f26 Mon Sep 17 00:00:00 2001
|
||||
From: Damien Ciabrini <damien.ciabrini@gmail.com>
|
||||
Date: Fri, 12 Aug 2016 10:57:58 +0200
|
||||
Subject: [PATCH] refs codership/mysql-wsrep#267 Fix Galera crash at startup
|
||||
when compiled with gcc 6
|
||||
|
||||
---
|
||||
sql/wsrep_mysqld.cc | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/sql/wsrep_mysqld.cc b/sql/wsrep_mysqld.cc
|
||||
index 90567b6..b1024b6 100644
|
||||
--- a/sql/wsrep_mysqld.cc
|
||||
+++ b/sql/wsrep_mysqld.cc
|
||||
@@ -169,7 +169,7 @@ static PSI_file_info wsrep_files[]=
|
||||
|
||||
my_bool wsrep_inited = 0; // initialized ?
|
||||
|
||||
-static const wsrep_uuid_t cluster_uuid = WSREP_UUID_UNDEFINED;
|
||||
+static wsrep_uuid_t cluster_uuid = WSREP_UUID_UNDEFINED;
|
||||
static char cluster_uuid_str[40]= { 0, };
|
||||
static const char* cluster_status_str[WSREP_VIEW_MAX] =
|
||||
{
|
11
mariadb.spec
11
mariadb.spec
@ -119,11 +119,11 @@
|
||||
# Make long macros shorter
|
||||
%global sameevr %{epoch}:%{version}-%{release}
|
||||
%global compatver 10.1
|
||||
%global bugfixver 16
|
||||
%global bugfixver 17
|
||||
|
||||
Name: mariadb
|
||||
Version: %{compatver}.%{bugfixver}
|
||||
Release: 2%{?with_debug:.debug}%{?dist}
|
||||
Release: 1%{?with_debug:.debug}%{?dist}
|
||||
Epoch: 3
|
||||
|
||||
Summary: A community developed branch of MySQL
|
||||
@ -179,7 +179,6 @@ Patch37: %{pkgnamepatch}-notestdb.patch
|
||||
# Patches for galera
|
||||
Patch40: %{pkgnamepatch}-galera.cnf.patch
|
||||
Patch41: %{pkgnamepatch}-galera-new-cluster-help.patch
|
||||
Patch42: %{pkgnamepatch}-wsrep.patch
|
||||
|
||||
BuildRequires: cmake
|
||||
BuildRequires: libaio-devel
|
||||
@ -567,7 +566,6 @@ MariaDB is a community developed branch of MySQL.
|
||||
%patch37 -p1
|
||||
%patch40 -p1
|
||||
%patch41 -p1
|
||||
%patch42 -p1
|
||||
|
||||
sed -i -e 's/2.8.7/2.6.4/g' cmake/cpack_rpm.cmake
|
||||
|
||||
@ -934,7 +932,7 @@ export MTR_BUILD_THREAD=%{__isa_bits}
|
||||
set -e
|
||||
cd mysql-test
|
||||
perl ./mysql-test-run.pl --force --retry=0 --ssl \
|
||||
--suite-timeout=720 --testcase-timeout=30 \
|
||||
--suite-timeout=720 --testcase-timeout=30 --skip-rpl \
|
||||
--mysqld=--binlog-format=mixed --force-restart \
|
||||
--shutdown-timeout=60 --max-test-fail=0 \
|
||||
%if %{check_testsuite}
|
||||
@ -1301,6 +1299,9 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Aug 31 2016 Jakub Dorňák <jdornak@redhat.com> - 3:10.1.17-1
|
||||
- Update to 10.1.17
|
||||
|
||||
* Mon Aug 29 2016 Jakub Dorňák <jdornak@redhat.com> - 3:10.1.16-2
|
||||
- Fixed galera replication
|
||||
Resolves: #1352946
|
||||
|
@ -10,3 +10,4 @@ main.userstat : rhbz#1096787
|
||||
perfschema.nesting : rhbz#1096787
|
||||
perfschema.socket_summary_by_event_name_func : rhbz#1096787
|
||||
perfschema.socket_summary_by_instance_func : rhbz#1096787
|
||||
sys_vars.wsrep_provider_options_basic : rhbz#1096787
|
||||
|
Loading…
Reference in New Issue
Block a user