Update to 10.1.10
This commit is contained in:
parent
61cbdd0245
commit
9a948cc78e
@ -1,41 +0,0 @@
|
||||
Support s390/s390x in performance schema's cycle-counting functions.
|
||||
Filed upstream at http://bugs.mysql.com/bug.php?id=59953
|
||||
|
||||
|
||||
diff -up mariadb-10.0.10/include/my_rdtsc.h.p4 mariadb-10.0.10/include/my_rdtsc.h
|
||||
--- mariadb-10.0.10/include/my_rdtsc.h.p4 2014-03-30 19:56:36.000000000 +0200
|
||||
+++ mariadb-10.0.10/include/my_rdtsc.h 2014-04-07 16:13:55.227792169 +0200
|
||||
@@ -125,6 +125,7 @@ C_MODE_END
|
||||
#define MY_TIMER_ROUTINE_MACH_ABSOLUTE_TIME 25
|
||||
#define MY_TIMER_ROUTINE_GETSYSTEMTIMEASFILETIME 26
|
||||
#define MY_TIMER_ROUTINE_ASM_SUNPRO_X86_64 27
|
||||
+#define MY_TIMER_ROUTINE_ASM_S390 28
|
||||
|
||||
#endif
|
||||
|
||||
diff -up mariadb-10.0.10/mysys/my_rdtsc.c.p4 mariadb-10.0.10/mysys/my_rdtsc.c
|
||||
--- mariadb-10.0.10/mysys/my_rdtsc.c.p4 2014-03-30 19:56:36.000000000 +0200
|
||||
+++ mariadb-10.0.10/mysys/my_rdtsc.c 2014-04-07 16:15:48.114901576 +0200
|
||||
@@ -224,6 +224,13 @@ ulonglong my_timer_cycles(void)
|
||||
clock_gettime(CLOCK_SGI_CYCLE, &tp);
|
||||
return (ulonglong) tp.tv_sec * 1000000000 + (ulonglong) tp.tv_nsec;
|
||||
}
|
||||
+#elif defined(__GNUC__) && defined(__s390__)
|
||||
+ /* covers both s390 and s390x */
|
||||
+ {
|
||||
+ ulonglong result;
|
||||
+ __asm__ __volatile__ ("stck %0" : "=Q" (result) : : "cc");
|
||||
+ return result;
|
||||
+ }
|
||||
#elif defined(HAVE_SYS_TIMES_H) && defined(HAVE_GETHRTIME)
|
||||
/* gethrtime may appear as either cycle or nanosecond counter */
|
||||
return (ulonglong) gethrtime();
|
||||
@@ -533,6 +540,8 @@ void my_timer_init(MY_TIMER_INFO *mti)
|
||||
mti->cycles.routine= MY_TIMER_ROUTINE_ASM_GCC_SPARC32;
|
||||
#elif defined(__sgi) && defined(HAVE_CLOCK_GETTIME) && defined(CLOCK_SGI_CYCLE)
|
||||
mti->cycles.routine= MY_TIMER_ROUTINE_SGI_CYCLE;
|
||||
+#elif defined(__GNUC__) && defined(__s390__)
|
||||
+ mti->cycles.routine= MY_TIMER_ROUTINE_ASM_S390;
|
||||
#elif defined(HAVE_SYS_TIMES_H) && defined(HAVE_GETHRTIME)
|
||||
mti->cycles.routine= MY_TIMER_ROUTINE_GETHRTIME;
|
||||
#else
|
11
mariadb.spec
11
mariadb.spec
@ -8,7 +8,7 @@
|
||||
%{!?runselftest:%global runselftest 1}
|
||||
|
||||
# Set this to 1 to see which tests fail
|
||||
%global check_testsuite 0
|
||||
%global check_testsuite 1
|
||||
|
||||
# In f20+ use unversioned docdirs, otherwise the old versioned one
|
||||
%global _pkgdocdirname %{pkg_name}%{!?_pkgdocdir:-%{version}}
|
||||
@ -112,11 +112,11 @@
|
||||
# Make long macros shorter
|
||||
%global sameevr %{epoch}:%{version}-%{release}
|
||||
%global compatver 10.1
|
||||
%global bugfixver 8
|
||||
%global bugfixver 10
|
||||
|
||||
Name: mariadb
|
||||
Version: %{compatver}.%{bugfixver}
|
||||
Release: 3%{?with_debug:.debug}%{?dist}
|
||||
Release: 1%{?with_debug:.debug}%{?dist}
|
||||
Epoch: 1
|
||||
|
||||
Summary: A community developed branch of MySQL
|
||||
@ -151,7 +151,6 @@ Source52: rh-skipped-tests-ppc-s390.list
|
||||
# Patches common for more mysql-like packages
|
||||
Patch1: %{pkgnamepatch}-strmov.patch
|
||||
Patch2: %{pkgnamepatch}-install-test.patch
|
||||
Patch3: %{pkgnamepatch}-s390-tsc.patch
|
||||
Patch4: %{pkgnamepatch}-logrotate.patch
|
||||
Patch5: %{pkgnamepatch}-file-contents.patch
|
||||
Patch7: %{pkgnamepatch}-scripts.patch
|
||||
@ -491,7 +490,6 @@ MariaDB is a community developed branch of MySQL.
|
||||
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
%patch5 -p1
|
||||
%patch7 -p1
|
||||
@ -1171,6 +1169,9 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Jan 19 2016 Jakub Dorňák <jdornak@redhat.com> - 1:10.1.10-1
|
||||
- Update to 10.1.10
|
||||
|
||||
* Mon Dec 07 2015 Dan Horák <dan[at]danny.cz> - 1:10.1.8-3
|
||||
- rebuilt for s390(x)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user