Rebase to 10.4.10
Upstream started to build the Galera libraries statically Spider SE patch updated, tiny part of it was upstreamed Commit also contains several tweaks for debug build
This commit is contained in:
parent
a0e96d6af7
commit
8d089185e5
@ -26,16 +26,13 @@ Update 6/2018
|
|||||||
beeing able to send the SIGHUP to the process and read the mysqld pid file, which root can.
|
beeing able to send the SIGHUP to the process and read the mysqld pid file, which root can.
|
||||||
* Submited as PR: https://github.com/MariaDB/server/pull/807
|
* Submited as PR: https://github.com/MariaDB/server/pull/807
|
||||||
|
|
||||||
--- mariadb-10.3.7/support-files/mysql-log-rotate.sh 2018-05-23 22:38:46.000000000 +0200
|
--- mariadb-10.3.19/support-files/mysql-log-rotate.sh 2019-11-03 17:03:27.000000000 +0100
|
||||||
+++ mariadb-10.3.7/support-files/mysql-log-rotate.sh_patched 2018-06-27 12:11:23.705719826 +0200
|
+++ mariadb-10.3.19/support-files/mysql-log-rotate.sh_patched 2019-11-06 15:07:54.205379672 +0100
|
||||||
@@ -1,25 +1,12 @@
|
@@ -3,23 +3,10 @@
|
||||||
# This logname can be set in /etc/my.cnf
|
# in the [mysqld] section as follows:
|
||||||
# by setting the variable "err-log"
|
|
||||||
-# in the [safe_mysqld] section as follows:
|
|
||||||
+# in the [mysqld] section as follows:
|
|
||||||
#
|
#
|
||||||
-# [safe_mysqld]
|
# [mysqld]
|
||||||
-# err-log=@localstatedir@/mysqld.log
|
-# log-error=@localstatedir@/mysqld.log
|
||||||
-#
|
-#
|
||||||
-# If the root user has a password you have to create a
|
-# If the root user has a password you have to create a
|
||||||
-# /root/.my.cnf configuration file with the following
|
-# /root/.my.cnf configuration file with the following
|
||||||
@ -49,15 +46,14 @@ Update 6/2018
|
|||||||
-#
|
-#
|
||||||
-# ATTENTION: This /root/.my.cnf should be readable ONLY
|
-# ATTENTION: This /root/.my.cnf should be readable ONLY
|
||||||
-# for root !
|
-# for root !
|
||||||
+# [mysqld]
|
+# log-error=@LOG_LOCATION@
|
||||||
+# log_error=@LOG_LOCATION@
|
|
||||||
|
|
||||||
-@localstatedir@/mysqld.log {
|
-@localstatedir@/mysqld.log {
|
||||||
- # create 600 mysql mysql
|
- # create 600 mysql mysql
|
||||||
+@LOG_LOCATION@ {
|
+@LOG_LOCATION@ {
|
||||||
+ create 600 mysql mysql
|
+ create 600 mysql mysql
|
||||||
notifempty
|
notifempty
|
||||||
daily
|
daily
|
||||||
rotate 3
|
rotate 3
|
||||||
@@ -27,11 +14,9 @@
|
@@ -27,11 +14,9 @@
|
||||||
compress
|
compress
|
||||||
|
@ -339,15 +339,6 @@ index 58351195a61..da2052ad79e 100644
|
|||||||
NullS)
|
NullS)
|
||||||
) {
|
) {
|
||||||
delete clone_row;
|
delete clone_row;
|
||||||
@@ -5473,7 +5473,7 @@ int spider_db_mbase_util::append_tables_top_down(
|
|
||||||
int error_num;
|
|
||||||
uint outer_join_backup;
|
|
||||||
TABLE_LIST *cur_table_list, *prev_table_list = NULL, *cond_table_list = NULL;
|
|
||||||
- bool first;
|
|
||||||
+ bool first = TRUE;
|
|
||||||
DBUG_ENTER("spider_db_mbase_util::append_tables_top_down");
|
|
||||||
DBUG_PRINT("info",("spider this=%p", this));
|
|
||||||
if (
|
|
||||||
@@ -13786,7 +13786,7 @@ int spider_mbase_handler::init_union_table_name_pos()
|
@@ -13786,7 +13786,7 @@ int spider_mbase_handler::init_union_table_name_pos()
|
||||||
if (!union_table_name_pos_first)
|
if (!union_table_name_pos_first)
|
||||||
{
|
{
|
||||||
|
40
mariadb.spec
40
mariadb.spec
@ -157,8 +157,8 @@
|
|||||||
%global sameevr %{epoch}:%{version}-%{release}
|
%global sameevr %{epoch}:%{version}-%{release}
|
||||||
|
|
||||||
Name: mariadb
|
Name: mariadb
|
||||||
Version: 10.4.7
|
Version: 10.4.10
|
||||||
Release: 2%{?with_debug:.debug}%{?dist}
|
Release: 1%{?with_debug:.debug}%{?dist}
|
||||||
Epoch: 3
|
Epoch: 3
|
||||||
|
|
||||||
Summary: A very fast and robust SQL database server
|
Summary: A very fast and robust SQL database server
|
||||||
@ -258,6 +258,10 @@ BuildRequires: perl(Symbol)
|
|||||||
# for running some openssl tests rhbz#1189180
|
# for running some openssl tests rhbz#1189180
|
||||||
BuildRequires: openssl openssl-devel
|
BuildRequires: openssl openssl-devel
|
||||||
|
|
||||||
|
%if %{with debug}
|
||||||
|
BuildRequires: valgrind-devel
|
||||||
|
%endif
|
||||||
|
|
||||||
Requires: bash coreutils grep
|
Requires: bash coreutils grep
|
||||||
|
|
||||||
Requires: %{name}-common%{?_isa} = %{sameevr}
|
Requires: %{name}-common%{?_isa} = %{sameevr}
|
||||||
@ -787,14 +791,23 @@ rm -r storage/tokudb/mysql-test/tokudb/t/*.py
|
|||||||
fi
|
fi
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
CFLAGS="%{optflags} -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE"
|
CFLAGS="$CFLAGS -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE"
|
||||||
# force PIC mode so that we can build libmysqld.so
|
# force PIC mode so that we can build libmysqld.so
|
||||||
CFLAGS="$CFLAGS -fPIC"
|
CFLAGS="$CFLAGS -fPIC"
|
||||||
# Override all optimization flags when making a debug build
|
|
||||||
%{?with_debug: CFLAGS="$CFLAGS -O0 -g"}
|
|
||||||
|
|
||||||
|
# Override all optimization flags when making a debug build
|
||||||
|
%if %{with debug}
|
||||||
|
CFLAGS="$CFLAGS -O0 -g
|
||||||
|
CPPFLAGS="$CPPFLAGS -O0 -g -D_FORTIFY_SOURCE=0
|
||||||
|
# Fix GCC flags broken by MariaDB upstream
|
||||||
|
CFLAGS="$CFLAGS -Wno-error=deprecated-copy -Wno-error=pessimizing-move -Wno-error=unused-result -Wno-error=maybe-uninitialized -Wno-error=stringop-overflow -Wno-error=sign-compare
|
||||||
CXXFLAGS="$CFLAGS"
|
CXXFLAGS="$CFLAGS"
|
||||||
export CFLAGS CXXFLAGS
|
CPPFLAGS="$CPPFLAGS -Wno-error=deprecated-copy -Wno-error=pessimizing-move -Wno-error=unused-result -Wno-error=maybe-uninitialized -Wno-error=stringop-overflow -Wno-error=sign-compare
|
||||||
|
%endif
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
|
export CFLAGS CXXFLAGS CPPFLAGS
|
||||||
|
|
||||||
|
|
||||||
# The INSTALL_xxx macros have to be specified relative to CMAKE_INSTALL_PREFIX
|
# The INSTALL_xxx macros have to be specified relative to CMAKE_INSTALL_PREFIX
|
||||||
@ -877,12 +890,6 @@ make -f /usr/share/selinux/devel/Makefile %{name}-server-galera.pp
|
|||||||
%install
|
%install
|
||||||
make DESTDIR=%{buildroot} install
|
make DESTDIR=%{buildroot} install
|
||||||
|
|
||||||
%if %{with galera}
|
|
||||||
# Install the wsrep library
|
|
||||||
install -D -p -m 0755 wsrep-lib/wsrep-API/libwsrep_api_v*.so %{buildroot}%{_libdir}
|
|
||||||
install -D -p -m 0755 wsrep-lib/src/libwsrep-lib.so %{buildroot}%{_libdir}
|
|
||||||
%endif
|
|
||||||
|
|
||||||
# multilib header support #1625157
|
# multilib header support #1625157
|
||||||
for header in mysql/server/my_config.h mysql/server/private/config.h; do
|
for header in mysql/server/my_config.h mysql/server/private/config.h; do
|
||||||
%multilib_fix_c_header --file %{_includedir}/$header
|
%multilib_fix_c_header --file %{_includedir}/$header
|
||||||
@ -1268,11 +1275,8 @@ fi
|
|||||||
|
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%if %{with clibrary} || %{with galera}
|
%if %{with clibrary}
|
||||||
%files libs
|
%files libs
|
||||||
%if %{with galera}
|
|
||||||
%{_libdir}/libwsrep*.so*
|
|
||||||
%endif
|
|
||||||
%if %{with clibrary}
|
%if %{with clibrary}
|
||||||
%exclude %{_libdir}/{libmysqlclient.so.18,libmariadb.so,libmysqlclient.so,libmysqlclient_r.so}
|
%exclude %{_libdir}/{libmysqlclient.so.18,libmariadb.so,libmysqlclient.so,libmysqlclient_r.so}
|
||||||
%{_libdir}/libmariadb.so*
|
%{_libdir}/libmariadb.so*
|
||||||
@ -1599,6 +1603,10 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Dec 03 2019 Michal Schorm <mschorm@redhat.com> - 3:10.4.10-1
|
||||||
|
- Rebase to 10.4.10
|
||||||
|
Upstream started linking the Galera libraries statically
|
||||||
|
|
||||||
* Wed Sep 25 2019 Michal Schorm <mschorm@redhat.com> - 3:10.4.7-2
|
* Wed Sep 25 2019 Michal Schorm <mschorm@redhat.com> - 3:10.4.7-2
|
||||||
- Disable building of the ed25519 client plugin.
|
- Disable building of the ed25519 client plugin.
|
||||||
From now on it will be shipped by 'mariadb-connector-c' package
|
From now on it will be shipped by 'mariadb-connector-c' package
|
||||||
|
Loading…
Reference in New Issue
Block a user