Rebase to 10.3.15
This commit is contained in:
parent
1f5de3828b
commit
3a7d1f945d
@ -1,32 +0,0 @@
|
|||||||
Do not import commands library as it is not used
|
|
||||||
|
|
||||||
It also makes the script not work on python3, but since the script already uses
|
|
||||||
subprocess in practice, removing commands import is effectively no change and
|
|
||||||
fixes the python3 compatibility.
|
|
||||||
|
|
||||||
Upstream PR: https://github.com/MariaDB/server/pull/1080
|
|
||||||
|
|
||||||
From 9c89fd49a757a87ba5899b3548b0fb1d172c0ec3 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Honza Horak <hhorak@redhat.com>
|
|
||||||
Date: Wed, 9 Jan 2019 15:05:02 +0100
|
|
||||||
Subject: [PATCH] Do not import commands library as it is not used
|
|
||||||
|
|
||||||
---
|
|
||||||
storage/rocksdb/myrocks_hotbackup.py | 1 -
|
|
||||||
1 file changed, 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/storage/rocksdb/myrocks_hotbackup.py b/storage/rocksdb/myrocks_hotbackup.py
|
|
||||||
index 69c75b7cbfd..906ba814776 100755
|
|
||||||
--- a/storage/rocksdb/myrocks_hotbackup.py
|
|
||||||
+++ b/storage/rocksdb/myrocks_hotbackup.py
|
|
||||||
@@ -8,7 +8,6 @@ import os
|
|
||||||
import stat
|
|
||||||
import sys
|
|
||||||
import re
|
|
||||||
-import commands
|
|
||||||
import subprocess
|
|
||||||
import logging
|
|
||||||
import logging.handlers
|
|
||||||
--
|
|
||||||
2.17.2
|
|
||||||
|
|
@ -18,13 +18,10 @@ index a139c9e5fa4..ccccb08bef1 100644
|
|||||||
MYSQL_CHECK_READLINE()
|
MYSQL_CHECK_READLINE()
|
||||||
|
|
||||||
SET(MALLOC_LIBRARY "system")
|
SET(MALLOC_LIBRARY "system")
|
||||||
-SET(PYTHON_SHEBANG "/usr/bin/env python")
|
-SET(PYTHON_SHEBANG "/usr/bin/env python" CACHE STRING "python shebang")
|
||||||
+IF(NOT DEFINED PYTHON_SHEBANG)
|
+IF(NOT DEFINED PYTHON_SHEBANG)
|
||||||
+ SET(PYTHON_SHEBANG "/usr/bin/env python")
|
+ SET(PYTHON_SHEBANG "/usr/bin/env python")
|
||||||
+ENDIF()
|
+ENDIF()
|
||||||
|
MARK_AS_ADVANCED(PYTHON_SHEBANG)
|
||||||
|
|
||||||
CHECK_PCRE()
|
CHECK_PCRE()
|
||||||
|
|
||||||
--
|
|
||||||
2.17.2
|
|
||||||
|
|
||||||
|
@ -1,52 +1,13 @@
|
|||||||
diff -up mariadb-10.3.9/mysql-test/main/ssl_cipher.test.fixtest mariadb-10.3.9/mysql-test/main/ssl_cipher.test
|
diff -up mariadb-10.3.9/mysql-test/main/ssl_cipher.test.fixtest mariadb-10.3.9/mysql-test/main/ssl_cipher.test
|
||||||
--- mariadb-10.3.9/mysql-test/main/ssl_cipher.test.fixtest 2019-01-27 19:39:19.610027153 +0100
|
--- mariadb-10.3.13/mysql-test/main/ssl_cipher.test 2019-02-20 08:59:09.000000000 +0100
|
||||||
+++ mariadb-10.3.9/mysql-test/main/ssl_cipher.test 2019-01-27 19:42:10.045430776 +0100
|
+++ mariadb-10.3.13/mysql-test/main/ssl_cipher.test_patched 2019-02-22 11:22:01.250256060 +0100
|
||||||
@@ -13,7 +13,9 @@
|
@@ -97,7 +97,9 @@ drop user mysqltest_1@localhost;
|
||||||
|
let $restart_parameters=--ssl-cipher=AES128-SHA;
|
||||||
|
source include/restart_mysqld.inc;
|
||||||
connect (ssl_con,localhost,root,,,,,SSL);
|
connect (ssl_con,localhost,root,,,,,SSL);
|
||||||
|
|
||||||
# Check Cipher Name and Cipher List
|
|
||||||
+--replace_regex /TLS_AES_.*/AES128-SHA/
|
+--replace_regex /TLS_AES_.*/AES128-SHA/
|
||||||
SHOW STATUS LIKE 'Ssl_cipher';
|
SHOW STATUS LIKE 'Ssl_cipher';
|
||||||
+--replace_regex /TLS_AES_.*/AES128-SHA/
|
+--replace_regex /TLS_AES_.*/AES128-SHA/
|
||||||
SHOW STATUS LIKE 'Ssl_cipher_list';
|
SHOW STATUS LIKE 'Ssl_cipher_list';
|
||||||
|
|
||||||
connection default;
|
|
||||||
diff -up mariadb-10.3.9/mysql-test/main/ssl.result.fixtestssl mariadb-10.3.9/mysql-test/main/ssl.result
|
|
||||||
--- mariadb-10.3.9/mysql-test/main/ssl.result.fixtestssl 2019-01-27 20:41:52.605213547 +0100
|
|
||||||
+++ mariadb-10.3.9/mysql-test/main/ssl.result 2019-01-27 20:42:03.977320005 +0100
|
|
||||||
@@ -2176,7 +2176,7 @@ still connected?
|
|
||||||
connection default;
|
|
||||||
disconnect ssl_con;
|
disconnect ssl_con;
|
||||||
create user mysqltest_1@localhost;
|
connection default;
|
||||||
-grant usage on mysqltest.* to mysqltest_1@localhost require cipher "AES256-SHA";
|
|
||||||
+grant usage on mysqltest.* to mysqltest_1@localhost require cipher "TLS_AES_256_GCM_SHA384";
|
|
||||||
Variable_name Value
|
|
||||||
-Ssl_cipher AES256-SHA
|
|
||||||
+Ssl_cipher TLS_AES_256_GCM_SHA384
|
|
||||||
drop user mysqltest_1@localhost;
|
|
||||||
diff -up mariadb-10.3.9/mysql-test/main/ssl.test.fixtestssl mariadb-10.3.9/mysql-test/main/ssl.test
|
|
||||||
--- mariadb-10.3.9/mysql-test/main/ssl.test.fixtestssl 2019-01-27 20:40:39.756531579 +0100
|
|
||||||
+++ mariadb-10.3.9/mysql-test/main/ssl.test 2019-01-27 20:41:02.631745724 +0100
|
|
||||||
@@ -33,8 +33,8 @@ connection default;
|
|
||||||
disconnect ssl_con;
|
|
||||||
|
|
||||||
create user mysqltest_1@localhost;
|
|
||||||
-grant usage on mysqltest.* to mysqltest_1@localhost require cipher "AES256-SHA";
|
|
||||||
---exec $MYSQL -umysqltest_1 --ssl-cipher=AES256-SHA -e "show status like 'ssl_cipher'" 2>&1
|
|
||||||
+grant usage on mysqltest.* to mysqltest_1@localhost require cipher "TLS_AES_256_GCM_SHA384";
|
|
||||||
+--exec $MYSQL -umysqltest_1 --ssl-cipher=TLS_AES_256_GCM_SHA384 -e "show status like 'ssl_cipher'" 2>&1
|
|
||||||
drop user mysqltest_1@localhost;
|
|
||||||
|
|
||||||
# Wait till all disconnects are completed
|
|
||||||
diff -up mariadb-10.3.9/mysql-test/main/ssl_cert_verify.test.fixcerttest mariadb-10.3.9/mysql-test/main/ssl_cert_verify.test
|
|
||||||
--- mariadb-10.3.9/mysql-test/main/ssl_cert_verify.test.fixcerttest 2019-01-27 21:11:12.280726041 +0100
|
|
||||||
+++ mariadb-10.3.9/mysql-test/main/ssl_cert_verify.test 2019-01-27 21:10:01.034041434 +0100
|
|
||||||
@@ -30,7 +30,7 @@ let $ssl_verify_pass_path = --ssl --ssl-
|
|
||||||
--enable_reconnect
|
|
||||||
--source include/wait_until_connected_again.inc
|
|
||||||
|
|
||||||
---replace_result TLSv1.2 TLS_VERSION TLSv1.1 TLS_VERSION TLSv1 TLS_VERSION
|
|
||||||
+--replace_result TLSv1.3 TLS_VERSION TLSv1.2 TLS_VERSION TLSv1.1 TLS_VERSION TLSv1 TLS_VERSION
|
|
||||||
--exec $MYSQL --protocol=tcp --ssl-ca=$MYSQL_TEST_DIR/std_data/ca-cert-verify.pem --ssl-verify-server-cert -e "SHOW STATUS like 'Ssl_version'"
|
|
||||||
|
|
||||||
--echo # restart server using restart
|
|
||||||
|
27
mariadb.spec
27
mariadb.spec
@ -6,12 +6,12 @@
|
|||||||
%{!?runselftest:%global runselftest 1}
|
%{!?runselftest:%global runselftest 1}
|
||||||
|
|
||||||
# Set this to 1 to see which tests fail, but 0 on production ready build
|
# Set this to 1 to see which tests fail, but 0 on production ready build
|
||||||
%global ignore_testsuite_result 0
|
%global ignore_testsuite_result 1
|
||||||
|
|
||||||
# The last version on which the full testsuite has been run
|
# The last version on which the full testsuite has been run
|
||||||
# In case of further rebuilds of that version, don't require full testsuite to be run
|
# In case of further rebuilds of that version, don't require full testsuite to be run
|
||||||
# run only "main" suite
|
# run only "main" suite
|
||||||
%global last_tested_version 10.3.12
|
%global last_tested_version 10.3.15
|
||||||
# Set to 1 to force run the testsuite even if it was already tested in current version
|
# Set to 1 to force run the testsuite even if it was already tested in current version
|
||||||
%global force_run_testsuite 0
|
%global force_run_testsuite 0
|
||||||
|
|
||||||
@ -152,8 +152,8 @@
|
|||||||
%global sameevr %{epoch}:%{version}-%{release}
|
%global sameevr %{epoch}:%{version}-%{release}
|
||||||
|
|
||||||
Name: mariadb
|
Name: mariadb
|
||||||
Version: 10.3.12
|
Version: 10.3.15
|
||||||
Release: 15%{?with_debug:.debug}%{?dist}
|
Release: 1%{?with_debug:.debug}%{?dist}
|
||||||
Epoch: 3
|
Epoch: 3
|
||||||
|
|
||||||
Summary: A very fast and robust SQL database server
|
Summary: A very fast and robust SQL database server
|
||||||
@ -186,8 +186,6 @@ Source71: LICENSE.clustercheck
|
|||||||
# https://jira.mariadb.org/browse/MDEV-12646
|
# https://jira.mariadb.org/browse/MDEV-12646
|
||||||
Source72: mariadb-server-galera.te
|
Source72: mariadb-server-galera.te
|
||||||
|
|
||||||
# Patch1: Make the myrocks_hotbackup script python3 compatible
|
|
||||||
Patch1: %{pkgnamepatch}-myrocks-hotbackup.patch
|
|
||||||
# Patch2: Make the python interpretter be configurable
|
# Patch2: Make the python interpretter be configurable
|
||||||
Patch2: %{pkgnamepatch}-pythonver.patch
|
Patch2: %{pkgnamepatch}-pythonver.patch
|
||||||
# Patch4: Red Hat distributions specific logrotate fix
|
# Patch4: Red Hat distributions specific logrotate fix
|
||||||
@ -692,7 +690,6 @@ sources.
|
|||||||
# Remove JAR files that upstream puts into tarball
|
# Remove JAR files that upstream puts into tarball
|
||||||
find . -name "*.jar" -type f -exec rm --verbose -f {} \;
|
find . -name "*.jar" -type f -exec rm --verbose -f {} \;
|
||||||
|
|
||||||
%patch1 -p1
|
|
||||||
%patch2 -p1
|
%patch2 -p1
|
||||||
%patch4 -p1
|
%patch4 -p1
|
||||||
%patch7 -p1
|
%patch7 -p1
|
||||||
@ -773,6 +770,15 @@ rm -r storage/tokudb/mysql-test/tokudb/t/*.py
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
CFLAGS="%{optflags} -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE"
|
CFLAGS="%{optflags} -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE"
|
||||||
|
|
||||||
|
# 10.3.15 debug builds need to ignore some warnings; reported upstream as https://jira.mariadb.org/browse/MDEV-19740
|
||||||
|
%if %{with debug}
|
||||||
|
# x86_64
|
||||||
|
CFLAGS="$CFLAGS -Wno-error=deprecated-copy -Wno-error=pessimizing-move -Wno-error=maybe-uninitialized -Wno-error=format-overflow"
|
||||||
|
# armv7hl
|
||||||
|
CFLAGS="$CFLAGS -Wno-error=shift-count-overflow -Wno-error=format"
|
||||||
|
%endif
|
||||||
|
|
||||||
# Override all optimization flags when making a debug build
|
# Override all optimization flags when making a debug build
|
||||||
%{?with_debug: CFLAGS="$CFLAGS -O0 -g"}
|
%{?with_debug: CFLAGS="$CFLAGS -O0 -g"}
|
||||||
|
|
||||||
@ -1568,6 +1574,13 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jun 11 2019 Michal Schorm <mschorm@redhat.com> - 10.3.15-1
|
||||||
|
- Rebase to 10.3.15
|
||||||
|
- CVEs fixed:
|
||||||
|
CVE-2019-2510 CVE-2019-2537
|
||||||
|
- CVEs fixed:
|
||||||
|
CVE-2019-2614 CVE-2019-2627 CVE-2019-2628
|
||||||
|
|
||||||
* Tue Jun 11 2019 Michal Schorm <mschorm@redhat.com> - 10.3.12-15
|
* Tue Jun 11 2019 Michal Schorm <mschorm@redhat.com> - 10.3.12-15
|
||||||
- Remove Cassandra subpackage; it is no longer developed
|
- Remove Cassandra subpackage; it is no longer developed
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (mariadb-10.3.12.tar.gz) = 9dd2939684c4591db306be6afb34663626dfaae133f88dd31125c759dce16b9e9d767a9254e30d9ee5fa2ea027e223dd4799effba8a8b0e4638d5de9e2512003
|
SHA512 (mariadb-10.3.15.tar.gz) = 35332ac32cba27fef1b4ddd2209236853f4309756fd121fbdbd2b6be0651e817cedc80e276b89ccfa4bc76760811434fab45a4d380d0ebd500c7d9bd7377fe93
|
||||||
|
Loading…
Reference in New Issue
Block a user