Fix sort_buffer_length option type
This commit is contained in:
parent
7ef2ba1389
commit
0cb82945a8
19
mariadb-sortbuffer.patch
Normal file
19
mariadb-sortbuffer.patch
Normal file
@ -0,0 +1,19 @@
|
||||
diff -up mariadb-5.5.29/storage/myisam/myisamchk.c.sortbuffer mariadb-5.5.29/storage/myisam/myisamchk.c
|
||||
--- mariadb-5.5.29/storage/myisam/myisamchk.c.sortbuffer 2013-02-27 16:46:02.258855014 +0100
|
||||
+++ mariadb-5.5.29/storage/myisam/myisamchk.c 2013-02-27 16:46:23.456854430 +0100
|
||||
@@ -294,13 +294,13 @@ static struct my_option my_long_options[
|
||||
{ "sort_buffer_size", OPT_SORT_BUFFER_SIZE,
|
||||
"Deprecated. myisam_sort_buffer_size alias is being used",
|
||||
&check_param.sort_buffer_length,
|
||||
- &check_param.sort_buffer_length, 0, GET_ULL, REQUIRED_ARG,
|
||||
+ &check_param.sort_buffer_length, 0, GET_ULONG, REQUIRED_ARG,
|
||||
(long) SORT_BUFFER_INIT, (long) (MIN_SORT_BUFFER + MALLOC_OVERHEAD),
|
||||
SIZE_T_MAX, (long) MALLOC_OVERHEAD, (long) 1L, 0},
|
||||
{ "myisam_sort_buffer_size", OPT_SORT_BUFFER_SIZE,
|
||||
"Alias of sort_buffer_size parameter",
|
||||
&check_param.sort_buffer_length,
|
||||
- &check_param.sort_buffer_length, 0, GET_ULL, REQUIRED_ARG,
|
||||
+ &check_param.sort_buffer_length, 0, GET_ULONG, REQUIRED_ARG,
|
||||
(long) SORT_BUFFER_INIT, (long) (MIN_SORT_BUFFER + MALLOC_OVERHEAD),
|
||||
SIZE_T_MAX, (long) MALLOC_OVERHEAD, (long) 1L, 0},
|
||||
{ "sort_key_blocks", OPT_SORT_KEY_BLOCKS, "",
|
10
mariadb.spec
10
mariadb.spec
@ -1,6 +1,6 @@
|
||||
Name: mariadb
|
||||
Version: 5.5.29
|
||||
Release: 5%{?dist}
|
||||
Release: 6%{?dist}
|
||||
|
||||
Summary: A community developed branch of MySQL
|
||||
Group: Applications/Databases
|
||||
@ -53,6 +53,7 @@ Patch11: mariadb-string-overflow.patch
|
||||
Patch12: mariadb-dh1024.patch
|
||||
Patch13: mariadb-man-plugin.patch
|
||||
Patch14: mariadb-buffer.patch
|
||||
Patch15: mariadb-sortbuffer.patch
|
||||
|
||||
BuildRequires: perl, readline-devel, openssl-devel
|
||||
BuildRequires: cmake, ncurses-devel, zlib-devel, libaio-devel
|
||||
@ -287,6 +288,7 @@ MariaDB is a community developed branch of MySQL.
|
||||
%patch12 -p1
|
||||
%patch13 -p1
|
||||
%patch14 -p1
|
||||
%patch15 -p1
|
||||
|
||||
# workaround for upstream bug #56342
|
||||
rm -f mysql-test/t/ssl_8k_key-master.opt
|
||||
@ -304,9 +306,6 @@ cat %{SOURCE15} >> mysql-test/rh-skipped-tests.list
|
||||
%ifarch ppc ppc64 ppc64p7 s390 s390x
|
||||
echo "main.gis-precise : rhbz#906367" >> mysql-test/rh-skipped-tests.list
|
||||
%endif
|
||||
%ifarch ppc s390
|
||||
echo "main.myisampack : rhbz#906367" >> mysql-test/rh-skipped-tests.list
|
||||
%endif
|
||||
|
||||
# install mysql_plugin
|
||||
cp %{SOURCE16} man/
|
||||
@ -788,6 +787,9 @@ fi
|
||||
%{_mandir}/man1/mysql_client_test.1*
|
||||
|
||||
%changelog
|
||||
* Wed Feb 27 2013 Honza Horak <hhorak@redhat.com> 5.5.29-6
|
||||
- Fix sort_buffer_length option type
|
||||
|
||||
* Wed Feb 13 2013 Honza Horak <hhorak@redhat.com> 5.5.29-5
|
||||
- Suppress warnings in tests and skip tests also on ppc64p7
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user