04c626f762
In the CMake "CONFIGURE_FILE(<input> <output>)" command, the <input> path is treated relative to SOURCE dir, however the <output> patch is relative to BUILD dir. Since the file has been copied to a wrong location, instead in-place updated as originally intended, the file that was later installed was the original unchanged file. Resolves: #1873999, #1874446 Fix mariadb-pcdir.patch hunk
20 lines
823 B
Diff
20 lines
823 B
Diff
Use PCDIR CMake option, if configured
|
|
|
|
Upstream install the server pkgconfig file into arch-independent directory
|
|
Reported to upstream as: https://jira.mariadb.org/browse/MDEV-14340
|
|
|
|
--- mariadb-10.5.5/support-files/CMakeLists.txt.old 2020-09-30 10:36:08.582490318 +0200
|
|
+++ mariadb-10.5.5/support-files/CMakeLists.txt 2020-09-30 10:38:58.079710848 +0200
|
|
@@ -91,7 +91,11 @@
|
|
ENDIF()
|
|
|
|
CONFIGURE_FILE(mariadb.pc.in ${CMAKE_CURRENT_BINARY_DIR}/mariadb.pc @ONLY)
|
|
+IF(INSTALL_PCDIR)
|
|
+ INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/mariadb.pc DESTINATION ${INSTALL_PCDIR} COMPONENT Development)
|
|
+ELSE()
|
|
INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/mariadb.pc DESTINATION ${INSTALL_LIBDIR}/pkgconfig COMPONENT Development)
|
|
+ENDIF()
|
|
|
|
INSTALL(FILES mysql.m4 DESTINATION ${INSTALL_SHAREDIR}/aclocal COMPONENT Development)
|
|
|