43456681ea
The upstream now defaults to the location we need, although the server pkgconfig file location is still NOT configurable. The CMake INSTALL_PCDIR option affects only the client library pkgconfig file location.
31 lines
1.3 KiB
Diff
31 lines
1.3 KiB
Diff
--- mariadb-10.3.23/support-files/CMakeLists.txt 2020-06-07 22:02:16.564626222 +0200
|
|
+++ mariadb-10.3.23/support-files/CMakeLists.txt_patched 2020-06-07 22:01:17.180909018 +0200
|
|
@@ -91,6 +91,7 @@ IF(UNIX)
|
|
ENDIF()
|
|
|
|
CONFIGURE_FILE(mariadb.pc.in ${CMAKE_CURRENT_BINARY_DIR}/mariadb.pc @ONLY)
|
|
+ CONFIGURE_FILE(rpm/server.cnf ${CMAKE_CURRENT_BINARY_DIR}/rpm/server.cnf @ONLY)
|
|
INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/mariadb.pc DESTINATION ${INSTALL_LIBDIR}/pkgconfig COMPONENT Development)
|
|
|
|
INSTALL(FILES mysql.m4 DESTINATION ${INSTALL_SHAREDIR}/aclocal COMPONENT Development)
|
|
diff -up mariadb-10.0.15/support-files/rpm/server.cnf.ownsetup mariadb-10.0.15/support-files/rpm/server.cnf
|
|
--- mariadb-10.0.15/support-files/rpm/server.cnf.ownsetup 2015-01-24 23:55:55.110063592 +0100
|
|
+++ mariadb-10.0.15/support-files/rpm/server.cnf 2015-01-24 23:57:42.308114387 +0100
|
|
@@ -9,7 +9,16 @@
|
|
[server]
|
|
|
|
# this is only for the mysqld standalone daemon
|
|
+# Settings user and group are ignored when systemd is used.
|
|
+# If you need to run mysqld under a different user or group,
|
|
+# customize your systemd unit file for mysqld/mariadb according to the
|
|
+# instructions in http://fedoraproject.org/wiki/Systemd
|
|
[mysqld]
|
|
+datadir=@MYSQL_DATADIR@
|
|
+socket=@MYSQL_UNIX_ADDR@
|
|
+log-error=@LOG_LOCATION@
|
|
+pid-file=@PID_FILE_DIR@/@DAEMON_NO_PREFIX@.pid
|
|
+
|
|
|
|
#
|
|
# * Galera-related settings
|