2ec2af3e11
This is an automated DistroBaker update from upstream sources. If you do not know what this is about or would like to opt out, contact the OSCI team. Source: https://src.fedoraproject.org/rpms/mariadb.git#95e69a74bcb5a5f4981ead3885ef81730e8f0217
20 lines
823 B
Diff
20 lines
823 B
Diff
Use PCDIR CMake option, if configured
|
|
|
|
Upstream install the server pkgconfig file into arch-independent directory
|
|
Reported to upstream as: https://jira.mariadb.org/browse/MDEV-14340
|
|
|
|
--- mariadb-10.5.5/support-files/CMakeLists.txt.old 2020-09-30 10:36:08.582490318 +0200
|
|
+++ mariadb-10.5.5/support-files/CMakeLists.txt 2020-09-30 10:38:58.079710848 +0200
|
|
@@ -91,7 +91,11 @@
|
|
ENDIF()
|
|
|
|
CONFIGURE_FILE(mariadb.pc.in ${CMAKE_CURRENT_BINARY_DIR}/mariadb.pc @ONLY)
|
|
+IF(INSTALL_PCDIR)
|
|
+ INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/mariadb.pc DESTINATION ${INSTALL_PCDIR} COMPONENT Development)
|
|
+ELSE()
|
|
INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/mariadb.pc DESTINATION ${INSTALL_LIBDIR}/pkgconfig COMPONENT Development)
|
|
+ENDIF()
|
|
|
|
INSTALL(FILES mysql.m4 DESTINATION ${INSTALL_SHAREDIR}/aclocal COMPONENT Development)
|
|
|