Merge branch 'master' into f24
This commit is contained in:
commit
f9a94dd4bc
@ -1,98 +0,0 @@
|
|||||||
diff -up mariadb-10.1.14/mysql-test/t/openssl_1.test.sslnew mariadb-10.1.14/mysql-test/t/openssl_1.test
|
|
||||||
--- mariadb-10.1.14/mysql-test/t/openssl_1.test.sslnew 2016-07-15 08:24:17.393378642 +0200
|
|
||||||
+++ mariadb-10.1.14/mysql-test/t/openssl_1.test 2016-07-15 08:28:00.918177536 +0200
|
|
||||||
@@ -134,7 +134,7 @@ drop table t1;
|
|
||||||
# verification of servers certificate by setting both ca certificate
|
|
||||||
# and ca path to NULL
|
|
||||||
#
|
|
||||||
---replace_result DHE-RSA-AES256-GCM-SHA384 DHE-RSA-AES256-SHA DHE-RSA-CHACHA20-POLY1305 DHE-RSA-AES256-SHA
|
|
||||||
+--replace_result DHE-RSA-AES256-GCM-SHA384 DHE-RSA-AES256-SHA DHE-RSA-CHACHA20-POLY1305 DHE-RSA-AES256-SHA AES256-GCM-SHA384 DHE-RSA-AES256-SHA
|
|
||||||
--exec $MYSQL --ssl --ssl-key=$MYSQL_TEST_DIR/std_data/client-key.pem --ssl-cert=$MYSQL_TEST_DIR/std_data/client-cert.pem -e "SHOW STATUS LIKE 'ssl_Cipher'" 2>&1
|
|
||||||
--echo End of 5.0 tests
|
|
||||||
|
|
||||||
@@ -259,7 +259,7 @@ select 'is still running; no cipher requ
|
|
||||||
GRANT SELECT ON test.* TO bug42158@localhost REQUIRE X509;
|
|
||||||
FLUSH PRIVILEGES;
|
|
||||||
connect(con1,localhost,bug42158,,,,,SSL);
|
|
||||||
---replace_result DHE-RSA-AES256-GCM-SHA384 DHE-RSA-AES256-SHA DHE-RSA-CHACHA20-POLY1305 DHE-RSA-AES256-SHA
|
|
||||||
+--replace_result DHE-RSA-AES256-GCM-SHA384 DHE-RSA-AES256-SHA DHE-RSA-CHACHA20-POLY1305 DHE-RSA-AES256-SHA AES256-GCM-SHA384 DHE-RSA-AES256-SHA
|
|
||||||
SHOW STATUS LIKE 'Ssl_cipher';
|
|
||||||
disconnect con1;
|
|
||||||
connection default;
|
|
||||||
diff -up mariadb-10.1.14/mysql-test/t/ssl_compress.test.sslnew mariadb-10.1.14/mysql-test/t/ssl_compress.test
|
|
||||||
--- mariadb-10.1.14/mysql-test/t/ssl_compress.test.sslnew 2016-07-15 08:24:17.395378649 +0200
|
|
||||||
+++ mariadb-10.1.14/mysql-test/t/ssl_compress.test 2016-07-15 08:29:53.924562035 +0200
|
|
||||||
@@ -11,7 +11,7 @@
|
|
||||||
connect (ssl_compress_con,localhost,root,,,,,SSL COMPRESS);
|
|
||||||
|
|
||||||
# Check ssl turned on
|
|
||||||
---replace_result DHE-RSA-AES256-GCM-SHA384 DHE-RSA-AES256-SHA DHE-RSA-CHACHA20-POLY1305 DHE-RSA-AES256-SHA
|
|
||||||
+--replace_result DHE-RSA-AES256-GCM-SHA384 DHE-RSA-AES256-SHA DHE-RSA-CHACHA20-POLY1305 DHE-RSA-AES256-SHA AES256-GCM-SHA384 DHE-RSA-AES256-SHA
|
|
||||||
SHOW STATUS LIKE 'Ssl_cipher';
|
|
||||||
|
|
||||||
# Check compression turned on
|
|
||||||
@@ -21,7 +21,7 @@ SHOW STATUS LIKE 'Compression';
|
|
||||||
-- source include/common-tests.inc
|
|
||||||
|
|
||||||
# Check ssl turned on
|
|
||||||
---replace_result DHE-RSA-AES256-GCM-SHA384 DHE-RSA-AES256-SHA DHE-RSA-CHACHA20-POLY1305 DHE-RSA-AES256-SHA
|
|
||||||
+--replace_result DHE-RSA-AES256-GCM-SHA384 DHE-RSA-AES256-SHA DHE-RSA-CHACHA20-POLY1305 DHE-RSA-AES256-SHA AES256-GCM-SHA384 DHE-RSA-AES256-SHA
|
|
||||||
SHOW STATUS LIKE 'Ssl_cipher';
|
|
||||||
|
|
||||||
# Check compression turned on
|
|
||||||
diff -up mariadb-10.1.14/mysql-test/t/ssl.test.sslnew mariadb-10.1.14/mysql-test/t/ssl.test
|
|
||||||
--- mariadb-10.1.14/mysql-test/t/ssl.test.sslnew 2016-07-15 08:24:17.397378656 +0200
|
|
||||||
+++ mariadb-10.1.14/mysql-test/t/ssl.test 2016-07-15 08:29:06.339400129 +0200
|
|
||||||
@@ -11,7 +11,7 @@
|
|
||||||
connect (ssl_con,localhost,root,,,,,SSL);
|
|
||||||
|
|
||||||
# Check ssl turned on
|
|
||||||
---replace_result DHE-RSA-AES256-GCM-SHA384 DHE-RSA-AES256-SHA DHE-RSA-CHACHA20-POLY1305 DHE-RSA-AES256-SHA
|
|
||||||
+--replace_result DHE-RSA-AES256-GCM-SHA384 DHE-RSA-AES256-SHA DHE-RSA-CHACHA20-POLY1305 DHE-RSA-AES256-SHA AES256-GCM-SHA384 DHE-RSA-AES256-SHA
|
|
||||||
SHOW STATUS LIKE 'Ssl_cipher';
|
|
||||||
|
|
||||||
# Check ssl expiration
|
|
||||||
@@ -22,7 +22,7 @@ SHOW STATUS LIKE 'Ssl_server_not_after';
|
|
||||||
-- source include/common-tests.inc
|
|
||||||
|
|
||||||
# Check ssl turned on
|
|
||||||
---replace_result DHE-RSA-AES256-GCM-SHA384 DHE-RSA-AES256-SHA DHE-RSA-CHACHA20-POLY1305 DHE-RSA-AES256-SHA
|
|
||||||
+--replace_result DHE-RSA-AES256-GCM-SHA384 DHE-RSA-AES256-SHA DHE-RSA-CHACHA20-POLY1305 DHE-RSA-AES256-SHA AES256-GCM-SHA384 DHE-RSA-AES256-SHA
|
|
||||||
SHOW STATUS LIKE 'Ssl_cipher';
|
|
||||||
|
|
||||||
#
|
|
||||||
diff -up mariadb-10.1.14/mysql-test/t/ssl_timeout.test.sslnew mariadb-10.1.14/mysql-test/t/ssl_timeout.test
|
|
||||||
--- mariadb-10.1.14/mysql-test/t/ssl_timeout.test.sslnew 2016-07-15 08:24:17.398378660 +0200
|
|
||||||
+++ mariadb-10.1.14/mysql-test/t/ssl_timeout.test 2016-07-15 08:28:51.920351068 +0200
|
|
||||||
@@ -7,7 +7,7 @@
|
|
||||||
connect (ssl_con,localhost,root,,,,,SSL read_timeout=5);
|
|
||||||
|
|
||||||
--echo # Check ssl turned on
|
|
||||||
---replace_result DHE-RSA-AES256-GCM-SHA384 DHE-RSA-AES256-SHA DHE-RSA-CHACHA20-POLY1305 DHE-RSA-AES256-SHA
|
|
||||||
+--replace_result DHE-RSA-AES256-GCM-SHA384 DHE-RSA-AES256-SHA DHE-RSA-CHACHA20-POLY1305 DHE-RSA-AES256-SHA AES256-GCM-SHA384 DHE-RSA-AES256-SHA
|
|
||||||
SHOW STATUS LIKE 'Ssl_cipher';
|
|
||||||
|
|
||||||
# --error CR_SERVER_LOST
|
|
||||||
diff -up mariadb-10.1.14/mysql-test/t/userstat.test.sslnew mariadb-10.1.14/mysql-test/t/userstat.test
|
|
||||||
--- mariadb-10.1.14/mysql-test/t/userstat.test.sslnew 2016-07-15 08:24:17.399378663 +0200
|
|
||||||
+++ mariadb-10.1.14/mysql-test/t/userstat.test 2016-07-15 08:28:40.693312869 +0200
|
|
||||||
@@ -35,7 +35,7 @@ drop table t1;
|
|
||||||
|
|
||||||
# test SSL connections
|
|
||||||
--connect (ssl_con,localhost,root,,,,,SSL)
|
|
||||||
---replace_result DHE-RSA-AES256-GCM-SHA384 DHE-RSA-AES256-SHA
|
|
||||||
+--replace_result DHE-RSA-AES256-GCM-SHA384 DHE-RSA-AES256-SHA DHE-RSA-CHACHA20-POLY1305 DHE-RSA-AES256-SHA AES256-GCM-SHA384 DHE-RSA-AES256-SHA
|
|
||||||
SHOW STATUS LIKE 'Ssl_cipher';
|
|
||||||
--connection default
|
|
||||||
|
|
||||||
diff -up mariadb-10.1.14/mysql-test/t/ssl_8k_key.test.newsslfix mariadb-10.1.14/mysql-test/t/ssl_8k_key.test
|
|
||||||
--- mariadb-10.1.14/mysql-test/t/ssl_8k_key.test.newsslfix 2016-07-15 10:45:15.158140490 +0200
|
|
||||||
+++ mariadb-10.1.14/mysql-test/t/ssl_8k_key.test 2016-07-15 10:37:13.886657684 +0200
|
|
||||||
@@ -5,6 +5,7 @@
|
|
||||||
#
|
|
||||||
# Bug#29784 YaSSL assertion failure when reading 8k key.
|
|
||||||
#
|
|
||||||
+--replace_result DHE-RSA-AES256-GCM-SHA384 DHE-RSA-AES256-SHA DHE-RSA-CHACHA20-POLY1305 DHE-RSA-AES256-SHA AES256-GCM-SHA384 DHE-RSA-AES256-SHA
|
|
||||||
--exec $MYSQL --ssl --ssl-key=$MYSQL_TEST_DIR/std_data/client-key.pem --ssl-cert=$MYSQL_TEST_DIR/std_data/client-cert.pem -e "SHOW STATUS LIKE 'ssl_Cipher'" 2>&1
|
|
||||||
|
|
||||||
## This test file is for testing encrypted communication only, not other
|
|
14
mariadb.spec
14
mariadb.spec
@ -119,11 +119,11 @@
|
|||||||
# Make long macros shorter
|
# Make long macros shorter
|
||||||
%global sameevr %{epoch}:%{version}-%{release}
|
%global sameevr %{epoch}:%{version}-%{release}
|
||||||
%global compatver 10.1
|
%global compatver 10.1
|
||||||
%global bugfixver 14
|
%global bugfixver 16
|
||||||
|
|
||||||
Name: mariadb
|
Name: mariadb
|
||||||
Version: %{compatver}.%{bugfixver}
|
Version: %{compatver}.%{bugfixver}
|
||||||
Release: 5%{?with_debug:.debug}%{?dist}
|
Release: 1%{?with_debug:.debug}%{?dist}
|
||||||
Epoch: 3
|
Epoch: 3
|
||||||
|
|
||||||
Summary: A community developed branch of MySQL
|
Summary: A community developed branch of MySQL
|
||||||
@ -173,7 +173,6 @@ Patch12: %{pkgnamepatch}-admincrash.patch
|
|||||||
Patch30: %{pkgnamepatch}-errno.patch
|
Patch30: %{pkgnamepatch}-errno.patch
|
||||||
Patch31: %{pkgnamepatch}-string-overflow.patch
|
Patch31: %{pkgnamepatch}-string-overflow.patch
|
||||||
Patch32: %{pkgnamepatch}-basedir.patch
|
Patch32: %{pkgnamepatch}-basedir.patch
|
||||||
Patch33: %{pkgnamepatch}-ssltests-replace.patch
|
|
||||||
Patch34: %{pkgnamepatch}-covscan-stroverflow.patch
|
Patch34: %{pkgnamepatch}-covscan-stroverflow.patch
|
||||||
Patch37: %{pkgnamepatch}-notestdb.patch
|
Patch37: %{pkgnamepatch}-notestdb.patch
|
||||||
|
|
||||||
@ -563,7 +562,6 @@ MariaDB is a community developed branch of MySQL.
|
|||||||
%patch30 -p1
|
%patch30 -p1
|
||||||
%patch31 -p1
|
%patch31 -p1
|
||||||
%patch32 -p1
|
%patch32 -p1
|
||||||
%patch33 -p1
|
|
||||||
%patch34 -p1
|
%patch34 -p1
|
||||||
%patch37 -p1
|
%patch37 -p1
|
||||||
%patch40 -p1
|
%patch40 -p1
|
||||||
@ -961,9 +959,11 @@ export MTR_BUILD_THREAD=%{__isa_bits}
|
|||||||
%post embedded -p /sbin/ldconfig
|
%post embedded -p /sbin/ldconfig
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
%if %{with galera}
|
||||||
%post server-galera
|
%post server-galera
|
||||||
semanage port -a -t mysqld_port_t -p tcp 4568 >/dev/null 2>&1 || :
|
semanage port -a -t mysqld_port_t -p tcp 4568 >/dev/null 2>&1 || :
|
||||||
semodule -i %{_datadir}/selinux/packages/%{name}/%{name}-server-galera.pp >/dev/null 2>&1 || :
|
semodule -i %{_datadir}/selinux/packages/%{name}/%{name}-server-galera.pp >/dev/null 2>&1 || :
|
||||||
|
%endif
|
||||||
|
|
||||||
%post server
|
%post server
|
||||||
%if %{with init_systemd}
|
%if %{with init_systemd}
|
||||||
@ -1102,17 +1102,20 @@ fi
|
|||||||
%lang(uk) %{_datadir}/%{pkg_name}/ukrainian
|
%lang(uk) %{_datadir}/%{pkg_name}/ukrainian
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
%if %{with galera}
|
||||||
%files server-galera
|
%files server-galera
|
||||||
%doc Docs/README.wsrep
|
%doc Docs/README.wsrep
|
||||||
%license LICENSE.clustercheck
|
%license LICENSE.clustercheck
|
||||||
%{_bindir}/clustercheck
|
%{_bindir}/clustercheck
|
||||||
%if %{with init_systemd}
|
%if %{with init_systemd}
|
||||||
%{_bindir}/galera_new_cluster
|
%{_bindir}/galera_new_cluster
|
||||||
|
%{_bindir}/galera_recovery
|
||||||
%{_datadir}/%{pkg_name}/systemd/use_galera_new_cluster.conf
|
%{_datadir}/%{pkg_name}/systemd/use_galera_new_cluster.conf
|
||||||
%endif
|
%endif
|
||||||
%config(noreplace) %{_sysconfdir}/my.cnf.d/galera.cnf
|
%config(noreplace) %{_sysconfdir}/my.cnf.d/galera.cnf
|
||||||
%attr(0640,root,root) %ghost %config(noreplace) %{_sysconfdir}/sysconfig/clustercheck
|
%attr(0640,root,root) %ghost %config(noreplace) %{_sysconfdir}/sysconfig/clustercheck
|
||||||
%{_datadir}/selinux/packages/%{name}/%{name}-server-galera.pp
|
%{_datadir}/selinux/packages/%{name}/%{name}-server-galera.pp
|
||||||
|
%endif
|
||||||
|
|
||||||
%files server
|
%files server
|
||||||
%doc README.mysql-cnf
|
%doc README.mysql-cnf
|
||||||
@ -1296,6 +1299,9 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jul 19 2016 Jakub Dorňák <jdornak@redhat.com> - 3:10.1.16-1
|
||||||
|
- Update to 10.1.16
|
||||||
|
|
||||||
* Fri Jul 15 2016 Honza Horak <hhorak@redhat.com> - 3:10.1.14-5
|
* Fri Jul 15 2016 Honza Horak <hhorak@redhat.com> - 3:10.1.14-5
|
||||||
- Fail build when test-suite fails
|
- Fail build when test-suite fails
|
||||||
- Use license macro for inclusion of licenses
|
- Use license macro for inclusion of licenses
|
||||||
|
@ -1,12 +1,8 @@
|
|||||||
|
|
||||||
connect.bin : rhbz#1096787 (pass on aarch64)
|
|
||||||
connect.endian : rhbz#1096787
|
|
||||||
|
|
||||||
main.partition_exchange : rhbz#1096787
|
|
||||||
main.analyze_stmt_orderby : rhbz#1096787
|
|
||||||
main.explain_json_innodb : rhbz#1096787
|
|
||||||
main.explain_json_format_partitions : rhbz#1096787
|
|
||||||
main.analyze_format_json : rhbz#1096787
|
main.analyze_format_json : rhbz#1096787
|
||||||
|
main.analyze_stmt_orderby : rhbz#1096787
|
||||||
|
main.explain_json_format_partitions : rhbz#1096787
|
||||||
|
main.explain_json_innodb : rhbz#1096787
|
||||||
main.explain_json : rhbz#1096787
|
main.explain_json : rhbz#1096787
|
||||||
|
main.partition_exchange : rhbz#1096787
|
||||||
main.subselect_cache : rhbz#1096787
|
main.subselect_cache : rhbz#1096787
|
||||||
main.type_year : rhbz#1096787
|
main.type_year : rhbz#1096787
|
||||||
|
@ -1,14 +1,12 @@
|
|||||||
# These tests fail with MariaDB 10:
|
# These tests fail with MariaDB 10:
|
||||||
|
|
||||||
main.userstat : rhbz#1096787
|
main.multi_update : rhbz#1096787
|
||||||
main.set_statement_notembedded_binlog : rhbz#1096787
|
main.set_statement_notembedded_binlog : rhbz#1096787
|
||||||
main.ssl_7937 : rhbz#1096787
|
|
||||||
main.ssl_crl_clients : rhbz#1096787
|
|
||||||
main.ssl : rhbz#1096787
|
|
||||||
main.ssl_8k_key : rhbz#1096787
|
|
||||||
main.ssl_cert_verify : rhbz#1096787
|
main.ssl_cert_verify : rhbz#1096787
|
||||||
main.ssl_compress : rhbz#1096787
|
main.ssl_crl_clients : rhbz#1096787
|
||||||
main.ssl_timeout : rhbz#1096787
|
main.ssl_7937 : rhbz#1096787
|
||||||
|
main.ssl_8k_key : rhbz#1096787
|
||||||
|
main.userstat : rhbz#1096787
|
||||||
perfschema.nesting : rhbz#1096787
|
perfschema.nesting : rhbz#1096787
|
||||||
perfschema.socket_summary_by_event_name_func : rhbz#1096787
|
perfschema.socket_summary_by_event_name_func : rhbz#1096787
|
||||||
perfschema.socket_summary_by_instance_func : rhbz#1096787
|
perfschema.socket_summary_by_instance_func : rhbz#1096787
|
||||||
|
Loading…
Reference in New Issue
Block a user