import mariadb-10.3.35-1.module+el8.6.0+15949+4ba4ec26
This commit is contained in:
parent
39e1cf5a6f
commit
f24404ff36
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
|||||||
SOURCES/mariadb-10.3.32.tar.gz
|
SOURCES/mariadb-10.3.35.tar.gz
|
||||||
|
@ -1 +1 @@
|
|||||||
ad2b6d16fcbcdc3e0a131e75efe72ec695054be3 SOURCES/mariadb-10.3.32.tar.gz
|
ea904f8e036c72f0b1db78cf2d350c1dd8250375 SOURCES/mariadb-10.3.35.tar.gz
|
||||||
|
@ -1,30 +0,0 @@
|
|||||||
# Fixing conflict with groonga package
|
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1763287
|
|
||||||
|
|
||||||
--- mariadb-10.3.18/storage/mroonga/vendor/groonga/CMakeLists.txt.withoutoption 2019-11-11 14:01:07.762595716 +0100
|
|
||||||
+++ mariadb-10.3.18/storage/mroonga/vendor/groonga/CMakeLists.txt 2019-11-11 14:33:05.224012458 +0100
|
|
||||||
@@ -86,7 +86,9 @@
|
|
||||||
set(INCLUDE_DIR "include")
|
|
||||||
set(GRN_INCLUDE_DIR "include/groonga")
|
|
||||||
set(DATA_DIR "share")
|
|
||||||
-set(GRN_DATA_DIR "${DATA_DIR}/${GRN_PROJECT_NAME}")
|
|
||||||
+if(NOT DEFINED GRN_DATA_DIR)
|
|
||||||
+ set(GRN_DATA_DIR "${DATA_DIR}/${GRN_PROJECT_NAME}")
|
|
||||||
+endif()
|
|
||||||
set(CONFIG_DIR "etc")
|
|
||||||
set(GRN_CONFIG_DIR "${CONFIG_DIR}/${GRN_PROJECT_NAME}")
|
|
||||||
set(GRN_CONFIG_PATH "${CMAKE_INSTALL_PREFIX}/${GRN_CONFIG_DIR}/groonga.conf")
|
|
||||||
|
|
||||||
--- mariadb-10.3.18/storage/mroonga/vendor/groonga/vendor/plugins/groonga-normalizer-mysql/CMakeLists.txt.withoutoption 2019-11-11 14:34:22.661005715 +0100
|
|
||||||
+++ mariadb-10.3.18/storage/mroonga/vendor/groonga/vendor/plugins/groonga-normalizer-mysql/CMakeLists.txt 2019-11-11 14:35:59.962244120 +0100
|
|
||||||
@@ -16,7 +16,9 @@
|
|
||||||
# MA 02110-1335 USA
|
|
||||||
|
|
||||||
cmake_minimum_required(VERSION 2.6)
|
|
||||||
-set(GROONGA_NORMALIZER_MYSQL_PROJECT_NAME "groonga-normalizer-mysql")
|
|
||||||
+if (NOT DEFINED GROONGA_NORMALIZER_MYSQL_PROJECT_NAME)
|
|
||||||
+ set(GROONGA_NORMALIZER_MYSQL_PROJECT_NAME "groonga-normalizer-mysql")
|
|
||||||
+endif()
|
|
||||||
project("${GROONGA_NORMALIZER_MYSQL_PROJECT_NAME}")
|
|
||||||
|
|
||||||
if(DEFINED GROONGA_NORMALIZER_MYSQL_EMBED)
|
|
@ -32,7 +32,7 @@ Update 01/2022
|
|||||||
|
|
||||||
--- mariadb-10.3.32/support-files/mysql-log-rotate.sh 2022-01-14 17:03:27.000000000 +0100
|
--- mariadb-10.3.32/support-files/mysql-log-rotate.sh 2022-01-14 17:03:27.000000000 +0100
|
||||||
+++ mariadb-10.3.32/support-files/mysql-log-rotate.sh_patched 2022-01-17 15:07:54.205379672 +0100
|
+++ mariadb-10.3.32/support-files/mysql-log-rotate.sh_patched 2022-01-17 15:07:54.205379672 +0100
|
||||||
@@ -3,35 +3,21 @@
|
@@ -3,36 +3,22 @@
|
||||||
# in the [mysqld] section as follows:
|
# in the [mysqld] section as follows:
|
||||||
#
|
#
|
||||||
# [mysqld]
|
# [mysqld]
|
||||||
@ -56,6 +56,7 @@ Update 01/2022
|
|||||||
- # create 600 mysql mysql
|
- # create 600 mysql mysql
|
||||||
+@LOG_LOCATION@ {
|
+@LOG_LOCATION@ {
|
||||||
+ create 600 mysql mysql
|
+ create 600 mysql mysql
|
||||||
|
su mysql mysql
|
||||||
notifempty
|
notifempty
|
||||||
daily
|
daily
|
||||||
rotate 3
|
rotate 3
|
||||||
|
@ -1,3 +1,8 @@
|
|||||||
# Fails on s390x
|
# Fails on s390x
|
||||||
disks.disks :
|
disks.disks :
|
||||||
disks.disks_notembedded :
|
disks.disks_notembedded :
|
||||||
|
|
||||||
|
# related to MDEV-20194
|
||||||
|
# first check of `undefined` table causes warning,
|
||||||
|
# instead INSERT and ALTER should cause it
|
||||||
|
innodb.row_size_error_log_warnings_3 :
|
||||||
|
@ -142,8 +142,8 @@
|
|||||||
%global sameevr %{epoch}:%{version}-%{release}
|
%global sameevr %{epoch}:%{version}-%{release}
|
||||||
|
|
||||||
Name: mariadb
|
Name: mariadb
|
||||||
Version: 10.3.32
|
Version: 10.3.35
|
||||||
Release: 2%{?with_debug:.debug}%{?dist}
|
Release: 1%{?with_debug:.debug}%{?dist}
|
||||||
Epoch: 3
|
Epoch: 3
|
||||||
|
|
||||||
Summary: A very fast and robust SQL database server
|
Summary: A very fast and robust SQL database server
|
||||||
@ -190,8 +190,6 @@ Patch9: %{pkgnamepatch}-ownsetup.patch
|
|||||||
Patch10: %{pkgnamepatch}-annocheck.patch
|
Patch10: %{pkgnamepatch}-annocheck.patch
|
||||||
# Patch12: Downstream fix for a correct pkgconfig file location
|
# Patch12: Downstream fix for a correct pkgconfig file location
|
||||||
Patch12: %{pkgnamepatch}-pcdir.patch
|
Patch12: %{pkgnamepatch}-pcdir.patch
|
||||||
# Patch15: Add option to edit groonga's and groonga-normalizer-mysql install path
|
|
||||||
Patch15: %{pkgnamepatch}-groonga.patch
|
|
||||||
|
|
||||||
|
|
||||||
BuildRequires: cmake gcc-c++
|
BuildRequires: cmake gcc-c++
|
||||||
@ -697,7 +695,6 @@ find . -name "*.jar" -type f -exec rm --verbose -f {} \;
|
|||||||
%patch9 -p1
|
%patch9 -p1
|
||||||
%patch10 -p1
|
%patch10 -p1
|
||||||
%patch12 -p1
|
%patch12 -p1
|
||||||
%patch15 -p1
|
|
||||||
|
|
||||||
# workaround for upstream bug #56342
|
# workaround for upstream bug #56342
|
||||||
#rm mysql-test/t/ssl_8k_key-master.opt
|
#rm mysql-test/t/ssl_8k_key-master.opt
|
||||||
@ -1587,8 +1584,15 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jun 30 2022 Zuzana Miklankova <zmiklank@redhat.com> - 3:10.3.35-1
|
||||||
|
- Rebase to 10.3.35
|
||||||
|
|
||||||
|
* Thu Jun 30 2022 Zuzana Miklankova <zmiklank@redhat.com> - 3:10.3.34-1
|
||||||
|
- Rebase to 10.3.34
|
||||||
|
|
||||||
* Mon Jan 17 2022 Zuzana Miklankova <zmiklank@redhat.com> - 3:10.3.32-2
|
* Mon Jan 17 2022 Zuzana Miklankova <zmiklank@redhat.com> - 3:10.3.32-2
|
||||||
- Add delaycompress option to the logrotate script
|
- Add delaycompress option to the logrotate script
|
||||||
|
- Resolves: rhbz:#2015580
|
||||||
|
|
||||||
* Wed Jan 12 2022 Zuzana Miklankova <zmiklank@redhat.com> - 3:10.3.32-1
|
* Wed Jan 12 2022 Zuzana Miklankova <zmiklank@redhat.com> - 3:10.3.32-1
|
||||||
- Rebase to 10.3.32
|
- Rebase to 10.3.32
|
||||||
@ -1601,6 +1605,7 @@ fi
|
|||||||
|
|
||||||
* Mon Aug 09 2021 Lukas Javorsky <ljavorsk@redhat.com> - 3:10.3.29-2
|
* Mon Aug 09 2021 Lukas Javorsky <ljavorsk@redhat.com> - 3:10.3.29-2
|
||||||
- Set user_map.conf file to be noreplace config file
|
- Set user_map.conf file to be noreplace config file
|
||||||
|
- Resolves: rhbz#1989534
|
||||||
|
|
||||||
* Tue May 05 2021 Michal Schorm <mschorm@redhat.com> - 3:10.3.29-1
|
* Tue May 05 2021 Michal Schorm <mschorm@redhat.com> - 3:10.3.29-1
|
||||||
- Rebase to 10.3.29
|
- Rebase to 10.3.29
|
||||||
|
Loading…
Reference in New Issue
Block a user