Rebase to 10.4.6 GA
This commit is contained in:
parent
164d5419b1
commit
dbc826fd1b
30
mariadb-auth_pam_tool_dir.patch
Normal file
30
mariadb-auth_pam_tool_dir.patch
Normal file
@ -0,0 +1,30 @@
|
|||||||
|
This scirpt is ran by the systemd service.
|
||||||
|
In Fedora the service has priviledges dropped to the mysql user.
|
||||||
|
Thus "chown 0" will always fail
|
||||||
|
|
||||||
|
Never parse 'ls' output!
|
||||||
|
http://mywiki.wooledge.org/BashFAQ/087
|
||||||
|
|
||||||
|
--- mariadb-10.4.6/scripts/mysql_install_db.sh 2019-06-18 00:00:32.000000000 +0200
|
||||||
|
+++ mariadb-10.4.6/scripts/mysql_install_db.sh_patched 2019-06-20 01:41:43.250208187 +0200
|
||||||
|
@@ -476,12 +476,15 @@ then
|
||||||
|
fi
|
||||||
|
if test -z "$srcdir"
|
||||||
|
then
|
||||||
|
- chown 0 "$pamtooldir/auth_pam_tool_dir/auth_pam_tool"
|
||||||
|
- if test $? -ne 0
|
||||||
|
+ if [ `stat "$pamtooldir/auth_pam_tool_dir/auth_pam_tool" -c %u` -ne 0 ]
|
||||||
|
then
|
||||||
|
- echo "Couldn't set an owner to '$pamtooldir/auth_pam_tool_dir/auth_pam_tool'."
|
||||||
|
- echo " It must be root, the PAM authentication plugin doesn't work otherwise.."
|
||||||
|
- echo
|
||||||
|
+ chown 0 "$pamtooldir/auth_pam_tool_dir/auth_pam_tool"
|
||||||
|
+ if test $? -ne 0
|
||||||
|
+ then
|
||||||
|
+ echo "Couldn't set an owner to '$pamtooldir/auth_pam_tool_dir/auth_pam_tool'."
|
||||||
|
+ echo " It must be root, the PAM authentication plugin doesn't work otherwise.."
|
||||||
|
+ echo
|
||||||
|
+ fi
|
||||||
|
fi
|
||||||
|
fi
|
||||||
|
args="$args --user=$user"
|
158
mariadb.spec
158
mariadb.spec
@ -11,7 +11,7 @@
|
|||||||
# The last version on which the full testsuite has been run
|
# The last version on which the full testsuite has been run
|
||||||
# In case of further rebuilds of that version, don't require full testsuite to be run
|
# In case of further rebuilds of that version, don't require full testsuite to be run
|
||||||
# run only "main" suite
|
# run only "main" suite
|
||||||
%global last_tested_version 10.4.5
|
%global last_tested_version 10.4.6
|
||||||
# Set to 1 to force run the testsuite even if it was already tested in current version
|
# Set to 1 to force run the testsuite even if it was already tested in current version
|
||||||
%global force_run_testsuite 0
|
%global force_run_testsuite 0
|
||||||
|
|
||||||
@ -157,8 +157,8 @@
|
|||||||
%global sameevr %{epoch}:%{version}-%{release}
|
%global sameevr %{epoch}:%{version}-%{release}
|
||||||
|
|
||||||
Name: mariadb
|
Name: mariadb
|
||||||
Version: 10.4.5
|
Version: 10.4.6
|
||||||
Release: 1.rc%{?with_debug:.debug}%{?dist}
|
Release: 1%{?with_debug:.debug}%{?dist}
|
||||||
Epoch: 3
|
Epoch: 3
|
||||||
|
|
||||||
Summary: A very fast and robust SQL database server
|
Summary: A very fast and robust SQL database server
|
||||||
@ -202,6 +202,8 @@ Patch7: %{pkgnamepatch}-scripts.patch
|
|||||||
Patch9: %{pkgnamepatch}-ownsetup.patch
|
Patch9: %{pkgnamepatch}-ownsetup.patch
|
||||||
# Patch10: Fix cipher name in the SSL Cipher name test
|
# Patch10: Fix cipher name in the SSL Cipher name test
|
||||||
Patch10: %{pkgnamepatch}-ssl-cipher-tests.patch
|
Patch10: %{pkgnamepatch}-ssl-cipher-tests.patch
|
||||||
|
# Patch11: Workaround for "chown 0" with priviledges dropped to "mysql" user
|
||||||
|
Patch11: %{pkgnamepatch}-auth_pam_tool_dir.patch
|
||||||
|
|
||||||
BuildRequires: cmake gcc-c++
|
BuildRequires: cmake gcc-c++
|
||||||
BuildRequires: multilib-rpm-config
|
BuildRequires: multilib-rpm-config
|
||||||
@ -709,6 +711,7 @@ find . -name "*.jar" -type f -exec rm --verbose -f {} \;
|
|||||||
%patch7 -p1
|
%patch7 -p1
|
||||||
%patch9 -p1
|
%patch9 -p1
|
||||||
#%patch10 -p1
|
#%patch10 -p1
|
||||||
|
%patch11 -p1
|
||||||
|
|
||||||
# workaround for upstream bug #56342
|
# workaround for upstream bug #56342
|
||||||
#rm mysql-test/t/ssl_8k_key-master.opt
|
#rm mysql-test/t/ssl_8k_key-master.opt
|
||||||
@ -968,7 +971,8 @@ ln -s unstable-tests %{buildroot}%{_datadir}/mysql-test/rh-skipped-tests.list
|
|||||||
# Client that uses libmysqld embedded server.
|
# Client that uses libmysqld embedded server.
|
||||||
# Pretty much like normal mysql command line client, but it doesn't require a running mariadb server.
|
# Pretty much like normal mysql command line client, but it doesn't require a running mariadb server.
|
||||||
%{?with_embedded:rm %{buildroot}%{_bindir}/mysql_embedded}
|
%{?with_embedded:rm %{buildroot}%{_bindir}/mysql_embedded}
|
||||||
rm %{buildroot}%{_mandir}/man1/mysql_embedded.1*
|
%{?with_embedded:rm %{buildroot}%{_bindir}/mariadb-embedded}
|
||||||
|
rm %{buildroot}%{_mandir}/man1/{mysql_,mariadb-}embedded.1*
|
||||||
# Static libraries
|
# Static libraries
|
||||||
rm %{buildroot}%{_libdir}/*.a
|
rm %{buildroot}%{_libdir}/*.a
|
||||||
# This script creates the MySQL system tables and starts the server.
|
# This script creates the MySQL system tables and starts the server.
|
||||||
@ -1029,6 +1033,7 @@ sed -i 's/^plugin-load-add/#plugin-load-add/' %{buildroot}%{_sysconfdir}/my.cnf.
|
|||||||
|
|
||||||
%if %{without embedded}
|
%if %{without embedded}
|
||||||
rm %{buildroot}%{_mandir}/man1/{mysql_client_test_embedded,mysqltest_embedded}.1*
|
rm %{buildroot}%{_mandir}/man1/{mysql_client_test_embedded,mysqltest_embedded}.1*
|
||||||
|
rm %{buildroot}%{_mandir}/man1/{mariadb-client-test-embedded,mariadb-test-embedded}.1*
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
|
||||||
@ -1073,12 +1078,16 @@ unlink %{buildroot}%{_libdir}/libmysqlclient_r.so
|
|||||||
%endif # devel
|
%endif # devel
|
||||||
|
|
||||||
%if %{without client}
|
%if %{without client}
|
||||||
rm %{buildroot}%{_bindir}/{msql2mysql,mysql,mysql_find_rows,\
|
rm %{buildroot}%{_bindir}/msql2mysql
|
||||||
mysql_plugin,mysql_waitpid,mysqlaccess,mysqladmin,mysqlbinlog,mysqlcheck,\
|
rm %{buildroot}%{_bindir}/{mysql,mariadb}
|
||||||
mysqldump,mysqlimport,mysqlshow,mysqlslap}
|
rm %{buildroot}%{_bindir}/mysql{access,admin,binlog,check,dump,_find_rows,import,_plugin,show,slap,_waitpid}
|
||||||
rm %{buildroot}%{_mandir}/man1/{msql2mysql,mysql,mysql_find_rows,\
|
rm %{buildroot}%{_bindir}/mariadb-{access,admin,binlog,check,dump,find-rows,import,plugin,show,slap,waitpid}
|
||||||
mysql_plugin,mysql_waitpid,mysqlaccess,mysqladmin,mysqlbinlog,mysqlcheck,\
|
|
||||||
mysqldump,mysqlimport,mysqlshow,mysqlslap}.1*
|
rm %{buildroot}%{_mandir}/man1/msql2mysql.1*
|
||||||
|
rm %{buildroot}%{_mandir}/man1/{mysql,mariadb}.1*
|
||||||
|
rm %{buildroot}%{_mandir}/man1/mysql{access,admin,binlog,check,dump,_find_rows,import,_plugin,show,slap,_waitpid}.1*
|
||||||
|
rm %{buildroot}%{_mandir}/man1/mariadb-{access,admin,binlog,check,dump,find-rows,import,plugin,show,slap,waitpid}.1*
|
||||||
|
|
||||||
rm %{buildroot}%{_sysconfdir}/my.cnf.d/mysql-clients.cnf
|
rm %{buildroot}%{_sysconfdir}/my.cnf.d/mysql-clients.cnf
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
@ -1119,12 +1128,16 @@ rm -r %{buildroot}%{_datadir}/sql-bench
|
|||||||
|
|
||||||
%if %{without test}
|
%if %{without test}
|
||||||
%if %{with embedded}
|
%if %{with embedded}
|
||||||
rm %{buildroot}%{_bindir}/{mysqltest_embedded,mysql_client_test_embedded}
|
rm %{buildroot}%{_bindir}/{mysql_client_test_embedded,mysqltest_embedded}
|
||||||
rm %{buildroot}%{_mandir}/man1/{mysqltest_embedded,mysql_client_test_embedded}.1*
|
rm %{buildroot}%{_bindir}/{mariadb-client-test-embedded,mariadb-test-embedded}
|
||||||
|
rm %{buildroot}%{_mandir}/man1/{mysql_client_test_embedded,mysqltest_embedded}.1*
|
||||||
|
rm %{buildroot}%{_mandir}/man1/{mariadb-client-test-embedded,mariadb-test-embedded}.1*
|
||||||
%endif # embedded
|
%endif # embedded
|
||||||
rm %{buildroot}%{_bindir}/test-connect-t
|
rm %{buildroot}%{_bindir}/test-connect-t
|
||||||
rm %{buildroot}%{_bindir}/{mysql_client_test,mysqltest}
|
rm %{buildroot}%{_bindir}/{mysql_client_test,mysqltest}
|
||||||
rm %{buildroot}%{_mandir}/man1/{mysql_client_test,my_safe_process,mysqltest}.1*
|
rm %{buildroot}%{_bindir}/{mariadb-client-test,mariadb-test}
|
||||||
|
rm %{buildroot}%{_mandir}/man1/{mysql_client_test,mysqltest,my_safe_process}.1*
|
||||||
|
rm %{buildroot}%{_mandir}/man1/{mariadb-client-test,mariadb-test}.1*
|
||||||
rm %{buildroot}%{_mandir}/man1/{mysql-test-run,mysql-stress-test}.pl.1*
|
rm %{buildroot}%{_mandir}/man1/{mysql-test-run,mysql-stress-test}.pl.1*
|
||||||
%endif # test
|
%endif # test
|
||||||
|
|
||||||
@ -1137,7 +1150,7 @@ rm %{buildroot}%{_datadir}/%{pkg_name}/systemd/use_galera_new_cluster.conf
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%if %{without rocksdb}
|
%if %{without rocksdb}
|
||||||
rm %{buildroot}%{_mandir}/man1/mysql_ldb.1*
|
rm %{buildroot}%{_mandir}/man1/{mysql_,mariadb-}ldb.1*
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%check
|
%check
|
||||||
@ -1238,32 +1251,15 @@ fi
|
|||||||
%if %{with client}
|
%if %{with client}
|
||||||
%files
|
%files
|
||||||
%{_bindir}/msql2mysql
|
%{_bindir}/msql2mysql
|
||||||
%{_bindir}/mysql
|
%{_bindir}/{mysql,mariadb}
|
||||||
%{_bindir}/mysql_find_rows
|
%{_bindir}/mysql{access,admin,binlog,check,dump,_find_rows,import,_plugin,show,slap,_waitpid}
|
||||||
%{_bindir}/mysql_plugin
|
%{_bindir}/mariadb-{access,admin,binlog,check,dump,find-rows,import,plugin,show,slap,waitpid}
|
||||||
%{_bindir}/mysql_waitpid
|
|
||||||
%{_bindir}/mysqlaccess
|
|
||||||
%{_bindir}/mysqladmin
|
|
||||||
%{_bindir}/mysqlbinlog
|
|
||||||
%{_bindir}/mysqlcheck
|
|
||||||
%{_bindir}/mysqldump
|
|
||||||
%{_bindir}/mysqlimport
|
|
||||||
%{_bindir}/mysqlshow
|
|
||||||
%{_bindir}/mysqlslap
|
|
||||||
|
|
||||||
%{_mandir}/man1/msql2mysql.1*
|
%{_mandir}/man1/msql2mysql.1*
|
||||||
%{_mandir}/man1/mysql.1*
|
%{_mandir}/man1/{mysql,mariadb}.1*
|
||||||
%{_mandir}/man1/mysql_find_rows.1*
|
%{_mandir}/man1/mysql{access,admin,binlog,check,dump,_find_rows,import,_plugin,show,slap,_waitpid}.1*
|
||||||
%{_mandir}/man1/mysql_plugin.1*
|
%{_mandir}/man1/mariadb-{access,admin,binlog,check,dump,find-rows,import,plugin,show,slap,waitpid}.1*
|
||||||
%{_mandir}/man1/mysql_waitpid.1*
|
|
||||||
%{_mandir}/man1/mysqlaccess.1*
|
|
||||||
%{_mandir}/man1/mysqladmin.1*
|
|
||||||
%{_mandir}/man1/mysqlbinlog.1*
|
|
||||||
%{_mandir}/man1/mysqlcheck.1*
|
|
||||||
%{_mandir}/man1/mysqldump.1*
|
|
||||||
%{_mandir}/man1/mysqlimport.1*
|
|
||||||
%{_mandir}/man1/mysqlshow.1*
|
|
||||||
%{_mandir}/man1/mysqlslap.1*
|
|
||||||
%config(noreplace) %{_sysconfdir}/my.cnf.d/mysql-clients.cnf
|
%config(noreplace) %{_sysconfdir}/my.cnf.d/mysql-clients.cnf
|
||||||
|
|
||||||
%endif
|
%endif
|
||||||
@ -1344,21 +1340,18 @@ fi
|
|||||||
%files server
|
%files server
|
||||||
%doc README.mysql-cnf
|
%doc README.mysql-cnf
|
||||||
|
|
||||||
%{_bindir}/aria_chk
|
%{_bindir}/aria_{chk,dump_log,ftdump,pack,read_log}
|
||||||
%{_bindir}/aria_dump_log
|
|
||||||
%{_bindir}/aria_ftdump
|
|
||||||
%{_bindir}/aria_pack
|
|
||||||
%{_bindir}/aria_read_log
|
|
||||||
%{_bindir}/mariadb-service-convert
|
%{_bindir}/mariadb-service-convert
|
||||||
%{_bindir}/myisamchk
|
%{_bindir}/myisamchk
|
||||||
%{_bindir}/myisam_ftdump
|
%{_bindir}/myisam_ftdump
|
||||||
%{_bindir}/myisamlog
|
%{_bindir}/myisamlog
|
||||||
%{_bindir}/myisampack
|
%{_bindir}/myisampack
|
||||||
%{_bindir}/my_print_defaults
|
%{_bindir}/my_print_defaults
|
||||||
%{_bindir}/mysql_install_db
|
|
||||||
%{_bindir}/mysql_secure_installation
|
%{_bindir}/mysql_{install_db,secure_installation,tzinfo_to_sql}
|
||||||
%{_bindir}/mysql_tzinfo_to_sql
|
%{_bindir}/mariadb-{install-db,secure-installation,tzinfo-to-sql}
|
||||||
%{_bindir}/mysqld_safe
|
%{_bindir}/{mysqld_,mariadbd-}safe
|
||||||
|
|
||||||
%{_bindir}/innochecksum
|
%{_bindir}/innochecksum
|
||||||
%{_bindir}/replace
|
%{_bindir}/replace
|
||||||
%{_bindir}/resolve_stack_dump
|
%{_bindir}/resolve_stack_dump
|
||||||
@ -1369,7 +1362,7 @@ fi
|
|||||||
%config(noreplace) %{_sysconfdir}/my.cnf.d/%{pkg_name}-server.cnf
|
%config(noreplace) %{_sysconfdir}/my.cnf.d/%{pkg_name}-server.cnf
|
||||||
%config(noreplace) %{_sysconfdir}/my.cnf.d/enable_encryption.preset
|
%config(noreplace) %{_sysconfdir}/my.cnf.d/enable_encryption.preset
|
||||||
|
|
||||||
%{_libexecdir}/mysqld
|
%{_libexecdir}/{mysqld,mariadbd}
|
||||||
|
|
||||||
%{_libdir}/%{pkg_name}/INFO_SRC
|
%{_libdir}/%{pkg_name}/INFO_SRC
|
||||||
%{_libdir}/%{pkg_name}/INFO_BIN
|
%{_libdir}/%{pkg_name}/INFO_BIN
|
||||||
@ -1379,6 +1372,8 @@ fi
|
|||||||
|
|
||||||
%dir %{_libdir}/%{pkg_name}
|
%dir %{_libdir}/%{pkg_name}
|
||||||
%dir %{_libdir}/%{pkg_name}/plugin
|
%dir %{_libdir}/%{pkg_name}/plugin
|
||||||
|
# Change from root:root to mysql:mysql, so it can be accessed by the server
|
||||||
|
%attr(0755,mysql,mysql) %dir %{_libdir}/%{pkg_name}/plugin/auth_pam_tool_dir
|
||||||
%{_libdir}/%{pkg_name}/plugin/*
|
%{_libdir}/%{pkg_name}/plugin/*
|
||||||
%{?with_oqgraph:%exclude %{_libdir}/%{pkg_name}/plugin/ha_oqgraph.so}
|
%{?with_oqgraph:%exclude %{_libdir}/%{pkg_name}/plugin/ha_oqgraph.so}
|
||||||
%{?with_connect:%exclude %{_libdir}/%{pkg_name}/plugin/ha_connect.so}
|
%{?with_connect:%exclude %{_libdir}/%{pkg_name}/plugin/ha_connect.so}
|
||||||
@ -1393,11 +1388,7 @@ fi
|
|||||||
%exclude %{_libdir}/%{pkg_name}/plugin/mysql_clear_password.so
|
%exclude %{_libdir}/%{pkg_name}/plugin/mysql_clear_password.so
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%{_mandir}/man1/aria_chk.1*
|
%{_mandir}/man1/aria_{chk,dump_log,ftdump,pack,read_log}.1*
|
||||||
%{_mandir}/man1/aria_dump_log.1*
|
|
||||||
%{_mandir}/man1/aria_ftdump.1*
|
|
||||||
%{_mandir}/man1/aria_pack.1*
|
|
||||||
%{_mandir}/man1/aria_read_log.1*
|
|
||||||
%{_mandir}/man1/galera_new_cluster.1*
|
%{_mandir}/man1/galera_new_cluster.1*
|
||||||
%{_mandir}/man1/galera_recovery.1*
|
%{_mandir}/man1/galera_recovery.1*
|
||||||
%{_mandir}/man1/mariadb-service-convert.1*
|
%{_mandir}/man1/mariadb-service-convert.1*
|
||||||
@ -1407,15 +1398,14 @@ fi
|
|||||||
%{_mandir}/man1/myisam_ftdump.1*
|
%{_mandir}/man1/myisam_ftdump.1*
|
||||||
%{_mandir}/man1/my_print_defaults.1*
|
%{_mandir}/man1/my_print_defaults.1*
|
||||||
%{_mandir}/man1/mysql.server.1*
|
%{_mandir}/man1/mysql.server.1*
|
||||||
%{_mandir}/man1/mysql_install_db.1*
|
%{_mandir}/man1/mysql_{install_db,secure_installation,tzinfo_to_sql}.1*
|
||||||
%{_mandir}/man1/mysql_secure_installation.1*
|
%{_mandir}/man1/mariadb-{install-db,secure-installation,tzinfo-to-sql}.1*
|
||||||
%{_mandir}/man1/mysql_tzinfo_to_sql.1*
|
%{_mandir}/man1/{mysqld_,mariadbd-}safe.1*
|
||||||
%{_mandir}/man1/mysqld_safe.1*
|
|
||||||
%{_mandir}/man1/innochecksum.1*
|
%{_mandir}/man1/innochecksum.1*
|
||||||
%{_mandir}/man1/replace.1*
|
%{_mandir}/man1/replace.1*
|
||||||
%{_mandir}/man1/resolveip.1*
|
%{_mandir}/man1/resolveip.1*
|
||||||
%{_mandir}/man1/resolve_stack_dump.1*
|
%{_mandir}/man1/resolve_stack_dump.1*
|
||||||
%{_mandir}/man8/mysqld.8*
|
%{_mandir}/man8/{mysqld,mariadbd}.8*
|
||||||
%{_mandir}/man1/wsrep_*.1*
|
%{_mandir}/man1/wsrep_*.1*
|
||||||
|
|
||||||
%{_datadir}/%{pkg_name}/fill_help_tables.sql
|
%{_datadir}/%{pkg_name}/fill_help_tables.sql
|
||||||
@ -1480,9 +1470,9 @@ fi
|
|||||||
|
|
||||||
%if %{with backup}
|
%if %{with backup}
|
||||||
%files backup
|
%files backup
|
||||||
%{_bindir}/mariabackup
|
%{_bindir}/maria{,db-}backup
|
||||||
%{_bindir}/mbstream
|
%{_bindir}/mbstream
|
||||||
%{_mandir}/man1/mariabackup.1*
|
%{_mandir}/man1/maria{,db-}backup.1*
|
||||||
%{_mandir}/man1/mbstream.1*
|
%{_mandir}/man1/mbstream.1*
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
@ -1490,10 +1480,10 @@ fi
|
|||||||
%files rocksdb-engine
|
%files rocksdb-engine
|
||||||
%config(noreplace) %{_sysconfdir}/my.cnf.d/rocksdb.cnf
|
%config(noreplace) %{_sysconfdir}/my.cnf.d/rocksdb.cnf
|
||||||
%{_bindir}/myrocks_hotbackup
|
%{_bindir}/myrocks_hotbackup
|
||||||
%{_bindir}/mysql_ldb
|
%{_bindir}/{mysql_,mariadb-}ldb
|
||||||
%{_bindir}/sst_dump
|
%{_bindir}/sst_dump
|
||||||
%{_libdir}/%{pkg_name}/plugin/ha_rocksdb.so
|
%{_libdir}/%{pkg_name}/plugin/ha_rocksdb.so
|
||||||
%{_mandir}/man1/mysql_ldb.1*
|
%{_mandir}/man1/{mysql_,mariadb-}ldb.1*
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%if %{with tokudb}
|
%if %{with tokudb}
|
||||||
@ -1538,26 +1528,21 @@ fi
|
|||||||
|
|
||||||
%files server-utils
|
%files server-utils
|
||||||
# Perl utilities
|
# Perl utilities
|
||||||
%{_bindir}/mysql_convert_table_format
|
%{_bindir}/mysql{_convert_table_format,dumpslow,_fix_extensions,hotcopy,_setpermission}
|
||||||
%{_bindir}/mysql_fix_extensions
|
%{_bindir}/mariadb-{convert-table-format,dumpslow,fix-extensions,hotcopy,setpermission}
|
||||||
%{_bindir}/mysql_setpermission
|
%{_bindir}/{mysqld_,mariadbd-}multi
|
||||||
%{_bindir}/mysqldumpslow
|
|
||||||
%{_bindir}/mysqld_multi
|
%{_mandir}/man1/mysql{_convert_table_format,dumpslow,_fix_extensions,hotcopy,_setpermission}.1*
|
||||||
%{_bindir}/mysqlhotcopy
|
%{_mandir}/man1/mariadb-{convert-table-format,dumpslow,fix-extensions,hotcopy,setpermission}.1*
|
||||||
%{_mandir}/man1/mysql_convert_table_format.1*
|
%{_mandir}/man1/{mysqld_,mariadbd-}multi.1*
|
||||||
%{_mandir}/man1/mysql_fix_extensions.1*
|
|
||||||
%{_mandir}/man1/mysqldumpslow.1*
|
|
||||||
%{_mandir}/man1/mysqld_multi.1*
|
|
||||||
%{_mandir}/man1/mysqlhotcopy.1*
|
|
||||||
%{_mandir}/man1/mysql_setpermission.1*
|
|
||||||
# Utilities that can be used remotely
|
# Utilities that can be used remotely
|
||||||
%{_bindir}/mysql_upgrade
|
%{_bindir}/{mysql_,mariadb-}upgrade
|
||||||
%{_bindir}/perror
|
%{_bindir}/perror
|
||||||
%{_mandir}/man1/mysql_upgrade.1*
|
%{_mandir}/man1/{mysql_,mariadb-}upgrade.1*
|
||||||
%{_mandir}/man1/perror.1*
|
%{_mandir}/man1/perror.1*
|
||||||
# Other utilities
|
# Other utilities
|
||||||
%{_bindir}/mysqld_safe_helper
|
%{_bindir}/{mysqld_safe_helper,mariadbd-safe-helper}
|
||||||
%{_mandir}/man1/mysqld_safe_helper.1*
|
%{_mandir}/man1/{mysqld_safe_helper,mariadbd-safe-helper}.1*
|
||||||
|
|
||||||
%if %{with devel}
|
%if %{with devel}
|
||||||
%files devel
|
%files devel
|
||||||
@ -1595,23 +1580,24 @@ fi
|
|||||||
%files test
|
%files test
|
||||||
%if %{with embedded}
|
%if %{with embedded}
|
||||||
%{_bindir}/test-connect-t
|
%{_bindir}/test-connect-t
|
||||||
%{_bindir}/mysql_client_test_embedded
|
%{_bindir}/{mysql_client_test_embedded,mysqltest_embedded}
|
||||||
%{_bindir}/mysqltest_embedded
|
%{_bindir}/{mariadb-client-test-embedded,mariadb-test-embedded}
|
||||||
%{_mandir}/man1/mysql_client_test_embedded.1*
|
%{_mandir}/man1/{mysql_client_test_embedded,mysqltest_embedded}.1*
|
||||||
%{_mandir}/man1/mysqltest_embedded.1*
|
%{_mandir}/man1/{mariadb-client-test-embedded,mariadb-test-embedded}.1*
|
||||||
%endif
|
%endif
|
||||||
%{_bindir}/mysql_client_test
|
%{_bindir}/{mysql_client_test,mysqltest,mariadb-client-test,mariadb-test}
|
||||||
%{_bindir}/my_safe_process
|
%{_bindir}/my_safe_process
|
||||||
%{_bindir}/mysqltest
|
|
||||||
%attr(-,mysql,mysql) %{_datadir}/mysql-test
|
%attr(-,mysql,mysql) %{_datadir}/mysql-test
|
||||||
%{_mandir}/man1/mysql_client_test.1*
|
%{_mandir}/man1/{mysql_client_test,mysqltest,mariadb-client-test,mariadb-test}.1*
|
||||||
%{_mandir}/man1/my_safe_process.1*
|
%{_mandir}/man1/my_safe_process.1*
|
||||||
%{_mandir}/man1/mysqltest.1*
|
|
||||||
%{_mandir}/man1/mysql-stress-test.pl.1*
|
%{_mandir}/man1/mysql-stress-test.pl.1*
|
||||||
%{_mandir}/man1/mysql-test-run.pl.1*
|
%{_mandir}/man1/mysql-test-run.pl.1*
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jun 20 2019 Michal Schorm <mschorm@redhat.com> - 3:10.4.6-1
|
||||||
|
- Rebase to 10.4.6
|
||||||
|
|
||||||
* Fri Jun 07 2019 Michal Schorm <mschorm@redhat.com> - 3:10.4.5-1
|
* Fri Jun 07 2019 Michal Schorm <mschorm@redhat.com> - 3:10.4.5-1
|
||||||
- Rebase to 10.4.5
|
- Rebase to 10.4.5
|
||||||
- This is a RC release! use with caution
|
- This is a RC release! use with caution
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (mariadb-10.4.5.tar.gz) = 080df03aff04375f6f424d94f988156cb09cb891e14d67dcea453c3f831737898ac1913b48735628034c6a7f215a06ad22b4d350a8762351ac572a60d492a07b
|
SHA512 (mariadb-10.4.6.tar.gz) = b04c47f72de2473d7b5edd04b4785a1d7179bb1f429f30ba53ae6cfbbb413200d9803eff1072949b2e81fd7d2164ea34c68620d621d4181b913daa2293ae140c
|
||||||
|
Loading…
Reference in New Issue
Block a user