Merge branch 'master' into f24
This commit is contained in:
commit
d398e86344
@ -1,20 +0,0 @@
|
||||
--- mariadb-10.1.15/mysql-test/t/openssl_1.test.orig 2016-06-29 22:56:09.000000000 +0200
|
||||
+++ mariadb-10.1.15/mysql-test/t/openssl_1.test 2016-07-04 10:47:13.366522457 +0200
|
||||
@@ -134,7 +134,7 @@ drop table t1;
|
||||
# verification of servers certificate by setting both ca certificate
|
||||
# and ca path to NULL
|
||||
#
|
||||
---replace_result DHE-RSA-AES256-GCM-SHA384 DHE-RSA-AES256-SHA DHE-RSA-CHACHA20-POLY1305 DHE-RSA-AES256-SHA
|
||||
+--replace_result DHE-RSA-AES256-GCM-SHA384 DHE-RSA-AES256-SHA DHE-RSA-CHACHA20-POLY1305 DHE-RSA-AES256-SHA AES256-GCM-SHA384 DHE-RSA-AES256-SHA
|
||||
--exec $MYSQL --ssl --ssl-key=$MYSQL_TEST_DIR/std_data/client-key.pem --ssl-cert=$MYSQL_TEST_DIR/std_data/client-cert.pem -e "SHOW STATUS LIKE 'ssl_Cipher'" 2>&1
|
||||
--echo End of 5.0 tests
|
||||
|
||||
@@ -259,7 +259,7 @@ select 'is still running; no cipher requ
|
||||
GRANT SELECT ON test.* TO bug42158@localhost REQUIRE X509;
|
||||
FLUSH PRIVILEGES;
|
||||
connect(con1,localhost,bug42158,,,,,SSL);
|
||||
---replace_result DHE-RSA-AES256-GCM-SHA384 DHE-RSA-AES256-SHA DHE-RSA-CHACHA20-POLY1305 DHE-RSA-AES256-SHA
|
||||
+--replace_result DHE-RSA-AES256-GCM-SHA384 DHE-RSA-AES256-SHA DHE-RSA-CHACHA20-POLY1305 DHE-RSA-AES256-SHA AES256-GCM-SHA384 DHE-RSA-AES256-SHA
|
||||
SHOW STATUS LIKE 'Ssl_cipher';
|
||||
disconnect con1;
|
||||
connection default;
|
37
mariadb.spec
37
mariadb.spec
@ -119,12 +119,12 @@
|
||||
# Make long macros shorter
|
||||
%global sameevr %{epoch}:%{version}-%{release}
|
||||
%global compatver 10.1
|
||||
%global bugfixver 15
|
||||
%global bugfixver 14
|
||||
|
||||
Name: mariadb
|
||||
Version: %{compatver}.%{bugfixver}
|
||||
Release: 3%{?with_debug:.debug}%{?dist}
|
||||
Epoch: 2
|
||||
Release: 4%{?with_debug:.debug}%{?dist}
|
||||
Epoch: 3
|
||||
|
||||
Summary: A community developed branch of MySQL
|
||||
Group: Applications/Databases
|
||||
@ -162,7 +162,6 @@ Source72: mariadb-server-galera.te
|
||||
# Patches common for more mysql-like packages
|
||||
Patch1: %{pkgnamepatch}-strmov.patch
|
||||
Patch2: %{pkgnamepatch}-install-test.patch
|
||||
Patch3: %{pkgnamepatch}-test-openssl_1.patch
|
||||
Patch4: %{pkgnamepatch}-logrotate.patch
|
||||
Patch5: %{pkgnamepatch}-file-contents.patch
|
||||
Patch7: %{pkgnamepatch}-scripts.patch
|
||||
@ -187,7 +186,9 @@ BuildRequires: libedit-devel
|
||||
BuildRequires: openssl-devel
|
||||
BuildRequires: ncurses-devel
|
||||
BuildRequires: perl
|
||||
%if 0%{?fedora} >= 22 || 0%{?rhel} > 7
|
||||
BuildRequires: perl-generators
|
||||
%endif
|
||||
BuildRequires: systemtap-sdt-devel
|
||||
BuildRequires: zlib-devel
|
||||
BuildRequires: multilib-rpm-config
|
||||
@ -549,7 +550,6 @@ MariaDB is a community developed branch of MySQL.
|
||||
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
%patch5 -p1
|
||||
%patch7 -p1
|
||||
@ -1098,9 +1098,8 @@ fi
|
||||
%files server-galera
|
||||
%doc Docs/README.wsrep
|
||||
%license LICENSE.clustercheck
|
||||
%{_bindir}/clustercheck
|
||||
%{_bindir}/galera_new_cluster
|
||||
%{_bindir}/galera_recovery
|
||||
%{_bindir}/clustercheck
|
||||
%{_datadir}/%{pkg_name}/systemd/use_galera_new_cluster.conf
|
||||
%config(noreplace) %{_sysconfdir}/my.cnf.d/galera.cnf
|
||||
%attr(0640,root,root) %ghost %config(noreplace) %{_sysconfdir}/sysconfig/clustercheck
|
||||
@ -1217,7 +1216,10 @@ fi
|
||||
%{_datadir}/%{pkg_name}/policy/selinux/README
|
||||
%{_datadir}/%{pkg_name}/policy/selinux/mariadb-server.*
|
||||
%{_datadir}/%{pkg_name}/systemd/mariadb.service
|
||||
# mariadb@ is installed only when we have cmake newer than 3.3
|
||||
%if 0%{?fedora} > 22 || 0%{?rhel} > 7
|
||||
%{_datadir}/%{pkg_name}/systemd/mariadb@.service
|
||||
%endif
|
||||
|
||||
%{daemondir}/%{daemon_name}*
|
||||
%{_libexecdir}/mysql-prepare-db-dir
|
||||
@ -1285,11 +1287,30 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Thu Jul 14 2016 Honza Horak <hhorak@redhat.com> - 3:10.1.14-4
|
||||
- Revert Update to 10.1.15, this release is broken
|
||||
https://lists.launchpad.net/maria-discuss/msg03691.html
|
||||
|
||||
* Thu Jul 14 2016 Honza Horak <hhorak@redhat.com> - 2:10.1.15-3
|
||||
- Check datadir more carefully to avoid unwanted data corruption
|
||||
Related: #1335849
|
||||
|
||||
* Thu May 26 2016 Jakub Dorňák <jdornak@redhat.com> - 1:10.1.14-2
|
||||
* Thu Jul 7 2016 Jakub Dorňák <jdornak@redhat.com> - 2:10.1.15-2
|
||||
- Bump epoch
|
||||
(related to the downgrade from the pre-release version)
|
||||
|
||||
* Fri Jul 1 2016 Jakub Dorňák <jdornak@redhat.com> - 1:10.1.15-1
|
||||
- Update to 10.1.15
|
||||
|
||||
* Fri Jul 1 2016 Jakub Dorňák <jdornak@redhat.com> - 1:10.1.14-3
|
||||
Revert "Update to 10.2.0"
|
||||
It is possible that MariaDB 10.2.0 won't be stable till f25 GA.
|
||||
|
||||
* Tue Jun 21 2016 Pavel Raiskup <praiskup@redhat.com> - 1:10.1.14-3
|
||||
- BR multilib-rpm-config and use it for multilib workarounds
|
||||
- install architecture dependant pc file to arch-dependant location
|
||||
|
||||
* Thu May 26 2016 Jakub Dorňák <jdornak@redhat.com> - 1:10.2.0-2
|
||||
- Fix mysql-prepare-db-dir
|
||||
Resolves: #1335849
|
||||
|
||||
|
@ -1,8 +1,12 @@
|
||||
main.analyze_format_json : rhbz#1096787
|
||||
main.analyze_stmt_orderby : rhbz#1096787
|
||||
main.explain_json : rhbz#1096787
|
||||
main.explain_json_format_partitions : rhbz#1096787
|
||||
main.explain_json_innodb : rhbz#1096787
|
||||
|
||||
connect.bin : rhbz#1096787 (pass on aarch64)
|
||||
connect.endian : rhbz#1096787
|
||||
|
||||
main.partition_exchange : rhbz#1096787
|
||||
main.analyze_stmt_orderby : rhbz#1096787
|
||||
main.explain_json_innodb : rhbz#1096787
|
||||
main.explain_json_format_partitions : rhbz#1096787
|
||||
main.analyze_format_json : rhbz#1096787
|
||||
main.explain_json : rhbz#1096787
|
||||
main.subselect_cache : rhbz#1096787
|
||||
main.type_year : rhbz#1096787
|
||||
|
@ -1,15 +1,14 @@
|
||||
# These tests fail with MariaDB 10:
|
||||
main.multi_update : rhbz#1096787
|
||||
main.set_statement_notembedded_binlog : rhbz#1096787
|
||||
main.ssl : rhbz#1096787
|
||||
main.ssl_ca : rhbz#1096787
|
||||
main.ssl_cert_verify : rhbz#1096787
|
||||
main.ssl_compress : rhbz#1096787
|
||||
main.ssl_crl_clients : rhbz#1096787
|
||||
main.ssl_timeout : rhbz#1096787
|
||||
main.ssl_7937 : rhbz#1096787
|
||||
main.ssl_8k_key : rhbz#1096787
|
||||
|
||||
main.userstat : rhbz#1096787
|
||||
main.set_statement_notembedded_binlog : rhbz#1096787
|
||||
main.ssl_7937 : rhbz#1096787
|
||||
main.ssl_crl_clients : rhbz#1096787
|
||||
main.openssl_1 : rhbz#1096787
|
||||
main.ssl : rhbz#1096787
|
||||
main.ssl_8k_key : rhbz#1096787
|
||||
main.ssl_compress : rhbz#1096787
|
||||
main.ssl_timeout : rhbz#1096787
|
||||
perfschema.nesting : rhbz#1096787
|
||||
perfschema.socket_summary_by_event_name_func : rhbz#1096787
|
||||
perfschema.socket_summary_by_instance_func : rhbz#1096787
|
||||
|
Loading…
Reference in New Issue
Block a user