Rebase to version 10.5.20
Patches 11 and 13 were upstreamed:75bbf645a6
f575de39af
Resolves: CVE-2022-47015
This commit is contained in:
parent
cb41bf05f1
commit
b6ec88a877
@ -1,12 +0,0 @@
|
|||||||
diff --git a/tpool/aio_linux.cc b/tpool/aio_linux.cc
|
|
||||||
index 8a6688e6775..5eff358723d 100644
|
|
||||||
--- a/tpool/aio_linux.cc
|
|
||||||
+++ b/tpool/aio_linux.cc
|
|
||||||
@@ -17,6 +17,7 @@ Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02111 - 1301 USA*/
|
|
||||||
#include "tpool.h"
|
|
||||||
|
|
||||||
#ifdef LINUX_NATIVE_AIO
|
|
||||||
+# include <cstdio>
|
|
||||||
# include <thread>
|
|
||||||
# include <atomic>
|
|
||||||
# include <libaio.h>
|
|
@ -1,21 +0,0 @@
|
|||||||
rocksdb: Define _GNU_SOURCE during fallocate CMake probe
|
|
||||||
|
|
||||||
The glibc headers declare fallocate only if _GNU_SOURCE is defined.
|
|
||||||
Upstream rocksdb does not need this because the probe is run with the
|
|
||||||
C++ compiler, and current g++ versions define _GNU_SOURCE
|
|
||||||
automatically.
|
|
||||||
|
|
||||||
Submitted upstream: <https://github.com/MariaDB/server/pull/2593>
|
|
||||||
|
|
||||||
|
|
||||||
diff -ur mariadb-10.5.18-downstream_modified.orig/storage/rocksdb/build_rocksdb.cmake mariadb-10.5.18-downstream_modified/storage/rocksdb/build_rocksdb.cmake
|
|
||||||
--- mariadb-10.5.18-downstream_modified.orig/storage/rocksdb/build_rocksdb.cmake 2022-11-02 13:37:22.000000000 +0100
|
|
||||||
+++ mariadb-10.5.18-downstream_modified/storage/rocksdb/build_rocksdb.cmake 2023-04-11 09:42:17.295837813 +0200
|
|
||||||
@@ -138,6 +138,7 @@
|
|
||||||
if(WITH_FALLOCATE AND UNIX)
|
|
||||||
include(CheckCSourceCompiles)
|
|
||||||
CHECK_C_SOURCE_COMPILES("
|
|
||||||
+#define _GNU_SOURCE
|
|
||||||
#include <fcntl.h>
|
|
||||||
#include <linux/falloc.h>
|
|
||||||
int main() {
|
|
13
mariadb.spec
13
mariadb.spec
@ -149,8 +149,8 @@
|
|||||||
%global sameevr %{epoch}:%{version}-%{release}
|
%global sameevr %{epoch}:%{version}-%{release}
|
||||||
|
|
||||||
Name: mariadb
|
Name: mariadb
|
||||||
Version: 10.5.19
|
Version: 10.5.20
|
||||||
Release: 2%{?with_debug:.debug}%{?dist}
|
Release: 1%{?with_debug:.debug}%{?dist}
|
||||||
Epoch: 3
|
Epoch: 3
|
||||||
|
|
||||||
Summary: A very fast and robust SQL database server
|
Summary: A very fast and robust SQL database server
|
||||||
@ -209,10 +209,7 @@ Patch7: %{pkgnamepatch}-scripts.patch
|
|||||||
Patch9: %{pkgnamepatch}-ownsetup.patch
|
Patch9: %{pkgnamepatch}-ownsetup.patch
|
||||||
# Patch10: Fix cipher name in the SSL Cipher name test
|
# Patch10: Fix cipher name in the SSL Cipher name test
|
||||||
Patch10: %{pkgnamepatch}-ssl-cipher-tests.patch
|
Patch10: %{pkgnamepatch}-ssl-cipher-tests.patch
|
||||||
# https://gcc.gnu.org/gcc-13/porting_to.html
|
|
||||||
Patch11: mariadb-10.5-gcc13.patch
|
|
||||||
Patch12: rocksdb-6.8-gcc13.patch
|
Patch12: rocksdb-6.8-gcc13.patch
|
||||||
Patch13: mariadb-c99.patch
|
|
||||||
|
|
||||||
BuildRequires: make
|
BuildRequires: make
|
||||||
BuildRequires: cmake gcc-c++
|
BuildRequires: cmake gcc-c++
|
||||||
@ -744,10 +741,8 @@ rm -r storage/rocksdb/
|
|||||||
# Keeping the patch commented out, need to revisit
|
# Keeping the patch commented out, need to revisit
|
||||||
# once the test is re-enabled by upstream in some future release
|
# once the test is re-enabled by upstream in some future release
|
||||||
#%patch -P10 -p1
|
#%patch -P10 -p1
|
||||||
%patch -P11 -p1
|
|
||||||
%if %{with rocksdb}
|
%if %{with rocksdb}
|
||||||
%patch -P12 -p1 -d storage/rocksdb/rocksdb/
|
%patch -P12 -p1 -d storage/rocksdb/rocksdb/
|
||||||
%patch -P13 -p1
|
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
# generate a list of tests that fail, but are not disabled by upstream
|
# generate a list of tests that fail, but are not disabled by upstream
|
||||||
@ -1648,6 +1643,10 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue May 30 2023 Lukas Javorsky <ljavorsk@redhat.com> - 3:10.5.20-1
|
||||||
|
- Rebase to version 10.5.20
|
||||||
|
- Patches 11 and 13 were upstreamed
|
||||||
|
|
||||||
* Fri Apr 28 2023 Siddhesh Poyarekar <siddhesh@redhat.com> - 3:10.5.19-2
|
* Fri Apr 28 2023 Siddhesh Poyarekar <siddhesh@redhat.com> - 3:10.5.19-2
|
||||||
- Use _fortify_level to disable fortification in debug builds.
|
- Use _fortify_level to disable fortification in debug builds.
|
||||||
|
|
||||||
|
@ -69,3 +69,21 @@ oqgraph.regression_1213120 :
|
|||||||
main.information_schema :
|
main.information_schema :
|
||||||
main.loadxml :
|
main.loadxml :
|
||||||
main.lock_kill :
|
main.lock_kill :
|
||||||
|
|
||||||
|
# Fails since 10.5.20
|
||||||
|
innodb.innodb_bug51920 :
|
||||||
|
binlog_encryption.rpl_cant_read_event_incident :
|
||||||
|
spider/bg.spider_fixes :
|
||||||
|
spider/bugfix.mdev_29904 :
|
||||||
|
sys_vars.completion_type_func :
|
||||||
|
rpl.rpl_report_port :
|
||||||
|
rpl.rpl_reset_slave_fail :
|
||||||
|
rpl.rpl_xa_survive_disconnect_lsu_off :
|
||||||
|
rpl.rpl_heartbeat_basic :
|
||||||
|
rpl.rpl_xa_survive_disconnect :
|
||||||
|
rpl.rpl_err_ignoredtable :
|
||||||
|
rpl.rpl_row_img_sequence_full :
|
||||||
|
rpl.rpl_row_img_sequence_min :
|
||||||
|
rpl.rpl_row_img_sequence_noblob :
|
||||||
|
rpl.rpl_xa_empty_transaction :
|
||||||
|
rpl.rpl_slave_shutdown_mdev20821 :
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (mariadb-10.5.19-downstream_modified.tar.gz) = 29ca4910099d51a0f5c17fad986dfae56739b3016410fa7c3052c155ad18ac9c52df97efc94beb5d896cbfd72b719e74cc1ecf4209fc42f28aa9d1bf5b29b09f
|
SHA512 (mariadb-10.5.20-downstream_modified.tar.gz) = 5438d656e8998e4f3a3cc61af9348ad93c467d3936ac8a9f4640a9b2b70345f025e4bfdd431ccfd0ad519a7ac756dc5a338885f9d68c6c2fe14b31a1de3241ca
|
||||||
|
Loading…
Reference in New Issue
Block a user