Rebase to 10.5.15
Logrotate patch rebased onto upstream commit:008c02c987
Groonga patch upstreamed:045f5f7b10
OpenSSL 3 patch rebased onto upstream commit:be1d965384
OpenSSL 3 CMake condition reverted - it should be only applied to series without OpenSSL 3 patch:c9beef4315
Full testsuite success on a Fedora Rawhide scratch build, setting "last_tested_version" to 10.5.15 so only the "main" test suite will be run on subsequent builds of the same MariaDB release -- Related: #2092370 Issues Fixed in MariaDB 10.5.14 Reolves: #2083371 #2068219 Issues Fixed in MariaDB 10.5.15 Resolves: #2055607
This commit is contained in:
parent
321dc0e0d4
commit
923d57f454
@ -1,30 +0,0 @@
|
||||
# Fixing conflict with groonga package
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1763287
|
||||
|
||||
--- mariadb-10.3.18/storage/mroonga/vendor/groonga/CMakeLists.txt.withoutoption 2019-11-11 14:01:07.762595716 +0100
|
||||
+++ mariadb-10.3.18/storage/mroonga/vendor/groonga/CMakeLists.txt 2019-11-11 14:33:05.224012458 +0100
|
||||
@@ -86,7 +86,9 @@
|
||||
set(INCLUDE_DIR "include")
|
||||
set(GRN_INCLUDE_DIR "include/groonga")
|
||||
set(DATA_DIR "share")
|
||||
-set(GRN_DATA_DIR "${DATA_DIR}/${GRN_PROJECT_NAME}")
|
||||
+if(NOT DEFINED GRN_DATA_DIR)
|
||||
+ set(GRN_DATA_DIR "${DATA_DIR}/${GRN_PROJECT_NAME}")
|
||||
+endif()
|
||||
set(CONFIG_DIR "etc")
|
||||
set(GRN_CONFIG_DIR "${CONFIG_DIR}/${GRN_PROJECT_NAME}")
|
||||
set(GRN_CONFIG_PATH "${CMAKE_INSTALL_PREFIX}/${GRN_CONFIG_DIR}/groonga.conf")
|
||||
|
||||
--- mariadb-10.3.18/storage/mroonga/vendor/groonga/vendor/plugins/groonga-normalizer-mysql/CMakeLists.txt.withoutoption 2019-11-11 14:34:22.661005715 +0100
|
||||
+++ mariadb-10.3.18/storage/mroonga/vendor/groonga/vendor/plugins/groonga-normalizer-mysql/CMakeLists.txt 2019-11-11 14:35:59.962244120 +0100
|
||||
@@ -16,7 +16,9 @@
|
||||
# MA 02110-1335 USA
|
||||
|
||||
cmake_minimum_required(VERSION 2.6)
|
||||
-set(GROONGA_NORMALIZER_MYSQL_PROJECT_NAME "groonga-normalizer-mysql")
|
||||
+if (NOT DEFINED GROONGA_NORMALIZER_MYSQL_PROJECT_NAME)
|
||||
+ set(GROONGA_NORMALIZER_MYSQL_PROJECT_NAME "groonga-normalizer-mysql")
|
||||
+endif()
|
||||
project("${GROONGA_NORMALIZER_MYSQL_PROJECT_NAME}")
|
||||
|
||||
if(DEFINED GROONGA_NORMALIZER_MYSQL_EMBED)
|
@ -32,9 +32,9 @@ Update 02/2021
|
||||
* Discussion continues in:
|
||||
https://jira.mariadb.org/browse/MDEV-16621
|
||||
|
||||
--- mariadb-10.5.8/support-files/mysql-log-rotate.sh 2021-02-12 08:37:47.857289694 +0100
|
||||
+++ mariadb-10.5.8/support-files/mysql-log-rotate.sh_pacthed 2021-02-12 08:40:26.420372325 +0100
|
||||
@@ -3,35 +3,22 @@
|
||||
--- mariadb-10.5.13-downstream_modified/support-files/mysql-log-rotate.sh 2022-02-22 04:56:35.571185622 +0100
|
||||
+++ mariadb-10.5.13-downstream_modified/support-files/mysql-log-rotate.sh_patched 2022-02-22 04:56:15.121003580 +0100
|
||||
@@ -3,36 +3,23 @@
|
||||
# in the [mysqld] section as follows:
|
||||
#
|
||||
# [mysqld]
|
||||
@ -58,6 +58,7 @@ Update 02/2021
|
||||
- # create 600 mysql mysql
|
||||
+@LOG_LOCATION@ {
|
||||
+ create 600 mysql mysql
|
||||
su mysql mysql
|
||||
notifempty
|
||||
daily
|
||||
rotate 3
|
||||
|
@ -88,9 +88,9 @@ diff -up mariadb-10.5.12-downstream_modified/include/ssl_compat.h.patch16 mariad
|
||||
#define EVP_MD_CTX_init(X) do { memset((X), 0, EVP_MD_CTX_SIZE); EVP_MD_CTX_reset(X); } while(0)
|
||||
#undef EVP_CIPHER_CTX_init
|
||||
@@ -74,7 +74,6 @@
|
||||
#define DH_set0_pqg(D,P,Q,G) ((D)->p= (P), (D)->g= (G))
|
||||
#endif
|
||||
|
||||
#define DH_set0_pqg(D,P,Q,G) ((D)->p= (P), (D)->g= (G))
|
||||
-#define EVP_CIPHER_CTX_buf_noconst(ctx) ((ctx)->buf)
|
||||
#define EVP_CIPHER_CTX_encrypting(ctx) ((ctx)->encrypt)
|
||||
#define EVP_CIPHER_CTX_SIZE sizeof(EVP_CIPHER_CTX)
|
||||
@ -376,3 +376,26 @@ diff -up mariadb-10.5.12-downstream_modified/unittest/mysys/aes-t.c.patch16 mari
|
||||
DO_TEST_P(MY_AES_ECB, 200, '.', 208, "\xd8\x73\x8e\x3a\xbc\x66\x99\x13\x7f\x90\x23\x52\xee\x97\x6f\x9a");
|
||||
DO_TEST_P(MY_AES_ECB, 128, '?', 144, "\x19\x58\x33\x85\x4c\xaa\x7f\x06\xd1\xb2\xec\xd7\xb7\x6a\xa9\x5b");
|
||||
DO_TEST_P(MY_AES_CBC, 159, '%', 160, "\x4b\x03\x18\x3d\xf1\xa7\xcd\xa1\x46\xb3\xc6\x8a\x92\xc0\x0f\xc9");
|
||||
|
||||
|
||||
|
||||
MariaDB before 10.8 series does not contain the OpenSSL 3 patch on the upstream.
|
||||
MariaDB upstream later added the following condition:
|
||||
https://github.com/MariaDB/server/commit/c9beef4315
|
||||
limiting the OpenSSL that can be used to < 3. and reverted this commit for 10.8 and later:
|
||||
https://github.com/MariaDB/server/commit/64e358821e
|
||||
|
||||
Since we apply the OpenSSL 3 patch from MariaDB 10.8 series to earlier series, we need to revert this commit
|
||||
on those earlier series too.
|
||||
|
||||
--- mariadb-10.5.15-downstream_modified/cmake/ssl.cmake 2022-02-22 05:13:17.259097302 +0100
|
||||
+++ mariadb-10.5.15-downstream_modified/cmake/ssl.cmake_patched 2022-02-23 07:22:20.290082378 +0100
|
||||
@@ -118,7 +118,7 @@ MACRO (MYSQL_CHECK_SSL)
|
||||
ENDIF()
|
||||
FIND_PACKAGE(OpenSSL)
|
||||
SET_PACKAGE_PROPERTIES(OpenSSL PROPERTIES TYPE RECOMMENDED)
|
||||
- IF(OPENSSL_FOUND AND OPENSSL_VERSION AND OPENSSL_VERSION VERSION_LESS "3.0.0")
|
||||
+ IF(OPENSSL_FOUND)
|
||||
SET(OPENSSL_LIBRARY ${OPENSSL_SSL_LIBRARY})
|
||||
INCLUDE(CheckSymbolExists)
|
||||
SET(SSL_SOURCES "")
|
||||
|
12
mariadb.spec
12
mariadb.spec
@ -15,7 +15,7 @@
|
||||
# The last version on which the full testsuite has been run
|
||||
# In case of further rebuilds of that version, don't require full testsuite to be run
|
||||
# run only "main" suite
|
||||
%global last_tested_version 10.5.13
|
||||
%global last_tested_version 10.5.15
|
||||
# Set to 1 to force run the testsuite even if it was already tested in current version
|
||||
%global force_run_testsuite 0
|
||||
|
||||
@ -153,8 +153,8 @@
|
||||
%global sameevr %{epoch}:%{version}-%{release}
|
||||
|
||||
Name: mariadb
|
||||
Version: 10.5.13
|
||||
Release: 2%{?with_debug:.debug}%{?dist}
|
||||
Version: 10.5.15
|
||||
Release: 1%{?with_debug:.debug}%{?dist}
|
||||
Epoch: 3
|
||||
|
||||
Summary: A very fast and robust SQL database server
|
||||
@ -224,8 +224,6 @@ Patch11: %{pkgnamepatch}-pcdir.patch
|
||||
# Picked from the upstream developement branch for MariaDB 10.8.
|
||||
# https://jira.mariadb.org/browse/MDEV-25785
|
||||
Patch12: %{pkgnamepatch}-openssl3.patch
|
||||
# Patch15: Add option to edit groonga's and groonga-normalizer-mysql install path
|
||||
Patch15: %{pkgnamepatch}-groonga.patch
|
||||
# Patch16: Fix MD5 in FIPS mode
|
||||
Patch16: %{pkgnamepatch}-fips.patch
|
||||
|
||||
@ -758,7 +756,6 @@ rm -r storage/rocksdb/
|
||||
%if 0%{?fedora} >= 35 || 0%{?rhel} >= 9
|
||||
%patch12 -p1
|
||||
%endif
|
||||
%patch15 -p1
|
||||
%patch16 -p1
|
||||
|
||||
# generate a list of tests that fail, but are not disabled by upstream
|
||||
@ -1662,6 +1659,9 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Sun Feb 20 2022 Michal Schorm <mschorm@redhat.com> - 3:10.5.15-1
|
||||
- Rebase to 10.5.15
|
||||
|
||||
* Mon Feb 07 2022 Honza Horak <hhorak@redhat.com> - 3:10.5.13-2
|
||||
- Fix md5 in FIPS mode with OpenSSL 3.0.0
|
||||
Resolves: #2050541
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (mariadb-10.5.13-downstream_modified.tar.gz) = e8b8dce731d2dd3b3d1f5109cc811db8554d10f8269f11f40fcbf62fa0e0f0d1c18bc3b28b8017c28dcfcee96024b18e5489f50cc270a93e4bedd9ea49db08c6
|
||||
SHA512 (mariadb-10.5.15-downstream_modified.tar.gz) = 093a677b0bc17bb6c47fee44648867b514505e7fcae2018728535596566a81aa0e94b5cde0d2a6b942743515c0f888a1948d719652c173e335334e99d6fd8884
|
||||
|
Loading…
Reference in New Issue
Block a user