Rebase to 10.5.2 - Beta
TokuDB SE has been deprecated https://jira.mariadb.org/browse/MDEV-19780 Remove the RocksDB manpage when RocksDB is not built Add failing tests
This commit is contained in:
parent
a35e17b2cb
commit
8d4561c7a1
@ -1,12 +1,12 @@
|
|||||||
diff -up mariadb-10.1.8/support-files/CMakeLists.txt.p9 mariadb-10.1.8/support-files/CMakeLists.txt
|
diff -Naup mariadb-10.1.8/support-files/CMakeLists.txt mariadb-10.1.8/support-files/CMakeLists.txt_patched
|
||||||
--- mariadb-10.1.8/support-files/CMakeLists.txt.p9 2015-11-03 11:38:46.029139464 +0100
|
--- mariadb-10.5.2/support-files/CMakeLists.txt 2020-03-25 11:13:19.000000000 +0100
|
||||||
+++ mariadb-10.1.8/support-files/CMakeLists.txt 2015-11-03 11:41:07.107605055 +0100
|
+++ mariadb-10.5.2/support-files/CMakeLists.txt_patched 2020-04-01 01:29:52.140847301 +0200
|
||||||
@@ -62,6 +62,7 @@ IF(UNIX)
|
@@ -91,6 +91,7 @@ IF(UNIX)
|
||||||
ENDIF()
|
ENDIF()
|
||||||
|
|
||||||
CONFIGURE_FILE(mariadb.pc.in ${CMAKE_CURRENT_BINARY_DIR}/mariadb.pc @ONLY)
|
CONFIGURE_FILE(mariadb.pc.in ${CMAKE_CURRENT_BINARY_DIR}/mariadb.pc @ONLY)
|
||||||
+ CONFIGURE_FILE(rpm/server.cnf ${CMAKE_CURRENT_BINARY_DIR}/rpm/server.cnf @ONLY)
|
+ CONFIGURE_FILE(rpm/server.cnf ${CMAKE_CURRENT_BINARY_DIR}/rpm/server.cnf @ONLY)
|
||||||
INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/mariadb.pc DESTINATION ${INSTALL_SHAREDIR}/pkgconfig COMPONENT Development)
|
INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/mariadb.pc DESTINATION ${INSTALL_LIBDIR}/pkgconfig COMPONENT Development)
|
||||||
|
|
||||||
INSTALL(FILES mysql.m4 DESTINATION ${INSTALL_SHAREDIR}/aclocal COMPONENT Development)
|
INSTALL(FILES mysql.m4 DESTINATION ${INSTALL_SHAREDIR}/aclocal COMPONENT Development)
|
||||||
diff -up mariadb-10.1.8/support-files/rpm/server.cnf.p9 mariadb-10.1.8/support-files/rpm/server.cnf
|
diff -up mariadb-10.1.8/support-files/rpm/server.cnf.p9 mariadb-10.1.8/support-files/rpm/server.cnf
|
||||||
|
@ -3,18 +3,17 @@ Use PCDIR CMake option, if configured
|
|||||||
Upstream install the server pkgconfig file into arch-independent directory
|
Upstream install the server pkgconfig file into arch-independent directory
|
||||||
Reported to upstream as: https://jira.mariadb.org/browse/MDEV-14340
|
Reported to upstream as: https://jira.mariadb.org/browse/MDEV-14340
|
||||||
|
|
||||||
--- mariadb-10.3.12/support-files/CMakeLists.txt 2019-03-20 15:25:53.423283135 +0100
|
--- mariadb-10.5.2/support-files/CMakeLists.txt 2020-04-01 01:31:21.426832942 +0200
|
||||||
+++ mariadb-10.3.12/support-files/CMakeLists.txt_patched 2019-03-20 15:38:56.372819958 +0100
|
+++ mariadb-10.5.2/support-files/CMakeLists.txt_patched 2020-04-01 01:35:05.808309914 +0200
|
||||||
@@ -82,7 +82,12 @@ IF(UNIX)
|
@@ -92,7 +92,11 @@ IF(UNIX)
|
||||||
|
|
||||||
CONFIGURE_FILE(mariadb.pc.in ${CMAKE_CURRENT_BINARY_DIR}/mariadb.pc @ONLY)
|
CONFIGURE_FILE(mariadb.pc.in ${CMAKE_CURRENT_BINARY_DIR}/mariadb.pc @ONLY)
|
||||||
CONFIGURE_FILE(rpm/server.cnf ${CMAKE_CURRENT_BINARY_DIR}/rpm/server.cnf @ONLY)
|
CONFIGURE_FILE(rpm/server.cnf ${CMAKE_CURRENT_BINARY_DIR}/rpm/server.cnf @ONLY)
|
||||||
+IF(INSTALL_PCDIR)
|
+IF(INSTALL_PCDIR)
|
||||||
+ INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/mariadb.pc DESTINATION ${INSTALL_PCDIR} COMPONENT Development)
|
+ INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/mariadb.pc DESTINATION ${INSTALL_PCDIR} COMPONENT Development)
|
||||||
+ELSE()
|
+ELSE()
|
||||||
INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/mariadb.pc DESTINATION ${INSTALL_SHAREDIR}/pkgconfig COMPONENT Development)
|
INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/mariadb.pc DESTINATION ${INSTALL_LIBDIR}/pkgconfig COMPONENT Development)
|
||||||
+ENDIF()
|
+ENDIF()
|
||||||
+
|
|
||||||
|
|
||||||
INSTALL(FILES mysql.m4 DESTINATION ${INSTALL_SHAREDIR}/aclocal COMPONENT Development)
|
INSTALL(FILES mysql.m4 DESTINATION ${INSTALL_SHAREDIR}/aclocal COMPONENT Development)
|
||||||
|
|
||||||
|
@ -1,11 +1,12 @@
|
|||||||
We have some downstream patches and other scripts that include variables to
|
We have some downstream patches and other scripts that include variables to
|
||||||
be expanded by cmake. Cmake needs to know about them, so adding them manually.
|
be expanded by cmake. Cmake needs to know about them, so adding them manually.
|
||||||
|
|
||||||
--- mariadb-10.3.8/scripts/CMakeLists.txt 2018-07-02 09:34:11.000000000 +0200
|
# Install libgcc as mylibgcc.a
|
||||||
+++ mariadb-10.3.8/scripts/CMakeLists.txt_patched 2018-07-03 10:58:15.954670153 +0200
|
--- mariadb-10.5.2/scripts/CMakeLists.txt 2020-03-25 11:13:17.000000000 +0100
|
||||||
@@ -361,6 +361,34 @@ ELSE()
|
+++ mariadb-10.5.2/scripts/CMakeLists.txt_patched 2020-04-01 01:26:59.398940396 +0200
|
||||||
|
@@ -377,6 +377,34 @@ ELSE()
|
||||||
COMPONENT ${${file}_COMPONENT}
|
COMPONENT ${${file}_COMPONENT}
|
||||||
)
|
)
|
||||||
ENDFOREACH()
|
ENDFOREACH()
|
||||||
+
|
+
|
||||||
+ # files for systemd
|
+ # files for systemd
|
||||||
|
24
mariadb.spec
24
mariadb.spec
@ -32,9 +32,10 @@
|
|||||||
|
|
||||||
|
|
||||||
|
|
||||||
# TokuDB engine
|
# TokuDB engine - DEPRECATED !
|
||||||
# https://mariadb.com/kb/en/mariadb/tokudb/
|
# https://mariadb.com/kb/en/mariadb/tokudb/
|
||||||
# TokuDB engine is available only for x86_64
|
# TokuDB engine is available only for x86_64
|
||||||
|
# The Percona upstream deprecated the SE. It is not part of MariaDB 10.5
|
||||||
# Mroonga engine
|
# Mroonga engine
|
||||||
# https://mariadb.com/kb/en/mariadb/about-mroonga/
|
# https://mariadb.com/kb/en/mariadb/about-mroonga/
|
||||||
# Current version in MariaDB, 7.07, only supports the x86_64
|
# Current version in MariaDB, 7.07, only supports the x86_64
|
||||||
@ -45,7 +46,8 @@
|
|||||||
# RocksDB may be built with jemalloc, if specified in CMake
|
# RocksDB may be built with jemalloc, if specified in CMake
|
||||||
%ifarch x86_64
|
%ifarch x86_64
|
||||||
%if 0%{?fedora}
|
%if 0%{?fedora}
|
||||||
%bcond_without tokudb
|
# TokuDB is deprecated in MariaDB 10.5 and later
|
||||||
|
%bcond_with tokudb
|
||||||
%bcond_without mroonga
|
%bcond_without mroonga
|
||||||
%bcond_without rocksdb
|
%bcond_without rocksdb
|
||||||
%else
|
%else
|
||||||
@ -151,7 +153,7 @@
|
|||||||
%global sameevr %{epoch}:%{version}-%{release}
|
%global sameevr %{epoch}:%{version}-%{release}
|
||||||
|
|
||||||
Name: mariadb
|
Name: mariadb
|
||||||
Version: 10.5.1
|
Version: 10.5.2
|
||||||
Release: 1%{?with_debug:.debug}%{?dist}
|
Release: 1%{?with_debug:.debug}%{?dist}
|
||||||
Epoch: 3
|
Epoch: 3
|
||||||
|
|
||||||
@ -989,6 +991,10 @@ rm %{buildroot}%{_datadir}/%{pkg_name}/mysqld_multi.server
|
|||||||
# Binary for monitoring MySQL performance
|
# Binary for monitoring MySQL performance
|
||||||
# Shipped as a standalone package in Fedora
|
# Shipped as a standalone package in Fedora
|
||||||
rm %{buildroot}%{_bindir}/mytop
|
rm %{buildroot}%{_bindir}/mytop
|
||||||
|
rm %{buildroot}%{_mandir}/man1/mytop.1*
|
||||||
|
|
||||||
|
# Should be shipped with mariadb-connector-c
|
||||||
|
rm %{buildroot}%{_mandir}/man1/mariadb-config.1*
|
||||||
|
|
||||||
# put logrotate script where it needs to be
|
# put logrotate script where it needs to be
|
||||||
mkdir -p %{buildroot}%{logrotateddir}
|
mkdir -p %{buildroot}%{logrotateddir}
|
||||||
@ -1147,6 +1153,7 @@ rm %{buildroot}%{_datadir}/%{pkg_name}/systemd/use_galera_new_cluster.conf
|
|||||||
|
|
||||||
%if %{without rocksdb}
|
%if %{without rocksdb}
|
||||||
rm %{buildroot}%{_mandir}/man1/{mysql_,mariadb-}ldb.1*
|
rm %{buildroot}%{_mandir}/man1/{mysql_,mariadb-}ldb.1*
|
||||||
|
rm %{buildroot}%{_mandir}/man1/myrocks_hotbackup.1*
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%check
|
%check
|
||||||
@ -1400,6 +1407,8 @@ fi
|
|||||||
%{_mandir}/man1/myisam_ftdump.1*
|
%{_mandir}/man1/myisam_ftdump.1*
|
||||||
%{_mandir}/man1/my_print_defaults.1*
|
%{_mandir}/man1/my_print_defaults.1*
|
||||||
|
|
||||||
|
%{_mandir}/man1/mariadb-conv.1*
|
||||||
|
|
||||||
%{_mandir}/man1/mysql_{install_db,secure_installation,tzinfo_to_sql}.1*
|
%{_mandir}/man1/mysql_{install_db,secure_installation,tzinfo_to_sql}.1*
|
||||||
%{_mandir}/man1/mariadb-{install-db,secure-installation,tzinfo-to-sql}.1*
|
%{_mandir}/man1/mariadb-{install-db,secure-installation,tzinfo-to-sql}.1*
|
||||||
%{_mandir}/man1/{mysqld_,mariadbd-}safe.1*
|
%{_mandir}/man1/{mysqld_,mariadbd-}safe.1*
|
||||||
@ -1490,6 +1499,7 @@ fi
|
|||||||
%{_bindir}/sst_dump
|
%{_bindir}/sst_dump
|
||||||
%{_libdir}/%{pkg_name}/plugin/ha_rocksdb.so
|
%{_libdir}/%{pkg_name}/plugin/ha_rocksdb.so
|
||||||
%{_mandir}/man1/{mysql_,mariadb-}ldb.1*
|
%{_mandir}/man1/{mysql_,mariadb-}ldb.1*
|
||||||
|
%{_mandir}/man1/myrocks_hotbackup.1*
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%if %{with tokudb}
|
%if %{with tokudb}
|
||||||
@ -1587,10 +1597,14 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Thu Apr 09 2020 Michal Schorm <mschorm@redhat.com> - 10.5.1-1
|
* Fri Sep 11 2020 Michal Schorm <mschorm@redhat.com> - 10.5.2-1
|
||||||
|
- Test rebase to 10.5.2 - Beta
|
||||||
|
- TokuDB SE has been deprecated
|
||||||
|
|
||||||
|
* Thu Sep 10 2020 Michal Schorm <mschorm@redhat.com> - 10.5.1-1
|
||||||
- Test rebase to 10.5.1 - Beta
|
- Test rebase to 10.5.1 - Beta
|
||||||
|
|
||||||
* Thu Apr 09 2020 Michal Schorm <mschorm@redhat.com> - 10.5.0-1
|
* Thu Sep 10 2020 Michal Schorm <mschorm@redhat.com> - 10.5.0-1
|
||||||
- Test rebase to 10.5.0 - Alpha
|
- Test rebase to 10.5.0 - Alpha
|
||||||
|
|
||||||
* Sun Sep 06 2020 Michal Schorm <mschorm@redhat.com> - 10.4.14-3
|
* Sun Sep 06 2020 Michal Schorm <mschorm@redhat.com> - 10.4.14-3
|
||||||
|
@ -38,6 +38,7 @@ sys_vars.tcp_nodelay :
|
|||||||
# Fails on i686
|
# Fails on i686
|
||||||
encryption.innodb-redo-badkey :
|
encryption.innodb-redo-badkey :
|
||||||
|
|
||||||
# Fails on all architectures since 10.4.14
|
# Fails since 10.5.2
|
||||||
main.ssl_system_ca :
|
main.mysqld--help2 :
|
||||||
disks.disks :
|
disks.disks :
|
||||||
|
disks.disks_notembedded :
|
||||||
|
@ -1,2 +1,5 @@
|
|||||||
# Fails on ppc64le since 10.4.12
|
# Fails on ppc64le since 10.4.12
|
||||||
oqgraph.social :
|
oqgraph.social :
|
||||||
|
|
||||||
|
# Fails since 10.5.2
|
||||||
|
rh-skipped-tests-ppc.list :
|
||||||
|
@ -1,4 +1,2 @@
|
|||||||
# Fails since 10.2.15
|
# Fails since 10.5.2
|
||||||
disks.disks :
|
perfschema.memory_aggregate_32bit :
|
||||||
# Fails since 10.4.11
|
|
||||||
disks.disks_notembedded :
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (mariadb-10.5.1.tar.gz) = eef4986fa0ff70b77d9d083ccbe6738d7bfda4236e3098bf37cd41034732cc8a8150a25be19ffb67849d9b29c5f1126c5b38e10e6a1afd9eb8d6d266b3638fb2
|
SHA512 (mariadb-10.5.2.tar.gz) = 7abfc4a5543c35ab49ca164a998ed4b31326cb63f57b15449a5de3b62523d99535f378c8a39835f1e8563cf0cea7fd96b13e4f089cbd1546b5e25256c5f9832f
|
||||||
|
Loading…
Reference in New Issue
Block a user