Fix conflicting files with groonga package
bz#1763287 Change path to groonga's packaged files
This commit is contained in:
parent
19d30aa668
commit
81e52111e8
30
mariadb-groonga.patch
Normal file
30
mariadb-groonga.patch
Normal file
@ -0,0 +1,30 @@
|
|||||||
|
# Fixing conflict with groonga package
|
||||||
|
# https://bugzilla.redhat.com/show_bug.cgi?id=1763287
|
||||||
|
|
||||||
|
--- mariadb-10.3.18/storage/mroonga/vendor/groonga/CMakeLists.txt.withoutoption 2019-11-11 14:01:07.762595716 +0100
|
||||||
|
+++ mariadb-10.3.18/storage/mroonga/vendor/groonga/CMakeLists.txt 2019-11-11 14:33:05.224012458 +0100
|
||||||
|
@@ -86,7 +86,9 @@
|
||||||
|
set(INCLUDE_DIR "include")
|
||||||
|
set(GRN_INCLUDE_DIR "include/groonga")
|
||||||
|
set(DATA_DIR "share")
|
||||||
|
-set(GRN_DATA_DIR "${DATA_DIR}/${GRN_PROJECT_NAME}")
|
||||||
|
+if(NOT DEFINED GRN_DATA_DIR)
|
||||||
|
+ set(GRN_DATA_DIR "${DATA_DIR}/${GRN_PROJECT_NAME}")
|
||||||
|
+endif()
|
||||||
|
set(CONFIG_DIR "etc")
|
||||||
|
set(GRN_CONFIG_DIR "${CONFIG_DIR}/${GRN_PROJECT_NAME}")
|
||||||
|
set(GRN_CONFIG_PATH "${CMAKE_INSTALL_PREFIX}/${GRN_CONFIG_DIR}/groonga.conf")
|
||||||
|
|
||||||
|
--- mariadb-10.3.18/storage/mroonga/vendor/groonga/vendor/plugins/groonga-normalizer-mysql/CMakeLists.txt.withoutoption 2019-11-11 14:34:22.661005715 +0100
|
||||||
|
+++ mariadb-10.3.18/storage/mroonga/vendor/groonga/vendor/plugins/groonga-normalizer-mysql/CMakeLists.txt 2019-11-11 14:35:59.962244120 +0100
|
||||||
|
@@ -16,7 +16,9 @@
|
||||||
|
# MA 02110-1335 USA
|
||||||
|
|
||||||
|
cmake_minimum_required(VERSION 2.6)
|
||||||
|
-set(GROONGA_NORMALIZER_MYSQL_PROJECT_NAME "groonga-normalizer-mysql")
|
||||||
|
+if (NOT DEFINED GROONGA_NORMALIZER_MYSQL_PROJECT_NAME)
|
||||||
|
+ set(GROONGA_NORMALIZER_MYSQL_PROJECT_NAME "groonga-normalizer-mysql")
|
||||||
|
+endif()
|
||||||
|
project("${GROONGA_NORMALIZER_MYSQL_PROJECT_NAME}")
|
||||||
|
|
||||||
|
if(DEFINED GROONGA_NORMALIZER_MYSQL_EMBED)
|
20
mariadb.spec
20
mariadb.spec
@ -153,7 +153,7 @@
|
|||||||
|
|
||||||
Name: mariadb
|
Name: mariadb
|
||||||
Version: 10.3.20
|
Version: 10.3.20
|
||||||
Release: 2%{?with_debug:.debug}%{?dist}
|
Release: 3%{?with_debug:.debug}%{?dist}
|
||||||
Epoch: 3
|
Epoch: 3
|
||||||
|
|
||||||
Summary: A very fast and robust SQL database server
|
Summary: A very fast and robust SQL database server
|
||||||
@ -203,7 +203,8 @@ Patch11: %{pkgnamepatch}-pcdir.patch
|
|||||||
Patch13: %{pkgnamepatch}-spider_on_armv7hl.patch
|
Patch13: %{pkgnamepatch}-spider_on_armv7hl.patch
|
||||||
# Patch14: Remove the '-Werror' flag so the debug build won't crash on random warnings
|
# Patch14: Remove the '-Werror' flag so the debug build won't crash on random warnings
|
||||||
Patch14: %{pkgnamepatch}-debug_build.patch
|
Patch14: %{pkgnamepatch}-debug_build.patch
|
||||||
|
# Patch15: Add option to edit groonga's and groonga-normalizer-mysql install path
|
||||||
|
Patch15: %{pkgnamepatch}-groonga.patch
|
||||||
|
|
||||||
BuildRequires: cmake gcc-c++
|
BuildRequires: cmake gcc-c++
|
||||||
BuildRequires: multilib-rpm-config
|
BuildRequires: multilib-rpm-config
|
||||||
@ -701,6 +702,7 @@ find . -name "*.jar" -type f -exec rm --verbose -f {} \;
|
|||||||
%patch11 -p1
|
%patch11 -p1
|
||||||
%patch13 -p1
|
%patch13 -p1
|
||||||
%patch14 -p1
|
%patch14 -p1
|
||||||
|
%patch15 -p1
|
||||||
|
|
||||||
# workaround for upstream bug #56342
|
# workaround for upstream bug #56342
|
||||||
#rm mysql-test/t/ssl_8k_key-master.opt
|
#rm mysql-test/t/ssl_8k_key-master.opt
|
||||||
@ -816,6 +818,8 @@ export CFLAGS CXXFLAGS CPPFLAGS
|
|||||||
-DMYSQL_DATADIR="%{dbdatadir}" \
|
-DMYSQL_DATADIR="%{dbdatadir}" \
|
||||||
-DMYSQL_UNIX_ADDR="/var/lib/mysql/mysql.sock" \
|
-DMYSQL_UNIX_ADDR="/var/lib/mysql/mysql.sock" \
|
||||||
-DTMPDIR=/var/tmp \
|
-DTMPDIR=/var/tmp \
|
||||||
|
-DGRN_DATA_DIR=share/%{name}-server/groonga \
|
||||||
|
-DGROONGA_NORMALIZER_MYSQL_PROJECT_NAME=%{name}-server/groonga-normalizer-mysql \
|
||||||
-DENABLED_LOCAL_INFILE=ON \
|
-DENABLED_LOCAL_INFILE=ON \
|
||||||
-DENABLE_DTRACE=ON \
|
-DENABLE_DTRACE=ON \
|
||||||
-DSECURITY_HARDENED=ON \
|
-DSECURITY_HARDENED=ON \
|
||||||
@ -1408,10 +1412,10 @@ fi
|
|||||||
%{_datadir}/%{pkg_name}/mroonga/uninstall.sql
|
%{_datadir}/%{pkg_name}/mroonga/uninstall.sql
|
||||||
%license %{_datadir}/%{pkg_name}/mroonga/COPYING
|
%license %{_datadir}/%{pkg_name}/mroonga/COPYING
|
||||||
%license %{_datadir}/%{pkg_name}/mroonga/AUTHORS
|
%license %{_datadir}/%{pkg_name}/mroonga/AUTHORS
|
||||||
%license %{_datadir}/groonga-normalizer-mysql/lgpl-2.0.txt
|
%license %{_datadir}/%{name}-server/groonga-normalizer-mysql/lgpl-2.0.txt
|
||||||
%license %{_datadir}/groonga/COPYING
|
%license %{_datadir}/%{name}-server/groonga/COPYING
|
||||||
%doc %{_datadir}/groonga-normalizer-mysql/README.md
|
%doc %{_datadir}/%{name}-server/groonga-normalizer-mysql/README.md
|
||||||
%doc %{_datadir}/groonga/README.md
|
%doc %{_datadir}/%{name}-server/groonga/README.md
|
||||||
%endif
|
%endif
|
||||||
%{_datadir}/%{pkg_name}/wsrep.cnf
|
%{_datadir}/%{pkg_name}/wsrep.cnf
|
||||||
%{_datadir}/%{pkg_name}/wsrep_notify
|
%{_datadir}/%{pkg_name}/wsrep_notify
|
||||||
@ -1576,6 +1580,10 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Nov 18 2019 Lukas Javorsky <ljavorsk@redhat.com> - 10.3.20-3
|
||||||
|
- Change path of groonga's packaged files
|
||||||
|
- Fix bz#1763287
|
||||||
|
|
||||||
* Tue Nov 12 2019 Michal Schorm <mschorm@redhat.com> - 10.3.20-2
|
* Tue Nov 12 2019 Michal Schorm <mschorm@redhat.com> - 10.3.20-2
|
||||||
- Rebuild on top fo new mariadb-connector-c
|
- Rebuild on top fo new mariadb-connector-c
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user